]> git.pld-linux.org Git - packages/ocaml-ppx_fields_conv.git/blob - ocaml-ppx_fields_conv.spec
- typo
[packages/ocaml-ppx_fields_conv.git] / ocaml-ppx_fields_conv.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Generation of accessor and iteration functions for OCaml records
11 Summary(pl.UTF-8):      Generowanie funkcji dostępowych i iterujących dla rekordów w OCamlu
12 Name:           ocaml-ppx_fields_conv
13 Version:        0.14.2
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_fields_conv/tags
18 Source0:        https://github.com/janestreet/ppx_fields_conv/archive/v%{version}/ppx_fields_conv-%{version}.tar.gz
19 # Source0-md5:  f9ff1b882775718cba29bd67839405f0
20 URL:            https://github.com/janestreet/ppx_fields_conv
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-fieldslib-devel >= 0.14
26 BuildRequires:  ocaml-fieldslib-devel < 0.15
27 BuildRequires:  ocaml-ppxlib-devel >= 0.18.0
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         debug_package   %{nil}
32
33 %description
34 Generation of accessor and iteration functions for OCaml records.
35
36 This package contains files needed to run bytecode executables using
37 ppx_fields_conv library.
38
39 %description -l pl.UTF-8
40 Generowanie funkcji dostępowych i iterujących dla rekordów w OCamlu.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki ppx_fields_conv.
44
45 %package devel
46 Summary:        Generation of accessor and iteration functions for OCaml records - development part
47 Summary(pl.UTF-8):      Generowanie funkcji dostępowych i iterujących dla rekordów w OCamlu - część programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51 Requires:       ocaml-base-devel >= 0.14
52 Requires:       ocaml-fieldslib-devel >= 0.14
53 Requires:       ocaml-ppxlib-devel >= 0.18.0
54
55 %description devel
56 This package contains files needed to develop OCaml programs using
57 ppx_fields_conv library.
58
59 %description devel -l pl.UTF-8
60 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
61 używających biblioteki ppx_fields_conv.
62
63 %prep
64 %setup -q -n ppx_fields_conv-%{version}
65
66 %build
67 dune build --verbose
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 dune install --destdir=$RPM_BUILD_ROOT
73
74 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75 cp -pr example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 # sources
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_fields_conv/*.ml
79 # packaged as %doc
80 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_fields_conv
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGES.md LICENSE.md README.md
88 %dir %{_libdir}/ocaml/ppx_fields_conv
89 %{_libdir}/ocaml/ppx_fields_conv/META
90 %{_libdir}/ocaml/ppx_fields_conv/*.cma
91 %if %{with ocaml_opt}
92 %attr(755,root,root) %{_libdir}/ocaml/ppx_fields_conv/*.cmxs
93 %endif
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_libdir}/ocaml/ppx_fields_conv/*.cmi
98 %{_libdir}/ocaml/ppx_fields_conv/*.cmt
99 %{_libdir}/ocaml/ppx_fields_conv/*.cmti
100 %{_libdir}/ocaml/ppx_fields_conv/*.mli
101 %if %{with ocaml_opt}
102 %{_libdir}/ocaml/ppx_fields_conv/ppx_fields_conv.a
103 %{_libdir}/ocaml/ppx_fields_conv/*.cmx
104 %{_libdir}/ocaml/ppx_fields_conv/*.cmxa
105 %endif
106 %{_libdir}/ocaml/ppx_fields_conv/dune-package
107 %{_libdir}/ocaml/ppx_fields_conv/opam
108 %{_examplesdir}/%{name}-%{version}
This page took 0.113143 seconds and 3 git commands to generate.