]> git.pld-linux.org Git - packages/ocaml-pcre.git/blob - ocaml-pcre.spec
- new URLs, updated to 7.0.2
[packages/ocaml-pcre.git] / ocaml-pcre.spec
1 Summary:        PCRE binding for OCaml
2 Summary(pl.UTF-8):      Wiązania PCRE dla OCamla
3 Name:           ocaml-pcre
4 Version:        7.0.2
5 Release:        1
6 License:        LGPL v2.1+ with OCaml linking exception
7 Group:          Libraries
8 # see it to get commit id of particular release
9 #Source0Download: https://bitbucket.org/mmottl/pcre-ocaml
10 Source0:        https://bitbucket.org/mmottl/pcre-ocaml/get/00e2295ec90d.tar.bz2
11 # Source0-md5:  8cdc4f56a7effd98f4e2343d996a7074
12 URL:            https://bitbucket.org/mmottl/pcre-ocaml
13 BuildRequires:  ocaml >= 1:3.12
14 BuildRequires:  ocaml-findlib >= 1.3.1
15 BuildRequires:  pcre-devel
16 %requires_eq    ocaml-runtime
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This OCaml-library interfaces the PCRE (Perl-compatibility regular
21 expressions) library which is written in C. It can be used for
22 matching regular expressions which are written in "Perl"-style.
23
24 This package contains files needed to run bytecode executables using
25 this library.
26
27 %description -l pl.UTF-8
28 Biblioteka zawarta w tym pakiecie umożliwia korzystanie z biblioteki
29 PCRE (wyrażenia regularne kompatybilne z Perlem), która jest z kolei
30 napisana w C. Może być ona używana do dopasowywania wyrażeń
31 regularnych napisanym w ,,stylu Perla''.
32
33 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
34 używających tej biblioteki.
35
36 %package devel
37 Summary:        PCRE binding for OCaml - development part
38 Summary(pl.UTF-8):      Wiązania PCRE dla OCamla - cześć programistyczna
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 %requires_eq    ocaml
42
43 %description devel
44 This OCaml-library interfaces the PCRE (Perl-compatibility regular
45 expressions) library which is written in C. It can be used for
46 matching regular expressions which are written in "Perl"-style.
47
48 This package contains files needed to develop OCaml programs using
49 this library.
50
51 %description devel -l pl.UTF-8
52 Biblioteka zawarta w tym pakiecie umożliwia korzystanie z biblioteki
53 PCRE (wyrażenia regularne kompatybilne z Perlem), która jest z kolei
54 napisana w C. Może być ona używana do dopasowywania wyrażeń
55 regularnych napisanym w ,,stylu Perla''.
56
57 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
58 tej biblioteki.
59
60 %prep
61 %setup -q -n mmottl-pcre-ocaml-00e2295ec90d
62
63 %build
64 # not autoconf configure
65 ./configure \
66         --prefix=%{_prefix} \
67         --docdir=$(pwd)/doc
68
69 %{__make} -j1 all \
70         CC="%{__cc}" \
71         CFLAGS="%{rpmcflags} -fPIC -DPIC"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{site-lib/pcre,stublibs}
76
77 %{__make} install \
78         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
79
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/pcre/*.mli
81
82 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/pcre/META \
86         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/pcre
87 echo 'directory = "+pcre"' >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/pcre/META
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS.txt CHANGES.txt README.md
95 %dir %{_libdir}/ocaml/pcre
96 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllpcre_stubs.so
97 %{_libdir}/ocaml/stublibs/dllpcre_stubs.so.owner
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc lib/*.mli
102 %{_libdir}/ocaml/pcre/libpcre_stubs.a
103 %{_libdir}/ocaml/pcre/pcre.a
104 %{_libdir}/ocaml/pcre/pcre.cm[ixa]*
105 %{_libdir}/ocaml/site-lib/pcre
106 %{_examplesdir}/%{name}-%{version}
This page took 0.111417 seconds and 3 git commands to generate.