]> git.pld-linux.org Git - packages/ocaml-parsexp.git/blob - ocaml-parsexp.spec
- typo
[packages/ocaml-parsexp.git] / ocaml-parsexp.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        S-expression parsing library
11 Summary(pl.UTF-8):      Biblioteka analizująca S-wyrażenia
12 Name:           ocaml-parsexp
13 Version:        0.14.1
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/parsexp/tags
18 Source0:        https://github.com/janestreet/parsexp/archive/v%{version}/parsexp-%{version}.tar.gz
19 # Source0-md5:  e6659d53f4d94de8979e05d17222b753
20 URL:            https://github.com/janestreet/parsexp
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-sexplib0-devel >= 0.14
26 BuildRequires:  ocaml-sexplib0-devel < 0.15
27 %requires_eq    ocaml-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         debug_package   %{nil}
31
32 %description
33 This library provides generic parsers for parsing S-expressions from
34 strings or other medium.
35
36 This package contains files needed to run bytecode executables using
37 parsexp library.
38
39 %description -l pl.UTF-8
40 Ta biblioteka zapewnia ogólne parsery do analizy S-wyrażeń z łańcuchów
41 lub innego nośnika.
42
43 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
44 używających biblioteki parsexp.
45
46 %package devel
47 Summary:        S-expression parsing library - development part
48 Summary(pl.UTF-8):      Biblioteka analizująca S-wyrażenia - część programistyczna
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 %requires_eq    ocaml
52 Requires:       ocaml-base-devel >= 0.14
53 Requires:       ocaml-sexplib0-devel >= 0.14
54
55 %description devel
56 This package contains files needed to develop OCaml programs using
57 parsexp library.
58
59 %description devel -l pl.UTF-8
60 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
61 używających biblioteki parsexp.
62
63 %prep
64 %setup -q -n parsexp-%{version}
65
66 %build
67 dune build --verbose
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 dune install --destdir=$RPM_BUILD_ROOT
73
74 # sources
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/parsexp/*.ml
76 # packaged as %doc
77 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/parsexp
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGES.md LICENSE.md README.org
85 %dir %{_libdir}/ocaml/parsexp
86 %{_libdir}/ocaml/parsexp/META
87 %{_libdir}/ocaml/parsexp/*.cma
88 %if %{with ocaml_opt}
89 %attr(755,root,root) %{_libdir}/ocaml/parsexp/*.cmxs
90 %endif
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/ocaml/parsexp/*.cmi
95 %{_libdir}/ocaml/parsexp/*.cmt
96 %{_libdir}/ocaml/parsexp/*.cmti
97 %{_libdir}/ocaml/parsexp/*.mli
98 %if %{with ocaml_opt}
99 %{_libdir}/ocaml/parsexp/parsexp.a
100 %{_libdir}/ocaml/parsexp/*.cmx
101 %{_libdir}/ocaml/parsexp/*.cmxa
102 %endif
103 %{_libdir}/ocaml/parsexp/dune-package
104 %{_libdir}/ocaml/parsexp/opam
This page took 0.082303 seconds and 3 git commands to generate.