]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
12f9d4bb16676dcb458158404d28d9ab2cf8eb81
[packages/ocaml-net.git] / ocaml-net.spec
1 %define         apxs    /usr/sbin/apxs
2 %define         apache  /usr/sbin/httpd
3 Summary:        Modules for Internet programming in OCaml
4 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
5 Name:           ocaml-net
6 Version:        3.6
7 Release:        1
8 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
9 Group:          Libraries
10 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
11 # Source0-md5:  c6a42744c456b3b336c7613f5481650a
12 Patch0:         %{name}-buildfix.patch
13 Patch1:         %{name}-lablgtk2.patch
14 Patch2:         %{name}-zip.patch
15 Patch3:         %{name}-apache-link.patch
16 URL:            http://projects.camlcity.org/projects/ocamlnet.html
17 BuildRequires:  %{apache}
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0
20 BuildRequires:  ncurses-devel
21 BuildRequires:  ocaml >= 1:3.09.2
22 BuildRequires:  ocaml-camlp4
23 BuildRequires:  ocaml-cryptgps-devel
24 BuildRequires:  ocaml-cryptokit-devel
25 BuildRequires:  ocaml-findlib
26 BuildRequires:  ocaml-findlib-devel
27 BuildRequires:  ocaml-lablgtk-devel
28 BuildRequires:  ocaml-lablgtk2-devel >= 2.14.2
29 BuildRequires:  ocaml-labltk-devel
30 BuildRequires:  ocaml-pcre-devel
31 BuildRequires:  ocaml-ssl-devel
32 BuildRequires:  ocaml-zip-devel
33 BuildRequires:  tcl-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _apachepkglibdir        %(%{apxs} -q LIBEXECDIR 2>/dev/null)
37 %define         _apachesysconfdir       %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
38
39 %description
40 Modules for Internet programming in OCaml.
41
42 %description -l pl.UTF-8
43 Moduły ułatwiające pisanie programów internetowych w OCamlu.
44
45 %package doc
46 Summary:        ocaml-net documentation
47 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
48 License:        BSD-like
49 Group:          Development/Libraries
50
51 %description doc
52 ocaml-net documentation.
53
54 %description doc -l pl.UTF-8
55 Dokumentacja dla pakietów ocaml-net.
56
57 %package netcgi-devel
58 Summary:        Common Gateway Interface library
59 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
60 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
61 Group:          Development/Libraries
62 Requires:       %{name}-netplex-devel = %{version}-%{release}
63 Requires:       %{name}-netstring-devel = %{version}-%{release}
64 Requires:       %{name}-netsys-devel = %{version}-%{release}
65 Obsoletes:      ocaml-net-cgi-devel
66 %requires_eq    ocaml
67
68 %description netcgi-devel
69 Common Gateway Interface library, part of Ocamlnet. This package
70 contains files needed to develop OCaml programs using netcgi library.
71
72 %description netcgi-devel -l pl.UTF-8
73 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
74 pakiet zawiera pliki niezbędne do tworzenia programów używających
75 biblioteki netcgi.
76
77 %package -n apache-mod_netcgi
78 Summary:        Apache module:
79 Summary(pl.UTF-8):      Moduł Apache'a:
80 Group:          Networking/Daemons/HTTP
81 Requires:       apache(modules-api) = %apache_modules_api
82
83 %description -n apache-mod_netcgi
84
85 %description -n apache-mod_netcgi -l pl.UTF-8
86
87 %package equeue-devel
88 Summary:        Event queue library for OCaml
89 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
90 License:        BSD-like
91 Group:          Development/Libraries
92 Requires:       %{name}-netsys-devel = %{version}-%{release}
93 %requires_eq    ocaml
94 Obsoletes:      ocaml-equeue-devel
95
96 %description equeue-devel
97 Equeue provides a generic event queue module, and a specific module
98 for file descriptor events.
99
100 This package contains files needed to develop OCaml programs using
101 equeue library.
102
103 %description equeue-devel -l pl.UTF-8
104 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
105 modułu obsługi zdarzeń na deskryptorach plików.
106
107 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
108 biblioteki equeue.
109
110 %package equeue-gtk-devel
111 Summary:        GTK event queue library for OCaml
112 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK dla OCamla
113 License:        BSD-like
114 Group:          Development/Libraries
115 Requires:       %{name}-equeue-devel = %{version}-%{release}
116 Requires:       ocaml-lablgtk-devel
117 %requires_eq    ocaml
118
119 %description equeue-gtk-devel
120 Equeue provides a generic event queue module, and a specific module
121 for file descriptor events.
122
123 This package contains files needed to develop OCaml programs using GTK
124 equeue library.
125
126 %description equeue-gtk-devel -l pl.UTF-8
127 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
128 modułu obsługi zdarzeń na deskryptorach plików.
129
130 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
131 biblioteki equeue GTK.
132
133 %package equeue-gtk2-devel
134 Summary:        GTK2 event queue library for OCaml
135 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
136 License:        BSD-like
137 Group:          Development/Libraries
138 Requires:       %{name}-equeue-devel = %{version}-%{release}
139 Requires:       ocaml-lablgtk2-devel
140 %requires_eq    ocaml
141
142 %description equeue-gtk2-devel
143 Equeue provides a generic event queue module, and a specific module
144 for file descriptor events.
145
146 This package contains files needed to develop OCaml programs using
147 GTK2 equeue library.
148
149 %description equeue-gtk2-devel -l pl.UTF-8
150 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
151 modułu obsługi zdarzeń na deskryptorach plików.
152
153 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
154 biblioteki equeue GTK2.
155
156 %package equeue-ssl
157 Summary:        Event queue library for OCaml, SSL support
158 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
159 License:        BSD-like
160 Group:          Libraries
161 %requires_eq    ocaml-runtime
162
163 %description equeue-ssl
164 This package makes it possible to let Equeue cooperate with the event
165 queue implementation of SSL.
166
167 This package contains files needed to run bytecode executables using
168 equeue-ssl library.
169
170 %description equeue-ssl -l pl.UTF-8
171 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
172 w SSL.
173
174 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
175 używających biblioteki equeue-ssl.
176
177 %package equeue-ssl-devel
178 Summary:        Equeue SSL support - development part
179 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
180 License:        BSD-like
181 Group:          Development/Libraries
182 Requires:       %{name}-equeue-devel = %{version}-%{release}
183 Requires:       %{name}-equeue-ssl = %{version}-%{release}
184 %requires_eq    ocaml-ssl-devel
185 %requires_eq    ocaml
186
187 %description equeue-ssl-devel
188 This package makes it possible to let Equeue cooperate with the event
189 queue implementation of SSL.
190
191 This package contains files needed to develop OCaml programs using
192 equeue-ssl library.
193
194 %description equeue-ssl-devel -l pl.UTF-8
195 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
196 w SSL.
197
198 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
199 biblioteki equeue-ssl.
200
201 %package equeue-tcl
202 Summary:        Event queue library for OCaml, Tcl support
203 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
204 License:        BSD-like
205 Group:          Libraries
206 %requires_eq    ocaml-runtime
207 %requires_eq    ocaml-labltk
208 Obsoletes:      ocaml-equeue-tcl
209
210 %description equeue-tcl
211 This package makes it possible to let Equeue cooperate with the event
212 queue implementation of Tcl.
213
214 This package contains files needed to run bytecode executables using
215 equeue-tcl library.
216
217 %description equeue-tcl -l pl.UTF-8
218 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
219 w Tcl.
220
221 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
222 używających biblioteki equeue-tcl.
223
224 %package equeue-tcl-devel
225 Summary:        Equeue Tcl support - development part
226 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
227 License:        BSD-like
228 Group:          Development/Libraries
229 Requires:       %{name}-equeue-devel = %{version}-%{release}
230 Requires:       %{name}-equeue-tcl = %{version}-%{release}
231 %requires_eq    ocaml-labltk-devel
232 %requires_eq    ocaml
233 Obsoletes:      ocaml-equeue-tcl-devel
234
235 %description equeue-tcl-devel
236 This package makes it possible to let Equeue cooperate with the event
237 queue implementation of Tcl.
238
239 This package contains files needed to develop OCaml programs using
240 this library.
241
242 %description equeue-tcl-devel -l pl.UTF-8
243 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
244 w Tcl.
245
246 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
247 biblioteki equeue-tcl.
248
249 %package netcamlbox-devel
250 Summary:        Fast IPC mechanism for OCaml
251 Summary(pl.UTF-8):      Szybki mechanizm IPC dla OCamla
252 License:        BSD-like
253 Group:          Development/Libraries
254 Requires:       %{name}-netsys-devel = %{version}-%{release}
255 %requires_eq    ocaml
256
257 %description netcamlbox-devel
258 Camlboxes are a fast IPC mechanism to send Ocaml values from one
259 process to another. Source and destination processes must run on the
260 same machine (no network). The Ocaml value is copied to a shared
261 memory object where it can be directly accessed by the receiver
262 without unmarshalling step. This means the sender writes the value
263 into the shared memory in a format that can immediately interpreted by
264 the receiver.
265
266 This package contains files needed to develop OCaml programs using
267 netcamlbox library.
268
269 %description netcamlbox-devel -l pl.UTF-8
270 Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
271 pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
272 samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
273 dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
274
275 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
276 biblioteki netcamlbox.
277
278 %package netclient-devel
279 Summary:        HTTP 1.1 client for OCaml
280 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
281 License:        BSD-like
282 Group:          Development/Libraries
283 Requires:       %{name}-equeue-devel = %{version}-%{release}
284 Requires:       %{name}-netstring-devel = %{version}-%{release}
285 %requires_eq    ocaml
286 Obsoletes:      ocaml-netclient-devel
287
288 %description netclient-devel
289 Implements much of HTTP/1.1. Implements the following advanced
290 features: chunked messages; persistent connections; connections in
291 pipelining mode ("full duplex" connections); modular authentication
292 methods, currently Basic and Digest; event-driven implementation;
293 allows concurrent service for several network connections.
294
295 This package contains files needed to develop OCaml programs using
296 netclient library.
297
298 %description netclient-devel -l pl.UTF-8
299 Biblioteka netclient implementuje większość HTTP/1.1, a także
300 następujące zaawansowane właściwości: komunikaty w kawałkach;
301 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
302 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
303 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
304
305 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
306 biblioteki netclient.
307
308 %package netgssapi-devel
309 Summary:        GSS-API generic definition
310 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
311 License:        GPL v2+
312 Group:          Development/Libraries
313 Requires:       %{name}-netstring-devel = %{version}-%{release}
314 Requires:       %{name}-netsys-devel = %{version}-%{release}
315 %requires_eq    ocaml
316
317 %description netgssapi-devel
318 GSSAPI library, part of Ocamlnet. This package contains the files
319 needed to develop OCaml programs using netgssapi library.
320
321 %description netgssapi-devel -l pl.UTF-8
322 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
323 pakiet zawiera pliki niezbędne do tworzenia programów używających
324 biblioteki netgssapi.
325
326 %package nethttpd-devel
327 Summary:        HTTPd library
328 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
329 License:        GPL v2+
330 Group:          Development/Libraries
331 Requires:       %{name}-equeue-devel = %{version}-%{release}
332 Requires:       %{name}-netcgi-devel = %{version}-%{release}
333 Requires:       %{name}-netplex-devel = %{version}-%{release}
334 %requires_eq    ocaml-pcre-devel
335 %requires_eq    ocaml
336
337 %description nethttpd-devel
338 HTTPd library, part of Ocamlnet. This package contains the files
339 needed to develop OCaml programs using nethttpd library.
340
341 %description nethttpd-devel -l pl.UTF-8
342 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
343 pakiet zawiera pliki niezbędne do tworzenia programów używających
344 biblioteki nethttpd.
345
346 %package netmech-scram-devel
347 Summary:        SCRAM mechanism for authentication
348 Summary(pl.UTF-8):      Mechanizm autentykacji SCRAM
349 License:        GPL v2+
350 Group:          Development/Libraries
351 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
352 Requires:       %{name}-netplex-devel = %{version}-%{release}
353 %requires_eq    ocaml
354
355 %description netmech-scram-devel
356 Netmech-scram library, part of Ocamlnet. This package contains the
357 files needed to develop OCaml programs using netmech-scram library.
358
359 %description netmech-scram-devel -l pl.UTF-8
360 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
361 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
362 używających biblioteki netmech-scram.
363
364 %package netmulticore-devel
365 Summary:        Multi-processing for compute jobs
366 Summary(pl.UTF-8):      Obsługa wieloprocesorowych obliczeń
367 License:        GPL v2+
368 Group:          Development/Libraries
369 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
370 Requires:       %{name}-netplex-devel = %{version}-%{release}
371 %requires_eq    ocaml
372
373 %description netmulticore-devel
374 Netmcore library, part of Ocamlnet. This package contains the files
375 needed to develop OCaml programs using netmulticore library.
376
377 %description netmulticore-devel -l pl.UTF-8
378 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
379 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
380 używających biblioteki netmulticore.
381
382 %package netplex
383 Summary:        Server framework
384 Summary(pl.UTF-8):      Szkielet serwerowy
385 License:        BSD-like
386 Group:          Libraries
387 %requires_eq    ocaml-runtime
388 %requires_eq    ocaml-labltk
389
390 %description netplex
391 Server framework.
392
393 This package contains files needed to run bytecode executables using
394 netplex library.
395
396 %description netplex -l pl.UTF-8
397 Szkielet serwerowy.
398
399 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
400 używających biblioteki netplex.
401
402 %package netplex-devel
403 Summary:        Server framework - development part
404 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
405 License:        BSD-like
406 Group:          Development/Libraries
407 Requires:       %{name}-equeue-devel = %{version}-%{release}
408 Requires:       %{name}-netplex = %{version}-%{release}
409 Requires:       %{name}-netstring-devel = %{version}-%{release}
410 Requires:       %{name}-netsys-devel = %{version}-%{release}
411 Requires:       %{name}-rpc-devel = %{version}-%{release}
412 %requires_eq    ocaml
413
414 %description netplex-devel
415 Server framework.
416
417 This package contains files needed to develop OCaml programs using
418 netplex library.
419
420 %description netplex-devel -l pl.UTF-8
421 Szkielet serwerowy.
422
423 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
424 biblioteki netplex.
425
426 %package netshm-devel
427 Summary:        Shared memory support - development package
428 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
429 License:        BSD-like
430 Group:          Development/Libraries
431 Requires:       %{name}-netsys-devel = %{version}-%{release}
432 %requires_eq    ocaml
433
434 %description netshm-devel
435 Shared memory support.
436
437 This package contains files needed to develop OCaml programs using
438 netshm library.
439
440 %description netshm-devel -l pl.UTF-8
441 Obsługa pamięci dzielonej.
442
443 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
444 biblioteki netshm.
445
446 %package netstring-devel
447 Summary:        String processing library
448 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
449 License:        BSD-like
450 Group:          Development/Libraries
451 Requires:       %{name}-netsys-devel = %{version}-%{release}
452 %requires_eq    ocaml-pcre-devel
453 %requires_eq    ocaml
454
455 %description netstring-devel
456 String processing library, part of Ocamlnet. This package contains
457 files needed to develop OCaml programs using netstring library.
458
459 %description netstring-devel -l pl.UTF-8
460 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
461 pakiet zawiera pliki niezbędne do tworzenia programów używających
462 biblioteki netstring.
463
464 %package netsys
465 Summary:        OS-specific functions
466 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
467 License:        BSD-like
468 Group:          Libraries
469 %requires_eq    ocaml-runtime
470
471 %description netsys
472 OS-specific functions.
473
474 This package contains files needed to run bytecode executables using
475 netsys library.
476
477 %description netsys -l pl.UTF-8
478 Funkcje specyficzne dla systemu operacyjnego.
479
480 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
481 używających biblioteki netsys.
482
483 %package netsys-devel
484 Summary:        OS-specific functions - development part
485 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
486 License:        BSD-like
487 Group:          Development/Libraries
488 Requires:       %{name}-netsys = %{version}-%{release}
489 %requires_eq    ocaml
490
491 %description netsys-devel
492 OS-specific functions.
493
494 This package contains files needed to develop OCaml programs using
495 netsys library.
496
497 %description netsys-devel -l pl.UTF-8
498 Funkcje specyficzne dla systemu operacyjnego.
499
500 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
501 biblioteki netsys.
502
503 %package netzip-devel
504 Summary:        Gzip channels - development part
505 Summary(pl.UTF-8):      Funkcje do kompresji kanałow - cześć programistyczna
506 License:        BSD-like
507 Group:          Development/Libraries
508 Requires:       %{name}-netstring-devel = %{version}-%{release}
509 %requires_eq    ocaml
510
511 %description netzip-devel
512 Gzip channels functions.
513
514 This package contains files needed to develop OCaml programs using
515 netzip library.
516
517 %description netzip-devel -l pl.UTF-8
518 Funkcje do kompresji kanałow.
519
520 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
521 biblioteki netzip.
522
523 %package pop3-devel
524 Summary:        Post Office Protocol (POP3) library
525 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
526 License:        BSD-like
527 Group:          Development/Libraries
528 Requires:       %{name}-netstring-devel = %{version}-%{release}
529 %requires_eq    ocaml
530
531 %description pop3-devel
532 Post Office Protocol (POP3) library, part of Ocamlnet. This package
533 contains files needed to develop OCaml programs using pop library.
534
535 %description pop3-devel -l pl.UTF-8
536 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
537 pliki niezbędne do tworzenia programów używających biblioteki pop.
538
539 %package rpc
540 Summary:        Remote Procedure Call (RPC) libraries
541 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
542 License:        BSD-like
543 Group:          Development/Libraries
544 Requires:       %{name}-equeue-ssl = %{version}-%{release}
545 %requires_eq    ocaml
546
547 %description rpc
548 Remote Procedure Call (RPC) libraries.
549
550 %description rpc -l pl.UTF-8
551 Biblioteki do obsługi RPC.
552
553 %package rpc-devel
554 Summary:        Remote Procedure Call (RPC) libraries - development part
555 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
556 License:        BSD-like
557 Group:          Development/Libraries
558 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
559 Requires:       %{name}-rpc = %{version}-%{release}
560 %requires_eq    ocaml
561
562 %description rpc-devel
563 Remote Procedure Call (RPC) libraries - development part.
564
565 %description rpc-devel -l pl.UTF-8
566 Biblioteki do obsługi RPC - część programistyczna.
567
568 %package shell-devel
569 Summary:        Unix shell functions
570 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
571 License:        BSD-like
572 Group:          Development/Libraries
573 Requires:       %{name}-equeue-devel = %{version}-%{release}
574 Requires:       %{name}-netsys-devel = %{version}-%{release}
575 %requires_eq    ocaml
576
577 %description shell-devel
578 Unix shell functions.
579
580 %description shell-devel -l pl.UTF-8
581 Funkcje powłoki uniksowej.
582
583 %package smtp-devel
584 Summary:        Simple Mail Transfer Protocol (SMTP) library
585 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
586 License:        BSD-like
587 Group:          Development/Libraries
588 Requires:       %{name}-netstring-devel = %{version}-%{release}
589 %requires_eq    ocaml
590
591 %description smtp-devel
592 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
593 RFC 2821.
594
595 %description smtp-devel -l pl.UTF-8
596 Interfejs dla protokołu SMTP opisanego w RFC 2821.
597
598 %prep
599 %setup -q -n ocamlnet-%{version}
600 %patch0 -p1
601 %patch1 -p1
602 %patch2 -p1
603 %patch3 -p1
604
605 %build
606 # no %%configure, please
607 ./configure \
608         -enable-gtk \
609         -enable-gtk2 \
610         -enable-ssl \
611         -enable-zip \
612         -enable-crypto \
613         -enable-apache \
614         -with-rpc-auth-dh \
615         -enable-tcl \
616         -equeue-tcl-libs "-ltcl" \
617         -with-nethttpd \
618         -apxs %{apxs} \
619         -apache %{apache}
620
621 %{__make} -j1 all opt
622
623 %install
624 rm -rf $RPM_BUILD_ROOT
625 install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml,%{_apachepkglibdir},%{_apachesysconfdir}}
626
627 %{__make} -j1 install \
628         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
629         DESTDIR=$RPM_BUILD_ROOT
630
631 cd src
632 for f in e* n* p* r* shell smtp ; do
633         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
634         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
635         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
636                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
637         echo "directory = \"+$f\"" \
638                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
639 done
640 cd ..
641
642 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/500netcgi_apache.info
643 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/META
644 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/mod_netcgi_apache.so
645
646 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
647 cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
648 LoadModule netcgi_module     modules/mod_netcgi.so
649
650 <IfModule netcgi_module>
651         NetcgiLoad pcre/pcre.cma
652         NetcgiLoad netsys/netsys.cma
653         NetcgiLoad netstring/netstring.cma
654         NetcgiLoad str.cma
655         NetcgiLoad netcgi2/netcgi.cma
656         NetcgiLoad netcgi2-apache/netcgi_apache.cma
657
658         NetcgiHandler Netcgi_apache.bytecode
659         AddHandler ocaml-bytecode .cma
660
661 #       Alias /caml-bin/ /path/to/your/scripts/
662 #       <Location /caml-bin>
663 #               SetHandler ocaml-bytecode
664 #               NetcgiHandler Netcgi_apache.bytecode
665 #               Options ExecCGI
666 #               Allow from all
667 #       </Location>
668 </IfModule>
669 EOF
670
671 # not sure about *.o
672 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
673
674 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,pop3,rpc}-%{version}
675 cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
676 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
677 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
678 cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
679 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
680 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
681 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
682 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
683
684 %clean
685 rm -rf $RPM_BUILD_ROOT
686
687 %files doc
688 %defattr(644,root,root,755)
689 %doc LICENSE* ChangeLog RELNOTES doc/html-main
690
691 %files netcgi-devel
692 %defattr(644,root,root,755)
693 %dir %{_libdir}/ocaml/netcgi*
694 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
695 %{_libdir}/ocaml/netcgi*/*.a
696 %{_libdir}/ocaml/site-lib/*cgi*
697 %{_examplesdir}/%{name}-netcgi-%{version}
698
699 %files -n apache-mod_netcgi
700 %defattr(644,root,root,755)
701 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
702 %attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
703
704 %files equeue-devel
705 %defattr(644,root,root,755)
706 %dir %{_libdir}/ocaml/equeue
707 %{_libdir}/ocaml/equeue/*.cm[ixao]*
708 %{_libdir}/ocaml/equeue/*.a
709 %{_libdir}/ocaml/site-lib/equeue
710 %{_examplesdir}/%{name}-equeue-%{version}
711
712 %files equeue-gtk-devel
713 %defattr(644,root,root,755)
714 %dir %{_libdir}/ocaml/equeue-gtk1
715 %{_libdir}/ocaml/equeue-gtk1/*.cm[ixao]*
716 %{_libdir}/ocaml/equeue-gtk1/*.a
717 %{_libdir}/ocaml/site-lib/equeue-gtk1
718
719 %files equeue-gtk2-devel
720 %defattr(644,root,root,755)
721 %dir %{_libdir}/ocaml/equeue-gtk2
722 %{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
723 %{_libdir}/ocaml/equeue-gtk2/*.a
724 %{_libdir}/ocaml/site-lib/equeue-gtk2
725
726 %files equeue-ssl
727 %defattr(644,root,root,755)
728 %dir %{_libdir}/ocaml/equeue-ssl
729 %attr(755,root,root) %{_libdir}/ocaml/equeue-ssl/*.so
730
731 %files equeue-ssl-devel
732 %defattr(644,root,root,755)
733 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
734 %{_libdir}/ocaml/equeue-ssl/*.a
735 %{_libdir}/ocaml/site-lib/equeue-ssl
736
737 %files equeue-tcl
738 %defattr(644,root,root,755)
739 %dir %{_libdir}/ocaml/equeue-tcl
740 %attr(755,root,root) %{_libdir}/ocaml/equeue-tcl/*.so
741
742 %files equeue-tcl-devel
743 %defattr(644,root,root,755)
744 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
745 %{_libdir}/ocaml/equeue-tcl/*.a
746 %{_libdir}/ocaml/site-lib/equeue-tcl
747
748 %files netcamlbox-devel
749 %defattr(644,root,root,755)
750 %dir %{_libdir}/ocaml/netcamlbox
751 %{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
752 %{_libdir}/ocaml/netcamlbox/*.a
753 %{_libdir}/ocaml/site-lib/netcamlbox
754 %{_examplesdir}/%{name}-netcamlbox-%{version}
755
756 %files netclient-devel
757 %defattr(644,root,root,755)
758 %dir %{_libdir}/ocaml/netclient
759 %{_libdir}/ocaml/netclient/*.cm[ixao]*
760 %{_libdir}/ocaml/netclient/*.a
761 %{_libdir}/ocaml/site-lib/netclient
762 %{_examplesdir}/%{name}-netclient-%{version}
763
764 %files netgssapi-devel
765 %defattr(644,root,root,755)
766 %dir %{_libdir}/ocaml/netgssapi
767 %{_libdir}/ocaml/netgssapi/*.cm[ixao]*
768 %{_libdir}/ocaml/netgssapi/*.a
769 %{_libdir}/ocaml/site-lib/netgssapi
770
771 %files nethttpd-devel
772 %defattr(644,root,root,755)
773 %dir %{_libdir}/ocaml/nethttpd
774 %{_libdir}/ocaml/nethttpd/*.cm[ixa]*
775 %{_libdir}/ocaml/nethttpd/*.a
776 %{_libdir}/ocaml/site-lib/nethttpd
777 %{_examplesdir}/%{name}-nethttpd-%{version}
778
779 %files netmech-scram-devel
780 %defattr(644,root,root,755)
781 %dir %{_libdir}/ocaml/netmech-scram
782 %{_libdir}/ocaml/netmech-scram/*.cm[ixa]*
783 %{_libdir}/ocaml/netmech-scram/*.a
784 %{_libdir}/ocaml/site-lib/netmech-scram
785
786 %files netmulticore-devel
787 %defattr(644,root,root,755)
788 %dir %{_libdir}/ocaml/netmulticore
789 %{_libdir}/ocaml/netmulticore/*.cm[ixa]*
790 %{_libdir}/ocaml/netmulticore/*.a
791 %{_libdir}/ocaml/site-lib/netmulticore
792 %{_examplesdir}/%{name}-netmulticore-%{version}
793
794 %files netplex
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_bindir}/netplex-admin
797
798 %files netplex-devel
799 %defattr(644,root,root,755)
800 %dir %{_libdir}/ocaml/netplex
801 %{_libdir}/ocaml/netplex/netplex-packlist
802 %{_libdir}/ocaml/netplex/*.cm[ixao]*
803 %{_libdir}/ocaml/netplex/*.a
804 %{_libdir}/ocaml/netplex/*.o
805 %{_libdir}/ocaml/site-lib/netplex
806
807 %files netshm-devel
808 %defattr(644,root,root,755)
809 %dir %{_libdir}/ocaml/netshm
810 %{_libdir}/ocaml/netshm/*.cm[ixao]*
811 %{_libdir}/ocaml/netshm/*.a
812 %{_libdir}/ocaml/site-lib/netshm
813
814 %files netstring-devel
815 %defattr(644,root,root,755)
816 %dir %{_libdir}/ocaml/netstring
817 %{_libdir}/ocaml/netstring/netdb-packlist
818 %{_libdir}/ocaml/netstring/*.cm[ixao]*
819 %{_libdir}/ocaml/netstring/*.a
820 %{_libdir}/ocaml/netstring/*.o
821 %attr(755,root,root) %{_libdir}/ocaml/netstring/*.so
822 %{_libdir}/ocaml/site-lib/netstring
823
824 %files netsys
825 %defattr(644,root,root,755)
826 %dir %{_libdir}/ocaml/netsys
827 %attr(755,root,root) %{_libdir}/ocaml/netsys/*.so
828 %{_libdir}/ocaml/netsys/*.o
829
830 %files netsys-devel
831 %defattr(644,root,root,755)
832 %{_libdir}/ocaml/netsys/*.cm[ixao]*
833 %{_libdir}/ocaml/netsys/*.a
834 %{_libdir}/ocaml/site-lib/netsys
835
836 %files netzip-devel
837 %defattr(644,root,root,755)
838 %dir %{_libdir}/ocaml/netzip
839 %{_libdir}/ocaml/netzip/*.cm[ixao]*
840 %{_libdir}/ocaml/netzip/*.a
841 %{_libdir}/ocaml/site-lib/netzip
842
843 %files pop3-devel
844 %defattr(644,root,root,755)
845 %dir %{_libdir}/ocaml/pop
846 %{_libdir}/ocaml/pop/*.cm[ixao]*
847 %{_libdir}/ocaml/pop/*.a
848 %{_libdir}/ocaml/site-lib/pop
849 %{_examplesdir}/%{name}-pop3-%{version}
850
851 %files rpc
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_bindir}/ocamlrpcgen
854 %dir %{_libdir}/ocaml/rpc-auth-local
855 %attr(755,root,root) %{_libdir}/ocaml/rpc-auth-local/dllrpc_auth_local.so
856
857 %files rpc-devel
858 %defattr(644,root,root,755)
859 %dir %{_libdir}/ocaml/rpc
860 %dir %{_libdir}/ocaml/rpc-auth-dh
861 %dir %{_libdir}/ocaml/rpc-generator
862 %dir %{_libdir}/ocaml/rpc-ssl
863 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
864 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
865 %{_libdir}/ocaml/rpc*/*.a
866 %{_libdir}/ocaml/site-lib/rpc*
867 %{_examplesdir}/%{name}-rpc-%{version}
868
869 %files shell-devel
870 %defattr(644,root,root,755)
871 %dir %{_libdir}/ocaml/shell
872 %{_libdir}/ocaml/shell/*.cm[ixao]*
873 %{_libdir}/ocaml/shell/*.a
874 %{_libdir}/ocaml/site-lib/shell
875
876 %files smtp-devel
877 %defattr(644,root,root,755)
878 %dir %{_libdir}/ocaml/smtp
879 %{_libdir}/ocaml/smtp/*.cm[ixao]*
880 %{_libdir}/ocaml/smtp/*.a
881 %{_libdir}/ocaml/site-lib/smtp
This page took 0.105781 seconds and 2 git commands to generate.