]> git.pld-linux.org Git - packages/ocaml-camlp4.git/blob - ocaml-camlp4.spec
- new, separated from ocaml.spec after 4.01
[packages/ocaml-camlp4.git] / ocaml-camlp4.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         main_ver        4.02.1
6 %define         subver          1
7
8 %define         doc_ver         3.06
9
10 %define         module  camlp4
11 Summary:        Objective Caml Preprocessor
12 Summary(pl.UTF-8):      Preprocesor OCamla
13 Name:           ocaml-camlp4
14 Version:        %{main_ver}.%{subver}
15 Release:        1
16 Epoch:          1
17 License:        LGPL v2 with linking exception
18 Group:          Libraries
19 Source0:        https://github.com/ocaml/camlp4/archive/%{main_ver}+%{subver}/camlp4-%{version}.tar.gz
20 # Source0-md5:  8c19bcca52b92a5496dcbcbb931a988b
21 # following 4 URLs are dead, some version now available at http://pauillac.inria.fr/camlp4/
22 Source1:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{doc_ver}-manual.html.tar.gz
23 # Source1-md5:  21370bae4e7f6435b38aeb21db7ce8bb
24 Source2:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{doc_ver}-manual.dvi.gz
25 # Source2-md5:  035915d1a530aa7ec9b194d9a7d258eb
26 Source3:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{doc_ver}-tutorial.html.tar.gz
27 # Source3-md5:  96d8eb4ca5abd58c9a280ba59f73b192
28 Source4:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{doc_ver}-tutorial.dvi.gz
29 # Source4-md5:  fcd87c235109364242a0c9ccf176dff8
30 URL:            https://github.com/ocaml/camlp4
31 BuildRequires:  ocaml >= 1:4.02
32 %requires_eq    ocaml-runtime
33 Provides:       camlp4 = %{epoch}:%{version}-%{release}
34 Obsoletes:      camlp4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         debug_package   %{nil}
38
39 %description
40 Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
41 tools for syntax (grammars) and the ability to modify the concrete
42 syntax of the language (quotations, syntax extensions).
43
44 Camlp4 can parse normal Ocaml concrete syntax or any other
45 user-definable syntax. As an example, an alternative syntax is
46 provided, named revised, because it tries to fix some small problems
47 of the normal syntax.
48
49 Camlp4 can pretty print the normal Ocaml concrete syntax or the
50 revised one. It is therefore always possible to have a version of your
51 sources compilable by the Objective Caml compiler without
52 preprocessing.
53
54 %description -l pl.UTF-8
55 Camlp4 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
56 składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
57 języka (cytowania, rozszerzenia).
58
59 Camlp4 potrafi analizować oryginalną składnię Ocamla lub dowolną inną
60 definiowalną przez użytkownika. Jako przykład podana jest alternatywna
61 składnia (revised syntax), która próbuje poprawić drobne problemy
62 występujące w składni oryginalnej.
63
64 Camlp4 umie ładnie formatować źródła zarówno w oryginalnej jak i
65 poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
66 składni na drugą.
67
68 %package doc-html
69 Summary:        Objective Caml Preprocessor - HTML documentation 
70 Summary(pl.UTF-8):      Preprocesor OCamla - dokumentacja HTML 
71 Group:          Documentation
72
73 %description doc-html
74 Objective Caml Preprocessor - HTML documentation.
75
76 %description doc-html -l pl.UTF-8
77 Preprocesor OCamla - dokumentacja HTML.
78
79 %prep
80 %setup -q -n camlp4-%{main_ver}-%{subver} -a1 -a3
81
82 mkdir -p docs/html
83 mv camlp4-%{doc_ver}-manual.html docs/html/camlp4
84 cp %{SOURCE2} docs/camlp4.ps.gz
85 mv camlp4-%{doc_ver}-tutorial.html docs/html/camlp4-tutorial
86 cp %{SOURCE4} docs/camlp4-tutorial.ps.gz
87
88 %build
89 ./configure
90
91 %{__make} %{?with_opt:all}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
98         LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc CHANGES.md LICENSE README.md
106 %attr(755,root,root) %{_bindir}/camlp4*
107 %attr(755,root,root) %{_bindir}/mkcamlp4
108 %{_libdir}/ocaml/camlp4
109
110 %files doc-html
111 %defattr(644,root,root,755)
112 %doc docs/html/camlp4*
This page took 0.065205 seconds and 3 git commands to generate.