]> git.pld-linux.org Git - packages/ocaml-biniou.git/blob - ocaml-biniou.spec
- up to 1.0.9
[packages/ocaml-biniou.git] / ocaml-biniou.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         module  biniou
6 Summary:        Flexible binary data format in OCaml
7 Summary(pl.UTF-8):      Wiązania biniou dla OCamla
8 Name:           ocaml-%{module}
9 Version:        1.0.9
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://mjambon.com/releases/biniou/%{module}-%{version}.tar.gz
14 # Source0-md5:  2f9f355281817912ac04c589eb463ef2
15 URL:            http://martin.jambon.free.fr/biniou.html
16 BuildRequires:  ocaml >= 3.04-7
17 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
18 BuildRequires:  ocaml-findlib >= 1.4
19 %requires_eq    ocaml-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         debug_package   %{nil}
23
24 %description
25 Biniou is a binary data format designed for speed, safety, ease of use
26 and backward compatibility as protocols evolve. Biniou is vastly
27 equivalent to JSON in terms of functionality but allows
28 implementations about 4 times as fast (see godi-yojson for
29 comparison), with 25-35% space savings. Biniou data can be decoded
30 into human-readable form without knowledge of type definitions except
31 for field and variant names which are represented by 31-bit hashes.
32
33 %description -l pl.UTF-8
34 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
35 używających tej biblioteki.
36
37 %package devel
38 Summary:        biniou binding for OCaml - development part
39 Summary(pl.UTF-8):      Wiązania biniou dla OCamla - cześć programistyczna
40 Group:          Development/Libraries
41 %requires_eq    ocaml
42
43 %description devel
44 This package contains files needed to develop OCaml programs using
45 this library.
46
47 %description devel -l pl.UTF-8
48 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
49 tej biblioteki.
50
51 %prep
52 %setup -q -n %{module}-%{version}
53
54 %build
55 %{__make} -j1 all %{?with_opt:opt} \
56         CC="%{__cc} %{rpmcflags} -fPIC"
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/ocaml}
61 %{__make} install \
62         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
63         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 # move to dir pld ocamlfind looks
67 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
68 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/{,site-lib/}%{module}/META
69 cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}/META
70 directory="+%{module}"
71 EOF
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files devel
77 %defattr(644,root,root,755)
78 %doc LICENSE
79 %dir %{_libdir}/ocaml/%{module}
80 %{_libdir}/ocaml/%{module}/*.cm[ix]
81 %{_libdir}/ocaml/%{module}/*.cm[ao]
82 %{_libdir}/ocaml/%{module}/*.mli
83 %if %{with opt}
84 %attr(755,root,root) %{_bindir}/bdump
85 %{_libdir}/ocaml/%{module}/*.[ao]
86 %{_libdir}/ocaml/%{module}/*.cmxa
87 %endif
88 %{_libdir}/ocaml/site-lib/%{module}
This page took 0.141463 seconds and 3 git commands to generate.