]> git.pld-linux.org Git - packages/ocaml-biniou.git/blob - ocaml-biniou.spec
- added missing deps
[packages/ocaml-biniou.git] / ocaml-biniou.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         module  biniou
6 Summary:        Flexible binary data format in OCaml
7 Summary(pl.UTF-8):      Wiązania biniou dla OCamla
8 Name:           ocaml-%{module}
9 Version:        1.0.9
10 Release:        2
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://mjambon.com/releases/biniou/%{module}-%{version}.tar.gz
14 # Source0-md5:  2f9f355281817912ac04c589eb463ef2
15 URL:            http://martin.jambon.free.fr/biniou.html
16 BuildRequires:  ocaml >= 3.04-7
17 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
18 BuildRequires:  ocaml-findlib >= 1.4
19 %requires_eq    ocaml-runtime
20 Requires:       ocaml-easy-format >= 1.0.1
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         debug_package   %{nil}
24
25 %description
26 Biniou is a binary data format designed for speed, safety, ease of use
27 and backward compatibility as protocols evolve. Biniou is vastly
28 equivalent to JSON in terms of functionality but allows
29 implementations about 4 times as fast (see godi-yojson for
30 comparison), with 25-35% space savings. Biniou data can be decoded
31 into human-readable form without knowledge of type definitions except
32 for field and variant names which are represented by 31-bit hashes.
33
34 %description -l pl.UTF-8
35 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
36 używających tej biblioteki.
37
38 %package devel
39 Summary:        biniou binding for OCaml - development part
40 Summary(pl.UTF-8):      Wiązania biniou dla OCamla - cześć programistyczna
41 Group:          Development/Libraries
42 %requires_eq    ocaml
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       ocaml-easy-format-devel >= 1.0.1
45
46 %description devel
47 This package contains files needed to develop OCaml programs using
48 this library.
49
50 %description devel -l pl.UTF-8
51 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
52 tej biblioteki.
53
54 %prep
55 %setup -q -n %{module}-%{version}
56
57 %build
58 %{__make} -j1 all %{?with_opt:opt} \
59         CC="%{__cc} %{rpmcflags} -fPIC"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/ocaml}
64 %{__make} install \
65         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
66         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 # move to dir pld ocamlfind looks
70 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
71 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/{,site-lib/}%{module}/META
72 cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}/META
73 directory="+%{module}"
74 EOF
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %dir %{_libdir}/ocaml/%{module}
82 %{_libdir}/ocaml/%{module}/*.cmxs
83 %{_libdir}/ocaml/site-lib/%{module}
84
85 %files devel
86 %defattr(644,root,root,755)
87 %doc LICENSE
88 %{_libdir}/ocaml/%{module}/*.cm[ix]
89 %{_libdir}/ocaml/%{module}/*.cm[ao]
90 %{_libdir}/ocaml/%{module}/*.mli
91 %if %{with opt}
92 %attr(755,root,root) %{_bindir}/bdump
93 %{_libdir}/ocaml/%{module}/*.[ao]
94 %{_libdir}/ocaml/%{module}/*.cmxa
95 %endif
This page took 0.110866 seconds and 3 git commands to generate.