]> git.pld-linux.org Git - packages/ocaml-benchmark.git/blob - ocaml-benchmark.spec
- use arm macro, ocaml epoch, updated docs, check-files cleanup
[packages/ocaml-benchmark.git] / ocaml-benchmark.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
6 %undefine       with_ocaml_opt
7 %endif
8
9 %define         _enable_debug_packages  0
10
11 Summary:        Benchmark - measure/compare run-time of OCaml functions
12 Summary(pl.UTF-8):      Biblioteka benchmark - mierzenie i porównywanie czasu działania funkcji ocamlowych
13 Name:           ocaml-benchmark
14 Version:        1.6
15 Release:        2
16 License:        LGPL v3 with linking exception
17 Group:          Development/Languages
18 #Source0Download: https://github.com/Chris00/ocaml-benchmark/releases
19 Source0:        https://github.com/Chris00/ocaml-benchmark/archive/%{version}/benchmark-%{version}.tar.gz
20 # Source0-md5:  3e716610143aeda29bace893ae3b056b
21 URL:            https://github.com/Chris00/ocaml-benchmark
22 BuildRequires:  ocaml >= 1:3.12.0
23 BuildRequires:  ocaml-camlp4
24 BuildRequires:  ocaml-dune
25 BuildRequires:  ocaml-findlib
26 %requires_eq    ocaml
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Benchmark provides functions to measure and compare the run-time of
31 OCaml functions. It is inspired by the Perl module of the same name.
32
33 %description -l pl.UTF-8
34 Biblioteka benchmark dostarcza funkcje do mierzenia i porównywania
35 czasu działania funkcji ocamlowych. Została zainspirowana modułem
36 Perla o tej samej nazwie.
37
38 %prep
39 %setup -q
40
41 %build
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 dune install \
48         --destdir $RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 # packaged as %doc
54 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/benchmark
55 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/benchmark/benchmark.mli
56 # sources
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/benchmark/benchmark.ml
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGES.md README.md src/benchmark.mli
65 %dir %{_libdir}/ocaml/benchmark
66 %{_libdir}/ocaml/benchmark/META
67 %{_libdir}/ocaml/benchmark/benchmark.cma
68 %{_libdir}/ocaml/benchmark/benchmark.cmi
69 %{_libdir}/ocaml/benchmark/benchmark.cmt
70 %{_libdir}/ocaml/benchmark/benchmark.cmti
71 %if %{with ocaml_opt}
72 %{_libdir}/ocaml/benchmark/benchmark.a
73 %{_libdir}/ocaml/benchmark/benchmark.cmx
74 %{_libdir}/ocaml/benchmark/benchmark.cmxa
75 %attr(755,root,root) %{_libdir}/ocaml/benchmark/benchmark.cmxs
76 %endif
77 %{_libdir}/ocaml/benchmark/dune-package
78 %{_libdir}/ocaml/benchmark/opam
79 %{_examplesdir}/%{name}-%{version}
This page took 0.069542 seconds and 3 git commands to generate.