]> git.pld-linux.org Git - packages/oc.git/blob - oc.spec
- new
[packages/oc.git] / oc.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform tests (requires network)
4 #
5 Summary:        The OPeNDAP C DAP2 library (client-side only)
6 Summary(pl.UTF-8):      Biblioteka OPeNDAP DAP2 dla C (tylko strona kliencka)
7 Name:           oc
8 Version:        2.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://www.opendap.org/pub/OC/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  488963bc74053674da4fc88bc13b6264
14 Patch0:         %{name}-libdir.patch
15 URL:            http://opendap.org/oc/
16 BuildRequires:  autoconf >= 2.62
17 BuildRequires:  automake
18 BuildRequires:  bison
19 BuildRequires:  curl-devel >= 7.16.4
20 BuildRequires:  libtool
21 BuildRequires:  ncurses-devel
22 BuildRequires:  readline-devel
23 Requires:       curl >= 7.16.4
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The OPeNDAP C API (OC) provides a set of C-language type definitions
28 and functions that can be used to retrieve data over the Internet from
29 servers that implement the OPeNDAP Data Access Protocol (DAP). The OC
30 implementation provides a low-overhead way to retrieve this data,
31 making it practical to include OPeNDAP capability in relatively simple
32 software.
33
34 %description -l pl.UTF-8
35 OPeNDAP C API (OC) zawiera zbiór definicji typów i funkcji języka C
36 przeznaczonych do pobierania danych poprzez Internet z serwerów
37 implementujących protokół OPeNDAP Data Access Protocol (DAP).
38 Implementacja OC daje możliwość pobierania tych danych z małym
39 narzutem, czyniąc praktycznym wbudowanie obsługi OPeNDAP w stosunkowo
40 proste oprogramowanie.
41
42 %package devel
43 Summary:        Header files for OC library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OC
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       curl-devel >= 7.16.4
48
49 %description devel
50 Header files for OC library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki OC.
54
55 %package static
56 Summary:        Static OC library
57 Summary(pl.UTF-8):      Statyczna biblioteka OC
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static OC library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka OC.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %{__libtoolize}
73 %{__aclocal} -I conf
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure
78 %{__make}
79
80 %{?with_tests:%{__make} check}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog README RELEASE_NOTES
97 %attr(755,root,root) %{_bindir}/ocprint
98 %attr(755,root,root) %{_libdir}/liboc.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/liboc.so.1
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/oc-config
104 %attr(755,root,root) %{_libdir}/liboc.so
105 %{_libdir}/liboc.la
106 %{_includedir}/oc
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/liboc.a
This page took 0.08289 seconds and 3 git commands to generate.