]> git.pld-linux.org Git - packages/nuget.git/blob - nuget.spec
848bdeca1b87e1cf275d571c070ede72aedbd3ba
[packages/nuget.git] / nuget.spec
1 Summary:        Package manager for .NET/Mono development platform
2 Summary(pl.UTF-8):      Zarządca pakietów dla platformy programistycznej .NET/Mono
3 Name:           nuget
4 Version:        2.8.7
5 Release:        1
6 License:        Apache v2.0
7 Group:          Development/Tools
8 %define veradd  md510+dhx1
9 #Source0:       http://download.mono-project.com/sources/nuget/%{name}_%{version}+%{veradd}.orig.tar.bz2
10 Source0:        https://launchpad.net/ubuntu/+archive/primary/+files/%{name}_%{version}+%{veradd}.orig.tar.bz2
11 # Source0-md5:  0fe8090470bf35f44f705c94d7150037
12 Source1:        %{name}-core.pc
13 Source2:        %{name}.sh
14 Patch0:         %{name}-fix_xdt_hintpath
15 URL:            http://nuget.org/
16 BuildRequires:  mono-devel >= 4.0
17 BuildRequires:  sed >= 4.0
18 Requires:       dotnet-nuget = %{version}-%{release}
19 ExclusiveArch:  %{ix86} %{x8664} arm aarch64 ia64 mips ppc ppc64 s390x sparc sparcv9 sparc64
20 ExcludeArch:    i386
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 NuGet is the package manager for the Microsoft development platform
25 including .NET. The NuGet client tools provide the ability to produce
26 and consume packages. The NuGet Gallery is the central package
27 repository used by all package authors and consumers.
28
29 %description -l pl.UTF-8
30 NuGet to zarządca pakietów dla platformy programistycznej platformy
31 Microsoft, w tym .NET. Narzędzia klienckie NuGet pozwalają produkować
32 i konsumować pakiety. NuGet Gallery to centralne repozytorium pakietów
33 używane przez wszystkich autorów i konsumentów pakietów.
34
35 %package -n dotnet-nuget
36 Summary:        NuGet package manager library for .NET
37 Summary(pl.UTF-8):      Biblioteka zarządców pakietów NuGet dla .NET
38 Group:          Libraries
39 Requires:       mono >= 4.0
40
41 %description -n dotnet-nuget
42 NuGet package manager library for .NET.
43
44 %description -n dotnet-nuget -l pl.UTF-8
45 Biblioteka zarządców pakietów NuGet dla .NET.
46
47 %package -n dotnet-nuget-devel
48 Summary:        Development files for NuGet .NET library
49 Summary(pl.UTF-8):      Pliki programistyczne biblioteki .NET NuGet
50 Group:          Development/Libraries
51 Requires:       dotnet-nuget = %{version}-%{release}
52 Obsoletes:      nuget-devel
53
54 %description -n dotnet-nuget-devel
55 Development files for NuGet .NET library.
56
57 %description -n dotnet-nuget-devel -l pl.UTF-8
58 Pliki programistyczne biblioteki .NET NuGet.
59
60 %prep
61 %setup -qn %{name}-git
62 %{__sed} -i "s/\r//g" src/Core/Core.csproj
63 %patch0 -p1
64
65 # fix compile with Mono4
66 find . -name "*.csproj" -print -exec sed -i 's#ToolsVersion="3.5"#ToolsVersion="4.0"#g; s#<TargetFrameworkVersion>.*</TargetFrameworkVersion>##g; s#<PropertyGroup>#<PropertyGroup><TargetFrameworkVersion>v4.5</TargetFrameworkVersion>#g' {} \;
67
68 %build
69 xbuild xdt/XmlTransform/Microsoft.Web.XmlTransform.csproj
70 xbuild src/Core/Core.csproj /p:Configuration="Mono Release"
71 xbuild src/CommandLine/CommandLine.csproj /p:Configuration="Mono Release"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pkgconfigdir},%{_prefix}/lib/mono/nuget}
76
77 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pkgconfigdir}/nuget-core.pc
78 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/nuget
79
80 cp -p src/CommandLine/bin/Release/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
81 cp -p xdt/XmlTransform/bin/Debug/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
82 cp -p src/CommandLine/bin/Release/NuGet.exe $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc COPYRIGHT.txt CREDITS.txt acknowledgements.md changelog.md
90 %attr(755,root,root) %{_bindir}/nuget
91 %{_prefix}/lib/mono/nuget/NuGet.exe
92
93 %files -n dotnet-nuget
94 %defattr(644,root,root,755)
95 %dir %{_prefix}/lib/mono/nuget
96 %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll
97 %{_prefix}/lib/mono/nuget/NuGet.Core.dll
98
99 %files -n dotnet-nuget-devel
100 %defattr(644,root,root,755)
101 %{_pkgconfigdir}/nuget-core.pc
This page took 0.055399 seconds and 2 git commands to generate.