]> git.pld-linux.org Git - packages/nuget.git/blob - nuget.spec
- use mono autodeps
[packages/nuget.git] / nuget.spec
1 %include        /usr/lib/rpm/macros.mono
2 Summary:        Package manager for .NET/Mono development platform
3 Summary(pl.UTF-8):      Zarządca pakietów dla platformy programistycznej .NET/Mono
4 Name:           nuget
5 Version:        2.8.7
6 Release:        1
7 License:        Apache v2.0
8 Group:          Development/Tools
9 %define veradd  md510+dhx1
10 #Source0:       http://download.mono-project.com/sources/nuget/%{name}_%{version}+%{veradd}.orig.tar.bz2
11 Source0:        https://launchpad.net/ubuntu/+archive/primary/+files/%{name}_%{version}+%{veradd}.orig.tar.bz2
12 # Source0-md5:  0fe8090470bf35f44f705c94d7150037
13 Source1:        %{name}-core.pc
14 Source2:        %{name}.sh
15 Patch0:         %{name}-fix_xdt_hintpath
16 URL:            http://nuget.org/
17 BuildRequires:  mono-devel >= 4.0
18 BuildRequires:  rpmbuild(monoautodeps)
19 BuildRequires:  sed >= 4.0
20 Requires:       dotnet-nuget = %{version}-%{release}
21 ExclusiveArch:  %{ix86} %{x8664} arm aarch64 ia64 mips ppc ppc64 s390x sparc sparcv9 sparc64
22 ExcludeArch:    i386
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 NuGet is the package manager for the Microsoft development platform
27 including .NET. The NuGet client tools provide the ability to produce
28 and consume packages. The NuGet Gallery is the central package
29 repository used by all package authors and consumers.
30
31 %description -l pl.UTF-8
32 NuGet to zarządca pakietów dla platformy programistycznej platformy
33 Microsoft, w tym .NET. Narzędzia klienckie NuGet pozwalają produkować
34 i konsumować pakiety. NuGet Gallery to centralne repozytorium pakietów
35 używane przez wszystkich autorów i konsumentów pakietów.
36
37 %package -n dotnet-nuget
38 Summary:        NuGet package manager library for .NET
39 Summary(pl.UTF-8):      Biblioteka zarządców pakietów NuGet dla .NET
40 Group:          Libraries
41 Requires:       mono >= 4.0
42
43 %description -n dotnet-nuget
44 NuGet package manager library for .NET.
45
46 %description -n dotnet-nuget -l pl.UTF-8
47 Biblioteka zarządców pakietów NuGet dla .NET.
48
49 %package -n dotnet-nuget-devel
50 Summary:        Development files for NuGet .NET library
51 Summary(pl.UTF-8):      Pliki programistyczne biblioteki .NET NuGet
52 Group:          Development/Libraries
53 Requires:       dotnet-nuget = %{version}-%{release}
54 Obsoletes:      nuget-devel
55
56 %description -n dotnet-nuget-devel
57 Development files for NuGet .NET library.
58
59 %description -n dotnet-nuget-devel -l pl.UTF-8
60 Pliki programistyczne biblioteki .NET NuGet.
61
62 %prep
63 %setup -qn %{name}-git
64 %{__sed} -i "s/\r//g" src/Core/Core.csproj
65 %patch0 -p1
66
67 # fix compile with Mono4
68 find . -name "*.csproj" -print -exec sed -i 's#ToolsVersion="3.5"#ToolsVersion="4.0"#g; s#<TargetFrameworkVersion>.*</TargetFrameworkVersion>##g; s#<PropertyGroup>#<PropertyGroup><TargetFrameworkVersion>v4.5</TargetFrameworkVersion>#g' {} \;
69
70 %build
71 xbuild xdt/XmlTransform/Microsoft.Web.XmlTransform.csproj
72 xbuild src/Core/Core.csproj /p:Configuration="Mono Release"
73 xbuild src/CommandLine/CommandLine.csproj /p:Configuration="Mono Release"
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pkgconfigdir},%{_prefix}/lib/mono/nuget}
78
79 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pkgconfigdir}/nuget-core.pc
80 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/nuget
81
82 cp -p src/CommandLine/bin/Release/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
83 cp -p xdt/XmlTransform/bin/Debug/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
84 cp -p src/CommandLine/bin/Release/NuGet.exe $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc COPYRIGHT.txt CREDITS.txt acknowledgements.md changelog.md
92 %attr(755,root,root) %{_bindir}/nuget
93 %{_prefix}/lib/mono/nuget/NuGet.exe
94
95 %files -n dotnet-nuget
96 %defattr(644,root,root,755)
97 %dir %{_prefix}/lib/mono/nuget
98 %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll
99 %{_prefix}/lib/mono/nuget/NuGet.Core.dll
100
101 %files -n dotnet-nuget-devel
102 %defattr(644,root,root,755)
103 %{_pkgconfigdir}/nuget-core.pc
This page took 0.079278 seconds and 3 git commands to generate.