]> git.pld-linux.org Git - packages/ntrack.git/blob - ntrack.spec
e09b8e51831c763d70acb802e2a0ee77726dc16b
[packages/ntrack.git] / ntrack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make check"
4 #
5 %define         file_ver        %(echo %{version} | tr -d .)
6 Summary:        Network status tracking made easy for desktop applications
7 Summary(pl.UTF-8):      Łatwe śledzenie stanu sieci dla aplikacji użytkowych
8 Name:           ntrack
9 Version:        0.16
10 Release:        4.1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        http://launchpad.net/ntrack/main/016/+download/%{name}-%{file_ver}.tar.gz
14 # Source0-md5:  21691dac43460a6791cba3decbc68242
15 Patch0:         %{name}-am.patch
16 URL:            http://launchpad.net/ntrack
17 BuildRequires:  QtCore-devel >= 4
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  glib2-devel >= 2.0
21 BuildRequires:  libnl-devel >= 1:3.2.3
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-devel >= 2.3.5
25 BuildRequires:  python-pygobject-devel >= 2.0
26 BuildRequires:  qt4-build >= 4
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.600
29 BuildConflicts: libnl1-devel
30 Requires:       libnl >= 1:3.2.3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ntrack aims to be a lightweight and easy to use library for
35 application developers that want to get events on network online
36 status changes such as online, offline or route changes.
37
38 %description -l pl.UTF-8
39 Projekt ntrack ma na celu dostarczenie lekkiej i łatwej w użyciu
40 biblioteki dla programistów aplikacji chcących otrzymywać zdarzenia
41 przy zmianach stanu podłączenia do sieci, tzn. podłączenia, odłączenia
42 lub zmianach trasowania.
43
44 %package devel
45 Summary:        Header files for ntrack library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ntrack
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       %{name}-qt4 = %{version}-%{release}
50
51 %description devel
52 Header files for ntrack library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki ntrack.
56
57 %package static
58 Summary:        Static ntrack library
59 Summary(pl.UTF-8):      Statyczna biblioteka ntrack
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static ntrack library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka ntrack.
68
69 %package glib
70 Summary:        GLib 2 and GObject bindings for ntrack library
71 Summary(pl.UTF-8):      Wiązania GLib 2 i GObject do biblioteki ntrack
72 Group:          Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description glib
76 GLib 2 and GObject bindings for ntrack library.
77
78 %description glib -l pl.UTF-8
79 Wiązania GLib 2 i GObject do biblioteki ntrack.
80
81 %package glib-devel
82 Summary:        GLib 2 and GObject bindings for ntrack library - header files
83 Summary(pl.UTF-8):      Wiązania GLib 2 i GObject do biblioteki ntrack - pliki nagłówkowe
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       %{name}-glib = %{version}-%{release}
87
88 %description glib-devel
89 GLib 2 and GObject bindings for ntrack library - header files.
90
91 %description glib-devel -l pl.UTF-8
92 Wiązania GLib 2 i GObject do biblioteki ntrack - pliki nagłówkowe.
93
94 %package glib-static
95 Summary:        GLib 2 and GObject bindings for ntrack library - static libraries
96 Summary(pl.UTF-8):      Wiązania GLib 2 i GObject do biblioteki ntrack - biblioteki statyczne
97 Group:          Development/Libraries
98 Requires:       %{name}-glib-devel = %{version}-%{release}
99
100 %description glib-static
101 GLib 2 and GObject bindings for ntrack library - static libraries.
102
103 %description glib-static -l pl.UTF-8
104 Wiązania GLib 2 i GObject do biblioteki ntrack - biblioteki statyczne.
105
106 %package qt4
107 Summary:        Qt4 bindings for ntrack library
108 Summary(pl.UTF-8):      Wiązania Qt4 do biblioteki ntrack
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description qt4
113 Qt4 bindings for ntrack library.
114
115 %description qt4 -l pl.UTF-8
116 Wiązania Qt4 do biblioteki ntrack.
117
118 %package qt4-devel
119 Summary:        Qt4 bindings for ntrack library - header files
120 Summary(pl.UTF-8):      Wiązania Qt4 do biblioteki ntrack - pliki nagłówkowe
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123 Requires:       %{name}-qt4 = %{version}-%{release}
124
125 %description qt4-devel
126 Qt4 bindings for ntrack library - header files.
127
128 %description qt4-devel -l pl.UTF-8
129 Wiązania Qt4 do biblioteki ntrack - pliki nagłówkowe.
130
131 %package qt4-static
132 Summary:        Qt4 bindings for ntrack library - static library
133 Summary(pl.UTF-8):      Wiązania Qt4 do biblioteki ntrack - biblioteka statyczna
134 Group:          Development/Libraries
135 Requires:       %{name}-qt4-devel = %{version}-%{release}
136
137 %description qt4-static
138 Qt4 bindings for ntrack library - static library.
139
140 %description qt4-static -l pl.UTF-8
141 Wiązania Qt4 do biblioteki ntrack - biblioteka statyczna.
142
143 %package -n python-ntrack
144 Summary:        Python bindings for ntrack library
145 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki ntrack
146 Group:          Libraries/Python
147 Requires:       %{name} = %{version}-%{release}
148
149 %description -n python-ntrack
150 Python bindings for ntrack library.
151
152 %description -n python-ntrack -l pl.UTF-8
153 Wiązania Pythona do biblioteki ntrack.
154
155 %prep
156 %setup -q -n %{name}-%{file_ver}
157 %patch0 -p1
158
159 %build
160 %{__libtoolize}
161 %{__aclocal}
162 %{__autoconf}
163 %{__autoheader}
164 %{__automake}
165 CFLAGS="%{rpmcflags} -std=c99 -D_GNU_SOURCE=1"
166 %configure
167
168 %{__make}
169
170 %{?with_tests:%{__make} -j1 check}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 %{__make} -j1 install \
175         DESTDIR=$RPM_BUILD_ROOT
176
177 # obsoleted by pkg-config
178 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
179 # loadable modules
180 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ntrack/modules/ntrack-*.{la,a} \
181         $RPM_BUILD_ROOT%{py_sitedir}/pyntrack.{la,a}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post   -p /sbin/ldconfig
187 %postun -p /sbin/ldconfig
188
189 %post   glib -p /sbin/ldconfig
190 %postun glib -p /sbin/ldconfig
191
192 %post   qt4 -p /sbin/ldconfig
193 %postun qt4 -p /sbin/ldconfig
194
195 %files
196 %defattr(644,root,root,755)
197 %doc AUTHORS ChangeLog NEWS README
198 %attr(755,root,root) %{_libdir}/libntrack.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libntrack.so.0
200 %dir %{_libdir}/ntrack
201 %dir %{_libdir}/ntrack/modules
202 %attr(755,root,root) %{_libdir}/ntrack/modules/ntrack-libnl3_x.so
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libntrack.so
207 %dir %{_includedir}/ntrack
208 %{_includedir}/ntrack/common
209 %{_pkgconfigdir}/libntrack.pc
210
211 %files static
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libntrack.a
214
215 %files glib
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libntrack-glib.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libntrack-glib.so.2
219 %attr(755,root,root) %{_libdir}/libntrack-gobject.so.*.*.*
220 %attr(755,root,root) %ghost %{_libdir}/libntrack-gobject.so.1
221
222 %files glib-devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libntrack-glib.so
225 %attr(755,root,root) %{_libdir}/libntrack-gobject.so
226 %{_includedir}/ntrack/glib
227 %{_includedir}/ntrack/gobject
228 %{_pkgconfigdir}/libntrack-glib.pc
229 %{_pkgconfigdir}/libntrack-gobject.pc
230
231 %files glib-static
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/libntrack-glib.a
234 %attr(755,root,root) %{_libdir}/libntrack-gobject.a
235
236 %files qt4
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/libntrack-qt4.so.*.*.*
239 %attr(755,root,root) %ghost %{_libdir}/libntrack-qt4.so.1
240
241 %files qt4-devel
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/libntrack-qt4.so
244 %{_pkgconfigdir}/libntrack-qt4.pc
245 %{_includedir}/ntrack/qt4
246
247 %files qt4-static
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_libdir}/libntrack-qt4.a
250
251 %files -n python-ntrack
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{py_sitedir}/pyntrack.so
This page took 0.085025 seconds and 2 git commands to generate.