]> git.pld-linux.org Git - packages/npth.git/blob - npth.spec
- updated to 1.2
[packages/npth.git] / npth.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        nPth - New GNU Portable Threads Library
6 Summary(pl.UTF-8):      nPth - nowa przenośna biblioteka wątków GNU
7 Name:           npth
8 Version:        1.2
9 Release:        1
10 License:        LGPL v3+ or GPL v2+
11 Group:          Libraries
12 Source0:        ftp://ftp.gnupg.org/gcrypt/npth/%{name}-%{version}.tar.bz2
13 # Source0-md5:  226bac7374b9466c6ec26b1c34dab844
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 nPth is the New GNU Portable Threads Library. This is a library to
18 provide the GNU Pth API and thus a non-preemptive threads
19 implementation.
20
21 In contrast to GNU Pth it is based on the system's standard threads
22 implementation. This allows the use of libraries which are not
23 compatible to GNU Pth. Experience with a Windows Pth emulation showed
24 that this is a solid way to provide a co-routine based framework.
25
26 %description -l pl.UTF-8
27 nPth (New GNU Portable Threads Library) to nowa przenośna biblioteka
28 wątków GNU. Jej celem jest dostarczenie API GNU Pth, a tym samym
29 implementacji niewywłaszczalnych wątków.
30
31 W przeciwieństwie do GNU Pth jest oparta na standardowej systemowej
32 implementacji wątków. Pozwala to na używanie bibliotek
33 niekompatybilnych z GNU Pth (doświadczenia z emulacją Pth na Windows
34 pokazały, że to jest solidna metoda zapewnienia szkieletu opartego na
35 korutynach).
36
37 %package devel
38 Summary:        Header files for nPth library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki nPth
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for nPth library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki nPth.
48
49 %package static
50 Summary:        Static nPth library
51 Summary(pl.UTF-8):      Statyczna biblioteka nPth
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static nPth library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka nPth.
60
61 %prep
62 %setup -q
63
64 %build
65 %configure \
66         %{?with_static_libs:--enable-static}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog NEWS README
84 %attr(755,root,root) %{_libdir}/libnpth.so.*.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libnpth.so.0
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/npth-config
90 %attr(755,root,root) %{_libdir}/libnpth.so
91 %{_libdir}/libnpth.la
92 %{_includedir}/npth.h
93 %{_aclocaldir}/npth.m4
94
95 %if %{with static_libs}
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libnpth.a
99 %endif
This page took 0.081297 seconds and 3 git commands to generate.