]> git.pld-linux.org Git - packages/nomacs.git/blob - nomacs.spec
- up to 3.12
[packages/nomacs.git] / nomacs.spec
1 # TODO: add plugins (https://github.com/nomacs/nomacs-plugins/)
2 Summary:        Lightweight image viewer
3 Summary(pl.UTF-8):      Lekka przeglądarka obrazków
4 Name:           nomacs
5 Version:        3.12
6 Release:        1
7 License:        GPL v3+
8 Group:          X11/Applications
9 Source0:        https://github.com/nomacs/nomacs/archive/%{version}/%{name}-%{version}-source.tar.gz
10 # Source0-md5:  7b2160cbcf907ee080d696c61b3dc4e8
11 Patch0:         %{name}-libqpsd.patch
12 URL:            http://nomacs.org/
13 BuildRequires:  Qt5Concurrent-devel >= 5.2.1
14 BuildRequires:  Qt5Core-devel >= 5.2.1
15 BuildRequires:  Qt5Gui-devel >= 5.2.1
16 BuildRequires:  Qt5Network-devel >= 5.2.1
17 BuildRequires:  Qt5Svg-devel >= 5.2.1
18 BuildRequires:  cmake >= 2.8
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  dos2unix
21 BuildRequires:  exiv2-devel >= 0.25
22 BuildRequires:  libqpsd-qt5-devel
23 BuildRequires:  libraw-devel >= 0.17
24 BuildRequires:  libstdc++-devel >= 6:4.3
25 BuildRequires:  libtiff-devel
26 BuildRequires:  libtiff-cxx-devel
27 BuildRequires:  libwebp-devel >= 0.3.1
28 BuildRequires:  opencv-devel >= 2.4.6
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt5-build >= 5.2.1
31 BuildRequires:  qt5-linguist >= 5.2.1
32 BuildRequires:  qt5-qmake >= 5.2.1
33 BuildRequires:  quazip-qt5-devel >= 0.7
34 Requires:       Qt5Concurrent >= 5.2.1
35 Requires:       Qt5Core >= 5.2.1
36 Requires:       Qt5Gui >= 5.2.1
37 Requires:       Qt5Network >= 5.2.1
38 Requires:       Qt5Svg >= 5.2.1
39 Requires:       exiv2-libs >= 0.25
40 Requires:       libraw >= 0.17
41 Requires:       opencv >= 2.4.6
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         skip_post_check_so      libnomacsCore.so.*
45 %description
46 nomacs is image viewer based on Qt library.
47
48 nomacs is small, fast and able to handle the most common image
49 formats. Additionally it is possible to synchronize multiple viewers
50 running on the same computer or via LAN is possible. It allows to
51 compare images and spot the differences e.g. schemes of architects to
52 show the progress).
53
54 %description -l pl.UTF-8
55 nomacs to przeglądarka obrazków oparta na bibliotece Qt.
56
57 nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
58 formatów obrazów. Ponadto możliwa jest synchronizacja wielu
59 przeglądarek działających na tym samym komputerze lub poprzez sieć
60 lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
61 np. projekty architektów w celu pokazania postępów.
62
63 %prep
64 %setup -q
65 cd ImageLounge
66 %patch0 -p1
67
68 %{__rm} -r 3rdparty/libqpsd
69
70 %build
71 install -d build
72 cd build
73 %cmake ../ImageLounge \
74         -DENABLE_PLUGINS=ON \
75         -DENABLE_RAW=1 \
76         -DUSE_SYSTEM_LIBQPSD=ON \
77         -DUSE_SYSTEM_QUAZIP=ON \
78         -DUSE_SYSTEM_WEBP=ON
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} -C build install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # API not exported, so keep only library files + soname symlinks
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnomacs*.so
90
91 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 /sbin/ldconfig
98 %update_desktop_database
99
100 %postun
101 /sbin/ldconfig
102 %update_desktop_database
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ImageLounge/Readme/{COPYRIGHT,LICENSE.OPENCV,README}
107 %attr(755,root,root) %{_bindir}/nomacs
108 %attr(755,root,root) %{_libdir}/libnomacsCore.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libnomacsCore.so.3
110 %{_mandir}/man1/nomacs.1*
111 %dir %{_datadir}/%{name}
112 %{_datadir}/%{name}/Image*
113 %{_datadir}/metainfo/nomacs.appdata.xml
114 %{_desktopdir}/nomacs.desktop
115 %{_pixmapsdir}/nomacs.svg
This page took 0.120763 seconds and 4 git commands to generate.