]> git.pld-linux.org Git - packages/nomacs.git/blob - nomacs.spec
ff0f0866aa433af888b8cb7ff9bf6ef4cb46a024
[packages/nomacs.git] / nomacs.spec
1 # TODO: system qpsd (http://sourceforge.net/projects/libqpsd/)
2 #
3 Summary:        Lightweight image viewer
4 Summary(pl.UTF-8):      Lekka przeglądarka obrazków
5 Name:           nomacs
6 Version:        3.4.1
7 Release:        1
8 License:        GPL v3+
9 Group:          X11/Applications
10 Source0:        https://github.com/nomacs/nomacs/archive/%{version}/%{name}-%{version}-source.tar.gz
11 # Source0-md5:  1daf7458717eb545b2da8534cff36d6e
12 Source1:        %{name}.appdata.xml
13 Patch0:         quazip-qt5.patch
14 URL:            http://nomacs.org/
15 BuildRequires:  Qt5Concurrent-devel >= 5.2.1
16 BuildRequires:  Qt5Core-devel >= 5.2.1
17 BuildRequires:  Qt5Gui-devel >= 5.2.1
18 BuildRequires:  Qt5Network-devel >= 5.2.1
19 BuildRequires:  Qt5Svg-devel >= 5.2.1
20 BuildRequires:  cmake >= 2.8
21 BuildRequires:  desktop-file-utils
22 BuildRequires:  dos2unix
23 BuildRequires:  exiv2-devel >= 0.25
24 BuildRequires:  libraw-devel >= 0.17
25 BuildRequires:  libstdc++-devel >= 6:4.3
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libwebp-devel >= 0.3.1
28 BuildRequires:  opencv-devel >= 2.4.6
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt5-build >= 5.2.1
31 BuildRequires:  qt5-linguist >= 5.2.1
32 BuildRequires:  qt5-qmake >= 5.2.1
33 BuildRequires:  quazip-qt5-devel >= 0.7
34 Requires:       Qt5Concurrent >= 5.2.1
35 Requires:       Qt5Core >= 5.2.1
36 Requires:       Qt5Gui >= 5.2.1
37 Requires:       Qt5Network >= 5.2.1
38 Requires:       Qt5Svg >= 5.2.1
39 Requires:       exiv2 >= 0.25
40 Requires:       libraw >= 0.17
41 Requires:       opencv >= 2.4.6
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 nomacs is image viewer based on Qt library.
46
47 nomacs is small, fast and able to handle the most common image
48 formats. Additionally it is possible to synchronize multiple viewers
49 running on the same computer or via LAN is possible. It allows to
50 compare images and spot the differences e.g. schemes of architects to
51 show the progress).
52
53 %description -l pl.UTF-8
54 nomacs to przeglądarka obrazków oparta na bibliotece Qt.
55
56 nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
57 formatów obrazów. Ponadto możliwa jest synchronizacja wielu
58 przeglądarek działających na tym samym komputerze lub poprzez sieć
59 lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
60 np. projekty architektów w celu pokazania postępów.
61
62 %prep
63 %setup -q
64 cd ImageLounge
65 %patch0 -p1
66
67 dos2unix Readme/*
68
69 %{__rm} -r 3rdparty/quazip-0.7
70
71 %build
72 install -d build
73 cd build
74 %cmake ../ImageLounge \
75         -DENABLE_PLUGINS=ON \
76         -DENABLE_RAW=1 \
77         -DUSE_SYSTEM_WEBP=ON \
78         -DUSE_SYSTEM_QUAZIP=ON
79
80 # TODO: -DUSE_SYSTEM_LIBQPSD=ON
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # unify
91 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_{zh,zh_CN}.qm
92 # translation to German "Vorarlbergerisch" dialect - should be de_AT@Vorarlberg?
93 # ("als" is wrong code - it's Tosk Albanian in iso-639-3)
94 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_als.qm
95
96 # API not exported, so keep only library files + soname symlinks
97 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnomacs*.so
98
99 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
100
101 install -d $RPM_BUILD_ROOT%{_datadir}/appdata
102 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/appdata/%{name}.appdata.xml
103
104 %find_lang %{name} --with-qm --without-mo
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /sbin/ldconfig
111 %update_desktop_database
112
113 %postun
114 /sbin/ldconfig
115 %update_desktop_database
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc ImageLounge/Readme/{COPYRIGHT,LICENSE.OPENCV,README}
120 %attr(755,root,root) %{_bindir}/nomacs
121 %attr(755,root,root) %{_libdir}/libnomacsCore.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libnomacsCore.so.3
123 %attr(755,root,root) %{_libdir}/libnomacsGui.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libnomacsGui.so.3
125 %attr(755,root,root) %{_libdir}/libnomacsLoader.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libnomacsLoader.so.3
127 %{_mandir}/man1/nomacs.1*
128 %dir %{_datadir}/%{name}
129 %dir %{_datadir}/%{name}/translations
130 %{_datadir}/appdata/nomacs.appdata.xml
131 %{_desktopdir}/nomacs.desktop
132 %{_pixmapsdir}/nomacs.svg
This page took 0.053788 seconds and 2 git commands to generate.