]> git.pld-linux.org Git - packages/nocache.git/blob - nocache.spec
ee9b1fe6b1465438811661ba2ecdda87d9852661
[packages/nocache.git] / nocache.spec
1 Summary:        Minimize filesystem caching effects
2 Name:           nocache
3 Version:        1.0
4 Release:        1
5 License:        BSD
6 Group:          Base
7 Source0:        https://github.com/Feh/nocache/archive/v%{version}.tar.gz
8 # Source0-md5:  29a177c7d990a75570645902c7ad9a4b
9 URL:            https://github.com/Feh/nocache
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 The nocache tool tries to minimize the effect an application has on
14 the Linux file system cache. This is done by intercepting the open and
15 close system calls and calling posix_fadvise with the
16 POSIX_FADV_DONTNEED parameter. Because the library remembers which
17 pages (ie., 4K-blocks of the file) were already in file system cache
18 when the file was opened, these will not be marked as "don't need",
19 because other applications might need that, although they are not
20 actively used (think: hot standby).
21
22 Use case: backup processes that should not interfere with the present
23 state of the cache.
24
25 %prep
26 %setup -q
27
28 %build
29 %{__make} \
30         CFLAGS+="%{rpmcppflags} %{rpmcflags}" \
31         LDFLAGS+="%{rpmldflags}"
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 %{__make} install \
37         DESTDIR=$RPM_BUILD_ROOT \
38         PREFIX= \
39         LIBDIR=%{_libdir} \
40         BINDIR=%{_bindir} \
41         MANDIR=%{_mandir}/man1
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README
49 %attr(755,root,root) %{_bindir}/cachedel
50 %attr(755,root,root) %{_bindir}/cachestats
51 %attr(755,root,root) %{_bindir}/nocache
52 %attr(755,root,root) %{_libdir}/nocache.so
53 %{_mandir}/man1/cachedel.1*
54 %{_mandir}/man1/cachestats.1*
55 %{_mandir}/man1/nocache.1*
This page took 0.096101 seconds and 2 git commands to generate.