]> git.pld-linux.org Git - packages/nlohmann-json.git/blob - nlohmann-json.spec
- updated to 3.11.2
[packages/nlohmann-json.git] / nlohmann-json.spec
1 Summary:        JSON for Modern C++ by Niels Lohmann
2 Summary(pl.UTF-8):      JSON dla współczesnego C++ autorstwa Nielsa Lohmanna
3 Name:           nlohmann-json
4 Version:        3.11.2
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/nlohmann/json/releases
9 Source0:        https://github.com/nlohmann/json/archive/v%{version}/json-%{version}.tar.gz
10 # Source0-md5:  e8d56bc54621037842ee9f0aeae27746
11 URL:            https://json.nlohmann.me/
12 BuildRequires:  cmake >= 3.1
13 BuildRequires:  libstdc++-devel >= 6:4.7
14 BuildRequires:  rpmbuild(macros) >= 1.605
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 JSON for Modern C++ by Niels Lohmann.
20
21 %description -l pl.UTF-8
22 JSON dla współczesnego C++ autorstwa Nielsa Lohmanna.
23
24 %package devel
25 Summary:        JSON for Modern C++ by Niels Lohmann
26 Summary(pl.UTF-8):      JSON dla współczesnego C++ autorstwa Nielsa Lohmanna
27 Group:          Development/Libraries
28 Requires:       libstdc++-devel >= 6:4.7
29
30 %description devel
31 JSON for Modern C++ by Niels Lohmann.
32
33 %description devel -l pl.UTF-8
34 JSON dla współczesnego C++ autorstwa Nielsa Lohmanna.
35
36 %prep
37 %setup -q -n json-%{version}
38
39 %build
40 install -d build
41 cd build
42 # force noarch libdir
43 %cmake .. \
44         -DCMAKE_INSTALL_LIBDIR=share \
45         -DJSON_MultipleHeaders=ON
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} -C build install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files devel
57 %defattr(644,root,root,755)
58 %doc ChangeLog.md LICENSE.MIT README.md
59 %dir %{_includedir}/nlohmann
60 %{_includedir}/nlohmann/adl_serializer.hpp
61 %{_includedir}/nlohmann/byte_container_with_subtype.hpp
62 %{_includedir}/nlohmann/json.hpp
63 %{_includedir}/nlohmann/json_fwd.hpp
64 %{_includedir}/nlohmann/ordered_map.hpp
65 %{_includedir}/nlohmann/detail
66 %{_includedir}/nlohmann/thirdparty
67 %{_npkgconfigdir}/nlohmann_json.pc
68 %{_datadir}/cmake/nlohmann_json
This page took 0.095662 seconds and 3 git commands to generate.