]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- rel 2; add headers more module
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - add njs: https://nginx.org/en/docs/njs/
5 #
6 # Conditional build for nginx:
7 # Features
8 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
9 %bcond_without  threads         # thread pool support
10 # Modules
11 %bcond_without  addition        # http addition module
12 %bcond_without  auth_request    # auth_request module
13 %bcond_without  dav             # WebDAV
14 %bcond_without  flv             # http FLV module
15 %bcond_without  gd              # without http image filter module
16 %bcond_without  geoip           # without http geoip module and stream geoip module
17 %bcond_without  http2           # HTTP/2 module
18 %bcond_without  mail            # don't build imap/mail proxy
19 %bcond_without  perl            # don't build with perl module
20 %bcond_without  poll            # poll module
21 %bcond_without  realip          # real ip (behind proxy)
22 %bcond_without  select          # select module
23 %bcond_without  ssl             # ssl support and http ssl module
24 %bcond_without  stream          # TCP/UDP proxy module
25 %bcond_without  stub_status     # http stub status module
26 %bcond_without  sub             # ngx_http_sub_module
27 %bcond_without  xslt            # without http xslt module
28 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
29 %bcond_with     modsecurity     # modsecurity module
30 %bcond_with     rtmp            # rtmp support
31 %bcond_without  vts             # virtual host traffic status module
32 %bcond_without  headers_more    # headers more module
33
34 %ifarch x32
35 %undefine       with_rtsig
36 %endif
37
38 %define         ssl_version     1.0.2
39 %define         rtmp_version    1.2.1
40 %define         vts_version     0.1.18
41 %define         headers_more_version    0.33
42 %define         modsecurity_version     2.9.3
43 Summary:        High perfomance HTTP and reverse proxy server
44 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
45 # nginx lines:
46 # - stable: production quality with stable API
47 # - mainline: production quality but API can change
48 # http://nginx.org/en/download.html
49 Name:           nginx
50 Version:        1.18.0
51 Release:        2
52 License:        BSD-like
53 Group:          Networking/Daemons/HTTP
54 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
55 # Source0-md5:  b2d33d24d89b8b1f87ff5d251aa27eb8
56 Source1:        http://nginx.net/favicon.ico
57 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
58 Source2:        proxy.conf
59 Source3:        %{name}.logrotate
60 Source4:        %{name}.mime
61 Source6:        %{name}.monitrc
62 Source7:        %{name}.init
63 Source14:       %{name}.conf
64 Source17:       %{name}-mime.types.sh
65 Source18:       %{name}.service
66 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
67 # Source22-md5: 215a96d679a5b0fadcf13b5d09b35422
68 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
69 # Source101-md5:        639ac2b78103adaccbcfe484a92acf44
70 Source102:      https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
71 # Source102-md5:        409a10dbd85e0b807cc77eecec29a3b5
72 Source103:      https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
73 # Source103-md5:        95e15a2331c2d4db3691a56268df5f47
74 Patch0:         %{name}-no-Werror.patch
75 Patch1:         %{name}-modsecurity-xheaders.patch
76 URL:            http://nginx.org/
77 BuildRequires:  mailcap
78 BuildRequires:  pcre-devel
79 BuildRequires:  rpmbuild(macros) >= 1.644
80 BuildRequires:  zlib-devel
81 %if %{with geoip}
82 BuildRequires:  GeoIP-devel
83 %endif
84 %if %{with gd}
85 BuildRequires:  gd-devel
86 %endif
87 %if %{with modsecurity}
88 BuildRequires:  lua-devel
89 %endif
90 %if %{with perl}
91 BuildRequires:  perl-CGI
92 BuildRequires:  perl-devel
93 BuildRequires:  python
94 BuildRequires:  rpm-perlprov
95 %endif
96 %if %{with ssl}
97 BuildRequires:  openssl-devel >= %{ssl_version}
98 Requires:       openssl >= %{ssl_version}
99 %endif
100 %if %{with xslt}
101 BuildRequires:  libxslt-devel
102 %endif
103 Provides:       group(http)
104 Provides:       group(nginx)
105 Provides:       user(nginx)
106 Provides:       webserver
107 Provides:       webserver(access)
108 Provides:       webserver(alias)
109 Provides:       webserver(auth)
110 Provides:       webserver(expires)
111 Provides:       webserver(headers)
112 Provides:       webserver(indexfile)
113 Provides:       webserver(log)
114 Provides:       webserver(mime)
115 Provides:       webserver(reqtimeout)
116 Provides:       webserver(rewrite)
117 Provides:       webserver(setenv)
118 Conflicts:      logrotate < 3.8.0
119 Requires(post,preun):   /sbin/chkconfig
120 Requires(post,preun,postun):    systemd-units >= 38
121 Requires(postun):       /usr/sbin/groupdel
122 Requires(postun):       /usr/sbin/userdel
123 Requires(pre):  /bin/id
124 Requires(pre):  /usr/bin/getgid
125 Requires(pre):  /usr/sbin/groupadd
126 Requires(pre):  /usr/sbin/useradd
127 Requires:       rc-scripts >= 0.2.0
128 Requires:       systemd-units >= 38
129 Suggests:       vim-syntax-nginx
130 Obsoletes:      nginx-common < 1.13.3
131 Obsoletes:      nginx-light < 1.13.3
132 Obsoletes:      nginx-standard < 1.13.3
133 Conflicts:      rpm < 4.4.2-0.2
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         _sysconfdir     /etc/%{name}
137 %define         _nginxdir       /home/services/%{name}
138
139 # minimizing restarts logics. we restart webserver:
140 #
141 # 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
142 # 2. first install of module (post: $1 = 1)
143 # 2. uninstall of module (postun: $1 == 0)
144 #
145 # the strict internal deps between modules and
146 # main package are very important for all this to work.
147
148 # restart webserver at the end of transaction
149
150 %define restart_webserver \
151         %systemd_post %{name}.service \
152         %service %{name} force-reload \
153         %{nil}
154
155 # macro called at module post scriptlet
156 %define module_post \
157 if [ "$1" = "1" ]; then \
158         %restart_webserver \
159 fi
160
161 # macro called at module postun scriptlet
162 %define module_postun \
163 if [ "$1" = "0" ]; then \
164         %restart_webserver \
165 fi
166
167 # it's sooo annoying to write them
168 %define module_scripts() \
169 %post %1 \
170 %module_post \
171 \
172 %postun %1 \
173 %module_postun
174
175 %description
176 nginx ("engine x") is a high-performance HTTP server and reverse
177 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
178 Sysoev for Rambler.ru, Russia's second-most visited website, where it
179 has been running in production for over two and a half years. Igor has
180 released the source code under a BSD-like license. Although still in
181 beta, nginx is known for its stability, rich feature set, simple
182 configuration, and low resource consumption.
183
184 %description -l pl.UTF-8
185 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
186 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
187 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
188 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
189 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
190 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
191 prostej konfiguracji oraz małej "zasobożerności".
192
193 %package mod_headers_more
194 Summary:        Nginx HTTP headers more module
195 Group:          Daemons
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       GeoIP
198
199 %description mod_headers_more
200 Set and clear input and output headers...more than "add".
201
202 %package mod_http_geoip
203 Summary:        Nginx HTTP geoip module
204 Group:          Daemons
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       GeoIP
207
208 %description mod_http_geoip
209 Nginx HTTP geoip module.
210
211 %package mod_stream_geoip
212 Summary:        Nginx stream geoip module
213 Group:          Daemons
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       %{name}-mod_stream = %{version}-%{release}
216 Requires:       GeoIP
217
218 %description mod_stream_geoip
219 Nginx stream geoip module.
220
221 %package mod_http_image_filter
222 Summary:        Nginx HTTP image filter module
223 Group:          Daemons
224 Requires:       %{name} = %{version}-%{release}
225
226 %description mod_http_image_filter
227 Nginx HTTP image filter module.
228
229 %package mod_http_perl
230 Summary:        Nginx HTTP Perl module
231 Group:          Networking/Daemons/HTTP
232 Requires:       %{name} = %{version}-%{release}
233
234 %description mod_http_perl
235 Nginx HTTP Perl module.
236
237 %package mod_http_xslt_filter
238 Summary:        Nginx XSLT module
239 Group:          Daemons
240 Requires:       %{name} = %{version}-%{release}
241
242 %description mod_http_xslt_filter
243 Nginx XSLT module.
244
245 %package mod_mail
246 Summary:        Nginx mail module
247 Group:          Networking/Daemons/HTTP
248 Requires:       %{name} = %{version}-%{release}
249
250 %description mod_mail
251 Nginx mail module.
252
253 %package mod_vts
254 Summary:        Nginx virtual host traffic status module
255 Group:          Networking/Daemons/HTTP
256 Requires:       %{name} = %{version}-%{release}
257
258 %description mod_vts
259 Nginx virtual host traffic status module.
260
261 %package mod_stream
262 Summary:        Nginx stream modules
263 Group:          Daemons
264 Requires:       %{name} = %{version}-%{release}
265
266 %description mod_stream
267 Nginx stream modules.
268
269 %package -n monit-rc-nginx
270 Summary:        nginx support for monit
271 Summary(pl.UTF-8):      Wsparcie nginx dla monit
272 Group:          Applications/System
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       monit
275
276 %description -n monit-rc-nginx
277 monitrc file for monitoring nginx webserver.
278
279 %description -n monit-rc-nginx -l pl.UTF-8
280 Plik monitrc do monitorowania serwera WWW nginx.
281
282 %prep
283 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102} %{?with_headers_more:-a103}
284 %patch0 -p0
285 %{?with_modsecurity:%patch1 -p0}
286
287 %if %{with rtmp}
288 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
289 %endif
290
291 %if %{with vts}
292 mv nginx-module-vts-%{vts_version} nginx-vts-module
293 %endif
294
295 %if %{with headers_more}
296 mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
297 %endif
298
299 # build mime.types.conf
300 #sh %{SOURCE17} /etc/mime.types
301
302 %build
303 # NB: not autoconf generated configure
304 cp -f configure auto/
305
306 ./configure \
307         --prefix=%{_prefix} \
308         --modules-path=%{_libdir}/%{name}/modules \
309         --sbin-path=%{_sbindir}/%{name} \
310         --conf-path=%{_sysconfdir}/%{name}.conf \
311         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
312         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
313         --pid-path=%{_localstatedir}/run/%{name}.pid \
314         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
315         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
316         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
317         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
318         --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
319         --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
320         --user=nginx \
321         --group=nginx \
322         %{?with_select:--with-select_module} \
323         %{?with_poll:--with-poll_module} \
324         %{?with_rtsig:--with-rtsig_module} \
325         %{?with_perl:--with-http_perl_module=dynamic} \
326         %{?with_gd:--with-http_image_filter_module=dynamic} \
327         %{?with_xslt:--with-http_xslt_module=dynamic} \
328         %{?with_geoip:--with-http_geoip_module=dynamic} \
329         %{?with_geoip:--with-stream_geoip_module=dynamic} \
330 %if %{with mail}
331         --with-mail=dynamic \
332         --with-mail_ssl_module \
333 %endif
334 %if %{with stream}
335         --with-stream=dynamic \
336         --with-stream_ssl_module \
337 %endif
338         --with-cc="%{__cc}" \
339         --with-cc-opt="%{rpmcflags}" \
340         --with-ld-opt="%{rpmldflags}" \
341         %{?with_debug:--with-debug} \
342         %{?with_addition:--with-http_addition_module} \
343         %{?with_dav:--with-http_dav_module} \
344         %{?with_flv:--with-http_flv_module} \
345         %{?with_sub:--with-http_sub_module} \
346         %{?with_realip:--with-http_realip_module} \
347         %{?with_stub_status:--with-http_stub_status_module} \
348         %{?with_ssl:--with-http_ssl_module} \
349         %{!?with_http_browser:--without-http_browser_module} \
350         %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
351         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
352         %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
353         %{?with_auth_request:--with-http_auth_request_module} \
354         %{?with_threads:--with-threads} \
355         %{?with_http2:--with-http_v2_module} \
356         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
357         --with-http_secure_link_module \
358         %{nil}
359
360 %{__make}
361
362 %if %{with modsecurity}
363 cd modsecurity-%{modsecurity_version}
364 ./autogen.sh
365 %configure \
366         --enable-standalone-module \
367         --disable-mlogc \
368         --enable-alp2 \
369         --with-lua=/usr
370 %{__make}
371 cd ..
372 %endif
373
374 %install
375 rm -rf $RPM_BUILD_ROOT
376 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
377         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
378         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
379         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
380         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
381         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
382         $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
383         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
384         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
385
386 %{__make} install \
387         INSTALLDIRS=vendor \
388         DESTDIR=$RPM_BUILD_ROOT
389
390 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
391
392 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
393 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
394 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
395 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
396
397 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
398 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
399 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
400 rm -r $RPM_BUILD_ROOT%{_prefix}/html
401 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
402 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
403 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
404
405 load_module() {
406         local module=ngx_${1}_module.so conffile=mod_$1.conf
407         printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
408                 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
409 }
410
411 %if %{with perl}
412 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
413 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
414 load_module http_perl
415 %endif
416
417 %if %{with geoip}
418 load_module http_geoip
419 load_module stream_geoip
420 %endif
421 %if %{with gd}
422 load_module http_image_filter
423 %endif
424 %if %{with xslt}
425 load_module http_xslt_filter
426 %endif
427 %if %{with mail}
428 load_module mail
429 %endif
430 %{?with_vts:load_module http_vhost_traffic_status}
431 %{?with_headers_more:load_module http_headers_more_filter}
432 %if %{with stream}
433 load_module stream
434 %endif
435
436 %clean
437 rm -rf $RPM_BUILD_ROOT
438
439 %pre
440 %groupadd -r -g 213 %{name}
441 %groupadd -g 51 http
442 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
443 %addusertogroup %{name} http
444
445 %post
446 for a in access.log error.log; do
447         if [ ! -f /var/log/%{name}/$a ]; then
448                 umask 022
449                 touch /var/log/%{name}/$a
450                 chown nginx:nginx /var/log/%{name}/$a
451                 chmod 644 /var/log/%{name}/$a
452         fi
453 done
454 /sbin/chkconfig --add %{name}
455
456 %posttrans
457 %restart_webserver
458
459 %preun
460 if [ "$1" = "0" ];then
461         %service %{name} stop
462         /sbin/chkconfig --del %{name}
463 fi
464 %systemd_preun %{name}.service
465
466 %postun
467 if [ "$1" = "0" ]; then
468         %userremove %{name}
469         %groupremove %{name}
470 fi
471 %systemd_reload
472
473 %module_scripts mod_http_geoip
474 %module_scripts mod_http_image_filter
475 %module_scripts mod_http_perl
476 %module_scripts mod_http_xslt_filter
477 %module_scripts mod_mail
478 %module_scripts mod_vts
479 %module_scripts mod_headers_more
480 %module_scripts mod_stream
481 %module_scripts mod_stream_geoip
482
483 %files
484 %defattr(644,root,root,755)
485 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
486 %doc %lang(ru) CHANGES.ru
487 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
488 %attr(754,root,root) /etc/rc.d/init.d/%{name}
489 %dir %attr(750,root,nginx) %{_sysconfdir}
490 %dir %{_sysconfdir}/conf.d
491 %dir %{_sysconfdir}/modules.d
492 %dir %{_sysconfdir}/snippets
493 %dir %{_sysconfdir}/vhosts.d
494 %dir %{_sysconfdir}/webapps.d
495 %attr(640,root,root) %{_sysconfdir}/mime.types
496 %attr(640,root,root) %{_sysconfdir}/koi-utf
497 %attr(640,root,root) %{_sysconfdir}/koi-win
498 %attr(640,root,root) %{_sysconfdir}/win-utf
499 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
501 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
502 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
503 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
504 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
505 %attr(755,root,root) %{_sbindir}/%{name}
506 %dir %{_libdir}/%{name}
507 %dir %{_libdir}/%{name}/modules
508 %{systemdunitdir}/%{name}.service
509
510 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
511 %attr(750,nginx,logs) /var/log/%{name}
512 %attr(770,root,nginx) /var/cache/%{name}
513
514 %dir %{_nginxdir}
515 %dir %{_nginxdir}/cgi-bin
516 %dir %{_nginxdir}/html
517 %dir %{_nginxdir}/errors
518 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
519 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
520
521 %if %{with geoip}
522 %files mod_http_geoip
523 %defattr(644,root,root,755)
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
525 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
526
527 %files mod_stream_geoip
528 %defattr(644,root,root,755)
529 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
530 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
531 %endif
532
533 %if %{with gd}
534 %files mod_http_image_filter
535 %defattr(644,root,root,755)
536 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
537 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
538 %endif
539
540 %if %{with perl}
541 %files mod_http_perl
542 %defattr(644,root,root,755)
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
544 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
545 %dir %{perl_vendorarch}/auto/%{name}
546 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
547 %{perl_vendorarch}/%{name}.pm
548 %{_mandir}/man3/nginx.3pm*
549 %endif
550
551 %if %{with xslt}
552 %files mod_http_xslt_filter
553 %defattr(644,root,root,755)
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
555 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
556 %endif
557
558 %if %{with mail}
559 %files mod_mail
560 %defattr(644,root,root,755)
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
562 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
563 %endif
564
565 %if %{with headers_more}
566 %files mod_headers_more
567 %defattr(644,root,root,755)
568 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
569 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
570 %endif
571
572 %if %{with vts}
573 %files mod_vts
574 %defattr(644,root,root,755)
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
576 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
577 %endif
578
579 %if %{with stream}
580 %files mod_stream
581 %defattr(644,root,root,755)
582 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
583 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
584 %endif
585
586 %files -n monit-rc-nginx
587 %defattr(644,root,root,755)
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.132221 seconds and 4 git commands to generate.