]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
6457d011f3811d87e55c09eab8b1e73e0c683a64
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 #
5 # Conditional build for nginx:
6 # Features
7 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
8 %bcond_without  threads         # thread pool support
9 # Modules
10 %bcond_without  addition        # http addition module
11 %bcond_without  auth_request    # auth_request module
12 %bcond_without  dav             # WebDAV
13 %bcond_without  flv             # http FLV module
14 %bcond_without  gd              # without http image filter module
15 %bcond_without  geoip           # without http geoip module
16 %bcond_without  http2           # HTTP/2 module
17 %bcond_without  mail            # don't build imap/mail proxy
18 %bcond_without  perl            # don't build with perl module
19 %bcond_without  poll            # poll module
20 %bcond_without  realip          # real ip (behind proxy)
21 %bcond_without  select          # select module
22 %bcond_without  ssl             # ssl support and http ssl module
23 %bcond_without  stream          # TCP/UDP proxy module
24 %bcond_without  stub_status     # http stub status module
25 %bcond_without  sub             # ngx_http_sub_module
26 %bcond_without  xslt            # without http xslt module
27 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
28 %bcond_with     modsecurity     # modsecurity module
29 %bcond_with     rtmp            # rtmp support
30
31 %ifarch x32
32 %undefine       with_rtsig
33 %endif
34
35 %define         ssl_version     1.0.2
36 %define         rtmp_version    1.1.7
37 %define         modsecurity_version     2.9.1
38 Summary:        High perfomance HTTP and reverse proxy server
39 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
40 # nginx lines:
41 # - stable: production quality with stable API
42 # - mainline: production quality but API can change
43 Name:           nginx
44 Version:        1.11.5
45 Release:        0.1
46 License:        BSD-like
47 Group:          Networking/Daemons/HTTP
48 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
49 # Source0-md5:  db43f2b19746f6f47401c3afc3924dc6
50 Source1:        http://nginx.net/favicon.ico
51 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
52 Source2:        proxy.conf
53 Source3:        %{name}.logrotate
54 Source4:        %{name}.mime
55 Source6:        %{name}.monitrc
56 Source7:        %{name}.init
57 Source14:       %{name}.conf
58 Source17:       %{name}-mime.types.sh
59 Source18:       %{name}.service
60 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
61 # Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
62 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
63 # Source101-md5:        8006de2560db3e55bb15d110220076ac
64 Patch0:         %{name}-no-Werror.patch
65 Patch1:         %{name}-modsecurity-xheaders.patch
66 URL:            http://nginx.net/
67 BuildRequires:  mailcap
68 BuildRequires:  pcre-devel
69 BuildRequires:  rpmbuild(macros) >= 1.644
70 BuildRequires:  zlib-devel
71 %if %{with geoip}
72 BuildRequires:  GeoIP-devel
73 %endif
74 %if %{with gd}
75 BuildRequires:  gd-devel
76 %endif
77 %if %{with modsecurity}
78 BuildRequires:  lua-devel
79 %endif
80 %if %{with perl}
81 BuildRequires:  perl-CGI
82 BuildRequires:  perl-devel
83 BuildRequires:  python
84 BuildRequires:  rpm-perlprov
85 %endif
86 %if %{with ssl}
87 BuildRequires:  openssl-devel >= %{ssl_version}
88 Requires:       openssl >= %{ssl_version}
89 %endif
90 %if %{with xslt}
91 BuildRequires:  libxslt-devel
92 %endif
93 Provides:       group(http)
94 Provides:       group(nginx)
95 Provides:       user(nginx)
96 Provides:       webserver
97 Provides:       webserver(access)
98 Provides:       webserver(alias)
99 Provides:       webserver(auth)
100 Provides:       webserver(expires)
101 Provides:       webserver(headers)
102 Provides:       webserver(indexfile)
103 Provides:       webserver(log)
104 Provides:       webserver(mime)
105 Provides:       webserver(reqtimeout)
106 Provides:       webserver(rewrite)
107 Provides:       webserver(setenv)
108 Conflicts:      logrotate < 3.8.0
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(post,preun,postun):    systemd-units >= 38
111 Requires(postun):       /usr/sbin/groupdel
112 Requires(postun):       /usr/sbin/userdel
113 Requires(pre):  /bin/id
114 Requires(pre):  /usr/bin/getgid
115 Requires(pre):  /usr/sbin/groupadd
116 Requires(pre):  /usr/sbin/useradd
117 Requires:       rc-scripts >= 0.2.0
118 Requires:       systemd-units >= 38
119 Suggests:       vim-syntax-nginx
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sysconfdir     /etc/%{name}
123 %define         _nginxdir       /home/services/%{name}
124
125 %description
126 nginx ("engine x") is a high-performance HTTP server and reverse
127 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
128 Sysoev for Rambler.ru, Russia's second-most visited website, where it
129 has been running in production for over two and a half years. Igor has
130 released the source code under a BSD-like license. Although still in
131 beta, nginx is known for its stability, rich feature set, simple
132 configuration, and low resource consumption.
133
134 %description -l pl.UTF-8
135 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
136 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
137 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
138 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
139 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
140 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
141 prostej konfiguracji oraz małej "zasobożerności".
142
143 %package mod_http_geoip
144 Summary:        Nginx HTTP geoip module
145 Group:          Daemons
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       GeoIP
148
149 %description mod_http_geoip
150 Nginx HTTP geoip module.
151
152 %package mod_http_image_filter
153 Summary:        Nginx HTTP image filter module
154 Group:          Daemons
155 Requires:       %{name} = %{version}-%{release}
156
157 %description mod_http_image_filter
158 Nginx HTTP image filter module.
159
160 %package mod_http_perl
161 Summary:        Nginx HTTP Perl module
162 Group:          Networking/Daemons/HTTP
163 Requires:       %{name} = %{version}-%{release}
164
165 %description mod_http_perl
166 Nginx HTTP Perl module.
167
168 %package mod_http_xslt_filter
169 Summary:        Nginx XSLT module
170 Group:          Daemons
171 Requires:       %{name} = %{version}-%{release}
172
173 %description mod_http_xslt_filter
174 Nginx XSLT module.
175
176 %package mod_mail
177 Summary:        Nginx mail module
178 Group:          Networking/Daemons/HTTP
179 Requires:       %{name} = %{version}-%{release}
180
181 %description mod_mail
182 Nginx mail module.
183
184 %package mod_stream
185 Summary:        Nginx stream modules
186 Group:          Daemons
187 Requires:       %{name} = %{version}-%{release}
188
189 %description mod_stream
190 Nginx stream modules.
191
192 %package -n monit-rc-nginx
193 Summary:        nginx support for monit
194 Summary(pl.UTF-8):      Wsparcie nginx dla monit
195 Group:          Applications/System
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       monit
198
199 %description -n monit-rc-nginx
200 monitrc file for monitoring nginx webserver.
201
202 %description -n monit-rc-nginx -l pl.UTF-8
203 Plik monitrc do monitorowania serwera WWW nginx.
204
205 %prep
206 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
207 %patch0 -p0
208 %{?with_modsecurity:%patch1 -p0}
209
210 %if %{with rtmp}
211 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
212 %endif
213
214 # build mime.types.conf
215 #sh %{SOURCE17} /etc/mime.types
216
217 %build
218 # NB: not autoconf generated configure
219 cp -f configure auto/
220
221 ./configure \
222         --prefix=%{_prefix} \
223         --modules-path=%{_libdir}/%{name}/modules \
224         --sbin-path=%{_sbindir}/%{name} \
225         --conf-path=%{_sysconfdir}/%{name}.conf \
226         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
227         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
228         --pid-path=%{_localstatedir}/run/%{name}.pid \
229         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
230         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
231         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
232         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
233         --user=nginx \
234         --group=nginx \
235         %{?with_select:--with-select_module} \
236         %{?with_poll:--with-poll_module} \
237         %{?with_rtsig:--with-rtsig_module} \
238         %{?with_perl:--with-http_perl_module=dynamic} \
239         %{?with_geoip:--with-http_geoip_module=dynamic} \
240         %{?with_gd:--with-http_image_filter_module=dynamic} \
241         %{?with_xslt:--with-http_xslt_module=dynamic} \
242 %if %{with mail}
243         --with-mail=dynamic \
244         --with-mail_ssl_module \
245 %endif
246 %if %{with stream}
247         --with-stream=dynamic \
248         --with-stream_ssl_module \
249 %endif
250         --with-cc="%{__cc}" \
251         --with-cc-opt="%{rpmcflags}" \
252         --with-ld-opt="%{rpmldflags}" \
253         %{?with_debug:--with-debug} \
254         %{?with_addition:--with-http_addition_module} \
255         %{?with_dav:--with-http_dav_module} \
256         %{?with_flv:--with-http_flv_module} \
257         %{?with_sub:--with-http_sub_module} \
258         %{?with_realip:--with-http_realip_module} \
259         %{?with_stub_status:--with-http_stub_status_module} \
260         %{?with_ssl:--with-http_ssl_module} \
261         %{!?with_http_browser:--without-http_browser_module} \
262         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
263         %{?with_auth_request:--with-http_auth_request_module} \
264         %{?with_threads:--with-threads} \
265         %{?with_http2:--with-http_v2_module} \
266         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
267         --with-http_secure_link_module \
268         %{nil}
269
270 %{__make}
271
272 %if %{with modsecurity}
273 cd modsecurity-%{modsecurity_version}
274 ./autogen.sh
275 %configure \
276         --enable-standalone-module \
277         --disable-mlogc \
278         --enable-alp2 \
279         --with-lua=/usr
280 %{__make}
281 cd ..
282 %endif
283
284 %install
285 rm -rf $RPM_BUILD_ROOT
286 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
287         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
288         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
289         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
290         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
291         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
292         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
293         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
294
295 %{__make} install \
296         INSTALLDIRS=vendor \
297         DESTDIR=$RPM_BUILD_ROOT
298
299 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
300
301 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
302 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
303 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
304 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
305
306 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
307 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
308 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
309 rm -r $RPM_BUILD_ROOT%{_prefix}/html
310 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
311 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
312 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
313
314 %if %{with perl}
315 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
316 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
317 %endif
318
319 # only touch these for ghost packaging
320 touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
321
322 %clean
323 rm -rf $RPM_BUILD_ROOT
324
325 %pre
326 %groupadd -r -g 213 %{name}
327 %groupadd -g 51 http
328 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
329 %addusertogroup %{name} http
330
331 %post
332 for a in access.log error.log; do
333         if [ ! -f /var/log/%{name}/$a ]; then
334                 umask 022
335                 touch /var/log/%{name}/$a
336                 chown nginx:nginx /var/log/%{name}/$a
337                 chmod 644 /var/log/%{name}/$a
338         fi
339 done
340 /sbin/chkconfig --add %{name}
341 %systemd_post %{name}.service
342 %service %{name} force-reload
343
344 %preun
345 if [ "$1" = "0" ];then
346         %service %{name} stop
347         /sbin/chkconfig --del %{name}
348 fi
349 %systemd_preun %{name}.service
350
351 %postun
352 if [ "$1" = "0" ]; then
353         %userremove %{name}
354         %groupremove %{name}
355 fi
356 %systemd_reload
357
358 %triggerpostun -- %{name} < 1.8.0-2
359 # skip *this* trigger on downgrade
360 [ $1 -le 1 ] && exit 0
361 ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
362 ln -sf scgi_params %{_sysconfdir}/scgi.params
363 ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
364 exit 0
365
366 %files
367 %defattr(644,root,root,755)
368 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
369 %doc %lang(ru) CHANGES.ru
370 %dir %attr(750,root,nginx) %{_sysconfdir}
371 %dir %{_nginxdir}
372 %dir %{_nginxdir}/cgi-bin
373 %dir %{_nginxdir}/html
374 %dir %{_nginxdir}/errors
375 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
376 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
377 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
378 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
379 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
380 %ghost %{_sysconfdir}/fastcgi.params
381 %ghost %{_sysconfdir}/scgi.params
382 %ghost %{_sysconfdir}/uwsgi.params
383 %attr(640,root,root) %{_sysconfdir}/mime.types
384 %attr(640,root,root) %{_sysconfdir}/koi-utf
385 %attr(640,root,root) %{_sysconfdir}/koi-win
386 %attr(640,root,root) %{_sysconfdir}/win-utf
387 %dir %{_sysconfdir}/webapps.d
388 %dir %{_sysconfdir}/vhosts.d
389 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
390 %attr(750,nginx,logs) /var/log/%{name}
391 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
392 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
393
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_sbindir}/%{name}
396 %attr(770,root,%{name}) /var/cache/%{name}
397 %attr(754,root,root) /etc/rc.d/init.d/%{name}
398 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
399 %dir %{_libdir}/%{name}
400 %dir %{_libdir}/%{name}/modules
401 %{systemdunitdir}/%{name}.service
402
403 %if %{with geoip}
404 %files mod_http_geoip
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
407 %endif
408
409 %if %{with gd}
410 %files mod_http_image_filter
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
413 %endif
414
415 %if %{with perl}
416 %files mod_http_perl
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
419 %dir %{perl_vendorarch}/auto/%{name}
420 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
421 %{perl_vendorarch}/%{name}.pm
422 %{_mandir}/man3/nginx.3pm*
423 %endif
424
425 %if %{with xslt}
426 %files mod_http_xslt_filter
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
429 %endif
430
431 %if %{with mail}
432 %files mod_mail
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
435 %endif
436
437 %if %{with stream}
438 %files mod_stream
439 %defattr(644,root,root,755)
440 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
441 %endif
442
443 %files -n monit-rc-nginx
444 %defattr(644,root,root,755)
445 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.415341 seconds and 2 git commands to generate.