]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
just one service file
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 #
5 # Conditional build for nginx:
6 %bcond_with     light           # don't build light version
7 %bcond_without  mail            # don't build imap/mail proxy
8 %bcond_without  perl            # don't build with perl module
9 %bcond_without  addition        # adds module
10 %bcond_without  dav             # WebDAV
11 %bcond_without  flv             # FLV stream
12 %bcond_without  ipv6            # build without ipv6 support
13 %bcond_without  sub             # ngx_http_sub_module
14 %bcond_without  poll            # poll
15 %bcond_without  realip          # real ip (behind proxy)
16 %bcond_without  select          # select
17 %bcond_without  http2           # HTTP/2 module
18 %bcond_without  status          # status module
19 %bcond_without  ssl             # ssl support
20 %bcond_without  threads         # thread pool support
21 %bcond_with     http_browser    # header "User-agent" parser
22 %bcond_with     rtmp            # rtmp support
23 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
24 %bcond_without  auth_request    # auth_request module
25 %bcond_with     modsecurity     # modsecurity module
26
27 %ifarch x32
28 %undefine       with_rtsig
29 %endif
30
31 %define         ssl_version     1.0.2
32 %define         rtmp_version    1.1.7
33 %define         modsecurity_version     2.9.1
34 Summary:        High perfomance HTTP and reverse proxy server
35 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
36 # nginx lines:
37 # - stable: production quality with stable API
38 # - mainline: production quality but API can change
39 Name:           nginx
40 Version:        1.11.5
41 Release:        0.1
42 License:        BSD-like
43 Group:          Networking/Daemons/HTTP
44 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
45 # Source0-md5:  db43f2b19746f6f47401c3afc3924dc6
46 Source1:        http://nginx.net/favicon.ico
47 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
48 Source2:        proxy.conf
49 Source3:        %{name}.logrotate
50 Source4:        %{name}.mime
51 Source6:        %{name}-light.monitrc
52 Source7:        %{name}.init
53 Source8:        %{name}-mail.conf
54 Source9:        %{name}-mail.monitrc
55 Source12:       %{name}-perl.monitrc
56 Source14:       %{name}.conf
57 Source15:       %{name}-standard.monitrc
58 Source17:       %{name}-mime.types.sh
59 Source18:       %{name}.service
60 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
61 # Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
62 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
63 # Source101-md5:        8006de2560db3e55bb15d110220076ac
64 Patch0:         %{name}-no-Werror.patch
65 Patch1:         %{name}-modsecurity-xheaders.patch
66 URL:            http://nginx.net/
67 %{?with_modsecurity:BuildRequires: lua-devel}
68 BuildRequires:  mailcap
69 %{?with_ssl:BuildRequires: openssl-devel >= %{ssl_version}}
70 BuildRequires:  pcre-devel
71 %{?with_perl:BuildRequires: perl-CGI}
72 %{?with_perl:BuildRequires: perl-devel}
73 %{?with_perl:BuildRequires: python}
74 %{?with_perl:BuildRequires: rpm-perlprov}
75 BuildRequires:  rpmbuild(macros) >= 1.644
76 BuildRequires:  zlib-devel
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _sysconfdir     /etc/%{name}
80 %define         _nginxdir       /home/services/%{name}
81
82 %description
83 nginx ("engine x") is a high-performance HTTP server and reverse
84 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
85 Sysoev for Rambler.ru, Russia's second-most visited website, where it
86 has been running in production for over two and a half years. Igor has
87 released the source code under a BSD-like license. Although still in
88 beta, nginx is known for its stability, rich feature set, simple
89 configuration, and low resource consumption.
90
91 %description -l pl.UTF-8
92 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
93 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
94 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
95 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
96 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
97 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
98 prostej konfiguracji oraz małej "zasobożerności".
99
100 %package common
101 Summary:        nginx - common files
102 Summary(pl.UTF-8):      nginx - pliki wspólne
103 Group:          Networking/Daemons/HTTP
104 Requires(postun):       /usr/sbin/groupdel
105 Requires(postun):       /usr/sbin/userdel
106 Requires(pre):  /bin/id
107 Requires(pre):  /usr/bin/getgid
108 Requires(pre):  /usr/sbin/groupadd
109 Requires(pre):  /usr/sbin/useradd
110 Requires:       rc-scripts >= 0.2.0
111 Requires:       systemd-units >= 38
112 Suggests:       vim-syntax-nginx
113 Provides:       group(http)
114 Provides:       group(nginx)
115 Provides:       user(nginx)
116 Provides:       webserver(access)
117 Provides:       webserver(alias)
118 Provides:       webserver(auth)
119 Provides:       webserver(expires)
120 Provides:       webserver(headers)
121 Provides:       webserver(indexfile)
122 Provides:       webserver(log)
123 Provides:       webserver(mime)
124 Provides:       webserver(reqtimeout)
125 Provides:       webserver(rewrite)
126 Provides:       webserver(setenv)
127 Obsoletes:      nginx < 1.4.1-4.1
128 Conflicts:      logrotate < 3.8.0
129
130 %description common
131 Common files for the nginx daemon.
132
133 %description common -l pl.UTF-8
134 Niezbędne pliki dla nginx.
135
136 %package light
137 Summary:        High perfomance HTTP and reverse proxy server
138 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
139 Group:          Networking/Daemons/HTTP
140 Requires(post,preun):   /sbin/chkconfig
141 Requires(post,preun,postun):    systemd-units >= 38
142 Requires:       %{name}-common = %{version}-%{release}
143 %{?with_ssl:Requires: openssl >= %{ssl_version}}
144 Provides:       nginx-daemon
145 Provides:       webserver
146
147 %description light
148 nginx ("engine x") is a high-performance HTTP server and reverse
149 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
150 Sysoev for Rambler.ru, Russia's second-most visited website, where it
151 has been running in production for over two and a half years. Igor has
152 released the source code under a BSD-like license. Although still in
153 beta, nginx is known for its stability, rich feature set, simple
154 configuration, and low resource consumption.
155
156 The smallest, but also the fastest nginx edition. No additional
157 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
158
159 %description light -l pl.UTF-8
160 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
161 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
162 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
163 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
164 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
165 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
166 prostej konfiguracji oraz małej "zasobożerności".
167
168 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
169 FLV oraz IMAP, POP3, SMTP proxy.
170
171 %package perl
172 Summary:        High perfomance HTTP and reverse proxy server
173 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
174 Group:          Networking/Daemons/HTTP
175 Requires(post,preun):   /sbin/chkconfig
176 Requires(post,preun,postun):    systemd-units >= 38
177 Requires:       %{name}-common = %{version}-%{release}
178 %{?with_ssl:Requires: openssl >= %{ssl_version}}
179 Provides:       nginx-daemon
180 Provides:       webserver
181
182 %description perl
183 nginx ("engine x") is a high-performance HTTP server and reverse
184 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
185 Sysoev for Rambler.ru, Russia's second-most visited website, where it
186 has been running in production for over two and a half years. Igor has
187 released the source code under a BSD-like license. Although still in
188 beta, nginx is known for its stability, rich feature set, simple
189 configuration, and low resource consumption.
190
191 nginx with Perl support. Mail modules not included.
192
193 %description perl -l pl.UTF-8
194 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
195 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
196 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
197 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
198 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
199 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
200 prostej konfiguracji oraz małej "zasobożerności".
201
202 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
203
204 %package mail
205 Summary:        High perfomance IMAP, POP3, SMTP proxy server
206 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
207 Group:          Networking/Daemons/HTTP
208 Requires(post,preun):   /sbin/chkconfig
209 Requires(post,preun,postun):    systemd-units >= 38
210 Requires:       %{name}-common = %{version}-%{release}
211 Provides:       nginx-daemon
212
213 %description mail
214 nginx ("engine x") is a high-performance HTTP server and reverse
215 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
216 Sysoev for Rambler.ru, Russia's second-most visited website, where it
217 has been running in production for over two and a half years. Igor has
218 released the source code under a BSD-like license. Although still in
219 beta, nginx is known for its stability, rich feature set, simple
220 configuration, and low resource consumption.
221
222 nginx with mail support. Only mail modules included.
223
224 %description mail -l pl.UTF-8
225 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
226 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
227 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
228 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
229 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
230 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
231 prostej konfiguracji oraz małej "zasobożerności".
232
233 nginx ze wsparciem tylko dla modułów poczty.
234
235 %package standard
236 Summary:        High perfomance HTTP and reverse proxy server
237 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
238 Group:          Networking/Daemons/HTTP
239 Requires(post,preun):   /sbin/chkconfig
240 Requires(post,preun,postun):    systemd-units >= 38
241 Requires:       %{name}-common = %{version}-%{release}
242 %{?with_ssl:Requires: openssl >= %{ssl_version}}
243 Provides:       nginx
244 Provides:       nginx-daemon
245 Provides:       webserver
246 Conflicts:      logrotate < 3.7-4
247
248 %description standard
249 nginx ("engine x") is a high-performance HTTP server and reverse
250 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
251 Sysoev for Rambler.ru, Russia's second-most visited website, where it
252 has been running in production for over two and a half years. Igor has
253 released the source code under a BSD-like license. Although still in
254 beta, nginx is known for its stability, rich feature set, simple
255 configuration, and low resource consumption.
256
257 This is standard nginx version, without Perl support and IMAP, POP3,
258 SMTP proxy.
259
260 %description standard -l pl.UTF-8
261 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
262 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
263 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
264 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
265 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
266 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
267 prostej konfiguracji oraz małej "zasobożerności". ginx ("engine x")
268 jest wysokowydajnym serwerem HTTP, odwrotnym proxy a także IMAP/POP3
269 proxy. nginx został napisany przez Igora Sysoeva na potrzeby serwisu
270 Rambler.ru. Jest to drugi pod względem ilości odwiedzin serwis w Rosji
271 i działa od ponad dwóch i pół roku. Igor opublikował źródła na
272 licencji BSD. Mimo, że projekt jest ciągle w fazie beta, już zasłynął
273 dzięki stabilności, bogactwu dodatków, prostej konfiguracji oraz małej
274 "zasobożerności".
275
276 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
277 IMAP, POP3, SMTP.
278
279 %package -n monit-rc-nginx
280 Summary:        nginx support for monit
281 Summary(pl.UTF-8):      Wsparcie nginx dla monit
282 Group:          Applications/System
283 URL:            http://nginx.eu/
284 Requires:       %{name}-common = %{version}-%{release}
285 Requires:       monit
286
287 %description -n monit-rc-nginx
288 monitrc file for monitoring nginx webserver.
289
290 %description -n monit-rc-nginx -l pl.UTF-8
291 Plik monitrc do monitorowania serwera WWW nginx.
292
293 %prep
294 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
295 %patch0 -p0
296 %{?with_modsecurity:%patch1 -p0}
297
298 %if %{with rtmp}
299 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
300 %endif
301
302 # build mime.types.conf
303 #sh %{SOURCE17} /etc/mime.types
304
305 %build
306 # NB: not autoconf generated configure
307 cp -f configure auto/
308
309 install -d bin
310
311 # build with default options
312 build() {
313         local type=$1; shift
314 ./configure \
315         --prefix=%{_prefix} \
316         --modules-path=%{_libdir}/%{name}/modules \
317         --sbin-path=%{_sbindir}/%{name} \
318         --conf-path=%{_sysconfdir}/%{name}.conf \
319         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
320         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
321         --pid-path=%{_localstatedir}/run/%{name}.pid \
322         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
323         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
324         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
325         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
326         --user=nginx \
327         --group=nginx \
328         %{?with_ipv6:--with-ipv6} \
329         %{?with_select:--with-select_module} \
330         %{?with_poll:--with-poll_module} \
331         %{?with_rtsig:--with-rtsig_module} \
332 %if %{with perl}
333         --with-http_perl_module=dynamic \
334 %endif
335 %if %{with mail}
336         --with-mail=dynamic \
337         --with-mail_ssl_module \
338 %endif
339         --with-cc="%{__cc}" \
340         --with-cc-opt="%{rpmcflags}" \
341         --with-ld-opt="%{rpmldflags}" \
342         %{?with_debug:--with-debug} \
343         "$@"
344 %{__make}
345 }
346
347 %if %{with modsecurity}
348 cd modsecurity-%{modsecurity_version}
349 ./autogen.sh
350 %configure \
351         --enable-standalone-module \
352         --disable-mlogc \
353         --enable-alp2 \
354         --with-lua=/usr
355 %{__make}
356 cd ..
357 %endif
358
359 %if %{with perl} && 0
360 build perl \
361         --with-http_perl_module \
362         %{?with_addition:--with-http_addition_module} \
363         %{?with_dav:--with-http_dav_module} \
364         %{?with_flv:--with-http_flv_module} \
365         %{?with_sub:--with-http_sub_module} \
366         %{?with_realip:--with-http_realip_module} \
367         %{?with_status:--with-http_stub_status_module} \
368         %{?with_ssl:--with-http_ssl_module} \
369         %{!?with_http_browser:--without-http_browser_module} \
370         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
371         %{?with_auth_request:--with-http_auth_request_module} \
372         %{?with_threads:--with-threads} \
373         %{?with_http2:--with-http_v2_module} \
374         --with-http_secure_link_module \
375         %{nil}
376
377 mv -f objs/nginx bin/nginx-perl
378 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so bin/nginx.so
379 mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
380 %endif
381
382 %if %{with mail} && 0
383 build mail \
384         --without-http \
385         --with-imap \
386         --with-mail \
387         --with-mail_ssl_module \
388         %{nil}
389
390 mv -f objs/nginx bin/nginx-mail
391 %endif
392
393 %if %{with light}
394 build light \
395         %{?with_realip:--with-http_realip_module} \
396         %{?with_status:--with-http_stub_status_module} \
397         %{?with_ssl:--with-http_ssl_module} \
398         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
399         %{?with_auth_request:--with-http_auth_request_module} \
400         %{?with_threads:--with-threads} \
401         %{?with_http2:--with-http_v2_module} \
402         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
403         --without-http_browser_module \
404         --with-http_secure_link_module \
405         %{nil}
406
407 mv -f objs/nginx bin/nginx-light
408 %endif
409
410 build standard \
411         %{?with_addition:--with-http_addition_module} \
412         %{?with_dav:--with-http_dav_module} \
413         %{?with_flv:--with-http_flv_module} \
414         %{?with_sub:--with-http_sub_module} \
415         %{?with_realip:--with-http_realip_module} \
416         %{?with_status:--with-http_stub_status_module} \
417         %{?with_ssl:--with-http_ssl_module} \
418         %{!?with_http_browser:--without-http_browser_module} \
419         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
420         %{?with_auth_request:--with-http_auth_request_module} \
421         %{?with_threads:--with-threads} \
422         %{?with_http2:--with-http_v2_module} \
423         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
424         --with-http_secure_link_module \
425         %{nil}
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
430         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
431         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
432         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
433         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
434         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
435         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
436         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
437
438 %{__make} install \
439         INSTALLDIRS=vendor \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
443
444 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
445 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
446 cp -p %{_sourcedir}/%{name}-standard.monitrc $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
447 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
448
449 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
450 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
451 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
452 rm -r $RPM_BUILD_ROOT%{_prefix}/html
453 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
454 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
455 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
456
457 %if %{with perl}
458 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
459 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
460 %endif
461
462 # only touch these for ghost packaging
463 touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
464
465 %clean
466 rm -rf $RPM_BUILD_ROOT
467
468 %pre
469 %groupadd -r -g 213 %{name}
470 %groupadd -g 51 http
471 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
472 %addusertogroup %{name} http
473
474 %post
475 for a in access.log error.log; do
476         if [ ! -f /var/log/%{name}/$a ]; then
477                 umask 022
478                 touch /var/log/%{name}/$a
479                 chown nginx:nginx /var/log/%{name}/$a
480                 chmod 644 /var/log/%{name}/$a
481         fi
482 done
483 /sbin/chkconfig --add %{name}
484 %systemd_post %{name}.service
485 %service %{name} force-reload
486
487 %preun
488 if [ "$1" = "0" ];then
489         %service %{name} stop
490         /sbin/chkconfig --del %{name}
491 fi
492 %systemd_preun %{name}.service
493
494 %postun
495 if [ "$1" = "0" ]; then
496         %userremove %{name}
497         %groupremove %{name}
498 fi
499 %systemd_reload
500
501 %triggerpostun -- %{name}-standard < 1.4.1-4
502 %systemd_trigger %{name}-standard.service
503
504 %triggerpostun -- %{name}-light < 1.4.1-4
505 %systemd_trigger %{name}-light.service
506
507 %triggerpostun -- %{name}-perl < 1.4.1-4
508 %systemd_trigger %{name}-perl.service
509
510 %triggerpostun -- %{name}-mail < 1.4.1-4
511 %systemd_trigger %{name}-mail.service
512
513 %triggerpostun common -- %{name}-common < 1.8.0-2
514 # skip *this* trigger on downgrade
515 [ $1 -le 1 ] && exit 0
516 ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
517 ln -sf scgi_params %{_sysconfdir}/scgi.params
518 ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
519 exit 0
520
521 %files
522 %defattr(644,root,root,755)
523 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
524 %doc %lang(ru) CHANGES.ru
525 %dir %attr(750,root,nginx) %{_sysconfdir}
526 %dir %{_nginxdir}
527 %dir %{_nginxdir}/cgi-bin
528 %dir %{_nginxdir}/html
529 %dir %{_nginxdir}/errors
530 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
534 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
535 %ghost %{_sysconfdir}/fastcgi.params
536 %ghost %{_sysconfdir}/scgi.params
537 %ghost %{_sysconfdir}/uwsgi.params
538 %attr(640,root,root) %{_sysconfdir}/mime.types
539 %attr(640,root,root) %{_sysconfdir}/koi-utf
540 %attr(640,root,root) %{_sysconfdir}/koi-win
541 %attr(640,root,root) %{_sysconfdir}/win-utf
542 %dir %{_sysconfdir}/webapps.d
543 %dir %{_sysconfdir}/vhosts.d
544 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
545 %attr(750,nginx,logs) /var/log/%{name}
546 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
547 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
548
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_sbindir}/%{name}
551 %attr(770,root,%{name}) /var/cache/%{name}
552 %attr(754,root,root) /etc/rc.d/init.d/%{name}
553 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
554 %{systemdunitdir}/%{name}.service
555
556 %if %{with mail}
557 %files mail
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
560 %endif
561
562 %if %{with light}
563 %files light
564 %defattr(644,root,root,755)
565 %endif
566
567 %if %{with perl}
568 %files perl
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
571 %dir %{perl_vendorarch}/auto/%{name}
572 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
573 %{perl_vendorarch}/%{name}.pm
574 %{_mandir}/man3/nginx.3pm*
575 %endif
576
577 %files -n monit-rc-nginx
578 %defattr(644,root,root,755)
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.117658 seconds and 3 git commands to generate.