]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
1b6713adae1dfb9437549f209edda3320bcc97c2
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 #
5 # Conditional build for nginx:
6 %bcond_with     light           # don't build light version
7 %bcond_without  mail            # don't build imap/mail proxy
8 %bcond_without  perl            # don't build with perl module
9 %bcond_without  addition        # adds module
10 %bcond_without  dav             # WebDAV
11 %bcond_without  flv             # FLV stream
12 %bcond_without  ipv6            # build without ipv6 support
13 %bcond_without  sub             # ngx_http_sub_module
14 %bcond_without  poll            # poll
15 %bcond_without  realip          # real ip (behind proxy)
16 %bcond_without  select          # select
17 %bcond_without  http2           # HTTP/2 module
18 %bcond_without  status          # status module
19 %bcond_without  ssl             # ssl support
20 %bcond_without  threads         # thread pool support
21 %bcond_with     http_browser    # header "User-agent" parser
22 %bcond_with     rtmp            # rtmp support
23 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
24 %bcond_without  auth_request    # auth_request module
25 %bcond_with     modsecurity     # modsecurity module
26
27 %ifarch x32
28 %undefine       with_rtsig
29 %endif
30
31 %define         ssl_version     1.0.2
32 %define         rtmp_version    1.1.7
33 %define         modsecurity_version     2.9.1
34 Summary:        High perfomance HTTP and reverse proxy server
35 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
36 # nginx lines:
37 # - stable: production quality with stable API
38 # - mainline: production quality but API can change
39 Name:           nginx
40 Version:        1.11.5
41 Release:        0.1
42 License:        BSD-like
43 Group:          Networking/Daemons/HTTP
44 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
45 # Source0-md5:  db43f2b19746f6f47401c3afc3924dc6
46 Source1:        http://nginx.net/favicon.ico
47 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
48 Source2:        proxy.conf
49 Source3:        %{name}.logrotate
50 Source4:        %{name}.mime
51 Source6:        %{name}.monitrc
52 Source7:        %{name}.init
53 Source14:       %{name}.conf
54 Source17:       %{name}-mime.types.sh
55 Source18:       %{name}.service
56 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
57 # Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
58 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
59 # Source101-md5:        8006de2560db3e55bb15d110220076ac
60 Patch0:         %{name}-no-Werror.patch
61 Patch1:         %{name}-modsecurity-xheaders.patch
62 URL:            http://nginx.net/
63 %{?with_modsecurity:BuildRequires: lua-devel}
64 BuildRequires:  mailcap
65 %{?with_ssl:BuildRequires: openssl-devel >= %{ssl_version}}
66 BuildRequires:  pcre-devel
67 %{?with_perl:BuildRequires: perl-CGI}
68 %{?with_perl:BuildRequires: perl-devel}
69 %{?with_perl:BuildRequires: python}
70 %{?with_perl:BuildRequires: rpm-perlprov}
71 BuildRequires:  rpmbuild(macros) >= 1.644
72 BuildRequires:  zlib-devel
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/%{name}
76 %define         _nginxdir       /home/services/%{name}
77
78 %description
79 nginx ("engine x") is a high-performance HTTP server and reverse
80 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
81 Sysoev for Rambler.ru, Russia's second-most visited website, where it
82 has been running in production for over two and a half years. Igor has
83 released the source code under a BSD-like license. Although still in
84 beta, nginx is known for its stability, rich feature set, simple
85 configuration, and low resource consumption.
86
87 %description -l pl.UTF-8
88 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
89 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
90 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
91 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
92 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
93 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
94 prostej konfiguracji oraz małej "zasobożerności".
95
96 %package common
97 Summary:        nginx - common files
98 Summary(pl.UTF-8):      nginx - pliki wspólne
99 Group:          Networking/Daemons/HTTP
100 Requires(postun):       /usr/sbin/groupdel
101 Requires(postun):       /usr/sbin/userdel
102 Requires(pre):  /bin/id
103 Requires(pre):  /usr/bin/getgid
104 Requires(pre):  /usr/sbin/groupadd
105 Requires(pre):  /usr/sbin/useradd
106 Requires:       rc-scripts >= 0.2.0
107 Requires:       systemd-units >= 38
108 Suggests:       vim-syntax-nginx
109 Provides:       group(http)
110 Provides:       group(nginx)
111 Provides:       user(nginx)
112 Provides:       webserver(access)
113 Provides:       webserver(alias)
114 Provides:       webserver(auth)
115 Provides:       webserver(expires)
116 Provides:       webserver(headers)
117 Provides:       webserver(indexfile)
118 Provides:       webserver(log)
119 Provides:       webserver(mime)
120 Provides:       webserver(reqtimeout)
121 Provides:       webserver(rewrite)
122 Provides:       webserver(setenv)
123 Obsoletes:      nginx < 1.4.1-4.1
124 Conflicts:      logrotate < 3.8.0
125
126 %description common
127 Common files for the nginx daemon.
128
129 %description common -l pl.UTF-8
130 Niezbędne pliki dla nginx.
131
132 %package light
133 Summary:        High perfomance HTTP and reverse proxy server
134 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
135 Group:          Networking/Daemons/HTTP
136 Requires(post,preun):   /sbin/chkconfig
137 Requires(post,preun,postun):    systemd-units >= 38
138 Requires:       %{name}-common = %{version}-%{release}
139 %{?with_ssl:Requires: openssl >= %{ssl_version}}
140 Provides:       nginx-daemon
141 Provides:       webserver
142
143 %description light
144 nginx ("engine x") is a high-performance HTTP server and reverse
145 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
146 Sysoev for Rambler.ru, Russia's second-most visited website, where it
147 has been running in production for over two and a half years. Igor has
148 released the source code under a BSD-like license. Although still in
149 beta, nginx is known for its stability, rich feature set, simple
150 configuration, and low resource consumption.
151
152 The smallest, but also the fastest nginx edition. No additional
153 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
154
155 %description light -l pl.UTF-8
156 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
157 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
158 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
159 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
160 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
161 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
162 prostej konfiguracji oraz małej "zasobożerności".
163
164 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
165 FLV oraz IMAP, POP3, SMTP proxy.
166
167 %package perl
168 Summary:        High perfomance HTTP and reverse proxy server
169 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
170 Group:          Networking/Daemons/HTTP
171 Requires(post,preun):   /sbin/chkconfig
172 Requires(post,preun,postun):    systemd-units >= 38
173 Requires:       %{name}-common = %{version}-%{release}
174 %{?with_ssl:Requires: openssl >= %{ssl_version}}
175 Provides:       nginx-daemon
176 Provides:       webserver
177
178 %description perl
179 nginx ("engine x") is a high-performance HTTP server and reverse
180 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
181 Sysoev for Rambler.ru, Russia's second-most visited website, where it
182 has been running in production for over two and a half years. Igor has
183 released the source code under a BSD-like license. Although still in
184 beta, nginx is known for its stability, rich feature set, simple
185 configuration, and low resource consumption.
186
187 nginx with Perl support. Mail modules not included.
188
189 %description perl -l pl.UTF-8
190 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
191 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
192 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
193 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
194 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
195 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
196 prostej konfiguracji oraz małej "zasobożerności".
197
198 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
199
200 %package mail
201 Summary:        High perfomance IMAP, POP3, SMTP proxy server
202 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
203 Group:          Networking/Daemons/HTTP
204 Requires(post,preun):   /sbin/chkconfig
205 Requires(post,preun,postun):    systemd-units >= 38
206 Requires:       %{name}-common = %{version}-%{release}
207 Provides:       nginx-daemon
208
209 %description mail
210 nginx ("engine x") is a high-performance HTTP server and reverse
211 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
212 Sysoev for Rambler.ru, Russia's second-most visited website, where it
213 has been running in production for over two and a half years. Igor has
214 released the source code under a BSD-like license. Although still in
215 beta, nginx is known for its stability, rich feature set, simple
216 configuration, and low resource consumption.
217
218 nginx with mail support. Only mail modules included.
219
220 %description mail -l pl.UTF-8
221 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
222 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
223 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
224 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
225 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
226 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
227 prostej konfiguracji oraz małej "zasobożerności".
228
229 nginx ze wsparciem tylko dla modułów poczty.
230
231 %package standard
232 Summary:        High perfomance HTTP and reverse proxy server
233 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
234 Group:          Networking/Daemons/HTTP
235 Requires(post,preun):   /sbin/chkconfig
236 Requires(post,preun,postun):    systemd-units >= 38
237 Requires:       %{name}-common = %{version}-%{release}
238 %{?with_ssl:Requires: openssl >= %{ssl_version}}
239 Provides:       nginx
240 Provides:       nginx-daemon
241 Provides:       webserver
242 Conflicts:      logrotate < 3.7-4
243
244 %description standard
245 nginx ("engine x") is a high-performance HTTP server and reverse
246 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
247 Sysoev for Rambler.ru, Russia's second-most visited website, where it
248 has been running in production for over two and a half years. Igor has
249 released the source code under a BSD-like license. Although still in
250 beta, nginx is known for its stability, rich feature set, simple
251 configuration, and low resource consumption.
252
253 This is standard nginx version, without Perl support and IMAP, POP3,
254 SMTP proxy.
255
256 %description standard -l pl.UTF-8
257 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
258 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
259 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
260 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
261 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
262 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
263 prostej konfiguracji oraz małej "zasobożerności". ginx ("engine x")
264 jest wysokowydajnym serwerem HTTP, odwrotnym proxy a także IMAP/POP3
265 proxy. nginx został napisany przez Igora Sysoeva na potrzeby serwisu
266 Rambler.ru. Jest to drugi pod względem ilości odwiedzin serwis w Rosji
267 i działa od ponad dwóch i pół roku. Igor opublikował źródła na
268 licencji BSD. Mimo, że projekt jest ciągle w fazie beta, już zasłynął
269 dzięki stabilności, bogactwu dodatków, prostej konfiguracji oraz małej
270 "zasobożerności".
271
272 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
273 IMAP, POP3, SMTP.
274
275 %package -n monit-rc-nginx
276 Summary:        nginx support for monit
277 Summary(pl.UTF-8):      Wsparcie nginx dla monit
278 Group:          Applications/System
279 URL:            http://nginx.eu/
280 Requires:       %{name}-common = %{version}-%{release}
281 Requires:       monit
282
283 %description -n monit-rc-nginx
284 monitrc file for monitoring nginx webserver.
285
286 %description -n monit-rc-nginx -l pl.UTF-8
287 Plik monitrc do monitorowania serwera WWW nginx.
288
289 %prep
290 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
291 %patch0 -p0
292 %{?with_modsecurity:%patch1 -p0}
293
294 %if %{with rtmp}
295 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
296 %endif
297
298 # build mime.types.conf
299 #sh %{SOURCE17} /etc/mime.types
300
301 %build
302 # NB: not autoconf generated configure
303 cp -f configure auto/
304
305 install -d bin
306
307 # build with default options
308 build() {
309         local type=$1; shift
310 ./configure \
311         --prefix=%{_prefix} \
312         --modules-path=%{_libdir}/%{name}/modules \
313         --sbin-path=%{_sbindir}/%{name} \
314         --conf-path=%{_sysconfdir}/%{name}.conf \
315         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
316         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
317         --pid-path=%{_localstatedir}/run/%{name}.pid \
318         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
319         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
320         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
321         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
322         --user=nginx \
323         --group=nginx \
324         %{?with_ipv6:--with-ipv6} \
325         %{?with_select:--with-select_module} \
326         %{?with_poll:--with-poll_module} \
327         %{?with_rtsig:--with-rtsig_module} \
328 %if %{with perl}
329         --with-http_perl_module=dynamic \
330 %endif
331 %if %{with mail}
332         --with-mail=dynamic \
333         --with-mail_ssl_module \
334 %endif
335         --with-cc="%{__cc}" \
336         --with-cc-opt="%{rpmcflags}" \
337         --with-ld-opt="%{rpmldflags}" \
338         %{?with_debug:--with-debug} \
339         "$@"
340 %{__make}
341 }
342
343 %if %{with modsecurity}
344 cd modsecurity-%{modsecurity_version}
345 ./autogen.sh
346 %configure \
347         --enable-standalone-module \
348         --disable-mlogc \
349         --enable-alp2 \
350         --with-lua=/usr
351 %{__make}
352 cd ..
353 %endif
354
355 %if %{with perl} && 0
356 build perl \
357         --with-http_perl_module \
358         %{?with_addition:--with-http_addition_module} \
359         %{?with_dav:--with-http_dav_module} \
360         %{?with_flv:--with-http_flv_module} \
361         %{?with_sub:--with-http_sub_module} \
362         %{?with_realip:--with-http_realip_module} \
363         %{?with_status:--with-http_stub_status_module} \
364         %{?with_ssl:--with-http_ssl_module} \
365         %{!?with_http_browser:--without-http_browser_module} \
366         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
367         %{?with_auth_request:--with-http_auth_request_module} \
368         %{?with_threads:--with-threads} \
369         %{?with_http2:--with-http_v2_module} \
370         --with-http_secure_link_module \
371         %{nil}
372
373 mv -f objs/nginx bin/nginx-perl
374 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so bin/nginx.so
375 mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
376 %endif
377
378 %if %{with mail} && 0
379 build mail \
380         --without-http \
381         --with-imap \
382         --with-mail \
383         --with-mail_ssl_module \
384         %{nil}
385
386 mv -f objs/nginx bin/nginx-mail
387 %endif
388
389 %if %{with light}
390 build light \
391         %{?with_realip:--with-http_realip_module} \
392         %{?with_status:--with-http_stub_status_module} \
393         %{?with_ssl:--with-http_ssl_module} \
394         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
395         %{?with_auth_request:--with-http_auth_request_module} \
396         %{?with_threads:--with-threads} \
397         %{?with_http2:--with-http_v2_module} \
398         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
399         --without-http_browser_module \
400         --with-http_secure_link_module \
401         %{nil}
402
403 mv -f objs/nginx bin/nginx-light
404 %endif
405
406 build standard \
407         %{?with_addition:--with-http_addition_module} \
408         %{?with_dav:--with-http_dav_module} \
409         %{?with_flv:--with-http_flv_module} \
410         %{?with_sub:--with-http_sub_module} \
411         %{?with_realip:--with-http_realip_module} \
412         %{?with_status:--with-http_stub_status_module} \
413         %{?with_ssl:--with-http_ssl_module} \
414         %{!?with_http_browser:--without-http_browser_module} \
415         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
416         %{?with_auth_request:--with-http_auth_request_module} \
417         %{?with_threads:--with-threads} \
418         %{?with_http2:--with-http_v2_module} \
419         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
420         --with-http_secure_link_module \
421         %{nil}
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
426         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
427         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
428         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
429         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
430         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
431         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
432         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
433
434 %{__make} install \
435         INSTALLDIRS=vendor \
436         DESTDIR=$RPM_BUILD_ROOT
437
438 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
439
440 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
441 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
442 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
443 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
444
445 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
446 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
447 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
448 rm -r $RPM_BUILD_ROOT%{_prefix}/html
449 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
450 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
451 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
452
453 %if %{with perl}
454 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
455 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
456 %endif
457
458 # only touch these for ghost packaging
459 touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
460
461 %clean
462 rm -rf $RPM_BUILD_ROOT
463
464 %pre
465 %groupadd -r -g 213 %{name}
466 %groupadd -g 51 http
467 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
468 %addusertogroup %{name} http
469
470 %post
471 for a in access.log error.log; do
472         if [ ! -f /var/log/%{name}/$a ]; then
473                 umask 022
474                 touch /var/log/%{name}/$a
475                 chown nginx:nginx /var/log/%{name}/$a
476                 chmod 644 /var/log/%{name}/$a
477         fi
478 done
479 /sbin/chkconfig --add %{name}
480 %systemd_post %{name}.service
481 %service %{name} force-reload
482
483 %preun
484 if [ "$1" = "0" ];then
485         %service %{name} stop
486         /sbin/chkconfig --del %{name}
487 fi
488 %systemd_preun %{name}.service
489
490 %postun
491 if [ "$1" = "0" ]; then
492         %userremove %{name}
493         %groupremove %{name}
494 fi
495 %systemd_reload
496
497 %triggerpostun -- %{name}-standard < 1.4.1-4
498 %systemd_trigger %{name}-standard.service
499
500 %triggerpostun -- %{name}-light < 1.4.1-4
501 %systemd_trigger %{name}-light.service
502
503 %triggerpostun -- %{name}-perl < 1.4.1-4
504 %systemd_trigger %{name}-perl.service
505
506 %triggerpostun -- %{name}-mail < 1.4.1-4
507 %systemd_trigger %{name}-mail.service
508
509 %triggerpostun common -- %{name}-common < 1.8.0-2
510 # skip *this* trigger on downgrade
511 [ $1 -le 1 ] && exit 0
512 ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
513 ln -sf scgi_params %{_sysconfdir}/scgi.params
514 ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
515 exit 0
516
517 %files
518 %defattr(644,root,root,755)
519 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
520 %doc %lang(ru) CHANGES.ru
521 %dir %attr(750,root,nginx) %{_sysconfdir}
522 %dir %{_nginxdir}
523 %dir %{_nginxdir}/cgi-bin
524 %dir %{_nginxdir}/html
525 %dir %{_nginxdir}/errors
526 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
527 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
529 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
530 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
531 %ghost %{_sysconfdir}/fastcgi.params
532 %ghost %{_sysconfdir}/scgi.params
533 %ghost %{_sysconfdir}/uwsgi.params
534 %attr(640,root,root) %{_sysconfdir}/mime.types
535 %attr(640,root,root) %{_sysconfdir}/koi-utf
536 %attr(640,root,root) %{_sysconfdir}/koi-win
537 %attr(640,root,root) %{_sysconfdir}/win-utf
538 %dir %{_sysconfdir}/webapps.d
539 %dir %{_sysconfdir}/vhosts.d
540 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
541 %attr(750,nginx,logs) /var/log/%{name}
542 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
543 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
544
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_sbindir}/%{name}
547 %attr(770,root,%{name}) /var/cache/%{name}
548 %attr(754,root,root) /etc/rc.d/init.d/%{name}
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
550 %{systemdunitdir}/%{name}.service
551
552 %if %{with mail}
553 %files mail
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
556 %endif
557
558 %if %{with light}
559 %files light
560 %defattr(644,root,root,755)
561 %endif
562
563 %if %{with perl}
564 %files perl
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
567 %dir %{perl_vendorarch}/auto/%{name}
568 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
569 %{perl_vendorarch}/%{name}.pm
570 %{_mandir}/man3/nginx.3pm*
571 %endif
572
573 %files -n monit-rc-nginx
574 %defattr(644,root,root,755)
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.288256 seconds and 2 git commands to generate.