]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- rel 2
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - nginx should have own group (and work with it) or use http group ?
5 #
6 # Conditional build for nginx:
7 %bcond_without  light           # don't build light version
8 %bcond_without  mail            # don't build imap/mail proxy
9 %bcond_without  perl            # don't build with perl module
10 %bcond_without  addition        # adds module
11 %bcond_without  dav             # WebDAV
12 %bcond_without  flv             # FLV stream
13 %bcond_without  ipv6            # build without ipv6 support
14 %bcond_without  sub             # ngx_http_sub_module
15 %bcond_without  poll            # poll
16 %bcond_without  realip          # real ip (behind proxy)
17 %bcond_without  rtsig           # rtsig
18 %bcond_without  select          # select
19 %bcond_without  status          # stats module
20 %bcond_without  ssl             # ssl support
21 %bcond_with     http_browser    # header "User-agent" parser
22 #
23 Summary:        High perfomance HTTP and reverse proxy server
24 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
25 Name:           nginx
26 Version:        1.0.11
27 Release:        2
28 License:        BSD-like
29 Group:          Networking/Daemons/HTTP
30 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
31 # Source0-md5:  a41a01d7cd46e13ea926d7c9ca283a95
32 Source1:        http://nginx.net/favicon.ico
33 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
34 Source2:        proxy.conf
35 Source3:        %{name}.logrotate
36 Source4:        %{name}.mime
37 Source5:        %{name}-light.conf
38 Source6:        %{name}-light.monitrc
39 Source7:        %{name}-light.init
40 Source8:        %{name}-mail.conf
41 Source9:        %{name}-mail.monitrc
42 Source10:       %{name}-mail.init
43 Source11:       %{name}-perl.conf
44 Source12:       %{name}-perl.monitrc
45 Source13:       %{name}-perl.init
46 Source14:       %{name}-standard.conf
47 Source15:       %{name}-standard.monitrc
48 Source16:       %{name}-standard.init
49 Source17:       %{name}-mime.types.sh
50 URL:            http://nginx.net/
51 BuildRequires:  mailcap
52 BuildRequires:  openssl-devel
53 BuildRequires:  pcre-devel
54 %{?with_perl:BuildRequires: perl-CGI}
55 %{?with_perl:BuildRequires: perl-devel}
56 %{?with_perl:BuildRequires: python}
57 %{?with_perl:BuildRequires: rpm-perlprov}
58 BuildRequires:  rpmbuild(macros) >= 1.268
59 BuildRequires:  zlib-devel
60 Requires(post,preun):   /sbin/chkconfig
61 Requires(postun):       /usr/sbin/groupdel
62 Requires(postun):       /usr/sbin/userdel
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 #Requires:      nginx-daemon
68 Requires:       openssl
69 Requires:       pcre
70 Requires:       rc-scripts >= 0.2.0
71 Requires:       zlib
72 Suggests:       nginx-standard
73 Provides:       group(http)
74 Provides:       group(nginx)
75 Provides:       user(nginx)
76 Provides:       webserver
77 Conflicts:      logrotate < 3.8.0
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _sysconfdir     /etc/%{name}
81 %define         _nginxdir       /home/services/%{name}
82
83 %description
84 nginx ("engine x") is a high-performance HTTP server and reverse
85 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
86 Sysoev for Rambler.ru, Russia's second-most visited website, where it
87 has been running in production for over two and a half years. Igor has
88 released the source code under a BSD-like license. Although still in
89 beta, nginx is known for its stability, rich feature set, simple
90 configuration, and low resource consumption.
91
92 Common files for nginx daemon.
93
94 %description -l pl.UTF-8
95 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
96 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
97 na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
98 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
99 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
100 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
101 prostej konfiguracji oraz małej "zasobożerności".
102
103 Niezbędne pliki dla nginx.
104
105 %package light
106 Summary:        High perfomance HTTP and reverse proxy server
107 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
108 Group:          Networking/Daemons/HTTP
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(postun):       /usr/sbin/groupdel
111 Requires(postun):       /usr/sbin/userdel
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       openssl
114 Requires:       pcre
115 Requires:       zlib
116 Provides:       group(http)
117 Provides:       group(nginx)
118 Provides:       nginx-daemon
119 Provides:       user(nginx)
120 Provides:       webserver
121
122 %description light
123 The smallest, but also the fastest nginx edition. No additional
124 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
125
126 %description light -l pl.UTF-8
127 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
128 FLV oraz IMAP, POP3, SMTP proxy.
129
130 %package perl
131 Summary:        High perfomance HTTP and reverse proxy server
132 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
133 Group:          Networking/Daemons/HTTP
134 Requires(post,preun):   /sbin/chkconfig
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       openssl
139 Provides:       group(http)
140 Provides:       group(nginx)
141 Provides:       nginx-daemon
142 Provides:       user(nginx)
143 Provides:       webserver
144
145 %description perl
146 nginx with Perl support. Mail modules not included.
147
148 %description perl -l pl.UTF-8
149 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
150
151 %package mail
152 Summary:        High perfomance IMAP, POP3, SMTP proxy server
153 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
154 Group:          Networking/Daemons/HTTP
155 Requires(post,preun):   /sbin/chkconfig
156 Requires(postun):       /usr/sbin/groupdel
157 Requires(postun):       /usr/sbin/userdel
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       openssl
160 Requires:       pcre
161 Requires:       zlib
162 Provides:       group(http)
163 Provides:       group(nginx)
164 Provides:       nginx-daemon
165 Provides:       user(nginx)
166 Provides:       webserver
167
168 %description mail
169 nginx with mail support. Only mail modules included.
170
171 %description mail -l pl.UTF-8
172 nginx ze wsparciem tylko dla modułów poczty.
173
174 %package standard
175 Summary:        High perfomance HTTP and reverse proxy server
176 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
177 Group:          Networking/Daemons/HTTP
178 Requires(post,preun):   /sbin/chkconfig
179 Requires(postun):       /usr/sbin/groupdel
180 Requires(postun):       /usr/sbin/userdel
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       openssl
183 Provides:       group(http)
184 Provides:       group(nginx)
185 Provides:       nginx-daemon
186 Conflicts:      logrotate < 3.7-4
187
188 %description standard
189 This is standard nginx version, without Perl support and IMAP, POP3,
190 SMTP proxy. 
191
192 %description standard -l pl.UTF-8
193 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
194 IMAP, POP3, SMTP.
195
196 %package -n monit-rc-nginx
197 Summary:        nginx support for monit
198 Summary(pl.UTF-8):      Wsparcie nginx dla monit
199 Group:          Applications/System
200 URL:            http://nginx.eu/
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       monit
203
204 %description -n monit-rc-nginx
205 monitrc file for monitoring nginx webserver.
206
207 %description -n monit-rc-nginx -l pl.UTF-8
208 Plik monitrc do monitorowania serwera WWW nginx.
209
210 %prep
211 %setup -q
212
213 # build mime.types.conf
214 #sh %{SOURCE17} /etc/mime.types
215
216 %build
217 # NB: not autoconf generated configure
218 cp -f configure auto/
219 #
220 %if %{with perl}
221 ./configure \
222         --prefix=%{_prefix} \
223         --sbin-path=%{_sbindir}/%{name}-perl \
224         --conf-path=%{_sysconfdir}/%{name}-perl.conf \
225         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
226         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
227         --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
228         --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
229         --user=nginx \
230         --group=nginx \
231         --with-http_perl_module \
232         --without-mail_pop3_module \
233         --without-mail_imap_module \
234         --without-mail_smtp_module \
235         %{?with_addition:--with-http_addition_module} \
236         %{?with_dav:--with-http_dav_module} \
237         %{?with_flv:--with-http_flv_module} \
238         %{?with_ipv6:--with-ipv6} \
239         %{?with_sub:--with-http_sub_module} \
240         %{?with_poll:--with-poll_module} \
241         %{?with_realip:--with-http_realip_module} \
242         %{?with_rtsig:--with-rtsig_module} \
243         %{?with_select:--with-select_module} \
244         %{?with_status:--with-http_stub_status_module} \
245         %{?with_ssl:--with-http_ssl_module} \
246         %{!?with_http_browser:--without-http_browser_module} \
247         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
248         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
249         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
250         --with-cc="%{__cc}" \
251         --with-cc-opt="%{rpmcflags}" \
252         --with-ld-opt="%{rpmldflags}"
253 %{__make}
254 mv -f objs/nginx contrib/nginx-perl
255 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
256 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
257 mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
258 %endif
259
260 %if %{with mail}
261 ./configure \
262         --prefix=%{_prefix} \
263         --sbin-path=%{_sbindir}/%{name}-mail \
264         --conf-path=%{_sysconfdir}/%{name}-mail.conf \
265         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
266         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
267         --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
268         --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
269         --user=nginx \
270         --group=nginx \
271         --with-imap \
272         --with-mail \
273         --with-mail_ssl_module \
274         --without-http \
275         %{?with_ipv6:--with-ipv6} \
276         %{?with_poll:--with-poll_module} \
277         %{?with_rtsig:--with-rtsig_module} \
278         %{?with_select:--with-select_module} \
279         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
280         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
281         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
282         --with-cc="%{__cc}" \
283         --with-cc-opt="%{rpmcflags}" \
284         --with-ld-opt="%{rpmldflags}" \
285         %{?debug:--with-debug}
286 %{__make}
287 mv -f objs/nginx contrib/nginx-mail
288 %endif
289
290 %if %{with light}
291 ./configure \
292         --prefix=%{_prefix} \
293         --sbin-path=%{_sbindir}/%{name}-light \
294         --conf-path=%{_sysconfdir}/%{name}-light.conf \
295         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
296         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
297         --pid-path=%{_localstatedir}/run/%{name}-light.pid \
298         --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
299         --user=nginx \
300         --group=nginx \
301         %{?with_ipv6:--with-ipv6} \
302         %{?with_poll:--with-poll_module} \
303         %{?with_realip:--with-http_realip_module} \
304         %{?with_rtsig:--with-rtsig_module} \
305         %{?with_select:--with-select_module} \
306         %{?with_status:--with-http_stub_status_module} \
307         %{?with_ssl:--with-http_ssl_module} \
308         --without-http_browser_module \
309         --without-mail_pop3_module \
310         --without-mail_imap_module \
311         --without-mail_smtp_module \
312         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
313         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
314         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
315         --with-cc="%{__cc}" \
316         --with-cc-opt="%{rpmcflags}" \
317         --with-ld-opt="%{rpmldflags}" \
318         %{?debug:--with-debug}
319 %{__make}
320 mv -f objs/nginx contrib/nginx-light
321 %endif
322
323 ./configure \
324         --prefix=%{_prefix} \
325         --sbin-path=%{_sbindir}/%{name}-standard \
326         --conf-path=%{_sysconfdir}/%{name}-standard.conf \
327         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
328         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
329         --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
330         --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
331         --user=nginx \
332         --group=nginx \
333         %{?with_addition:--with-http_addition_module} \
334         %{?with_dav:--with-http_dav_module} \
335         %{?with_flv:--with-http_flv_module} \
336         %{?with_ipv6:--with-ipv6} \
337         %{?with_sub:--with-http_sub_module} \
338         %{?with_poll:--with-poll_module} \
339         %{?with_realip:--with-http_realip_module} \
340         %{?with_rtsig:--with-rtsig_module} \
341         %{?with_select:--with-select_module} \
342         %{?with_status:--with-http_stub_status_module} \
343         %{?with_ssl:--with-http_ssl_module} \
344         %{!?with_http_browser:--without-http_browser_module} \
345         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
346         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
347         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
348         --with-cc="%{__cc}" \
349         --with-cc-opt="%{rpmcflags}" \
350         --with-ld-opt="%{rpmldflags}" \
351         %{?debug:--with-debug}
352 %{__make}
353
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
358         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
359         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
360         $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
361         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
362         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
363         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
364
365 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
366 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
367 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
368 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
369 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
370 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
371 install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
372 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
373 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
374 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
375 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
376 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
377 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
378 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
379
380 %if %{with light}
381 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
382 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
383 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
384 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
385 %endif
386
387 %if %{with mail}
388 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
389 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
390 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
391 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
392 %endif
393
394 %if %{with perl}
395 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
396 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
397 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
398 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
399 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
400 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
401 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
402 install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
403 %endif
404
405 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
406 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %pre
412 %groupadd -r -g 213 %{name}
413 %groupadd -g 51 http
414 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
415 %addusertogroup %{name} http
416
417 %post standard
418 for a in access.log error.log; do
419         if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
420                 umask 022
421                 touch /var/log/%{name}/nginx-standard_$a
422                 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
423                 chmod 644 /var/log/%{name}/nginx-standard_$a
424         fi
425 done
426 /sbin/chkconfig --add %{name}-standard
427 %service %{name}-standard restart
428 echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
429
430 %post light
431 for a in access.log error.log; do
432         if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
433                 umask 022
434                 touch /var/log/%{name}/nginx-light_$a
435                 chown nginx:nginx /var/log/%{name}/nginx-light_$a
436                 chmod 644 /var/log/%{name}/nginx-light_$a
437         fi
438 done
439 /sbin/chkconfig --add %{name}-light
440 %service %{name}-light restart
441 echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
442
443 %post perl
444 for a in access.log error.log; do
445         if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
446                 umask 022
447                 touch /var/log/%{name}/nginx-perl_$a
448                 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
449                 chmod 644 /var/log/%{name}/nginx-perl_$a
450         fi
451 done
452 /sbin/chkconfig --add %{name}-perl
453 %service %{name}-perl restart
454 echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
455
456 %post mail
457 for a in access.log error.log; do
458         if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
459                 umask 022
460                 touch /var/log/%{name}/nginx-mail_$a
461                 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
462                 chmod 644 /var/log/%{name}/nginx-mail_$a
463         fi
464 done
465 /sbin/chkconfig --add %{name}-mail
466 %service %{name}-mail restart
467 echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
468
469 %preun standard
470 if [ "$1" = "0" ];then
471         %service %{name}-standard stop
472         /sbin/chkconfig --del %{name}-standard
473 fi
474
475 %preun light
476 if [ "$1" = "0" ]; then
477         %service %{name}-light stop
478         /sbin/chkconfig --del %{name}-light
479 fi
480
481 %preun perl
482 if [ "$1" = "0" ]; then
483         %service %{name}-perl stop
484         /sbin/chkconfig --del %{name}-perl
485 fi
486
487 %preun mail
488 if [ "$1" = "0" ]; then
489         %service %{name}-mail stop
490         /sbin/chkconfig --del %{name}-mail
491 fi
492
493 %postun
494 if [ "$1" = "0" ]; then
495         %userremove %{name}
496         %groupremove %{name}
497 fi
498
499 %files
500 %defattr(644,root,root,755)
501 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
502 %doc %lang(ru) CHANGES.ru
503 %dir %attr(754,root,root) %{_sysconfdir}
504 %dir %{_nginxdir}
505 %dir %{_nginxdir}/cgi-bin
506 %dir %{_nginxdir}/html
507 %dir %{_nginxdir}/errors
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
509 # XXX: duplicates, don't use such glob here
510 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
512 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
513 %attr(640,root,root) %{_sysconfdir}/mime.types
514 %attr(640,root,root) %{_sysconfdir}/koi-utf
515 %attr(640,root,root) %{_sysconfdir}/koi-win
516 %attr(640,root,root) %{_sysconfdir}/win-utf
517 %attr(750,root,root) %dir /var/log/archive/%{name}
518 %attr(750,%{name},logs) /var/log/%{name}
519 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
520 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
521
522 %files standard
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_sbindir}/%{name}-standard
525 %attr(770,root,%{name}) /var/cache/%{name}-standard
526 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
527 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
528
529 %if %{with mail}
530 %files mail
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_sbindir}/%{name}-mail
533 %attr(770,root,%{name}) /var/cache/%{name}-mail
534 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
535 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
536 %endif
537
538 %if %{with light}
539 %files light
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_sbindir}/%{name}-light
542 %attr(770,root,%{name}) /var/cache/%{name}-light
543 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
544 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
545 %endif
546
547 %if %{with perl}
548 %files perl
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_sbindir}/%{name}-perl
551 %attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
552 %attr(770,root,%{name}) /var/cache/%{name}-perl
553 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
554 %dir %{perl_vendorarch}/auto/%{name}
555 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
556 %{perl_vendorarch}/auto/%{name}/%{name}.bs
557 %{perl_vendorarch}/%{name}.pm
558 %endif
559
560 %files -n monit-rc-nginx
561 %defattr(644,root,root,755)
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
563 %if %{with perl}
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
565 %endif
566 %if %{with light}
567 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
568 %endif
569 %if %{with mail}
570 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
571 %endif
This page took 0.083547 seconds and 3 git commands to generate.