]> git.pld-linux.org Git - packages/nghttp3.git/blob - nghttp3.spec
9d7f3c5117f8da4c0369975e6930b0d910141258
[packages/nghttp3.git] / nghttp3.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (files missing in tarball)
4 %bcond_without  static_libs     # static libraries
5 #
6 Summary:        Implementation of HTTP/3 mapping over QUIC and QPACK in C
7 Summary(pl.UTF-8):      Implementacja w C odwzorowania HTTP/3 w oparciu o QUIC i QPACK
8 Name:           nghttp3
9 Version:        0.7.1
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/ngtcp2/nghttp3/releases
14 Source0:        https://github.com/ngtcp2/nghttp3/releases/download/v%{version}/%{name}-%{version}.tar.xz
15 # Source0-md5:  1448b49160206c4a3ae09ac241de8337
16 URL:            https://github.com/ngtcp2/nghttp3
17 BuildRequires:  libstdc++-devel >= 6:7
18 BuildRequires:  pkgconfig >= 1:0.20
19 BuildRequires:  rpm-build >= 4.6
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with apidocs}
23 BuildRequires:  sphinx-pdg
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 nghttp3 is an implementation of HTTP/3 mapping over QUIC and QPACK in
29 C.
30
31 It does not depend on any particular QUIC transport implementation.
32
33 %description -l pl.UTF-8
34 nghttp3 to implementacja w C odwzorowania HTTP/3 w oparciu o QUIC i
35 QPACK.
36
37 %package devel
38 Summary:        Header files for nghttp3 library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki nghttp3
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for nghttp3 library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki nghttp3.
48
49 %package static
50 Summary:        Static nghttp3 library
51 Summary(pl.UTF-8):      Statyczna biblioteka nghttp3
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static nghttp3 library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka nghttp3.
60
61 %package apidocs
62 Summary:        API documentation for nghttp3 library
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki nghttp3
64 Group:          Documentation
65 BuildArch:      noarch
66
67 %description apidocs
68 API documentation for nghttp3 library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki nghttp3.
72
73 %prep
74 %setup -q
75
76 %build
77 %configure \
78         --disable-silent-rules \
79         %{!?with_static_libs:--disable-static}
80 %{__make}
81
82 %if %{with apidocs}
83 %{__make} -C doc html
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # no external dependencies, obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp3.la
94 # packaged as %doc
95 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nghttp3
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS COPYING ChangeLog README.rst
106 %attr(755,root,root) %{_libdir}/libnghttp3.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libnghttp3.so.3
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libnghttp3.so
112 %{_includedir}/nghttp3
113 %{_pkgconfigdir}/libnghttp3.pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libnghttp3.a
119 %endif
120
121 %if %{with apidocs}
122 %files apidocs
123 %defattr(644,root,root,755)
124 %doc doc/build/*
125 %endif
This page took 0.085916 seconds and 2 git commands to generate.