]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
comment on CXX and improve others
[packages/netsurf.git] / netsurf.spec
1 Summary:        Light www browser
2 Name:           netsurf
3 Version:        2.9
4 Release:        1
5 License:        GPL v2
6 Group:          Applications/Networking
7 Source0:        http://download.netsurf-browser.org/netsurf/releases/source-full/%{name}-%{version}-full-src.tar.gz
8 # Source0-md5:  cfc2789997b356f2ea9d9f7694c4c909
9 Source1:        %{name}.desktop
10 Patch0:         enable-nsfb.patch
11 Patch1:         libnsfb-xcb-fix.patch
12 Patch2:         nsfb-F10-exit.patch
13 URL:            http://netsurf-browser.org/
14 BuildRequires:  SDL-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  libglade2-devel
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libmng-devel
20 BuildRequires:  libpng-devel
21 BuildRequires:  librsvg-devel
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Small web browser with CSS support. NetSurf is a multi-platform
28 lightweight web browser. Its aim is to provide comprehensive rendering
29 of HTML 5 with CSS 2 in a small resource footprint while remaining
30 fast.
31
32 %package common
33 Summary:        netsurf - common files
34 Summary(pl.UTF-8):      netsurf - pliki wspólne
35 License:        GPL v2
36 Group:          Applications/Networking
37
38 %description common
39 netsurf - common files.
40
41 %description common -l pl.UTF-8
42 netsurf - wspólne pliki.
43
44 %package gtk
45 Summary:        netsurf browser gtk version
46 Summary(pl.UTF-8):      Wersja gtk netsurfa
47 License:        GPL v2
48 Group:          Applications/Networking
49 Requires:       %{name}-common = %{version}-%{release}
50
51 %description gtk
52 Small web browser with CSS support. NetSurf is a multi-platform
53 lightweight web browser. Its aim is to provide comprehensive rendering
54 of HTML 5 with CSS 2 in a small resource footprint while remaining
55 fast.
56
57 This is gtk version.
58
59 %package sdl
60 Summary:        netsurf browser SDL version
61 Summary(pl.UTF-8):      Wersja SDL netsurfa
62 License:        GPL v2
63 Group:          Applications/Networking
64 Requires:       %{name}-common = %{version}-%{release}
65
66 %description sdl
67 Small web browser with CSS support. NetSurf is a multi-platform
68 lightweight web browser. Its aim is to provide comprehensive rendering
69 of HTML 5 with CSS 2 in a small resource footprint while remaining
70 fast.
71
72 This is SDL version.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79
80 cat << EOF > netsurf-2.9/Makefile.config
81 NETSURF_FB_FONTLIB := freetype
82 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
83 EOF
84
85 %build
86 export CC="%{__cc}"
87 # while cxx not needed, somewhy it helps race condition on carme build
88 export CXX="%{__cxx}"
89 # silence -Werror:
90 #src/surface/vnc.c: In function 'vnc_input':
91 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
92 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
93 export LDFLAGS="%{rpmldflags}"
94
95 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
96
97 %{__make} -j1 \
98         PREFIX=%{_prefix} \
99         Q='' \
100         TARGET=gtk
101
102 %{__make} -j1 \
103         PREFIX=%{_prefix} \
104         Q='' \
105         TARGET=framebuffer
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} install \
110         Q='' \
111         PREFIX=%{_prefix} \
112         TARGET=gtk \
113         DESTDIR=$RPM_BUILD_ROOT
114
115
116 %{__make} install \
117         Q='' \
118         PREFIX=%{_prefix} \
119         TARGET=framebuffer \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 # this is binary from last "make install", we install more specific binary ourself
123 %{__rm} $RPM_BUILD_ROOT%{_bindir}/netsurf
124
125 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
126 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
127 install -p netsurf-2.9/nsfb $RPM_BUILD_ROOT/%{_bindir}
128 install -p netsurf-2.9/nsgtk $RPM_BUILD_ROOT/%{_bindir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files common
134 %defattr(644,root,root,755)
135 %doc netsurf-2.9/ChangeLog netsurf-2.9/README
136 %dir %{_datadir}/%{name}
137 %{_datadir}/%{name}/*
138
139 %files gtk
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/nsgtk
142 %{_desktopdir}/netsurf.desktop
143
144 %files sdl
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.06694 seconds and 4 git commands to generate.