]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
- rebuild with libmng 2.0.2
[packages/netsurf.git] / netsurf.spec
1 Summary:        Light www browser
2 Name:           netsurf
3 Version:        3.0
4 Release:        4
5 License:        GPL v2
6 Group:          Applications/Networking
7 Source0:        http://download.netsurf-browser.org/netsurf/releases/source-full/%{name}-%{version}-full-src.tar.gz
8 # Source0-md5:  51b13676d5f012409e0aefc6404938f6
9 Source1:        %{name}.desktop
10 Patch0:         scroll.patch
11 Patch1:         libnsfb-xcb-fix.patch
12 Patch2:         nsfb-F10-exit.patch
13 Patch3:         nsfb-ldflags.patch
14 URL:            http://netsurf-browser.org/
15 BuildRequires:  SDL-devel
16 BuildRequires:  curl-devel
17 BuildRequires:  freetype-devel
18 BuildRequires:  libCSS-devel
19 BuildRequires:  libdom-devel
20 BuildRequires:  libglade2-devel
21 BuildRequires:  libhubbub-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libmng-devel
24 BuildRequires:  libnsbmp-devel
25 BuildRequires:  libnsfb-devel
26 BuildRequires:  libnsgif-devel
27 BuildRequires:  libparserutils-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  librsvg-devel
30 BuildRequires:  libsvgtiny-devel
31 BuildRequires:  libwapcaplet-devel
32 BuildRequires:  netsurf-buildsystem
33 BuildRequires:  nsgenbind
34 BuildRequires:  perl-base
35 BuildRequires:  pkgconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Small web browser with CSS support. NetSurf is a multi-platform
40 lightweight web browser. Its aim is to provide comprehensive rendering
41 of HTML 5 with CSS 2 in a small resource footprint while remaining
42 fast.
43
44 %package common
45 Summary:        netsurf - common files
46 Summary(pl.UTF-8):      netsurf - pliki wspólne
47 License:        GPL v2
48 Group:          Applications/Networking
49
50 %description common
51 netsurf - common files.
52
53 %description common -l pl.UTF-8
54 netsurf - wspólne pliki.
55
56 %package gtk
57 Summary:        netsurf browser gtk version
58 Summary(pl.UTF-8):      Wersja gtk netsurfa
59 License:        GPL v2
60 Group:          Applications/Networking
61 Requires:       %{name}-common = %{version}-%{release}
62
63 %description gtk
64 Small web browser with CSS support. NetSurf is a multi-platform
65 lightweight web browser. Its aim is to provide comprehensive rendering
66 of HTML 5 with CSS 2 in a small resource footprint while remaining
67 fast.
68
69 This is gtk version.
70
71 %package sdl
72 Summary:        netsurf browser SDL version
73 Summary(pl.UTF-8):      Wersja SDL netsurfa
74 License:        GPL v2
75 Group:          Applications/Networking
76 Requires:       %{name}-common = %{version}-%{release}
77
78 %description sdl
79 Small web browser with CSS support. NetSurf is a multi-platform
80 lightweight web browser. Its aim is to provide comprehensive rendering
81 of HTML 5 with CSS 2 in a small resource footprint while remaining
82 fast.
83
84 This is SDL version.
85
86 %prep
87 %setup -q -n netsurf-full-%{version}
88 %patch0 -p1
89 #%patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92
93 cat << EOF > src/netsurf-3.0/Makefile.config
94 NETSURF_FB_FONTLIB := freetype
95 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
96 EOF
97
98 %build
99 cd src/netsurf-%{version}
100 export CC="%{__cc}"
101 # while cxx not needed, somewhy it helps race condition on carme build
102 export CXX="%{__cxx}"
103 # silence -Werror:
104 #src/surface/vnc.c: In function 'vnc_input':
105 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
106 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
107 export LDFLAGS="%{rpmldflags}"
108
109 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
110
111 %{__make} -j1 \
112         PREFIX=%{_prefix} \
113         Q='' \
114         TARGET=gtk
115
116 %{__make} -j1 \
117         PREFIX=%{_prefix} \
118         Q='' \
119         TARGET=framebuffer
120
121 %install
122 cd src/netsurf-%{version}
123 rm -rf $RPM_BUILD_ROOT
124 %{__make} install \
125         Q='' \
126         PREFIX=%{_prefix} \
127         TARGET=gtk \
128         DESTDIR=$RPM_BUILD_ROOT
129
130
131 %{__make} install \
132         Q='' \
133         PREFIX=%{_prefix} \
134         TARGET=framebuffer \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # this is binary from last "make install", we install more specific binary ourself
138 %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/netsurf
139
140 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
141 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
142 install nsfb $RPM_BUILD_ROOT/%{_bindir}
143 install nsgtk $RPM_BUILD_ROOT/%{_bindir}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files common
149 %defattr(644,root,root,755)
150 %doc src/netsurf-%{version}/README
151 %dir %{_datadir}/%{name}
152 %{_datadir}/%{name}/*
153
154 %files gtk
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/nsgtk
157 %{_desktopdir}/netsurf.desktop
158
159 %files sdl
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.044215 seconds and 4 git commands to generate.