]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
fix desktopfile
[packages/netsurf.git] / netsurf.spec
1 Summary:        Light WWW browser
2 Name:           netsurf
3 Version:        3.0
4 Release:        5
5 License:        GPL v2
6 Group:          Applications/Networking
7 Source0:        http://download.netsurf-browser.org/netsurf/releases/source-full/%{name}-%{version}-full-src.tar.gz
8 # Source0-md5:  51b13676d5f012409e0aefc6404938f6
9 Source1:        %{name}.desktop
10 Patch0:         scroll.patch
11 Patch1:         libnsfb-xcb-fix.patch
12 Patch2:         nsfb-F10-exit.patch
13 Patch3:         nsfb-ldflags.patch
14 URL:            http://netsurf-browser.org/
15 BuildRequires:  SDL-devel
16 BuildRequires:  curl-devel
17 BuildRequires:  freetype-devel
18 BuildRequires:  libCSS-devel
19 BuildRequires:  libdom-devel
20 BuildRequires:  libglade2-devel
21 BuildRequires:  libhubbub-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libmng-devel
24 BuildRequires:  libnsbmp-devel
25 BuildRequires:  libnsfb-devel
26 BuildRequires:  libnsgif-devel
27 BuildRequires:  libparserutils-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  librsvg-devel
30 BuildRequires:  libsvgtiny-devel
31 BuildRequires:  libwapcaplet-devel
32 BuildRequires:  netsurf-buildsystem
33 BuildRequires:  nsgenbind
34 BuildRequires:  perl-base
35 BuildRequires:  pkgconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Small web browser with CSS support. NetSurf is a multi-platform
40 lightweight web browser. Its aim is to provide comprehensive rendering
41 of HTML 5 with CSS 2 in a small resource footprint while remaining
42 fast.
43
44 %package common
45 Summary:        netsurf - common files
46 Summary(pl.UTF-8):      netsurf - pliki wspólne
47 Group:          Applications/Networking
48
49 %description common
50 netsurf - common files.
51
52 %description common -l pl.UTF-8
53 netsurf - wspólne pliki.
54
55 %package gtk
56 Summary:        Netsurf browser GTK version
57 Summary(pl.UTF-8):      Wersja gtk netsurfa
58 Group:          Applications/Networking
59 Requires:       %{name}-common = %{version}-%{release}
60
61 %description gtk
62 Small web browser with CSS support. NetSurf is a multi-platform
63 lightweight web browser. Its aim is to provide comprehensive rendering
64 of HTML 5 with CSS 2 in a small resource footprint while remaining
65 fast.
66
67 This is GTK version.
68
69 %package sdl
70 Summary:        netsurf browser SDL version
71 Summary(pl.UTF-8):      Wersja SDL netsurfa
72 Group:          Applications/Networking
73 Requires:       %{name}-common = %{version}-%{release}
74
75 %description sdl
76 Small web browser with CSS support. NetSurf is a multi-platform
77 lightweight web browser. Its aim is to provide comprehensive rendering
78 of HTML 5 with CSS 2 in a small resource footprint while remaining
79 fast.
80
81 This is SDL version.
82
83 %prep
84 %setup -q -n %{name}-full-%{version}
85 %patch0 -p1
86 #%patch1 -p1
87 %patch2 -p1
88 %patch3 -p1
89
90 cat << EOF > src/netsurf-3.0/Makefile.config
91 NETSURF_FB_FONTLIB := freetype
92 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
93 EOF
94
95 %build
96 cd src/netsurf-%{version}
97 export CC="%{__cc}"
98 # while cxx not needed, somewhy it helps race condition on carme build
99 export CXX="%{__cxx}"
100 # silence -Werror:
101 #src/surface/vnc.c: In function 'vnc_input':
102 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
103 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
104 export LDFLAGS="%{rpmldflags}"
105
106 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
107
108 %{__make} -j1 \
109         PREFIX=%{_prefix} \
110         Q='' \
111         TARGET=gtk
112
113 %{__make} -j1 \
114         PREFIX=%{_prefix} \
115         Q='' \
116         TARGET=framebuffer
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 cd src/netsurf-%{version}
121 rm -rf $RPM_BUILD_ROOT
122 %{__make} install \
123         Q='' \
124         PREFIX=%{_prefix} \
125         TARGET=gtk \
126         DESTDIR=$RPM_BUILD_ROOT
127
128
129 %{__make} install \
130         Q='' \
131         PREFIX=%{_prefix} \
132         TARGET=framebuffer \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 # this is binary from last "make install", we install more specific binary ourself
136 %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/netsurf
137
138 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
139 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
140 install nsfb $RPM_BUILD_ROOT/%{_bindir}
141 install nsgtk $RPM_BUILD_ROOT/%{_bindir}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files common
147 %defattr(644,root,root,755)
148 %doc src/netsurf-%{version}/README
149 %dir %{_datadir}/%{name}
150 %{_datadir}/%{name}/*
151
152 %files gtk
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/nsgtk
155 %{_desktopdir}/netsurf.desktop
156
157 %files sdl
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.03558 seconds and 4 git commands to generate.