]> git.pld-linux.org Git - packages/netcdf.git/blob - netcdf.spec
b5fa70065c727ac66fac964f24519f56ffdf4819
[packages/netcdf.git] / netcdf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4                                 # (note: tests need endoder-enabled szip)
5 %bcond_with     tests_net       # remote tests (Internet access required)
6 #
7 Summary:        NetCDF: Network Common Data Form
8 Summary(pl.UTF-8):      NetCDF: obsługa wspólnego sieciowego formatu danych
9 Name:           netcdf
10 Version:        4.3.2
11 Release:        4
12 License:        BSD-like
13 Group:          Libraries
14 Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
15 # Source0-md5:  2fd2365e1fe9685368cd6ab0ada532a0
16 URL:            http://www.unidata.ucar.edu/packages/netcdf/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  curl-devel
20 BuildRequires:  doxygen
21 BuildRequires:  hdf5-devel >= 1.8.5
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  szip-devel >= 2.1-2
26 BuildRequires:  texinfo
27 Requires:       hdf5 >= 1.8.5
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 NetCDF (network Common Data Form) is an interface for array-oriented
32 data access and a library that provides an implementation of the
33 interface. The netCDF library also defines a machine-independent
34 format for representing scientific data. Together, the interface,
35 library, and format support the creation, access, and sharing of
36 scientific data. The netCDF software was developed at the Unidata
37 Program Center in Boulder, Colorado.
38
39 This package contains C library.
40
41 %description -l pl.UTF-8
42 NetCDF (Network Common Data Form) jest interfejsem dostępu do danych
43 zorganizowanych w tablice. Biblioteka netCDF definiuje niezależny od
44 maszyny format reprezentowania danych naukowych. Interfejs oraz
45 biblioteka pozwalają na tworzenie, dostęp i współdzielenie danych.
46 NetCDF powstał w Unidata Program Center w Boulder, Colorado.
47
48 Ten pakiet zawiera bibliotekę dla C.
49
50 %package devel
51 Summary:        Header files for netCDF
52 Summary(pl.UTF-8):      Pliki nagłówkowe netCDF
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       curl-devel
56 Requires:       hdf5-devel >= 1.8.5
57 Requires:       szip-devel
58
59 %description devel
60 Header files for netCDF - C interface.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe do biblioteki netCDF - interfejs dla C.
64
65 %package static
66 Summary:        NetCDF - static library
67 Summary(pl.UTF-8):      Biblioteka statyczna netCDF
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static version of netCDF C library.
73
74 %description static -l pl.UTF-8
75 Statyczna wersja biblioteki netCDF dla C.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         %{!?with_tests_net:--disable-dap-remote-tests} \
88         --enable-dap \
89         --enable-doxygen \
90         --enable-netcdf-4 \
91 # --enable-cdmremote doesn't build atm. (tested on 4.2)
92 # --enable-rpc the same
93 # --enable-hdf4 would cause dependency loop (hdf4 requires netcdf)
94
95 # some substitutions are missing when using autotools
96 %{__sed} -i -e 's,@SHOW_DOXYGEN_TAG_LIST@,NO,' \
97         -e 's,@CMAKE_CURRENT_BINARY_DIR@,.,' \
98         man4/Doxyfile
99
100 %{__make}
101
102 %if %{with tests}
103 %{__make} -j1 check
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc COPYRIGHT README.md RELEASE_NOTES.md
121 %attr(755,root,root) %{_bindir}/nccopy
122 %attr(755,root,root) %{_bindir}/ncdump
123 %attr(755,root,root) %{_bindir}/ncgen
124 %attr(755,root,root) %{_bindir}/ncgen3
125 %attr(755,root,root) %{_libdir}/libnetcdf.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libnetcdf.so.7
127 %{_mandir}/man1/nccopy.1*
128 %{_mandir}/man1/ncdump.1*
129 %{_mandir}/man1/ncgen.1*
130 %{_mandir}/man1/ncgen3.1*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc man4/html/*
135 %attr(755,root,root) %{_bindir}/nc-config
136 %attr(755,root,root) %{_libdir}/libnetcdf.so
137 %{_libdir}/libnetcdf.la
138 %{_includedir}/netcdf.h
139 %{_pkgconfigdir}/netcdf.pc
140 %{_mandir}/man3/netcdf.3*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libnetcdf.a
This page took 0.066175 seconds and 2 git commands to generate.