]> git.pld-linux.org Git - packages/netcdf.git/blob - netcdf.spec
- release 2 (by relup.sh)
[packages/netcdf.git] / netcdf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4                                 # (note: tests need endoder-enabled szip)
5 %bcond_with     tests_net       # remote tests (Internet access required)
6 #
7 Summary:        NetCDF: Network Common Data Form
8 Summary(pl.UTF-8):      NetCDF: obsługa wspólnego sieciowego formatu danych
9 Name:           netcdf
10 Version:        4.3.0
11 Release:        2
12 License:        BSD-like
13 Group:          Libraries
14 Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
15 # Source0-md5:  39fc507bf2966980fa92defecd9d2167
16 URL:            http://www.unidata.ucar.edu/packages/netcdf/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  curl-devel
20 BuildRequires:  doxygen
21 BuildRequires:  hdf5-devel >= 1.8.5
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  szip-devel >= 2.1-2
25 BuildRequires:  texinfo
26 Requires:       hdf5 >= 1.8.5
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 NetCDF (network Common Data Form) is an interface for array-oriented
31 data access and a library that provides an implementation of the
32 interface. The netCDF library also defines a machine-independent
33 format for representing scientific data. Together, the interface,
34 library, and format support the creation, access, and sharing of
35 scientific data. The netCDF software was developed at the Unidata
36 Program Center in Boulder, Colorado.
37
38 This package contains C library.
39
40 %description -l pl.UTF-8
41 NetCDF (Network Common Data Form) jest interfejsem dostępu do danych
42 zorganizowanych w tablice. Biblioteka netCDF definiuje niezależny od
43 maszyny format reprezentowania danych naukowych. Interfejs oraz
44 biblioteka pozwalają na tworzenie, dostęp i współdzielenie danych.
45 NetCDF powstał w Unidata Program Center w Boulder, Colorado.
46
47 Ten pakiet zawiera bibliotekę dla C.
48
49 %package devel
50 Summary:        Header files for netCDF
51 Summary(pl.UTF-8):      Pliki nagłówkowe netCDF
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       curl-devel
55 Requires:       hdf5-devel >= 1.8.5
56 Requires:       szip-devel
57
58 %description devel
59 Header files for netCDF - C interface.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe do biblioteki netCDF - interfejs dla C.
63
64 %package static
65 Summary:        NetCDF - static library
66 Summary(pl.UTF-8):      Biblioteka statyczna netCDF
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static version of netCDF C library.
72
73 %description static -l pl.UTF-8
74 Statyczna wersja biblioteki netCDF dla C.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         %{!?with_tests_net:--disable-dap-remote-tests} \
87         --enable-dap \
88         --enable-doxygen \
89         --enable-netcdf-4 \
90 # --enable-cdmremote doesn't build atm. (tested on 4.2)
91 # --enable-rpc the same
92 # --enable-hdf4 would cause dependency loop (hdf4 requires netcdf)
93
94 %{__make}
95
96 %if %{with tests}
97 %{__make} check
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc COPYRIGHT README RELEASE_NOTES
115 %attr(755,root,root) %{_bindir}/nccopy
116 %attr(755,root,root) %{_bindir}/ncdump
117 %attr(755,root,root) %{_bindir}/ncgen
118 %attr(755,root,root) %{_bindir}/ncgen3
119 %attr(755,root,root) %{_libdir}/libnetcdf.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libnetcdf.so.7
121 %{_mandir}/man1/nccopy.1*
122 %{_mandir}/man1/ncdump.1*
123 %{_mandir}/man1/ncgen.1*
124 %{_mandir}/man1/ncgen3.1*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %doc man4/html/*
129 %attr(755,root,root) %{_bindir}/nc-config
130 %attr(755,root,root) %{_libdir}/libnetcdf.so
131 %{_libdir}/libnetcdf.la
132 %{_includedir}/netcdf.h
133 %{_pkgconfigdir}/netcdf.pc
134 %{_mandir}/man3/netcdf.3*
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libnetcdf.a
This page took 0.090712 seconds and 3 git commands to generate.