]> git.pld-linux.org Git - packages/neovim.git/blob - neovim.spec
d9e27f678453b0ee92a9c925341803b29330acf9
[packages/neovim.git] / neovim.spec
1 # TODO
2 # - -rt subpackage? -lang subpackage?
3 Summary:        Vim-fork focused on extensibility and agility
4 Name:           neovim
5 Version:        0.1.5
6 Release:        0.1
7 License:        Apache v2.0
8 Group:          Applications/Editors/Vim
9 Source0:        https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
10 URL:            https://neovim.io/
11 Source1:        %{name}.desktop
12 Source2:        %{name}.svg
13 BuildRequires:  cmake
14 BuildRequires:  fdupes
15 BuildRequires:  hicolor-icon-theme
16 BuildRequires:  jemalloc-devel
17 BuildRequires:  libmsgpack-devel >= 1.2.0
18 BuildRequires:  libmsgpackc-devel >= 1.2.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libuv-devel
21 BuildRequires:  lua51-BitOp
22 BuildRequires:  lua51-LPeg
23 BuildRequires:  lua51-mpack
24 BuildRequires:  luajit-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  pkgconfig(termkey)
27 BuildRequires:  pkgconfig(unibilium)
28 BuildRequires:  pkgconfig(vterm)
29 BuildRequires:  update-desktop-files
30 Suggests:       python-neovim
31 Suggests:       python3-neovim
32 Suggests:       xsel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Neovim is a refactor - and sometimes redactor - in the tradition of
37 Vim, which itself derives from Stevie. It is not a rewrite, but a
38 continuation and extension of Vim. Many rewrites, clones, emulators
39 and imitators exist; some are very clever, but none are Vim. Neovim
40 strives to be a superset of Vim, notwithstanding some intentionally
41 removed misfeatures; excepting those few and carefully-considered
42 excisions, Neovim is Vim. It is built for users who want the good
43 parts of Vim, without compromise, and more.
44
45 %prep
46 %setup -q
47
48 # Remove __DATE__ and __TIME__.
49 BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
50 BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
51 sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
52 sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
53
54 %build
55 %cmake \
56         -DLUA_PRG=%{_bindir}/lua \
57         -DUSE_BUNDLED=OFF               \
58         -DLUAJIT_USE_BUNDLED=OFF \
59         -DENABLE_JEMALLOC=ON
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
69 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/neovim.svg
70
71 %find_lang nvim
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 %update_desktop_database
78 %icon_theme_cache_post
79
80 %postun
81 %update_desktop_database
82 %icon_theme_cache_postun
83
84 %files -f nvim.lang
85 %defattr(644,root,root,755)
86 %doc BACKERS.md CONTRIBUTING.md LICENSE README.md
87 %attr(755,root,root) %{_bindir}/nvim
88 %{_datadir}/nvim
89 %{_desktopdir}/%{name}.desktop
90 %{_iconsdir}/hicolor/*/apps/%{name}.svg
91 %{_mandir}/man1/nvim.1*
This page took 0.069519 seconds and 2 git commands to generate.