]> git.pld-linux.org Git - packages/neovim.git/blob - neovim.spec
up to 0.9.1
[packages/neovim.git] / neovim.spec
1 # TODO
2 # - -rt subpackage? -lang subpackage?
3 #
4 # Conditional build:
5 %bcond_with     prefer_lua              # Prefer Lua over LuaJit
6
7 %ifnarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 mipsel ppc
8 %define         with_prefer_lua 1
9 %endif
10
11 %if %{with prefer_lua}
12 %define         luv_includedir  /usr/include/lua5.1
13 %define         luv_library     /usr/%{_lib}/lua/5.1/luv.so
14 %else
15 %define         luv_includedir  /usr/include/luajit-2.1
16 %define         luv_library     /usr/%{_lib}/luajit/2.1/luv.so
17 %endif
18
19 Summary:        Vim-fork focused on extensibility and agility
20 Name:           neovim
21 Version:        0.9.1
22 Release:        1
23 License:        Apache v2.0
24 Group:          Applications/Editors/Vim
25 # Source0Download: https://github.com/neovim/neovim/releases
26 Source0:        https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
27 # Source0-md5:  e7677dbba956c71508cf298a9f4e11ac
28 URL:            https://neovim.io/
29 Source2:        %{name}.svg
30 Patch0:         desktop.patch
31 Patch1:         build-type.patch
32 Patch2:         luv.patch
33 BuildRequires:  cmake >= 3.10
34 BuildRequires:  gcc >= 6:4.4
35 BuildRequires:  gettext-tools
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtermkey-devel >= 0.22
38 BuildRequires:  libuv-devel >= 1.28.0
39 BuildRequires:  libvterm-devel >= 0.3
40 BuildRequires:  lua-bitop >= 1.0.2
41 BuildRequires:  lua-lpeg
42 BuildRequires:  lua-mpack >= 1.0.2
43 BuildRequires:  msgpack-devel >= 1.1.0
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpm-build >= 4.6
46 BuildRequires:  rpmbuild(macros) >= 1.605
47 BuildRequires:  tree-sitter-devel >= 0.20.8
48 BuildRequires:  unibilium-devel >= 2.0.0
49 %if %{with prefer_lua}
50 BuildRequires:  lua51
51 BuildRequires:  lua51-devel
52 BuildRequires:  lua51-luv-devel >= 1.43.0
53 %else
54 BuildRequires:  luajit
55 BuildRequires:  luajit-devel
56 BuildRequires:  luajit-luv-devel >= 1.43.0
57 %endif
58 Requires:       libtermkey >= 0.22
59 Requires:       libuv >= 1.28.0
60 Requires:       libvterm >= 0.3
61 Requires:       %{?with_prefer_lua:lua51}%{!?with_prefer_lua:luajit}-luv
62 Requires:       tree-sitter >= 0.20.8
63 Suggests:       %{name}-desktop = %{version}-%{release}
64 Suggests:       python-neovim
65 Suggests:       python3-neovim
66 Suggests:       ruby-neovim
67 Suggests:       xsel
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # gcc 4.0 and better turn on _FORTIFY_SOURCE=2 automatically. This currently
71 # does not work with Neovim due to some uses of dynamically-sized structures.
72 # See https://github.com/neovim/neovim/issues/223 for details.
73 %define         filterout_c     -Wp,-D_FORTIFY_SOURCE=2
74
75 %description
76 Neovim is a refactor - and sometimes redactor - in the tradition of
77 Vim, which itself derives from Stevie. It is not a rewrite, but a
78 continuation and extension of Vim. Many rewrites, clones, emulators
79 and imitators exist; some are very clever, but none are Vim. Neovim
80 strives to be a superset of Vim, notwithstanding some intentionally
81 removed misfeatures; excepting those few and carefully-considered
82 excisions, Neovim is Vim. It is built for users who want the good
83 parts of Vim, without compromise, and more.
84
85 %package desktop
86 Summary:        Desktop files for Neovim
87 Group:          Applications/Editors/Vim
88 Requires(post,postun):  desktop-file-utils
89 Requires(post,postun):  gtk-update-icon-cache
90 Requires(post,postun):  hicolor-icon-theme
91 Requires:       %{name} = %{version}-%{release}
92 BuildArch:      noarch
93
94 %description desktop
95 Desktop files for Neovim.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1 -R
102
103 %build
104 %cmake -B build \
105         -DPREFER_LUA=%{!?with_prefer_lua:OFF}%{?with_prefer_lua:ON} \
106         -DLUA_PRG=%{!?with_prefer_lua:/usr/bin/luajit}%{?with_prefer_lua:/usr/bin/lua5.1} \
107         -DLUA_INCLUDE_DIR=/usr/include/lua5.1 \
108         -DUSE_BUNDLED=OFF \
109         -DENABLE_JEMALLOC=ON \
110         -DLIBLUV_INCLUDE_DIR=%{luv_includedir} \
111         -DLIBLUV_LIBRARY=%{luv_library}
112
113 %{__make} -C build
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 %{__make} -C build install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install -d $RPM_BUILD_ROOT{/etc/xdg/nvim,%{_iconsdir}/hicolor/scalable/apps}
121 touch $RPM_BUILD_ROOT/etc/xdg/nvim/init.vim
122 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/nvim.svg
123
124 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
125 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
126 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
127 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
128 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.UTF-8
129 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
130 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
131 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
132
133 %find_lang nvim
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 %banner -e -o %{name} << 'EOF'
140
141 The Neovim executable is called 'nvim'. To use your existing Vim
142 configuration:
143     ln -s ~/.vim ~/.config/nvim
144     ln -s ~/.vimrc ~/.config/nvim/init.vim
145 See ':help nvim' for more information on Neovim.
146
147 If you want support for Python plugins such as YouCompleteMe, you need
148 to install a Python module in addition to Neovim itself.
149
150 See ':help provider-python' or this page for more information:
151     http://neovim.io/doc/user/provider.html
152
153 If you have any questions, have a look at:
154     https://github.com/neovim/neovim/wiki/FAQ.
155 EOF
156
157 %post desktop
158 %update_desktop_database
159 %update_icon_cache hicolor
160
161 %postun desktop
162 %update_desktop_database
163 %update_icon_cache hicolor
164
165 %files -f nvim.lang
166 %defattr(644,root,root,755)
167 %doc BACKERS.md CONTRIBUTING.md LICENSE.txt README.md
168 %dir /etc/xdg/nvim
169 %config(noreplace) %verify(not md5 mtime size) /etc/xdg/nvim/init.vim
170 %attr(755,root,root) %{_bindir}/nvim
171 %{_mandir}/man1/nvim.1*
172 %{_datadir}/nvim
173
174 %files desktop
175 %defattr(644,root,root,755)
176 %{_desktopdir}/nvim.desktop
177 %{_iconsdir}/hicolor/*/apps/nvim.png
178 %{_iconsdir}/hicolor/*/apps/nvim.svg
This page took 0.074831 seconds and 3 git commands to generate.