]> git.pld-linux.org Git - packages/needrestart.git/blob - needrestart.spec
requires coreutils (who is used to obtain runlevel)
[packages/needrestart.git] / needrestart.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Check which daemons need to be restarted after library upgrades
3 Name:           needrestart
4 Version:        2.0
5 Release:        0.10
6 License:        GPL v2
7 Group:          Applications
8 Source0:        https://github.com/liske/needrestart/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  21d04f18accdd1fc538b436e2c8dac0c
10 URL:            https://fiasko-nw.net/~thomas/tag/needrestart.html
11 BuildRequires:  rpm-perlprov >= 4.1-13
12 Requires:       coreutils
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 needrestart checks which daemons need to be restarted after library
18 upgrades. It is inspired by checkrestart from the debian-goodies
19 package.
20
21 Features:
22 - supports (but does not require) systemd
23 - binary blacklisting (i.e. display managers)
24 - tries to detect pending kernel upgrades
25 - tries to detect required restarts of interpreter based daemons
26   (supports Perl, Python, Ruby)
27 - fully integrated into apt/dpkg using hooks
28
29 %prep
30 %setup -q -c
31 mv %{name}-*/* .
32
33 %{__rm} perl/lib/NeedRestart/UI/Debconf.pm
34
35 %build
36 cd perl
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/NeedRestart/.packlist
47 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
48 %ifos Linux
49 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/NeedRestart/Kernel/kFreeBSD.pm
50 %endif
51 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/hook.d/10-dpkg
52 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/hook.d/30-pacman
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc AUTHORS ChangeLog README.* INSTALL NEWS
60 %dir %{_sysconfdir}/%{name}
61 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/needrestart.conf
62 %dir %{_sysconfdir}/%{name}/hook.d
63 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/hook.d/20-rpm
64 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/hook.d/90-none
65 %dir %{_sysconfdir}/%{name}/conf.d
66 %{_sysconfdir}/%{name}/conf.d/README.needrestart
67 %dir %{_sysconfdir}/%{name}/notify.d
68 %{_sysconfdir}/%{name}/notify.d/README.needrestart
69 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/notify.d/200-write
70 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/notify.d/400-notify-send
71 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/notify.d/600-mail
72
73 %attr(755,root,root) %{_sbindir}/needrestart
74 %{_datadir}/polkit-1/actions/net.fiasko-nw.needrestart.policy
75
76 %{perl_vendorlib}/NeedRestart.pm
77 %{perl_vendorlib}/NeedRestart
This page took 0.032182 seconds and 3 git commands to generate.