]> git.pld-linux.org Git - packages/nant.git/blob - nant.spec
6b505b559f97c634b0ccc91c1ca30b538db6d10c
[packages/nant.git] / nant.spec
1 #
2 # TODO: make backward compatibility for mono-1.0 and mono-1.1 or drop these frameworks
3 # note: mono 2.8 doesn't support .NET 1.0/1.1 any longer
4 #
5 %include        /usr/lib/rpm/macros.mono
6 Summary:        A .NET based build tool
7 Summary(pl.UTF-8):      Narzędzie do budowania pod .NET
8 Name:           nant
9 Version:        0.91
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Building
13 Source0:        http://downloads.sourceforge.net/nant/nant-%{version}-src.tar.gz
14 # Source0-md5:  571e72813bdb3f0e8362403025445a61
15 URL:            http://nant.sourceforge.net/
16 BuildRequires:  mono-compat-links >= 2.8
17 BuildRequires:  mono-csharp >= 2.8
18 BuildRequires:  pkgconfig
19 Requires:       mono-devel >= 2.8
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 NAnt is a .NET based build tool. In theory it is kind of like make
24 without make's wrinkles. In practice it's a lot like Ant.
25
26 %description -l pl.UTF-8
27 NAnt jest narzędziem wspomagającym budowanie oprogramowania w
28 środowisku .NET. Teoretycznie jest to lepsze ,,make''. W praktyce
29 działa jak Ant.
30
31 %prep
32 %setup -q
33
34 cat <<'EOF' > %{name}.sh
35 #!/bin/sh
36 exec mono %{_datadir}/NAnt/bin/NAnt.exe "$@"
37 EOF
38
39 %build
40 %{__make} -j1
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 mono bootstrap/NAnt.exe \
45         -f:NAnt.build install-linux \
46         -D:install.prefix=$RPM_BUILD_ROOT%{_prefix}
47
48 install %{name}.sh $RPM_BUILD_ROOT%{_bindir}/nant
49
50 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/NAnt
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README.txt doc/*
58 %attr(755,root,root) %{_bindir}/nant
59 %{_datadir}/NAnt
60 %{_pkgconfigdir}/nant.pc
This page took 0.067548 seconds and 2 git commands to generate.