]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
65cca6af2ce107f6485cf24070beff32e3225e37
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 # - bundled jquery in themes
4 #
5 # Conditional build:
6 %bcond_without  gd      # without statusmap and trends, which require gd library
7 %bcond_without  doc     # don't build html docs
8 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
9 %bcond_with     tests
10
11 Summary:        Open Source host, service and network monitoring program
12 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
13 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
14 Name:           nagios
15 Version:        4.0.3
16 Release:        1
17 License:        GPL v2+
18 Group:          Networking
19 Source0:        http://downloads.sourceforge.net/nagios/nagios-4.x/%{name}-%{version}/%{name}-%{version}.tar.gz
20 # Source0-md5:  1c63271f6371226e93cbc2e1a08b1f0e
21 Source1:        %{name}-apache.conf
22 Source2:        %{name}.init
23 Source3:        %{name}.sysconfig
24 # http://git.pld-linux.org/cgi-bin/cgit.cgi/projects/nagios-config.git/
25 Source4:        %{name}-config-20090914.tar.bz2
26 # Source4-md5:  605f1cd28c00db961dad6f529d849f16
27 Source5:        %{name}-lighttpd.conf
28 Source6:        http://www.google.com/mapfiles/shadow50.png
29 # Source6-md5:  eff99f302f21b95a900d321743fce72b
30 Source7:        http://www.google.com/mapfiles/marker.png
31 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
32 Source8:        googlemap.js
33 Source9:        %{name}wall.php
34 Patch0:         %{name}-resources.patch
35 Patch1:         %{name}-iconv-in-libc.patch
36 Patch2:         %{name}-webapps.patch
37 Patch3:         %{name}-cgi-http_charset.patch
38 Patch4:         %{name}-cmd-typo.patch
39 Patch5:         config.patch
40 Patch6:         %{name}-googlemap.patch
41 Patch7:         %{name}-doc-usermacros.patch
42 Patch8:         archivelog-timeformat.patch
43 Patch9:         system-magpierss.patch
44 Patch10:        system-jquery.patch
45 Patch11:        do-not-fetch-rss.patch
46 URL:            http://www.nagios.org/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 %{?with_doc:BuildRequires:      doxygen}
50 BuildRequires:  rpmbuild(macros) >= 1.268
51 BuildRequires:  sed >= 4.0
52 %if %{with gd}
53 BuildRequires:  gd-devel
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libpng-devel
56 %endif
57 %if %{with tests}
58 BuildRequires:  perl-HTML-Lint
59 BuildRequires:  perl-Test-WWW-Mechanize-CGI
60 %endif
61 Requires(post,preun):   /sbin/chkconfig
62 Requires:       %{name}-common = %{version}-%{release}
63 Requires:       rc-scripts >= 0.4.5.5
64 Requires:       sh-utils
65 Suggests:       nagios-notify >= 0.13
66 Suggests:       nagios-plugin-check_load
67 Suggests:       nagios-plugin-check_ping
68 Suggests:       nagios-plugins
69 Provides:       nagios-core
70 Obsoletes:      netsaint
71 Conflicts:      iputils-ping < 1:ss020124
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/%{name}
75 %define         cgidir          %{_libdir}/%{name}/cgi
76 %define         htmldir         %{_prefix}/share/%{name}
77 %define         _localstatedir  /var/lib/%{name}
78 %define         _webapps        /etc/webapps
79 %define         _webapp         %{name}
80
81 %description
82 Nagios is a program that will monitor hosts and services on your
83 network. It has the ability to email or page you when a problem arises
84 and when a problem is resolved. Nagios is written in C and is designed
85 to run under Linux (and some other *NIX variants) as a background
86 process, intermittently running checks on various services that you
87 specify.
88
89 The actual service checks are performed by separate "plugin" programs
90 which return the status of the checks to Nagios. The plugins are
91 available in nagios-plugins packages.
92
93 Nagios is successor to NetSaint.
94
95 %description -l pl.UTF-8
96 Nagios to program, który monitoruje serwery oraz usługi w naszej
97 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
98 rozwiązaniu problemu. Nagios został napisany w C oraz jest
99 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
100 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
101 sprawdzające.
102
103 Właściwe sprawdzanie jest wykonywane przez osobne programy
104 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
105 są dostępne na stronie w pakietach nagios-plugins.
106
107 Nagios jest następcą NetSainta.
108
109 %description -l pt_BR.UTF-8
110 O Nagios é um programa que monitora máquinas e serviços na sua rede.
111 Ele pode enviar um email ou um aviso de pager para o administrador
112 quando surgir um problema e quando ele for resolvido. Nagios é escrito
113 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
114 variações de *NIX) como um processo em segundo plano, periodicamente
115 executando checagens nos diversos serviços que forem especificados.
116
117 %package common
118 Summary:        Common files needed by both nagios and nrpe
119 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
120 Group:          Networking
121 Requires(postun):       /usr/sbin/groupdel
122 Requires(postun):       /usr/sbin/userdel
123 Requires(pre):  /bin/id
124 Requires(pre):  /usr/bin/getgid
125 Requires(pre):  /usr/sbin/groupadd
126 Requires(pre):  /usr/sbin/groupmod
127 Requires(pre):  /usr/sbin/useradd
128 Requires(pre):  /usr/sbin/usermod
129 Provides:       group(nagcmd)
130 Provides:       group(nagios)
131 Provides:       user(nagios)
132
133 %description common
134 Common files needed by both nagios and nrpe.
135
136 %description common -l pl.UTF-8
137 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
138
139 %package cgi
140 Summary:        CGI webinterface for Nagios
141 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
142 Group:          Applications/WWW
143 # for dirs... and accessing local logs, nagios config
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       %{name}-imagepaks
146 Requires:       %{name}-theme
147 Requires:       group(http)
148 Requires:       jquery
149 Requires:       webapps
150 Requires:       webserver
151 Requires:       webserver(access)
152 Requires:       webserver(alias)
153 Requires:       webserver(auth)
154 Requires:       webserver(cgi)
155 Requires:       webserver(indexfile)
156 Suggests:       %{name}-doc
157 Suggests:       php-magpierss >= 0.72
158
159 %description cgi
160 CGI webinterface for Nagios.
161
162 %description cgi -l pl.UTF-8
163 Interfejs CGI dla Nagiosa.
164
165 %package mrtggraphs
166 Summary:        MRTG Graphs: Nagios Statistics
167 Group:          Applications/Networking
168 Requires:       %{name} = %{version}-%{release}
169 Provides:       mrtg-start
170 %if "%{_rpmversion}" >= "5"
171 BuildArch:      noarch
172 %endif
173
174 %description mrtggraphs
175 This pacakge graphs several Nagios statistics which can be useful for
176 debugging and trending purposes. The nagiostats binary is used to
177 generate the data.
178
179 %package doc
180 Summary:        HTML Documentation for Nagios
181 Group:          Documentation
182 %if "%{_rpmversion}" >= "5"
183 BuildArch:      noarch
184 %endif
185 # does not require base
186
187 %description doc
188 HTML Documentation for Nagios.
189
190 %package theme-classicui
191 Summary:        ClassicUI Nagios theme
192 Group:          Applications/WWW
193 Requires:       %{name}-cgi = %{version}-%{release}
194 Requires:       webserver(php)
195 Provides:       nagios-theme
196 Obsoletes:      nagios-theme
197 %if "%{_rpmversion}" >= "5"
198 BuildArch:      noarch
199 %endif
200
201 %description theme-classicui
202 Original theme from Nagios.
203
204 %description theme-classicui -l pl.UTF-8
205 Oryginalny motyw z Nagiosa.
206
207 %package theme-default
208 Summary:        Virtual package to handle Nagios theme migration
209 Group:          Applications/WWW
210 Requires:       nagios-theme
211 Suggests:       nagios-theme-classicui
212 Suggests:       nagios-theme-exfoliation
213 Suggests:       nagios-theme-nuvola
214 Obsoletes:      nagios-theme-default < 3.3.1-1.4
215 %if "%{_rpmversion}" >= "5"
216 BuildArch:      noarch
217 %endif
218
219 %description theme-default
220 Virtual package to handle Nagios theme migration
221
222 %package devel
223 Summary:        Include files that Nagios-related applications may compile against
224 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
225 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
226 Group:          Development/Libraries
227 # doesn't require base
228
229 %description devel
230 This package contains the header files, static libraries and
231 development documentation for Nagios. If you are a NEB-module author
232 or wish to write addons for Nagios using Nagios' own API's, you should
233 install this package.
234
235 %description devel -l pl.UTF-8
236 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
237 przez aplikacje związane z nagiosem podczas kompilacji.
238
239 %description devel -l pt_BR.UTF-8
240 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
241 aplicativos para o Nagios.
242
243 %prep
244 %setup -qc -a4
245 mv %{name}-%{version}/* .
246 %undos cgi/*.c
247 %undos include/*.h
248 %undos base/*
249 %patch0 -p0
250 %patch1 -p1
251 %patch2 -p1
252 %patch3 -p1
253 #fixed
254 #%patch4 -p1
255 %patch5 -p1
256 %patch6 -p1
257 %patch7 -p1
258 %patch8 -p1
259 %patch9 -p1
260 %patch10 -p1
261 %patch11 -p1
262
263 find -name .cvsignore -o -name .gitignore | xargs rm
264
265 mv nagios-config-*/objects/*.cfg sample-config/template-object
266 mv nagios-config-*/*.cfg sample-config
267
268 # cleanup backups after patching
269 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
270
271 sed -i -e '
272         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
273         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
274 ' $(find contrib/eventhandlers -type f)
275
276 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
277 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
278
279 # fixup cgi config
280 %{__sed} -i -e '
281         # kill trailing spaces
282         s, \+$,,
283         # use real paths
284         s,/usr/local/%{name}/share,@datadir@,g
285         # we want all authorized users have default access
286         s,=nagiosadmin,=*,g
287 ' sample-config/*.cfg.in
288
289 #rm t/611cgistatus-hosturgencies.t
290
291 %build
292 cp -f /usr/share/automake/config.sub .
293 %{__aclocal}
294 %{__autoconf}
295 %if %{with tests}
296 cd tap
297 %{__libtoolize}
298 %{__aclocal}
299 %{__autoconf}
300 cd ..
301 %endif
302 %configure \
303         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
304         --bindir=%{_sbindir} \
305         --sbindir=%{cgidir} \
306         --datadir=%{htmldir} \
307         --with-nagios-user=%{name} \
308         --with-nagios-grp=%{name} \
309         --with-command-user=%{name} \
310         --with-command-grp=%{name} \
311         --with-lockfile=%{_localstatedir}/%{name}.pid \
312         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
313         --with-ping_command='/bin/ping -n %%s -c %%d' \
314         %{!?with_gd:--disable-statusmap --disable-trends} \
315         %{?with_tests:--enable-libtap} \
316         --enable-event-broker
317
318 %{__make} all
319
320 %{?with_doc:%{__make} dox}
321
322 %{?with_tests:%{__make} test}
323
324 %install
325 rm -rf $RPM_BUILD_ROOT
326 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
327         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
328         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
329         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
330 %if "%{_lib}" != "lib"
331         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
332 %endif
333
334 %{__make} install-unstripped install-devel \
335         DESTDIR=$RPM_BUILD_ROOT \
336         INSTALL_OPTS="" \
337         INIT_OPTS="" \
338         COMMAND_OPTS=""
339
340 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
341 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
342
343 # install templated configuration files
344 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
345         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
346 done
347
348 # webserver files
349 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
350 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
351 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
352 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
353 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
354 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
355 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
356 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{htmldir}
357 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
358 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
359
360 # install event handlers, sample config
361 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
362 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
363 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
364 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
365
366 # mrtg script
367 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
368 cp -p sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
369
370 # Object data/cache files
371 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
372         > $RPM_BUILD_ROOT%{_localstatedir}/$i
373 done
374 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
375 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.qh
376
377 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
378 %{__cp} -a Documentation/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}
379
380 %clean
381 rm -rf $RPM_BUILD_ROOT
382
383 %post
384 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
385         [ ! -f $i ] && touch $i
386         chown root:nagios $i
387         chmod 664 $i
388 done
389
390 /sbin/chkconfig --add %{name}
391 %service %{name} restart "Nagios service"
392
393 %preun
394 if [ "$1" = "0" ] ; then
395         %service %{name} stop
396         /sbin/chkconfig --del %{name}
397 fi
398
399 %pre common
400 # rename group netsaint -> nagios
401 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
402         /usr/sbin/groupmod -n nagios netsaint
403 fi
404 # rename group nagios-data -> nagcmd
405 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
406         /usr/sbin/groupmod -n nagcmd nagios-data
407 fi
408 %groupadd -g 72 nagios
409 %groupadd -g 147 -f nagcmd
410 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
411         /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
412 fi
413 %useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
414
415 %postun common
416 if [ "$1" = "0" ]; then
417         %userremove nagios
418         %groupremove nagios
419         %groupremove nagcmd
420 fi
421
422 %post cgi
423 if [ "$1" = 1 ]; then
424 %banner %{name} -e <<EOF
425 NOTE:
426 You need to add user to %{_webapps}/%{_webapp}/passwd and
427 %{_webapps}/%{_webapp}/group to access Nagios via web.
428
429 EOF
430 fi
431
432 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
433 %addusertogroup http nagcmd
434 %webapp_register apache %{_webapp}
435
436 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
437 %webapp_unregister apache %{_webapp}
438
439 %triggerin cgi -- apache < 2.2.0, apache-base
440 %addusertogroup http nagcmd
441 %webapp_register httpd %{_webapp}
442
443 %triggerun cgi -- apache < 2.2.0, apache-base
444 %webapp_unregister httpd %{_webapp}
445
446 %triggerin cgi -- lighttpd
447 %addusertogroup lighttpd nagcmd
448 %webapp_register lighttpd %{_webapp}
449
450 %triggerun cgi -- lighttpd
451 %webapp_unregister lighttpd %{_webapp}
452
453 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
454 chown root:http %{_sysconfdir}/cgi.cfg
455
456 %triggerpostun -- nagios < 3.1.2-4
457 # restore lost files
458 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
459         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
460                 mv -f %{_sysconfdir}/$a{.rpmsave,}
461         fi
462 done
463 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
464
465 %files
466 %defattr(644,root,root,755)
467 %doc Changelog README* UPGRADING INSTALLING LICENSE
468 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
469
470 # leave main nagios config readable for -cgi.
471 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
472
473 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
474 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
475 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
476 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
477 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
478 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
479
480 %attr(754,root,root) /etc/rc.d/init.d/%{name}
481 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
482
483 %attr(755,root,root) %{_sbindir}/%{name}
484 %attr(755,root,root) %{_sbindir}/nagiostats
485 %dir %{_libdir}/%{name}/brokers
486
487 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
488 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
489
490 %attr(770,root,nagcmd) %dir %{_localstatedir}
491 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
492 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
493 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.qh
494 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
495 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
496 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
497 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
498 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
499
500 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
501
502 %{_examplesdir}/%{name}-%{version}
503
504 %files common
505 %defattr(644,root,root,755)
506 %attr(750,root,nagcmd) %dir %{_sysconfdir}
507 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
508 %dir %{_libdir}/%{name}
509 %dir %{_libdir}/%{name}/plugins
510 %dir %{_libdir}/%{name}/eventhandlers
511
512 %if "%{_lib}" != "lib"
513 %dir %{_prefix}/lib/%{name}
514 %dir %{_prefix}/lib/%{name}/plugins
515 %dir %{_prefix}/lib/%{name}/eventhandlers
516 %endif
517
518 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
519
520 %files mrtggraphs
521 %defattr(644,root,root,755)
522 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
523
524 %files doc
525 %defattr(644,root,root,755)
526 %{_docdir}/%{name}
527
528 %files cgi
529 %defattr(644,root,root,755)
530 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
534 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
535 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
536 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
537 %dir %{cgidir}
538 %attr(755,root,root) %{cgidir}/*.cgi
539
540 %dir %{htmldir}
541 %dir %{htmldir}/includes
542 %dir %{htmldir}/images
543 %dir %{htmldir}/stylesheets
544 %{htmldir}/robots.txt
545 %{htmldir}/contexthelp
546 %{htmldir}/media
547 %{htmldir}/ssi
548 %{htmldir}/images/favicon.ico
549 %{htmldir}/images/marker.png
550 %{htmldir}/images/shadow50.png
551 %{htmldir}/nagioswall.php
552
553 %files theme-classicui
554 %defattr(644,root,root,755)
555 %exclude %{htmldir}/nagioswall.php
556 %{htmldir}/*.php
557 %{htmldir}/includes/*
558 %{htmldir}/images/*
559 %exclude %{htmldir}/images/favicon.ico
560 %exclude %{htmldir}/images/marker.png
561 %exclude %{htmldir}/images/shadow50.png
562 %{htmldir}/stylesheets/*
563
564 %files theme-default
565 %defattr(644,root,root,755)
566
567 %files devel
568 %defattr(644,root,root,755)
569 %dir %{_includedir}/%{name}
570 %{_includedir}/%{name}/*.h
571 %{_includedir}/%{name}/lib
572 %{_libdir}/libnagios.a
This page took 0.075534 seconds and 2 git commands to generate.