]> git.pld-linux.org Git - packages/nagios-plugins.git/blob - nagios-plugins.spec
- release 5 (by relup.sh)
[packages/nagios-plugins.git] / nagios-plugins.spec
1 # NOTE:
2 # - the former team of nagios-plugins developers has moved to monitoring-plugins,
3 #   we have it packaged as monitoring-plugins.spec.
4 # TODO:
5 # - package requisites for unifished packages -nwstat
6 #   REQUIREMENTS explains the dependencies.
7 # - handle --without-dbi (new package)
8 # - add --without-radius bcond
9 # - check_ide_smart deps
10 # - check_http 2.1.x corrupts output https://github.com/nagios-plugins/nagios-plugins/issues/103
11 #
12 # Conditional build:
13 %bcond_without  ldap            # build without ldap
14
15 %include        /usr/lib/rpm/macros.perl
16 Summary:        Host/service/network monitoring program plugins for Nagios
17 Summary(pl.UTF-8):      Wtyczki do monitorowania hostów/usług/sieci dla Nagiosa
18 Name:           nagios-plugins
19 Version:        2.1.1
20 Release:        5
21 License:        GPL v3
22 Group:          Networking
23 Source0:        http://www.nagios-plugins.org/download/%{name}-%{version}.tar.gz
24 # Source0-md5:  e199ca874df5723bfaca8c43887b1a79
25 # https://git.pld-linux.org/projects/nagios-config
26 Source1:        %{name}-config-20150805.tar.xz
27 # Source1-md5:  50c1eff5152ff03948b984631fa0ff61
28 Source2:        nagios-utils.php
29 #Patch:         %{name}-shared.patch # needs finishing
30 Patch0:         %{name}-tainted.patch
31 Patch4:         %{name}-noroot.patch
32 Patch5:         %{name}-check_ping-socket-filter-warning.patch
33 Patch7:         %{name}-pgsql.patch
34 Patch9:         %{name}-check_log_paths.patch
35 Patch13:        %{name}-check_radius_segfault.patch
36 Patch21:        %{name}-check_hpjd-no-paper-out.patch
37 Patch23:        %{name}-check_disk_smb-zero-cap.patch
38 Patch24:        %{name}-paths.patch
39 Patch27:        %{name}-ping.patch
40 Patch28:        use-lib.patch
41 Patch29:        syntax-error.patch
42 URL:            http://www.nagiosplugins.org/
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  file
46 BuildRequires:  gettext-devel >= 0.14.3
47 BuildRequires:  libdbi-devel
48 BuildRequires:  libtap-devel
49 BuildRequires:  libtool
50 BuildRequires:  mysql-devel
51 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
52 BuildRequires:  openssl-devel >= 0.9.7d
53 BuildRequires:  perl-Net-SNMP
54 BuildRequires:  postgresql-devel
55 BuildRequires:  tar >= 1:1.22
56 BuildRequires:  xz
57 %if "%{pld_release}" == "ac"
58 BuildRequires:  radiusclient-devel
59 %else
60 BuildRequires:  radiusclient-ng-devel
61 BuildConflicts: radiusclient-devel
62 %endif
63 BuildRequires:  rpm >= 4.4.9-56
64 BuildRequires:  rpm-perlprov >= 4.1-13
65 BuildRequires:  rpmbuild(macros) >= 1.654
66 Requires:       nagios-common
67 Obsoletes:      netsaint-plugins
68 Conflicts:      nagios < 3.1.2-3
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir             /etc/nagios/plugins
72 %define         plugindir               %{_prefix}/lib/nagios/plugins
73 %define         nrpeddir                /etc/nagios/nrpe.d
74 %define         _noautoprovfiles        utils.pm
75 %define         _noautoreq_perl DBD::Oracle RRD::File packet_utils snmputil utils
76
77 %description
78 Nagios is a program that will monitor hosts and services on your
79 network, and to email or page you when a problem arises or is
80 resolved. Nagios runs on a Unix server as a background or daemon
81 process, intermittently running checks on various services that you
82 specify. The actual service checks are performed by separate "plugin"
83 programs which return the status of the checks to Nagios.
84
85 This package contains the basic plugins necessary for use with the
86 nagios package.
87
88 %description -l pl.UTF-8
89 Nagios to program monitorujący hosty i usługi w sieci i powiadamiający
90 pocztą elektroniczną lub na pager o wystąpieniu lub rozwiązaniu
91 problemów. Nagios działa na serwerze uniksowym w tle lub jako demon,
92 regularnie przeprowadzając kontrolę różnych podanych mu usług. Sama
93 kontrola usług jest wykonywana poprzez oddzielne "wtyczki" - programy
94 zwracajace stan danej usługi do Nagiosa.
95
96 Ten pakiet zawiera podstawowe wtyczki do używania z pakietem nagios.
97
98 %package libs
99 Summary:        Nagios plugins base libraries
100 Summary(pl.UTF-8):      Podstawowe biblioteki wtyczek Nagiosa
101 Group:          Networking
102
103 %description libs
104 This package contains nagios plugins base libraries that plugins
105 depend on.
106
107 %description libs -l pl.UTF-8
108 Ten pakiet zawiera podstawowe biblioteki wtyczek Nagiosa, wymagane
109 przez wtyczki.
110
111 %package devel
112 Summary:        Include files that Nagios plugins may compile against
113 Group:          Development/Libraries
114 # doesn't require base
115
116 %description devel
117 This package provides include files that Nagios plugins may compile
118 against.
119
120 # NOTE for sub package requires:
121 # Requires:     nagios-common for plugins directory and nagios group
122 # and add Requires:     %{name}-libs = %{version}-%{release} for utils.{sh,pm,php}
123 ##############################################################################
124
125 %package mysql
126 Summary:        Nagios plugin to test a MySQL DBMS
127 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania systemu baz danych MySQL
128 Group:          Networking
129 Requires:       nagios-common
130
131 %description mysql
132 This plugin tests a MySQL DBMS to determine whether it is active and
133 accepting queries.
134
135 %description mysql -l pl.UTF-8
136 Ta wtyczka sprawdza serwer baz danych MySQL, aby określić, czy jest
137 aktywny i przyjmuje zapytania.
138
139 %package perl
140 Summary:        Nagios plugins written in Perl
141 Summary(pl.UTF-8):      Wtyczki Nagiosa napisane w Perlu
142 Group:          Networking
143 Requires:       nagios-common
144 # for utils.pm
145 Requires:       %{name}-libs = %{version}-%{release}
146 %if "%{_rpmversion}" >= "5"
147 BuildArch:      noarch
148 %endif
149
150 %description perl
151 This package contains Nagios plugins written in Perl.
152
153 %description perl -l pl.UTF-8
154 Ten pakiet zawiera wtyczki Nagiosa napisane w Perlu.
155
156 %package samba
157 Summary:        Nagios plugin to check remote disk using smbclient
158 Summary(pl.UTF-8):      Wtyczka Nagiosa do zdalnego sprawdzania dysku z użyciem smbclienta
159 Group:          Networking
160 Requires:       nagios-common
161 # for utils.pm
162 Requires:       %{name}-libs = %{version}-%{release}
163 Requires:       samba-client
164 %if "%{_rpmversion}" >= "5"
165 BuildArch:      noarch
166 %endif
167
168 %description samba
169 Perl Check SMB Disk plugin for Nagios.
170
171 %description samba -l pl.UTF-8
172 Perlowa wtyczka dla Nagiosa sprawdzająca dyski SMB.
173
174 %package snmp
175 Summary:        Nagios plugins using SNMP protocol to query information
176 Summary(pl.UTF-8):      Wtyczki Nagiosa używające protokołu SNMP w celu uzyskania informacji
177 Group:          Networking
178 Requires:       nagios-common
179 # for utils.pm
180 Requires:       %{name}-libs = %{version}-%{release}
181 Requires:       net-snmp-utils
182 Requires:       perl-Net-SNMP
183
184 %description snmp
185 Nagios plugins using SNMP protocol to query information.
186
187 %description snmp -l pl.UTF-8
188 Wtyczki Nagiosa używające protokołu SNMP w celu uzyskania informacji.
189
190 %package ssh
191 Summary:        Nagios plugins to check remote services via SSH
192 Summary(pl.UTF-8):      Wtyczki Nagiosa do sprawdzania zdalnych usług po SSH
193 Group:          Networking
194 Requires:       nagios-common
195 Requires:       openssh-clients
196
197 %description ssh
198 This plugin uses SSH to execute commands on a remote host.
199
200 %description ssh -l pl.UTF-8
201 Ta wtyczka używa SSH do wykonywania poleceń na zdalnym hoście.
202
203 %package -n nagios-plugin-check_dig
204 Summary:        Nagios plugin to check DNS servers with dig
205 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania DNS-u przy użyciu programu dig
206 Group:          Networking
207 Requires:       bind-utils
208 Requires:       nagios-common
209 Provides:       nagios-plugins-dig = %{version}-%{release}
210 Obsoletes:      nagios-plugins-dig
211
212 %description -n nagios-plugin-check_dig
213 Test the DNS service on the specified host using dig.
214
215 %description -n nagios-plugin-check_dig -l pl.UTF-8
216 Ta wtyczka sprawdza usługę DNS na podanym hoście przy użyciu programu
217 dig.
218
219 %package -n nagios-plugin-check_dns
220 Summary:        Nagios plugin to check DNS with nslookup
221 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania DNS-u przy użyciu nslookup
222 Group:          Networking
223 Requires:       bind-utils
224 Requires:       nagios-common
225 Provides:       nagios-plugins-dns = %{version}-%{release}
226 Obsoletes:      nagios-plugins-dns
227
228 %description -n nagios-plugin-check_dns
229 This plugin uses the nslookup program to obtain the IP address for the
230 given host/domain query. A optional DNS server to use may be
231 specified. If no DNS server is specified, the default server(s)
232 specified in /etc/resolv.conf will be used.
233
234 %description -n nagios-plugin-check_dns -l pl.UTF-8
235 Ta wtyczka używa programu nslookup do uzyskania adresu IP danego dla
236 danego zapytania o host/domenę. Można opcjonalnie podać serwer DNS,
237 który ma być użyty. Jeśli nie podano serwera DNS, używany jest
238 domyślny serwer (lub serwery) podany w /etc/resolv.conf.
239
240 %package -n nagios-plugin-check_file_age
241 Summary:        Nagios plugin to check local file age and size
242 Group:          Networking
243 Requires:       nagios-common
244 # for utils.pm
245 Requires:       %{name}-libs = %{version}-%{release}
246 %if "%{_rpmversion}" >= "5"
247 BuildArch:      noarch
248 %endif
249
250 %description -n nagios-plugin-check_file_age
251 Nagios plugin to check local file age and size.
252
253 %package -n nagios-plugin-check_fping
254 Summary:        Nagios plugin to check host up state with fping
255 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania hosta przy użyciu programu fping
256 Group:          Networking
257 Requires:       fping
258 Requires:       nagios-common
259 Provides:       nagios-plugins-fping = %{version}-%{release}
260 Obsoletes:      nagios-plugins-fping
261
262 %description -n nagios-plugin-check_fping
263 This plugin will use the /bin/fping command to ping the specified host
264 for a fast check if the host is alive.
265
266 %description -n nagios-plugin-check_fping -l pl.UTF-8
267 Ta wtyczka używa polecenia /bin/fping do szybkiego sprawdzenia, czy
268 dany host działa.
269
270 %package -n nagios-plugin-check_game
271 Summary:        Nagios plugin to check status of Internet game servers
272 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania stanu serwerów gier internetowych
273 Group:          Networking
274 Requires:       nagios-common
275 Requires:       qstat
276 Provides:       nagios-plugins-qstat = %{version}-%{release}
277 Obsoletes:      nagios-plugins-qstat
278
279 %description -n nagios-plugin-check_game
280 This plugin uses the 'qstat' command, the popular game server status
281 query tool.
282
283 QStat is a command-line program that displays information about
284 Internet game servers.
285
286 The servers are either down, non-responsive, or running a game. For
287 servers running a game, the server name, map name, current number of
288 players, and response time are displayed. Server rules and player
289 information may also be displayed.
290
291 %description -n nagios-plugin-check_game -l pl.UTF-8
292 Ta wtyczka używa polecenia 'qstat' - popularnego narzędzia do zapytań
293 o stan serwerów gier.
294
295 QStat to program działający z linii poleceń wyświetlający informacje o
296 serwerach gier internetowych.
297
298 Serwery mogą być wyłączone, nie odpowiadać, bądź mieć uruchomioną grę.
299 Dla serwerów z grami wyświetlanea są: nazwa serwera, nazwa mapy,
300 aktualna liczba graczy i czas odpowiedzi. Mogą być dodatkowo
301 wyświetlone reguły serwera i informacje o graczach.
302
303 %package -n nagios-plugin-check_ldap
304 Summary:        Nagios plugin to check LDAP servers
305 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania serwerów LDAP
306 Group:          Networking
307 Requires:       nagios-common
308 Suggests:       openldap
309 Provides:       nagios-plugins-ldap = %{version}-%{release}
310 Obsoletes:      nagios-plugins-ldap
311
312 %description -n nagios-plugin-check_ldap
313 Nagios plugin to check LDAP servers.
314
315 %description -n nagios-plugin-check_ldap -l pl.UTF-8
316 Wtyczka Nagiosa do sprawdzania serwerów LDAP.
317
318 %package -n nagios-plugin-check_load
319 Summary:        Nagios plugin to check uptime using procps
320 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania uptime'u przy użyciu procps
321 Group:          Networking
322 Requires:       nagios-common
323 Requires:       procps
324 Provides:       nagios-plugins-procps = %{version}-%{release}
325 Obsoletes:      nagios-plugins-procps
326
327 %description -n nagios-plugin-check_load
328 Nagios plugin to check uptime using procps.
329
330 %description -n nagios-plugin-check_load -l pl.UTF-8
331 Wtyczka Nagiosa do sprawdzania uptime'u przy użyciu procps.
332
333 %package -n nagios-plugin-check_mailq
334 Summary:        Nagios plugin to check the number of messages in the local mail queue
335 Group:          Networking
336 Requires:       nagios-common
337 # for utils.pm
338 Requires:       %{name}-libs = %{version}-%{release}
339 %if "%{_rpmversion}" >= "5"
340 BuildArch:      noarch
341 %endif
342
343 %description -n nagios-plugin-check_mailq
344 Checks the number of messages in the mail queue (supports multiple
345 sendmail queues, qmail).
346
347 %package -n nagios-plugin-check_nt
348 Summary:        Nagios plugin to check NT server with NSClient
349 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania serwera NT przy użyciu NSClienta
350 Group:          Networking
351 Requires:       %{name}-libs = %{version}-%{release}
352 Requires:       nagios-common
353
354 %description -n nagios-plugin-check_nt
355 Nagios plugin to check NT server with NSClient.
356
357 %description -n nagios-plugin-check_nt -l pl.UTF-8
358 Wtyczka Nagiosa do sprawdzania serwera NT przy użyciu NSClienta.
359
360 %package -n nagios-plugin-check_ntp
361 Summary:        Nagios plugin to check time using NTP protocol
362 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania czasu przy użyciu protokołu NTP
363 Group:          Networking
364 Requires:       nagios-common
365 # for utils.pm
366 Requires:       %{name}-libs = %{version}-%{release}
367 Requires:       ntp-client
368 Provides:       nagios-plugins-ntp = %{version}-%{release}
369 Obsoletes:      nagios-plugins-ntp
370
371 %description -n nagios-plugin-check_ntp
372 Checks the local timestamp offset versus <host> with ntpdate. Checks
373 the jitter/dispersion of clock signal between <host> and its sys.peer
374 with ntpq.
375
376 %description -n nagios-plugin-check_ntp -l pl.UTF-8
377 Ta wtyczka sprawdza przesunięcie lokalnego czasu względem danego hosta
378 przy użyciu ntpdate. Sprawdza wahania/dyspersję sygnału zegara
379 pomiędzy hostem a jego sys.peer przy użyciu ntpq.
380
381 %package -n nagios-plugin-check_pgsql
382 Summary:        Nagios plugin to test a PostgreSQL DBMS
383 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania systemu baz danych PostgreSQL
384 Group:          Networking
385 Requires:       nagios-common
386 Provides:       nagios-plugins-pgsql = %{version}-%{release}
387 Obsoletes:      nagios-plugins-pgsql
388
389 %description -n nagios-plugin-check_pgsql
390 This plugin tests a PostgreSQL DBMS to determine whether it is active
391 and accepting queries. In its current operation, it simply connects to
392 the specified database, and then disconnects. If no database is
393 specified, it connects to the template1 database, which is present in
394 every functioning PostgreSQL DBMS.
395
396 %description -n nagios-plugin-check_pgsql -l pl.UTF-8
397 Ta wtyczka sprawdza serwer baz danych PostgreSQL, aby określić, czy
398 jest aktywny i przyjmuje zapytania. Aktualnie po prostu łączy się do
399 określonej bazy danych i rozłącza. Jeśli nie podano bazy danych, łączy
400 się do bazy danych template1, obecnej w każdym działającym systemie
401 PostgreSQL.
402
403 %package -n nagios-plugin-check_ping
404 Summary:        Nagios plugin to check host up state with ping
405 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania hosta przy użyciu programu ping
406 Group:          Networking
407 Requires:       iputils-ping >= 1:s20070202-1
408 Requires:       nagios-common
409
410 %description -n nagios-plugin-check_ping
411 This plugin will use the /bin/ping command to ping the specified host
412 if the host is alive.
413
414 %description -n nagios-plugin-check_ping -l pl.UTF-8
415 Ta wtyczka używa polecenia /bin/ping do sprawdzenia, czy dany host
416 działa.
417
418 %package -n nagios-plugin-check_radius
419 Summary:        Nagios plugin to test a radius server to see if it is accepting connections
420 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania serwera radius pod kątem przyjmowania połączeń
421 Group:          Networking
422 Requires:       nagios-common
423 Requires:       radiusclient
424 Provides:       nagios-plugins-radius = %{version}-%{release}
425 Obsoletes:      nagios-plugins-radius
426
427 %description -n nagios-plugin-check_radius
428 This plugin tests a radius server to see if it is accepting
429 connections.
430
431 %description -n nagios-plugin-check_radius -l pl.UTF-8
432 Ta wtyczka sprawdza serwer usługi radius, aby zobaczyć, czy przyjmuje
433 połączenia.
434
435 %package -n nagios-plugin-check_sensors
436 Summary:        Nagios plugin to check hardware status using the lm_sensors package
437 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania stanu sprzętu przy użyciu pakietu lm_sensors
438 Group:          Networking
439 Requires:       nagios-common
440 # for utils.sh
441 Requires:       %{name}-libs = %{version}-%{release}
442 Requires:       lm_sensors
443 Provides:       nagios-plugins-sensors = %{version}-%{release}
444 Obsoletes:      nagios-plugins-sensors
445 %if "%{_rpmversion}" >= "5"
446 BuildArch:      noarch
447 %endif
448
449 %description -n nagios-plugin-check_sensors
450 This plugin checks hardware status using the lm_sensors package.
451
452 %description -n nagios-plugin-check_sensors -l pl.UTF-8
453 Ta wtyczka sprawdza stan sprzętu przy użyciu pakietu lm_sensors.
454
455 %package -n nagios-plugin-check_dbi
456 Summary:        Nagios plugin to check database with libdbi
457 Group:          Networking
458 Requires:       nagios-common
459 Suggests:       libdbi-drivers-firebird
460 Suggests:       libdbi-drivers-freetds
461 Suggests:       libdbi-drivers-mysql
462 Suggests:       libdbi-drivers-pgsql
463 Suggests:       libdbi-drivers-sqlite
464 Suggests:       libdbi-drivers-sqlite3
465
466 %description -n nagios-plugin-check_dbi
467 Nagios plugin to check database with libdbi.
468
469 # requisite not packaged in PLD
470 %package nwstat
471 Summary:        Nagios plugin nwstat
472 Summary(pl.UTF-8):      Wtyczka nwstat do Nagiosa
473 Group:          Networking
474 Requires:       %{name}-libs = %{version}-%{release}
475 Requires:       mrtgext
476 Requires:       nagios-common
477
478 %description nwstat
479 Nagios plugin using MRTGEXT module
480 <http://forge.novell.com/modules/xfmod/project/?mrtgext>.
481
482 %description nwstat -l pl.UTF-8
483 Wtyczka nagiosa używająca modułu MRTGEXT
484 <http://forge.novell.com/modules/xfmod/project/?mrtgext>.
485
486 %package contrib
487 Summary:        Contributed nagios plugins
488 Summary(pl.UTF-8):      Wtyczki przekazane do projektu Nagios
489 Group:          Networking
490 Requires:       nagios-common
491 # for utils.pm, utils.sh, utils.py
492 Requires:       %{name}-libs = %{version}-%{release}
493 # check_apache
494 Suggests:       perl-URI
495 Suggests:       perl-libwww
496 # check_apc_ups
497 Suggests:       net-snmp-utils
498 # check_arping
499 Suggests:       perl-Net-Arping
500 # check_bgpstate
501 Suggests:       perl-Net-SNMP
502 Suggests:       whois
503 # check_traceroute
504 Suggests:       traceroute
505 # check_traceroute-pure_perl
506 Suggests:       perl-Net-Traceroute
507 # check_temp_fsc
508 Suggests:       perl-SNMP_Session
509 # check_smart
510 Suggests:       smartmontools
511 # check_smb
512 Suggests:       samba
513 # check_adptraid
514 #Suggests:      dptutil
515 # unfinished... more deps are actually needed.
516
517 %description contrib
518 Contributed nagios plugins. Some of them work, some do not. Use at
519 your own risk.
520
521 %description contrib -l pl.UTF-8
522 Wtyczki przekazane do projektu Nagios. Część z nich działa, część nie.
523
524 %prep
525 %setup -q -a1
526 mv nagios-plugins-config-*/* .
527 %patch0 -p1
528 %patch4 -p1
529 %patch5 -p1
530 %patch7 -p1
531 %patch13 -p1
532 %patch21 -p1
533 %patch23 -p1
534 %patch24 -p1
535 %patch27 -p1
536 %patch28 -p1
537 %patch29 -p1
538
539 # remove libtool m4 macro copies, breaks when system libtool is older
540 %{__rm} gl/m4/libtool.m4 gl/m4/lt*.m4
541
542 # cleanup backups after patching
543 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
544
545 # force regen in build
546 rm -f configure
547
548 %build
549 if [ ! -f configure ]; then
550         %{__gettextize}
551         %{__libtoolize}
552         %{__aclocal} -I m4 -I gl/m4
553         %{__autoconf}
554         %{__autoheader}
555         %{__automake}
556 fi
557
558 %configure \
559         --libexecdir=%{plugindir} \
560         --enable-libtap=/usr \
561         --with-cgiurl=/nagios/cgi-bin \
562         --with-mysql=/usr \
563         --with-pgsql=/usr \
564         --with-openssl=/usr \
565         --with-ping-command='/bin/ping -n -U -w %%d -c %%d %%s' \
566         --with-ping6-command='/bin/ping6 -n -U -w %%d -c %%d %%s' \
567         --with-ps-command="/bin/ps axwo 'stat uid ppid vsz rss pcpu comm args'" \
568         --with-ps-format="%%s %%d %%d %%d %%d %%f %%s %%n" \
569         --with-ps-cols=8 \
570         --with-ps-varlist="procstat,&procuid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos" \
571         --with-proc-meminfo=/proc/meminfo \
572         --with-proc-loadavg=/proc/loadavg \
573         --with-nslookup-command="/usr/bin/nslookup -sil" \
574         --with-uptime-command=/usr/bin/uptime \
575         --with-rpcinfo-command=/usr/sbin/rpcinfo \
576         --with-ntpdate-command=/usr/sbin/ntpdate \
577         --with-smbclient-command=/usr/bin/smbclient \
578         --with-dig-command=/usr/bin/dig \
579         --with-fping-command=/usr/sbin/fping \
580         --with-fping6-command=/usr/sbin/fping6 \
581         --with-qstat-command=/usr/bin/qstat \
582         --with-ssh-command=/usr/bin/ssh \
583         --with-snmpget-command=/usr/bin/snmpget \
584         --with-snmpgetnext-command=/usr/bin/snmpgetnext \
585         --with-df-command='/bin/df -P' \
586         --with-apt-get-command=/usr/bin/apt-get \
587         --with-qmail-qstat-command=/usr/bin/qmail-qstat \
588         --with-mailq-command=/usr/bin/mailq \
589         --with-sudo-command=/usr/bin/sudo \
590         --without-included-regex
591
592 %{__make}
593
594 %install
595 rm -rf $RPM_BUILD_ROOT
596
597 %{__make} install \
598         DESTDIR=$RPM_BUILD_ROOT
599
600 %{__make} install-root -C plugins-root \
601         DESTDIR=$RPM_BUILD_ROOT
602
603 %{__rm} $RPM_BUILD_ROOT%{plugindir}/check_nwstat
604
605 # for nagios-plugin-check_mysql_perf (at least)
606 install -d $RPM_BUILD_ROOT%{_libdir}
607 cp -p lib/libnagiosplug.a $RPM_BUILD_ROOT%{_libdir}
608 cp -p gl/libgnu.a $RPM_BUILD_ROOT%{_libdir}
609 cp -p plugins/utils.o $RPM_BUILD_ROOT%{_libdir}
610 cp -p plugins/netutils.o $RPM_BUILD_ROOT%{_libdir}
611 install -d $RPM_BUILD_ROOT%{_includedir}/nagiosplug/{plugins,gl,lib}
612 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/nagiosplug
613 cp -p plugins/*.h $RPM_BUILD_ROOT%{_includedir}/nagiosplug/plugins
614 cp -p gl/*.h $RPM_BUILD_ROOT%{_includedir}/nagiosplug/gl
615 cp -p lib/*.h $RPM_BUILD_ROOT%{_includedir}/nagiosplug/lib
616
617 install -d $RPM_BUILD_ROOT%{_sysconfdir}
618 cp -p commands/*.cfg $RPM_BUILD_ROOT%{_sysconfdir}
619
620 %find_lang %{name}
621
622 # replace USER1 macro with actual value
623 plugins=$(grep -Eoh 'command_line.*USER1\$/[^ ]+' $RPM_BUILD_ROOT%{_sysconfdir}/*.cfg | awk -F/ '{print $NF}' | sort -u)
624 for plugin in $plugins; do
625         sed -i -e "s,\\\$USER1\\\$/$plugin ,%{plugindir}/$plugin ," $RPM_BUILD_ROOT%{_sysconfdir}/*.cfg
626 done
627
628 install -d $RPM_BUILD_ROOT%{nrpeddir}
629 touch $RPM_BUILD_ROOT%{nrpeddir}/check_mailq.cfg
630
631 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{plugindir}/utils.php
632 chmod a-x $RPM_BUILD_ROOT%{plugindir}/utils.*
633
634 %clean
635 rm -rf $RPM_BUILD_ROOT
636
637 %if 0
638 # this is for shared lib
639 %post   libs    -p /sbin/ldconfig
640 %postun libs    -p /sbin/ldconfig
641 %endif
642
643 %triggerin -n nagios-plugin-check_mailq -- nagios-nrpe
644 %nagios_nrpe -a check_mailq -f %{_sysconfdir}/check_mailq.cfg
645
646 %triggerun -n nagios-plugin-check_mailq -- nagios-nrpe
647 %nagios_nrpe -d check_mailq -f %{_sysconfdir}/check_mailq.cfg
648
649 %if "%{_lib}" != "lib"
650 %triggerpostun -- nagios-plugins < 2.1.1-4.1, nagios-plugin-check_dns < 2.1.1-4.1, nagios-plugin-check_load < 2.1.1-4.1, nagios-plugin-check_nt < 2.1.1-4.1, nagios-plugin-check_ntp < 2.1.1-4.1, nagios-plugin-check_ping < 2.1.1-4.1, nagios-plugins-mysql < 2.1.1-4.1, nagios-plugins-snmp < 2.1.1-4.1
651 # update path to plugin in config if neccessary
652 for c in \
653         %{_sysconfdir}/check_{dhcp,disk,dns,dummy,ftp,hpjd,http,imap,load,mrtgtraf,mysql,nntp,nt,ntp,ping,pop,procs,smtp,snmp,ssh,swap,tcp,telnet,udp,users}.cfg \
654 ; do
655         test -f $c || continue
656         grep -q 'command_line.*%{_prefix}/%{_lib}/nagios/plugins' $c || continue
657         %{__sed} -i -e '/command_line/ s,%{_prefix}/%{_lib}/nagios/plugins,%{plugindir},g' $c
658 done
659 %endif
660
661 %files -f %{name}.lang
662 %defattr(644,root,root,755)
663 %doc ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog
664 %doc FAQ LEGAL NEWS README REQUIREMENTS SUPPORT THANKS
665
666 # plugins
667 %attr(755,root,root) %{plugindir}/check_apt
668 %attr(755,root,root) %{plugindir}/check_cluster
669 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_disk.cfg
670 %attr(755,root,root) %{plugindir}/check_disk
671 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_dummy.cfg
672 %attr(755,root,root) %{plugindir}/check_dummy
673 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_http.cfg
674 %attr(755,root,root) %{plugindir}/check_http
675 %attr(755,root,root) %{plugindir}/check_ide_smart
676 %attr(755,root,root) %{plugindir}/check_mrtg
677 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_mrtgtraf.cfg
678 %attr(755,root,root) %{plugindir}/check_mrtgtraf
679 %attr(755,root,root) %{plugindir}/check_nagios
680 # req: over-cr >= 0.99.53 http://www.molitor.org/overcr
681 %attr(755,root,root) %{plugindir}/check_overcr
682 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_procs.cfg
683 %attr(755,root,root) %{plugindir}/check_procs
684 %attr(755,root,root) %{plugindir}/check_real
685 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_smtp.cfg
686 %attr(755,root,root) %{plugindir}/check_smtp
687 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_ssh.cfg
688 %attr(755,root,root) %{plugindir}/check_ssh
689 %attr(755,root,root) %{plugindir}/check_time
690 %attr(755,root,root) %{plugindir}/check_ups
691 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_users.cfg
692 %attr(755,root,root) %{plugindir}/check_users
693 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_swap.cfg
694 %attr(755,root,root) %{plugindir}/check_swap
695 %attr(755,root,root) %{plugindir}/check_log
696
697 # check_tcp and symlinks
698 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_tcp.cfg
699 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_telnet.cfg
700 %attr(755,root,root) %{plugindir}/check_tcp
701 %attr(755,root,root) %{plugindir}/check_clamd
702 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_ftp.cfg
703 %attr(755,root,root) %{plugindir}/check_ftp
704 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_imap.cfg
705 %attr(755,root,root) %{plugindir}/check_imap
706 %attr(755,root,root) %{plugindir}/check_jabber
707 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_nntp.cfg
708 %attr(755,root,root) %{plugindir}/check_nntp
709 %attr(755,root,root) %{plugindir}/check_nntps
710 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_pop.cfg
711 %attr(755,root,root) %{plugindir}/check_pop
712 %attr(755,root,root) %{plugindir}/check_simap
713 %attr(755,root,root) %{plugindir}/check_spop
714 %attr(755,root,root) %{plugindir}/check_ssmtp
715 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_udp.cfg
716 %attr(755,root,root) %{plugindir}/check_udp
717 %attr(755,root,root) %{plugindir}/check_uptime
718
719 # these plugins need suid bit to operate
720 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_dhcp.cfg
721 %attr(755,root,root) %{plugindir}/check_dhcp
722 %attr(755,root,root) %{plugindir}/check_icmp
723
724 # Cannot determine ORACLE_HOME for sid
725 # probably needs some external programs. can't test
726 %attr(755,root,root) %{plugindir}/check_oracle
727
728 %files libs
729 %defattr(644,root,root,755)
730 #%attr(755,root,root) %{_libdir}/libnagiosplug.so.0.0.0
731 %attr(755,root,root) %{plugindir}/negate
732 %attr(755,root,root) %{plugindir}/urlize
733
734 %{plugindir}/utils.pm
735 %{plugindir}/utils.php
736 %{plugindir}/utils.sh
737
738 %files devel
739 %defattr(644,root,root,755)
740 %{_libdir}/libgnu.a
741 %{_libdir}/libnagiosplug.a
742 %{_libdir}/netutils.o
743 %{_libdir}/utils.o
744 %{_includedir}/nagiosplug
745
746 %files mysql
747 %defattr(644,root,root,755)
748 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_mysql.cfg
749 %attr(755,root,root) %{plugindir}/check_mysql
750 %attr(755,root,root) %{plugindir}/check_mysql_query
751
752 %files perl
753 %defattr(644,root,root,755)
754 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_ircd.cfg
755 %attr(755,root,root) %{plugindir}/check_ircd
756 %attr(755,root,root) %{plugindir}/check_rpc
757
758 # requires license.dat
759 %attr(755,root,root) %{plugindir}/check_flexlm
760
761 %files samba
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{plugindir}/check_disk_smb
764
765 # Not to be confused with nagios-snmp-plugins
766 %files snmp
767 %defattr(644,root,root,755)
768 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_snmp.cfg
769 %attr(755,root,root) %{plugindir}/check_snmp
770 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_hpjd.cfg
771 %attr(755,root,root) %{plugindir}/check_hpjd
772 %attr(755,root,root) %{plugindir}/check_ifoperstatus
773 %attr(755,root,root) %{plugindir}/check_ifstatus
774 %attr(755,root,root) %{plugindir}/check_wave
775 %attr(755,root,root) %{plugindir}/check_breeze
776
777 %files ssh
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{plugindir}/check_by_ssh
780
781 %files -n nagios-plugin-check_dig
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{plugindir}/check_dig
784
785 %files -n nagios-plugin-check_dns
786 %defattr(644,root,root,755)
787 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_dns.cfg
788 %attr(755,root,root) %{plugindir}/check_dns
789
790 %files -n nagios-plugin-check_file_age
791 %defattr(644,root,root,755)
792 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_file_age.cfg
793 %attr(755,root,root) %{plugindir}/check_file_age
794
795 %files -n nagios-plugin-check_fping
796 %defattr(644,root,root,755)
797 %attr(2755,root,adm) %{plugindir}/check_fping
798
799 %files -n nagios-plugin-check_game
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{plugindir}/check_game
802
803 %if %{with ldap}
804 %files -n nagios-plugin-check_ldap
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{plugindir}/check_ldap
807 %attr(755,root,root) %{plugindir}/check_ldaps
808 %endif
809
810 %files -n nagios-plugin-check_load
811 %defattr(644,root,root,755)
812 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_load.cfg
813 %attr(755,root,root) %{plugindir}/check_load
814
815 %files -n nagios-plugin-check_mailq
816 %defattr(644,root,root,755)
817 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_mailq.cfg
818 %attr(755,root,root) %{plugindir}/check_mailq
819 %ghost %{nrpeddir}/check_mailq.cfg
820
821 %files -n nagios-plugin-check_nt
822 %defattr(644,root,root,755)
823 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_nt.cfg
824 %attr(755,root,root) %{plugindir}/check_nt
825
826 %files -n nagios-plugin-check_ntp
827 %defattr(644,root,root,755)
828 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_ntp.cfg
829 %attr(755,root,root) %{plugindir}/check_ntp
830 %attr(755,root,root) %{plugindir}/check_ntp_peer
831 %attr(755,root,root) %{plugindir}/check_ntp_time
832
833 %files -n nagios-plugin-check_pgsql
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{plugindir}/check_pgsql
836
837 %files -n nagios-plugin-check_ping
838 %defattr(644,root,root,755)
839 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/check_ping.cfg
840 %attr(2755,root,adm) %{plugindir}/check_ping
841
842 %files -n nagios-plugin-check_radius
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{plugindir}/check_radius
845
846 %files -n nagios-plugin-check_sensors
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{plugindir}/check_sensors
849
850 %files -n nagios-plugin-check_dbi
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{plugindir}/check_dbi
This page took 0.162274 seconds and 3 git commands to generate.