]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- 0.26.0, builds, files needs updating
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Python bindings; missing MySQLdb
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
10 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
11 # - dozen of unpackaged files
12 #
13 # Specfile for MythTV
14 #
15 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
16 #  building an rpm by hand on the machine it will be used on, I encourage you
17 #  to use "--with cpu_autodetect" to let mythtv decide for you.
18 #
19 # Conditional build:
20 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
21 %bcond_without  lirc            # lirc support
22 %bcond_without  alsa            # alsa support
23 %bcond_without  oss             # oss support
24 %bcond_without  jack            # jack audio connection kit
25 %bcond_without  pulseaudio      # pulseaudio support
26 %bcond_without  dvb             # DVB support
27 %bcond_without  xrandr          # disable X11 resolution switching
28 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
29 %bcond_without  iptv
30 %bcond_without  firewire        # ieee1394 (NFY)
31 %bcond_without  vdpau           # disable nvidia vdpau support
32 %bcond_without  fftw3           # disable fftw3 support
33 %bcond_with     mmx             # enable MMX
34 %bcond_without  nellymoserdec
35 %bcond_with     vaapi           # enable vaapi
36 %bcond_with     dshowserver     # enable directshow codecs server
37 %bcond_with     perl
38 %bcond_with     python
39 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers
40                                 # instead of libvdpau
41
42 # enable mmx automatically on arches having it
43 %ifarch %{ix86} %{x8664}
44 %ifnarch i386 i486 i586 i686
45 %define with_mmx 1
46 %endif
47 %endif
48
49 # dshowserver is exclusive arch for x86 x86_64 only
50 %ifnarch %{ix86} %{x8664}
51 %undefine with_dshowserver
52 %endif
53
54 %include        /usr/lib/rpm/macros.perl
55 Summary:        A personal video recorder (PVR) application
56 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
57 Name:           mythtv
58 Version:        0.26.0
59 Release:        0.1
60 License:        GPL v2
61 Group:          Applications/Multimedia
62 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
63 # Source0-md5:  f57066bf75e6f14824c494d41639f4f9
64 Source1:        mythbackend.sysconfig
65 Source2:        mythbackend.init
66 Source3:        mythbackend.logrotate
67 Source4:        %{name}.tmpfiles
68 Source5:        pld-mythfrontend.desktop
69 # Source5-md5:  f37a903ac97463683bebacdf29406951
70 Source6:        pld-mythfrontend.png
71 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
72 Source20:       dshowcodecs
73 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
74 Patch0:         %{name}-configure.patch
75 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
76 Patch30:        %{name}-dshowserver-0.22.patch
77 URL:            http://www.mythtv.org/
78 BuildRequires:  Mesa-libGLU-devel
79 BuildRequires:  OpenGL-devel
80 BuildRequires:  Qt3Support-devel
81 BuildRequires:  QtCore-devel
82 BuildRequires:  QtGui-devel
83 BuildRequires:  QtNetwork-devel
84 BuildRequires:  QtOpenGL-devel
85 BuildRequires:  QtScript-devel
86 BuildRequires:  QtSql-devel
87 BuildRequires:  QtWebKit-devel
88 BuildRequires:  QtXml-devel
89 %{?with_alsa:BuildRequires:     alsa-lib-devel}
90 BuildRequires:  ffmpeg-devel
91 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
92 BuildRequires:  freetype-devel >= 1:2.0.0
93 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
94 BuildRequires:  lame-libs-devel
95 %{?with_firewire:BuildRequires: libavc1394-devel}
96 BuildRequires:  libdts-devel
97 %{?with_dvb:BuildRequires:      libdvb-devel}
98 BuildRequires:  libdvdnav-devel
99 %{?with_firewire:BuildRequires: libiec61883-devel}
100 %{?with_firewire:BuildRequires: libraw1394-devel}
101 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
102 BuildRequires:  linux-libc-headers >= 7:2.6.10
103 %{?with_lirc:BuildRequires:     lirc-devel}
104 BuildRequires:  mysql-devel
105 BuildRequires:  perl-devel
106 BuildRequires:  perl-tools-pod
107 BuildRequires:  pkgconfig
108 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
109 BuildRequires:  python-devel
110 BuildRequires:  qt4-build
111 BuildRequires:  qt4-qmake
112 BuildRequires:  rpm-perlprov >= 4.1-13
113 BuildRequires:  rpm-pythonprov
114 BuildRequires:  rpmbuild(macros) >= 1.228
115 BuildRequires:  sed >= 4.0
116 BuildRequires:  which
117 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
118 BuildRequires:  xorg-lib-libXext-devel
119 BuildRequires:  xorg-lib-libXxf86vm-devel
120 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
121 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
122 # for Perl bindings
123 BuildRequires:  perl-ExtUtils-MakeMaker
124 ExclusiveArch:  %{ix86} %{x8664} ppc
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
128
129 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
130 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
131 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
132 %define         no_install_post_check_so 1
133
134 %description
135 MythTV implements the following PVR features, and more, with a unified
136 graphical interface:
137 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
138 - Video compression using RTjpeg or MPEG-4
139 - Program listing retrieval using XMLTV
140 - Themable, semi-transparent on-screen display
141 - Electronic program guide
142 - Scheduled recording of TV programs
143 - Resolution of conflicts between scheduled recordings
144 - Basic video editing
145
146 %description -l pl.UTF-8
147 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
148 ujednoliconym interfejsem graficznym:
149 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
150   przewijanie "żywej" telewizji
151 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
152 - odczyt listy programów przy użyciu XMLTV
153 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
154 - elektroniczny przewodnik po programie
155 - planowane nagrywanie programów telewizyjnych
156 - rozwiązywanie konfliktów między planowanymi nagraniami
157 - podstawowa edycja obrazu
158
159 %package backend
160 Summary:        Server component of mythtv (a PVR)
161 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
162 Group:          Applications/Multimedia
163 Requires(post,preun):   /sbin/chkconfig
164 Requires(postun):       /usr/sbin/groupdel
165 Requires(postun):       /usr/sbin/userdel
166 Requires(pre):  /bin/id
167 Requires(pre):  /usr/bin/getgid
168 Requires(pre):  /usr/sbin/groupadd
169 Requires(pre):  /usr/sbin/useradd
170 Requires:       libmyth = %{version}-%{release}
171 Requires:       mythtv = %{version}-%{release}
172 Suggests:       mysql
173 Provides:       group(mythtv)
174 Provides:       user(mythtv)
175 Conflicts:      logrotate < 3.8.0
176
177 %description backend
178 MythTV provides a unified graphical interface for recording and
179 viewing television programs. Refer to the mythtv package for more
180 information.
181
182 This package contains only the server software, which provides video
183 and audio capture and encoding services. In order to be useful, it
184 requires a mythtv-frontend installation, either on the same system or
185 one reachable via the network.
186
187 %description backend -l pl.UTF-8
188 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
189 oglądania programów telewizyjnych. Więcej informacji w pakiecie
190 mythtv.
191
192 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
193 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
194 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
195 albo innym osiągalnym w sieci.
196
197 %package frontend
198 Summary:        Client component of mythtv (a PVR)
199 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
200 Group:          Applications/Multimedia
201 Requires:       libmyth = %{version}-%{release}
202 Requires:       mythtv = %{version}-%{release}
203 Requires:       mythtv-themes = %{version}-%{release}
204 Provides:       mythtv-frontend-api = %{myth_api_version}
205
206 %description frontend
207 MythTV provides a unified graphical interface for recording and
208 viewing television programs. Refer to the mythtv package for more
209 information.
210
211 This package contains only the client software, which provides a
212 front-end for playback and configuration. It requires access to a
213 mythtv-backend installation, either on the same system or one
214 reachable via the network.
215
216 %description frontend -l pl.UTF-8
217 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
218 oglądania programów telewizyjnych. Więcej informacji w pakiecie
219 mythtv.
220
221 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
222 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
223 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
224
225 %package setup
226 Summary:        Setup the mythtv backend
227 Summary(pl.UTF-8):      Konfigurator backendu mythtv
228 Group:          Applications/Multimedia
229 Requires:       libmyth = %{version}-%{release}
230
231 %description setup
232 MythTV provides a unified graphical interface for recording and
233 viewing television programs. Refer to the mythtv package for more
234 information.
235
236 This package contains only the setup software for configuring the
237 mythtv backend.
238
239 %description setup -l pl.UTF-8
240 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
241 oglądania programów telewizyjnych. Więcej informacji w pakiecie
242 mythtv.
243
244 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
245
246 %package themes
247 Summary:        Base themes for mythtv's frontend
248 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
249 Group:          Themes
250 Requires:       %{name}-frontend = %{version}-%{release}
251
252 %description themes
253 MythTV provides a unified graphical interface for recording and
254 viewing television programs. Refer to the mythtv package for more
255 information.
256
257 This package contains only the base themes used by the frontend and
258 mythtvsetup.
259
260 %description themes -l pl.UTF-8
261 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
262 oglądania programów telewizyjnych. Więcej informacji w pakiecie
263 mythtv.
264
265 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
266 mythtvsetup.
267
268 %package -n libmyth
269 Summary:        Library providing mythtv support
270 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
271 Group:          Libraries
272 Requires:       QtSql-mysql
273 Requires:       freetype >= 1:2.0.0
274 Requires:       lame
275
276 %description -n libmyth
277 Common library code for MythTV and add-on modules (development) MythTV
278 provides a unified graphical interface for recording and viewing
279 television programs. Refer to the mythtv package for more information.
280
281 %description -n libmyth -l pl.UTF-8
282 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
283 dostarczający ujednolicony interfejs graficzny do nagrywania i
284 oglądania programów telewizyjnych. Więcej informacji w pakiecie
285 mythtv.
286
287 %package -n libmyth-devel
288 Summary:        Development files for libmyth
289 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
290 Group:          Development/Libraries
291 Requires:       libmyth = %{version}-%{release}
292
293 %description -n libmyth-devel
294 This package contains the header files for developing add-ons for
295 mythtv.
296
297 %description -n libmyth-devel -l pl.UTF-8
298 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
299
300 %package -n libmyth-static
301 Summary:        Static libmyth library
302 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
303 Group:          Development/Libraries
304 Requires:       libmyth-devel = %{version}-%{release}
305
306 %description -n libmyth-static
307 Static libmyth library.
308
309 %description -n libmyth-static -l pl.UTF-8
310 Statyczna biblioteka libmyth.
311
312 %package -n perl-MythTV
313 Summary:        MythTV Perl bindings
314 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
315 Group:          Libraries
316
317 %description -n perl-MythTV
318 MythTV Perl bindings.
319
320 %description -n perl-MythTV -l pl.UTF-8
321 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
322
323 %package -n python-MythTV
324 Summary:        MythTV Python bindings
325 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
326 Group:          Libraries
327 Requires:       python-MySQLdb
328
329 %description -n python-MythTV
330 MythTV Python bindings.
331
332 %description -n python-MythTV -l pl.UTF-8
333 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
334
335 %prep
336
337 %setup -q
338
339 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
340         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
341
342 %patch0  -p1
343 %{?with_dshowserver:%patch20 -p1}
344 #%patch30 -p1
345
346 rm -rf database/old # not supported in PLD
347
348 # lib64 fix - enable to update patch
349 %if %{_lib} != "lib" && 0
350 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
351 xargs grep -l /lib . | xargs sed -i -e '
352         s,/''usr/lib/,/%{_libdir}/,g
353         s,/''lib/mythtv,/%{_lib}/mythtv,g
354         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
355 '
356 exit 1
357 %endif
358
359 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
360 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
361 # prevent compiler finding libs from system when they should be looked
362 # from current buildtree.
363 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
364 # so we make QMAKE wrapper which will do sed subst after calling
365 # qmake. this is the wrapper.
366 cat > qmake-wrapper.sh <<'EOF'
367 #!/bin/sh
368 getmakefile() {
369         while [ $# -gt 0 ]; do
370                 case "$1" in
371                 -o)
372                         shift
373                         makefile="$1"
374                         return
375                         ;;
376         esac
377                 shift
378         done
379 }
380
381 qmake-qt4 "$@"
382 getmakefile "$@"
383 if [ "$makefile" ]; then
384         %{__sed} -i -e '
385                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
386                 s;-L$(QTDIR)/%{_lib};;
387         ' $makefile
388 fi
389 EOF
390 chmod +x qmake-wrapper.sh
391
392 # move perl bindings to vendor prefix
393 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
394   bindings/perl/Makefile
395
396 %build
397
398 %if %{with cpu_autodetect}
399 # Make sure we have /proc mounted
400 if [ ! -r /proc/cpuinfo ]; then
401         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
402         exit 1
403 fi
404 %endif
405
406 ./configure \
407         --prefix=%{_prefix} \
408         --libdir=%{_libdir} \
409         --libdir-name=%{_lib} \
410         --mandir=%{_mandir} \
411         --disable-distcc --disable-ccache \
412         --compile-type=%{?debug:debug}%{!?debug:release} \
413         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
414         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
415 %if %{with cpu_autodetect}
416         --enable-proc-opt \
417 %else
418         %ifarch %{ix86}
419                 %ifarch athlon
420                         --arch=athlon \
421                 %else
422                         --cpu=%{_target_cpu} --tune=pentium4 \
423                 %endif
424         %endif
425         %ifarch i386 i486 i586
426         --enable-disable-mmx-for-debugging \
427         %endif
428         %ifarch %{x8664}
429         --arch=x86_64 \
430         %endif
431         %{?with_mmx:--enable-mmx} \
432 %endif
433         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
434         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
435         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
436         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
437         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
438         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
439         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
440         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
441         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
442         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
443         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
444         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
445         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
446         --enable-xv \
447         --enable-x11 \
448
449 #%{_libdir}/qt4/bin/qmake mythtv.pro
450 %{__make}
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
455                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
456                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
457                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
458                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
459                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
460                 $RPM_BUILD_ROOT%{_pixmapsdir} \
461                 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
462
463 %{__make} install \
464         INSTALL_ROOT=$RPM_BUILD_ROOT
465
466 # Install the files that we added on top of mythtv's own stuff
467 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
468 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
469 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
470 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
471
472 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
473
474 # desktop entries
475 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
476 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
477
478 # Install settings.pro so people can see the build options we used
479 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
480 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
481
482 for p in mythfrontend; do
483         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
484                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
485         done > $p.lang
486 done
487
488 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
489         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
490 done > mythbackend.lang
491
492 # glibc language codes. attempt was made to change it on libmyth side,
493 # but that was just asking for trouble due large coverage of
494 # language.lower() usage.
495 sed -i -e '
496 s,%%lang(en_gb),%%lang(en_GB),
497 s,%%lang(zh_tw),%%lang(zh_TW),
498 s,%%lang(pt_br),%%lang(pt_BR),
499 ' *.lang
500
501 rm -rf mythwelcome mythlcdserver
502 install -d mythwelcome
503 cp -a programs/mythwelcome/README mythwelcome
504 cp -a programs/mythlcdserver/README mythlcdserver
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %pre backend
510 %groupadd -g 149 %{name}
511 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
512 %addusertogroup %{name} video
513 %addusertogroup %{name} audio
514
515 %post backend
516 /sbin/chkconfig --add mythbackend
517
518 %preun backend
519 if [ "$1" = "0" ]; then
520         %service -q mythbackend stop
521         /sbin/chkconfig --del mythbackend
522 fi
523
524 %postun backend
525 if [ "$1" = "0" ]; then
526         %userremove %{name}
527         %groupremove %{name}
528 fi
529
530 %post   -n libmyth -p /sbin/ldconfig
531 %postun -n libmyth -p /sbin/ldconfig
532
533 %post setup
534 if [ "$1" = 1 ]; then
535 %banner -e %{name}-setup <<EOF
536 To grant mysql permissions to mythtv, please run
537 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
538 EOF
539 fi
540
541 %files
542 %defattr(644,root,root,755)
543 %doc README* UPGRADING AUTHORS FAQ
544 %doc docs contrib
545 %doc keys.txt mythwelcome mythlcdserver
546
547 %files backend -f mythbackend.lang
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/mythbackend
550 %attr(755,root,root) %{_bindir}/mythcommflag
551 %attr(755,root,root) %{_bindir}/mythfilldatabase
552 %attr(755,root,root) %{_bindir}/mythjobqueue
553 %attr(755,root,root) %{_bindir}/mythlcdserver
554 %attr(755,root,root) %{_bindir}/mythtranscode
555 %attr(755,root,root) %{_bindir}/mythreplex
556 %attr(755,root,root) %{_bindir}/mythffmpeg
557 %attr(755,root,root) %{_bindir}/mythpreviewgen
558 %attr(775,root,mythtv) %dir /var/lib/mythtv
559 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
560 %attr(775,root,mythtv) %dir /var/cache/mythtv
561 %attr(775,root,mythtv) %dir /var/run/mythtv
562 /usr/lib/tmpfiles.d/%{name}.conf
563 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
566 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
567
568 %files frontend -f mythfrontend.lang
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/mythfrontend
571 %attr(755,root,root) %{_bindir}/mythshutdown
572 %attr(755,root,root) %{_bindir}/mythavtest
573 %attr(755,root,root) %{_bindir}/mythwelcome
574 %dir %{_datadir}/mythtv
575 %dir %{_datadir}/mythtv/themes
576 %{_datadir}/mythtv/internetcontent
577 %{_datadir}/mythtv/metadata
578 %dir %{_libdir}/mythtv
579 %{_datadir}/mythtv/*.xml
580 %dir %{_libdir}/mythtv/filters
581 %dir %{_libdir}/mythtv/plugins
582 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
583 %{_datadir}/mythtv/fonts/*.ttf
584 %dir %{_datadir}/mythtv/i18n
585 %if %{with dshowserver}
586 %{_datadir}/mythtv/dshowcodecs
587 %endif
588 %{_desktopdir}/*.desktop
589 %{_pixmapsdir}/*.png
590
591 %files setup
592 %defattr(644,root,root,755)
593 %doc database
594 %attr(755,root,root) %{_bindir}/mythtv-setup
595
596 %files themes
597 %defattr(644,root,root,755)
598 %{_datadir}/mythtv/themes/*
599
600 %files -n libmyth
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/lib*.so.*
603 %attr(755,root,root) %{_libdir}/lib*.a
604 %dir %{_datadir}/mythtv
605 %{_datadir}/mythtv/*.pl
606
607 %files -n libmyth-devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/*.so
610 %{_includedir}/*
611 %{_datadir}/mythtv/build
612
613 %files -n libmyth-static
614 %defattr(644,root,root,755)
615
616 %if %{with perl}
617 %files -n perl-MythTV
618 %defattr(644,root,root,755)
619 %{perl_vendorlib}/MythTV.pm
620 %dir %{perl_vendorlib}/MythTV
621 %{perl_vendorlib}/MythTV/*.pm
622 %dir %{perl_vendorlib}/IO/Socket/INET
623 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
624 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
625 %endif
626
627 %if %{with python}
628 %files -n python-MythTV
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/mythpython
631 %dir %{py_sitescriptdir}/MythTV
632 %{py_sitescriptdir}/MythTV/*
633 %{py_sitescriptdir}/*.egg-info
634 %endif
This page took 0.131653 seconds and 3 git commands to generate.