]> git.pld-linux.org Git - packages/mydumper.git/blob - mydumper.spec
- rebuild with mysql 5.7
[packages/mydumper.git] / mydumper.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # build documentation
4 %bcond_without  tests           # build without tests
5
6 Summary:        MySQL Data Dumper
7 Name:           mydumper
8 Version:        0.9.3
9 Release:        2
10 License:        GPL v3
11 Group:          Applications/Databases
12 Source0:        https://github.com/maxbube/mydumper/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  72e411c8f20fa7d7c36bb78625536b1d
14 URL:            https://github.com/maxbube/mydumper
15 BuildRequires:  cmake
16 BuildRequires:  glib2-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  mysql-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  pcre-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A high-performance multi-threaded backup toolset for MySQL and
27 Drizzle.
28
29 %prep
30 %setup -q
31
32 %build
33 install -d build
34 cd build
35 %cmake \
36         -DBUILD_DOCS=%{!?with_doc:OFF}%{?with_doc:ON} \
37         ..
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__make} install -C build \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README
51 %attr(755,root,root) %{_bindir}/mydumper
52 %attr(755,root,root) %{_bindir}/myloader
This page took 0.073884 seconds and 3 git commands to generate.