]> git.pld-linux.org Git - packages/musl.git/blob - musl.spec
1.1.15 - July 5, 2016
[packages/musl.git] / musl.spec
1 Summary:        musl libc - new standard library to power a new generation of Linux-based devices
2 Summary(pl.UTF-8):      musl libc - nowa biblioteka standardowa dla urządzeń linuksowych nowej generacji
3 Name:           musl
4 Version:        1.1.15
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://www.musl-libc.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  9590a9d47ee64f220b3c12f7afb864ca
10 URL:            http://www.musl-libc.org/
11 BuildRequires:  gcc >= 5:3.2
12 BuildRequires:  zlib-devel
13 Requires:       uname(release) >= 2.6.0
14 ExclusiveArch:  %{ix86} %{x8664} x32 arm mips microblaze ppc
15 ExcludeArch:    i386
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _libdir         %{_prefix}/%{_lib}/musl
19 %define         _includedir     %{_prefix}/include/musl
20 %define         _fortify_cflags %{nil}
21 %define         _ssp_cflags     %{nil}
22
23 # i386, x86_64, x32, arm, mips, microblaze, ppc
24 %ifarch x32
25 %define         musl_arch       x32
26 %else
27 %define         musl_arch       %{_target_base_arch}
28 %endif
29
30 %description
31 musl libc is a new standard library to power a new generation of
32 Linux-based devices. It is lightweight, fast, simple, free, and
33 strives to be correct in the sense of standards-conformance and
34 safety.
35
36 musl is an alternative to glibc, uClibc, dietlibc, and klibc.
37
38 %description -l pl.UTF-8
39 musl libc to nowa biblioteka standardowa, przeznaczona do zasilania
40 urządzeń linuksowych nowej generacji. Jest lekka, szybka, prosta,
41 wolnodostępna i stara się być poprawna w sensie zgodności ze
42 standardami i bezpieczeństwa.
43
44 musl jest alternatywą dla bibliotek glibc, uClibc, dietlibc i klibc.
45
46 %package devel
47 Summary:        Development files for musl libc
48 Summary(pl.UTF-8):      Pliki programistyczne biblioteki musl libc
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Development files for musl libc.
54
55 %description devel -l pl.UTF-8
56 Pliki programistyczne biblioteki musl libc.
57
58 %prep
59 %setup -q
60
61 %build
62 %configure \
63         --syslibdir=/%{_lib}
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT%{_sysconfdir}
72 echo '%{_libdir}' > $RPM_BUILD_ROOT%{_sysconfdir}/ld-musl-%{musl_arch}.path
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc COPYRIGHT INSTALL README WHATSNEW
80 %attr(755,root,root) /%{_lib}/ld-musl-%{musl_arch}.so.1
81 %dir %{_libdir}
82 %attr(755,root,root) %{_libdir}/libc.so
83 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld-musl-%{musl_arch}.path
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/musl-gcc
88 %{_libdir}/libc.a
89 # empty stubs
90 %{_libdir}/libcrypt.a
91 %{_libdir}/libdl.a
92 %{_libdir}/libm.a
93 %{_libdir}/libpthread.a
94 %{_libdir}/libresolv.a
95 %{_libdir}/librt.a
96 %{_libdir}/libutil.a
97 %{_libdir}/libxnet.a
98 # crts
99 %{_libdir}/Scrt1.o
100 %{_libdir}/crt*.o
101 %{_libdir}/rcrt1.o
102 %{_libdir}/musl-gcc.specs
103 %{_includedir}
This page took 0.074803 seconds and 4 git commands to generate.