]> git.pld-linux.org Git - packages/musl.git/blob - musl.spec
- release 2 (by relup.sh)
[packages/musl.git] / musl.spec
1 Summary:        musl libc - new standard library to power a new generation of Linux-based devices
2 Summary(pl.UTF-8):      musl libc - nowa biblioteka standardowa dla urządzeń linuksowych nowej generacji
3 Name:           musl
4 Version:        1.1.10
5 Release:        2
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://www.musl-libc.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  fc30892ee582c91920505bbd0021049f
10 Patch0:         musl-locale.patch
11 URL:            http://www.musl-libc.org/
12 BuildRequires:  gcc >= 5:3.2
13 BuildRequires:  zlib-devel
14 Requires:       uname(release) >= 2.6.0
15 ExclusiveArch:  %{ix86} %{x8664} x32 arm mips microblaze ppc
16 ExcludeArch:    i386
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _libdir         %{_prefix}/%{_lib}/musl
20 %define         _includedir     %{_prefix}/include/musl
21 %define         _fortify_cflags %{nil}
22 %define         _ssp_cflags     %{nil}
23
24 # i386, x86_64, x32, arm, mips, microblaze, ppc
25 %ifarch x32
26 %define         musl_arch       x32
27 %else
28 %define         musl_arch       %{_target_base_arch}
29 %endif
30
31 %description
32 musl libc is a new standard library to power a new generation of
33 Linux-based devices. It is lightweight, fast, simple, free, and
34 strives to be correct in the sense of standards-conformance and
35 safety.
36
37 musl is an alternative to glibc, uClibc, dietlibc, and klibc.
38
39 %description -l pl.UTF-8
40 musl libc to nowa biblioteka standardowa, przeznaczona do zasilania
41 urządzeń linuksowych nowej generacji. Jest lekka, szybka, prosta,
42 wolnodostępna i stara się być poprawna w sensie zgodności ze
43 standardami i bezpieczeństwa.
44
45 musl jest alternatywą dla bibliotek glibc, uClibc, dietlibc i klibc.
46
47 %package devel
48 Summary:        Development files for musl libc
49 Summary(pl.UTF-8):      Pliki programistyczne biblioteki musl libc
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Development files for musl libc.
55
56 %description devel -l pl.UTF-8
57 Pliki programistyczne biblioteki musl libc.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 %configure \
65         --syslibdir=/%{_lib}
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{_sysconfdir}
74 echo '%{_libdir}' > $RPM_BUILD_ROOT%{_sysconfdir}/ld-musl-%{musl_arch}.path
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc COPYRIGHT INSTALL README WHATSNEW
82 %attr(755,root,root) /%{_lib}/ld-musl-%{musl_arch}.so.1
83 %dir %{_libdir}
84 %attr(755,root,root) %{_libdir}/libc.so
85 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld-musl-%{musl_arch}.path
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/musl-gcc
90 %{_libdir}/libc.a
91 # empty stubs
92 %{_libdir}/libcrypt.a
93 %{_libdir}/libdl.a
94 %{_libdir}/libm.a
95 %{_libdir}/libpthread.a
96 %{_libdir}/libresolv.a
97 %{_libdir}/librt.a
98 %{_libdir}/libutil.a
99 %{_libdir}/libxnet.a
100 # crts
101 %{_libdir}/Scrt1.o
102 %{_libdir}/crt*.o
103 %{_libdir}/rcrt1.o
104 %{_libdir}/musl-gcc.specs
105 %{_includedir}
This page took 0.05779 seconds and 4 git commands to generate.