]> git.pld-linux.org Git - packages/musl.git/blob - musl.spec
2f2af208c87319306b3487a9332ffbed1e810f25
[packages/musl.git] / musl.spec
1 Summary:        musl libc - new standard library to power a new generation of Linux-based devices
2 Summary(pl.UTF-8):      musl libc - nowa biblioteka standardowa dla urządzeń linuksowych nowej generacji
3 Name:           musl
4 Version:        0.9.15
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://www.musl-libc.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  06f590a38c85722ee9343db2416425f4
10 URL:            http://www.musl-libc.org/
11 BuildRequires:  gcc >= 5:3.2
12 BuildRequires:  zlib-devel
13 Requires:       uname(release) >= 2.6.0
14 ExclusiveArch:  %{ix86} %{x8664} arm mips microblaze ppc
15 ExcludeArch:    i386
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _libdir         %{_prefix}/%{_lib}/musl
19 %define         _includedir     %{_prefix}/include/musl
20 %define         _fortify_cflags %{nil}
21 %define         _ssp_cflags     %{nil}
22
23 # i386, x86_64, arm, mips, microblaze, ppc
24 %define         musl_arch       %{_target_base_arch}
25
26 %description
27 musl libc is a new standard library to power a new generation of
28 Linux-based devices. It is lightweight, fast, simple, free, and
29 strives to be correct in the sense of standards-conformance and
30 safety.
31
32 musl is an alternative to glibc, uClibc, dietlibc, and klibc.
33
34 %description -l pl.UTF-8
35 musl libc to nowa biblioteka standardowa, przeznaczona do zasilania
36 urządzeń linuksowych nowej generacji. Jest lekka, szybka, prosta,
37 wolnodostępna i stara się być poprawna w sensie zgodności ze
38 standardami i bezpieczeństwa.
39
40 musl jest alternatywą dla bibliotek glibc, uClibc, dietlibc i klibc.
41
42 %package devel
43 Summary:        Development files for musl libc
44 Summary(pl.UTF-8):      Pliki programistyczne biblioteki musl libc
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Development files for musl libc.
50
51 %description devel -l pl.UTF-8
52 Pliki programistyczne biblioteki musl libc.
53
54 %prep
55 %setup -q
56
57 %build
58 %configure \
59         --syslibdir=/%{_lib}
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_sysconfdir}
68 echo '%{_libdir}' > $RPM_BUILD_ROOT%{_sysconfdir}/ld-musl-%{musl_arch}.path
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc COPYRIGHT INSTALL README WHATSNEW
76 %attr(755,root,root) /%{_lib}/ld-musl-%{musl_arch}.so.1
77 %dir %{_libdir}
78 %attr(755,root,root) %{_libdir}/libc.so
79 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld-musl-%{musl_arch}.path
80
81 %files devel
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/musl-gcc
84 %{_libdir}/libc.a
85 # empty stubs
86 %{_libdir}/libcrypt.a
87 %{_libdir}/libdl.a
88 %{_libdir}/libm.a
89 %{_libdir}/libpthread.a
90 %{_libdir}/libresolv.a
91 %{_libdir}/librt.a
92 %{_libdir}/libutil.a
93 %{_libdir}/libxnet.a
94 # crts
95 %{_libdir}/Scrt1.o
96 %{_libdir}/crt*.o
97 %{_libdir}/musl-gcc.specs
98 %{_includedir}
This page took 0.0634 seconds and 2 git commands to generate.