]> git.pld-linux.org Git - packages/musl.git/blob - musl.spec
- and one more upstream fix
[packages/musl.git] / musl.spec
1 Summary:        musl libc - new standard library to power a new generation of Linux-based devices
2 Summary(pl.UTF-8):      musl libc - nowa biblioteka standardowa dla urządzeń linuksowych nowej generacji
3 Name:           musl
4 Version:        1.1.10
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://www.musl-libc.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  fc30892ee582c91920505bbd0021049f
10 Patch0:         musl-locale.patch
11 URL:            http://www.musl-libc.org/
12 BuildRequires:  gcc >= 5:3.2
13 BuildRequires:  zlib-devel
14 Requires:       uname(release) >= 2.6.0
15 ExclusiveArch:  %{ix86} %{x8664} arm mips microblaze ppc
16 ExcludeArch:    i386
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _libdir         %{_prefix}/%{_lib}/musl
20 %define         _includedir     %{_prefix}/include/musl
21 %define         _fortify_cflags %{nil}
22 %define         _ssp_cflags     %{nil}
23
24 # i386, x86_64, arm, mips, microblaze, ppc
25 %define         musl_arch       %{_target_base_arch}
26
27 %description
28 musl libc is a new standard library to power a new generation of
29 Linux-based devices. It is lightweight, fast, simple, free, and
30 strives to be correct in the sense of standards-conformance and
31 safety.
32
33 musl is an alternative to glibc, uClibc, dietlibc, and klibc.
34
35 %description -l pl.UTF-8
36 musl libc to nowa biblioteka standardowa, przeznaczona do zasilania
37 urządzeń linuksowych nowej generacji. Jest lekka, szybka, prosta,
38 wolnodostępna i stara się być poprawna w sensie zgodności ze
39 standardami i bezpieczeństwa.
40
41 musl jest alternatywą dla bibliotek glibc, uClibc, dietlibc i klibc.
42
43 %package devel
44 Summary:        Development files for musl libc
45 Summary(pl.UTF-8):      Pliki programistyczne biblioteki musl libc
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Development files for musl libc.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne biblioteki musl libc.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %configure \
61         --syslibdir=/%{_lib}
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT%{_sysconfdir}
70 echo '%{_libdir}' > $RPM_BUILD_ROOT%{_sysconfdir}/ld-musl-%{musl_arch}.path
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc COPYRIGHT INSTALL README WHATSNEW
78 %attr(755,root,root) /%{_lib}/ld-musl-%{musl_arch}.so.1
79 %dir %{_libdir}
80 %attr(755,root,root) %{_libdir}/libc.so
81 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld-musl-%{musl_arch}.path
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/musl-gcc
86 %{_libdir}/libc.a
87 # empty stubs
88 %{_libdir}/libcrypt.a
89 %{_libdir}/libdl.a
90 %{_libdir}/libm.a
91 %{_libdir}/libpthread.a
92 %{_libdir}/libresolv.a
93 %{_libdir}/librt.a
94 %{_libdir}/libutil.a
95 %{_libdir}/libxnet.a
96 # crts
97 %{_libdir}/Scrt1.o
98 %{_libdir}/crt*.o
99 %{_libdir}/rcrt1.o
100 %{_libdir}/musl-gcc.specs
101 %{_includedir}
This page took 0.057167 seconds and 3 git commands to generate.