]> git.pld-linux.org Git - packages/muparser.git/blob - muparser.spec
- new URL, updated to 2.3.2
[packages/muparser.git] / muparser.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  openmp  # OpenMP support
5 #
6 Summary:        A fast math parser library
7 Summary(pl.UTF-8):      Biblioteka szybkiego analizatora matematycznego
8 Name:           muparser
9 Version:        2.3.2
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/beltoforion/muparser/releases
14 Source0:        https://github.com/beltoforion/muparser/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  cbc1b284e03abc7081b3c30997959893
16 URL:            https://github.com/beltoforion/muparser
17 BuildRequires:  cmake >= 3.1.0
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %{?with_openmp:BuildRequires:   libgomp-devel}
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  rpmbuild(macros) >= 1.752
22 BuildRequires:  sed >= 4.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Many applications require the parsing of mathematical expressions. The
27 main objective of this project is to provide a fast and easy way of
28 doing this. muParser is an extensible high performance math parser
29 library. It is based on transforming an expression into a bytecode and
30 precalculating constant parts of it.
31
32 %description -l pl.UTF-8
33 Wiele aplikacji wymaga analizowania wyrażeń matematycznych. Głównym
34 celem tego projektu jest zapewnienie szybkiego i wygodnego sposobu
35 wykonywania tego zadania. muParser to bardzo wydajna, rozszerzalna
36 biblioteka analizatora matematycznego. Opiera się na przekształcaniu
37 wyrażenia na bajtkod oraz wstępnym obliczaniu jego stałych części.
38
39 %package devel
40 Summary:        Development and doc files for muParser library
41 Summary(pl.UTF-8):      Pliki programistyczne i dokumentacja do biblioteki muParser
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libstdc++-devel
45
46 %description devel
47 Development and doc files for muParser library.
48
49 %description devel -l pl.UTF-8
50 Pliki programistyczne i dokumentacja do biblioteki muParser.
51
52 %package apidocs
53 Summary:        API documentation for muParser library
54 Summary(pl.UTF-8):      Dokumentacja API biblioteki muParser
55 Group:          Documentation
56 %{?noarchpackage}
57
58 %description apidocs
59 API documentation for muParser library.
60
61 %description apidocs -l pl.UTF-8
62 Dokumentacja API biblioteki muParser.
63
64 %prep
65 %setup -q
66
67 # html/misc/footer.html not present (even in git)
68 %{__sed} -i -e '/^HTML_FOOTER .*/s/.*/HTML_FOOTER = /' docs/Doxyfile
69
70 %build
71 install -d build
72 cd build
73 %cmake .. \
74         %{!?with_openmp:-DENABLE_OPENMP=OFF} \
75         -DENABLE_SAMPLES=OFF
76
77 %{__make}
78
79 %if %{with apidocs}
80 cd ../docs
81 doxygen
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc Changes.txt License.txt README.rst docs/muparser_doc.html
99 %attr(755,root,root) %{_libdir}/libmuparser.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libmuparser.so.2
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libmuparser.so
105 %{_includedir}/muParser*.h
106 %{_pkgconfigdir}/muparser.pc
107
108 %if %{with apidocs}
109 %files apidocs
110 %defattr(644,root,root,755)
111 %doc docs/html/*
112 %endif
This page took 0.091537 seconds and 3 git commands to generate.