]> git.pld-linux.org Git - packages/muffin.git/blob - muffin.spec
ec84a5837f81152710b29e0b68538149e22f7022
[packages/muffin.git] / muffin.spec
1 %define         _internal_version  392f000
2 Summary:        Window and compositing manager based on Clutter
3 Summary(pl.UTF-8):      Zarządca okien i składania oparty na bibliotece Clutter
4 Name:           muffin
5 Version:        1.1.1
6 Release:        3
7 License:        GPL v2+
8 Group:          X11/Applications
9 Source0:        https://github.com/linuxmint/muffin/tarball/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  e8b44ea43f041af680f94822d4a35032
11 URL:            https://github.com/linuxmint/muffin
12 BuildRequires:  GConf2-devel
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  cairo-devel >= 1.10.0
16 BuildRequires:  clutter-devel >= 1.9.10
17 BuildRequires:  cogl-devel >= 1.9.6
18 BuildRequires:  desktop-file-utils
19 BuildRequires:  glib2-devel >= 1:2.25.10
20 BuildRequires:  gettext-devel
21 BuildRequires:  gnome-common
22 BuildRequires:  gnome-doc-utils >= 0.8.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.5
24 BuildRequires:  gsettings-desktop-schemas-devel >= 3.3.0
25 BuildRequires:  gtk-doc
26 BuildRequires:  gtk+3-devel >= 3.3.7
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  libcanberra-gtk3-devel >= 0.26
29 BuildRequires:  pango-devel >= 1.2.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  python >= 1:2.5
32 BuildRequires:  startup-notification-devel >= 0.7
33 BuildRequires:  xorg-lib-libSM-devel
34 BuildRequires:  xorg-lib-libX11-devel
35 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.2
36 BuildRequires:  xorg-lib-libXcursor-devel
37 BuildRequires:  xorg-lib-libXdamage-devel
38 BuildRequires:  xorg-lib-libXext-devel
39 BuildRequires:  xorg-lib-libXfixes-devel
40 BuildRequires:  xorg-lib-libXinerama-devel
41 BuildRequires:  xorg-lib-libXrandr-devel
42 BuildRequires:  xorg-lib-libXrender-devel
43 Requires:       GConf2
44 Requires:       cairo >= 1.10.0
45 Requires:       clutter >= 1.9.10
46 Requires:       cogl >= 1.9.6
47 #Requires:      control-center-filesystem
48 Requires:       dbus-x11
49 Requires:       glib2 >= 1:2.25.10
50 Requires:       gtk+3 >= 3.3.7
51 Requires:       libcanberra-gtk3 >= 0.26
52 Requires:       pango >= 1.2.0
53 Requires:       startup-notification >= 0.7
54 Requires:       xorg-lib-libXcomposite >= 0.2
55 Requires:       zenity
56 Requires(post): /sbin/ldconfig
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Muffin is a window and compositing manager that displays and manages
61 your desktop via OpenGL. Muffin combines a sophisticated display
62 engine using the Clutter toolkit with solid window-management logic
63 inherited from the Metacity window manager.
64
65 While Muffin can be used stand-alone, it is primarily intended to be
66 used as the display core of a larger system such as Cinnamon. For this
67 reason, Muffin is very extensible via plugins, which are used both to
68 add fancy visual effects and to rework the window management behaviors
69 to meet the needs of the environment.
70
71 %description -l pl.UTF-8
72 Muffin to zarządca okien i składania, wyświetlający i zarządzający
73 pulpitem poprzez OpenGL. Muffin łączy przemyślany silnik wyświetlania
74 wykorzystujący toolkit Clutter z solidną logiką zarządcy okien
75 odziedziczoną z zarządcy okien Metacity.
76
77 Mimo że Muffin może być używany samodzielnie, jest pomyślany głównie
78 jako główny element większego systemu, takiego jak Cinnamon. Z tego
79 powodu Muffin może być znacząco rozszerzany poprzez wtyczki, które
80 mogą zarówno dodawać ładne efekty wizualne, jak i zmieniać zachowanie
81 zarządzania oknami, aby pasowały do potrzeb środowiska.
82
83 %package devel
84 Summary:        Development package for Muffin
85 Summary(pl.UTF-8):      Pakiet programistyczny dla Muffina
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       clutter-devel >= 1.9.10
89 Requires:       gsettings-desktop-schemas-devel >= 3.3.0
90 Requires:       gtk+3-devel >= 3.3.7
91 Requires:       xorg-lib-libX11-devel
92
93 %description devel
94 Header files for developing Muffin plugins. Also includes utilities
95 for testing Metacity/Muffin themes.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe do tworzenia wtyczek Muffina. Pakiet zawiera
99 dodatkowo narzędzia do testowania motywów Metacity/Muffina.
100
101 %prep
102 %setup -q -n linuxmint-%{name}-%{_internal_version}
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         ZENITY=/usr/bin/zenity \
112         --disable-silent-rules \
113         --disable-static \
114         --enable-compile-warnings=minimum
115
116 SHOULD_HAVE_DEFINED="HAVE_SM HAVE_XINERAMA HAVE_XFREE_XINERAMA HAVE_SHAPE HAVE_RANDR HAVE_STARTUP_NOTIFICATION"
117
118 for I in $SHOULD_HAVE_DEFINED; do
119         if ! grep -q "define $I" config.h; then
120                 echo "$I was not defined in config.h"
121                 grep "$I" config.h
122                 exit 1
123         else
124                 echo "$I was defined as it should have been"
125                 grep "$I" config.h
126         fi
127 done
128
129 %{__make} V=1
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 %{__make} install \
134         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # Remove libtool archives.
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
139
140 %find_lang %{name}
141
142 # Muffin contains a .desktop file so we just need to validate it
143 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %glib_compile_schemas
151
152 %postun
153 /sbin/ldconfig
154 %glib_compile_schemas
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %doc README AUTHORS NEWS HACKING doc/theme-format.txt
159 %attr(755,root,root) %{_bindir}/muffin
160 %attr(755,root,root) %{_bindir}/muffin-message
161 %{_mandir}/man1/muffin.1*
162 %{_mandir}/man1/muffin-message.1*
163 %{_desktopdir}/muffin.desktop
164 %dir %{_datadir}/muffin
165 %dir %{_datadir}/muffin/icons
166 %attr(755,root,root) %{_libdir}/libmuffin.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libmuffin.so.0
168 %{_libdir}/muffin/Meta-3.0.gir
169 %{_libdir}/muffin/Meta-3.0.typelib
170 %dir %{_libdir}/muffin
171 %dir %{_libdir}/muffin/plugins
172 %attr(755,root,root) %{_libdir}/muffin/plugins/default.so
173 %{_datadir}/GConf/gsettings/muffin-schemas.convert
174 %{_datadir}/glib-2.0/schemas/org.cinnamon.muffin.gschema.xml
175 %{_datadir}/gnome-control-center/keybindings/50-muffin-windows.xml
176
177 # XXX: nothing uses this?
178 %dir %{_datadir}/gnome/wm-properties
179 %{_datadir}/gnome/wm-properties/muffin-wm.desktop
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/muffin-theme-viewer
184 %attr(755,root,root) %{_bindir}/muffin-window-demo
185 %attr(755,root,root) %{_libdir}/libmuffin.so
186 %{_includedir}/muffin
187 %{_datadir}/muffin/icons/muffin-window-demo.png
188 %{_pkgconfigdir}/libmuffin.pc
189 %{_pkgconfigdir}/muffin-plugins.pc
190 %{_mandir}/man1/muffin-theme-viewer.1*
191 %{_mandir}/man1/muffin-window-demo.1*
This page took 0.063041 seconds and 2 git commands to generate.