]> git.pld-linux.org Git - packages/msitools.git/blob - msitools.spec
- new
[packages/msitools.git] / msitools.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  vala            # Vala API
5 #
6 Summary:        MSI manipulation library and tools
7 Summary(pl.UTF-8):      Biblioteka i narzędzia do obróbki plików MSI
8 Name:           msitools
9 Version:        0.91
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/msitools/0.91/%{name}-%{version}.tar.xz
14 # Source0-md5:  bec9d9d884213309605528846f7549af
15 Patch0:         %{name}-link.patch
16 URL:            https://live.gnome.org/msitools
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake
19 BuildRequires:  gcab-devel >= 0.1.10
20 BuildRequires:  gettext-devel >= 0.18
21 BuildRequires:  glib2-devel >= 1:2.23.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.4
23 BuildRequires:  intltool >= 0.35
24 BuildRequires:  libgsf-devel
25 BuildRequires:  libtool
26 BuildRequires:  libuuid-devel >= 1.41.3
27 BuildRequires:  libxml2-devel >= 1:2.7
28 BuildRequires:  tar >= 1:1.22
29 %{?with_vala:BuildRequires:     vala >= 2:0.16}
30 BuildRequires:  xz
31 Requires:       glib2 >= 1:2.23.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 msitools is a set of programs to inspect and build Windows Installer
36 (.MSI) files. It is based on libmsi, a portable library to read and
37 write .MSI files. libmsi in turn is a port of (and a subset of) Wine's
38 implementation of the Windows Installer.
39
40 %description -l pl.UTF-8
41 msitools to zbiór programów do badania i tworzenia plików Windows
42 Installera (.MSI). Jest oparty na libmsi - przenośnej bibliotece do
43 odczytu i zapisu plików .MSI. libmsi to z kolei port (podzbioru)
44 implementacji Windows Installera z WINE.
45
46 %package devel
47 Summary:        Header files for MSI library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MSI
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glib2-devel >= 1:2.23.0
52
53 %description devel
54 Header files for MSI library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki MSI.
58
59 %package static
60 Summary:        Static MSI library
61 Summary(pl.UTF-8):      Statyczna biblioteka MSI
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static MSI library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka MSI.
70
71 %package -n vala-libmsi
72 Summary:        Vala API for MSI library
73 Summary(pl.UTF-8):      API języka Vala do biblioteki MSI
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76 Requires:       vala >= 2:0.16
77
78 %description -n vala-libmsi
79 Vala API for MSI library.
80
81 %description -n vala-libmsi -l pl.UTF-8
82 API języka Vala do biblioteki MSI.
83
84 %package -n bash-completion-msitools
85 Summary:        Bash completion for MSI tools
86 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla narzędzi MSI
87 Group:          Applications/Shells
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       bash-completion >= 2.0
90
91 %description -n bash-completion-msitools
92 Bash completion for MSI tools (msiinfo and msibuild).
93
94 %description -n bash-completion-msitools -l pl.UTF-8
95 Bashowe dopełnianie poleceń dla narzędzi MSI (msiinfo oraz msibuild).
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --enable-fast-install \
109         --disable-silent-rules \
110         %{!?with_static_libs:--disable-static}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmsi.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS README TODO
128 %attr(755,root,root) %{_bindir}/msibuild
129 %attr(755,root,root) %{_bindir}/msiextract
130 %attr(755,root,root) %{_bindir}/msiinfo
131 %attr(755,root,root) %{_bindir}/wixl
132 %attr(755,root,root) %{_bindir}/wixl-heat
133 %attr(755,root,root) %{_libdir}/libmsi.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libmsi.so.0
135 %{_libdir}/girepository-1.0/Libmsi-1.0.typelib
136 %{_datadir}/wixl-%{version}
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libmsi.so
141 %{_includedir}/libmsi-1.0
142 %{_datadir}/gir-1.0/Libmsi-1.0.gir
143 %{_pkgconfigdir}/libmsi-1.0.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libmsi.a
149 %endif
150
151 %if %{with vala}
152 %files -n vala-libmsi
153 %defattr(644,root,root,755)
154 %{_datadir}/vala/vapi/libmsi-1.0.vapi
155 %endif
156
157 %files -n bash-completion-msitools
158 %defattr(644,root,root,755)
159 %{_datadir}/bash-completion/completions/msitools
This page took 0.055905 seconds and 3 git commands to generate.