]> git.pld-linux.org Git - packages/msgpack.git/blob - msgpack.spec
update BR
[packages/msgpack.git] / msgpack.spec
1 # TODO
2 # - should c and c++ have separate -devel packages?
3
4 # Conditional build:
5 %bcond_without  tests           # build without tests
6
7 Summary:        Binary-based efficient object serialization library
8 Name:           msgpack
9 Version:        1.4.1
10 Release:        1
11 License:        Boost
12 Group:          Libraries
13 Source0:        https://github.com/msgpack/msgpack-c/releases/download/cpp-%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  fde8da1388d4f8daf21faee5536a53cf
15 URL:            http://msgpack.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 %if %{with tests}
21 BuildRequires:  gtest-devel
22 BuildRequires:  zlib-devel
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 MessagePack is a binary-based efficient object serialization library.
28 It enables to exchange structured objects between many languages like
29 JSON. But unlike JSON, it is very fast and small.
30
31 %package devel
32 Summary:        Libraries and header files for %{name}
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Libraries and header files for %{name}
38
39 %prep
40 %setup -q
41
42 %build
43 %{__aclocal}
44 %{__libtoolize}
45 %{__autoconf}
46 %{__autoheader}
47 %{__automake} --force-missing
48 %configure \
49         --disable-static
50 %{__make}
51
52 %if %{with tests}
53 %{__make} check
54 %endif
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmsgpackc.la
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog NOTICE README README.md
72 %attr(755,root,root) %{_libdir}/libmsgpackc.so.*.*.*
73 %ghost %{_libdir}/libmsgpackc.so.2
74
75 %files devel
76 %defattr(644,root,root,755)
77 %{_includedir}/msgpack.h
78 %{_includedir}/msgpack.hpp
79 %{_includedir}/msgpack
80 %{_libdir}/libmsgpackc.so
81 %{_pkgconfigdir}/msgpack.pc
This page took 0.057376 seconds and 3 git commands to generate.