]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- build by default with -fvisibility=hidden (reduces number of symbols from
[packages/mplayer.git] / mplayer.spec
1 # Conditional build:
2 %bcond_with     directfb        # with DirectFB video output
3 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
4 %bcond_with     ggi             # with ggi video output
5 %bcond_with     nas             # with NAS audio output
6 %bcond_with     svga            # with svgalib video output
7 %bcond_without  osd             # with osd menu support
8 %bcond_without  altivec         # without altivec support
9 %bcond_without  x264            # without x264 support
10 %bcond_with     xmms            # with XMMS inputplugin support
11 %bcond_without  aalib           # without aalib video output
12 %bcond_without  jack            # without JACKD support
13 %bcond_without  alsa            # without ALSA audio output
14 %bcond_without  arts            # without arts audio output
15 %bcond_without  caca            # without libcaca video output
16 %bcond_without  cdparanoia      # without cdparanoia support
17 %bcond_without  dvdnav          # without dvdnav support
18 %bcond_without  enca            # disable using ENCA charset oracle library
19 %bcond_without  esd             # disable EsounD sound support
20 %bcond_without  faad            # disable FAAD2 (AAC) support
21 %bcond_without  gif             # disable GIF support
22 %bcond_without  gui             # without GTK+ GUI
23 %bcond_without  joystick        # disable joystick support
24 %bcond_without  libdts          # disable libdts support
25 %bcond_without  libdv           # disable libdv en/decoding support
26 %bcond_without  lirc            # without lirc support
27 %bcond_without  live            # without LIVE555 libraries
28 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
29 %bcond_without  mad             # without mad (audio MPEG) support
30 %bcond_without  pulseaudio      # without pulseaudio output
31 %bcond_without  quicktime       # without binary quicktime dll support
32 %bcond_without  real            # without Real* 8/9 codecs support
33 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
34                                 #  in compile time (advertised by mplayer authors as working faster); in this case
35                                 #  mplayer may not work on machine other then where it was compiled
36 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
37 %bcond_without  smb             # disable Samba (SMB) input support
38 %bcond_without  theora          # without theora support
39 %bcond_without  win32           # without win32 codecs support
40 %bcond_without  vdpau           # disable vdpau
41 %bcond_without  vidix           # disable vidix
42 %bcond_without  vorbis          # without Ogg-Vorbis audio support
43 %bcond_without  xvid            # disable XviD codec
44 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
45 %bcond_without  sdl             # disable SDL
46 %bcond_without  doc             # don't build docs (slow)
47 %bcond_with     shared          # experimental libmplayer.so support
48 %bcond_with     amr             # enable Adaptive Multi Rate (AMR) speech codec support
49 %bcond_without  gnomess         # disable controling gnome screensaver
50 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
51 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
52
53 %if %{with alsa}
54 %undefine       with_select
55 %endif
56
57 %ifnarch %{ix86}
58 %undefine       with_win32
59 %undefine       with_quicktime
60 %undefine       with_vidix
61 %endif
62
63 %ifnarch %{ix86} %{x8664} ppc ppc64
64 %undefine       with_runtime
65 %endif
66
67 %if %{_lib} == "lib64"
68 %define         _suf    64
69 %else
70 %define         _suf    32
71 %endif
72
73 %define         subver  rc4
74 %define         svnver  29930
75 %define         rel     0.4
76
77 Summary:        MPlayer - THE Movie Player for UN*X
78 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
79 Summary(es.UTF-8):      Otro reproductor de películas
80 Summary(ko.UTF-8):      리눅스용 미디어플레이어
81 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
82 Summary(pt_BR.UTF-8):   Reprodutor de filmes
83 Name:           mplayer
84 Version:        1.0
85 Release:        5.%{subver}_svn%{svnver}.%{rel}
86 # DO NOT increase epoch unless it's really neccessary!
87 # especially such changes like pre7->pre7try2, increase Release instead!
88 # PS: $ rpmvercmp pre7try2 pre7
89 # pre7try2 > pre7
90 Epoch:          3
91 License:        GPL
92 Group:          Applications/Multimedia
93 Source0:        mplayer-r%{svnver}.tar.xz
94 # Source0-md5:  b3261cc2e8cb2240131e58e0ce734f8a
95 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
96 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
97 Source5:        g%{name}.desktop
98 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
99 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
100 Source7:        %{name}.png
101 Source8:        %{name}.desktop
102 # http://www.on2.com/gpl/mplayer/
103 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
104 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
105
106 # build (configure / Makefile) related:
107 Patch10:        %{name}-ldflags.patch
108 Patch11:        %{name}-altivec.patch
109 Patch12:        %{name}-check-byteswap.patch
110 Patch13:        %{name}-visibility-hidden-fix.patch
111 Patch14:        %{name}-ffmpeg.patch
112 Patch15:        %{name}-shared_live.patch
113 Patch16:        %{name}-shared.patch
114
115 # codecs, outputs, demuxers:
116 Patch20:        %{name}-auto-expand.patch
117 Patch21:        %{name}-release_directfb.patch
118
119 # goodies:
120 Patch30:        %{name}-cp1250-fontdesc.patch
121 Patch31:        %{name}-fontconfig_sub.patch
122 Patch32:        %{name}-350.patch
123 # update
124 #Patch33:       %{name}-gnome-screensaver.patch
125
126 Patch100:       %{name}-on2flix.patch
127
128 URL:            http://www.mplayerhq.hu/
129 %{?with_directfb:BuildRequires: DirectFB-devel}
130 BuildRequires:  OpenAL-devel
131 BuildRequires:  OpenGL-devel
132 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
133 %{?with_aalib:BuildRequires:    aalib-devel}
134 %{?with_alsa:BuildRequires:     alsa-lib-devel}
135 %if %{with amr}
136 BuildRequires:  opencore-amr
137 %endif
138 %{?with_arts:BuildRequires:     artsc-devel}
139 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
140 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
141 %{?with_doc:BuildRequires:      docbook-style-xsl}
142 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
143 %{?with_dxr3:BuildRequires:     em8300-devel}
144 %{?with_enca:BuildRequires:     enca-devel}
145 %{?with_esd:BuildRequires:      esound-devel}
146 BuildRequires:  faac-devel
147 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
148 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
149 BuildRequires:  freetype-devel
150 BuildRequires:  fribidi-devel
151 %{?with_vidix:BuildRequires:    vidix-devel}
152 %ifarch ppc
153 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
154 %endif
155 %{?with_gif:BuildRequires:      giflib-devel}
156 %if %{with gui}
157 BuildRequires:  gtk+2-devel
158 %endif
159 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
160 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
161 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
162 BuildRequires:  lame-libs-devel
163 %{?with_caca:BuildRequires:     libcaca-devel}
164 %{?with_libdts:BuildRequires:   libdts-devel}
165 %{?with_libdv:BuildRequires:    libdv-devel}
166 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
167 %{?with_ggi:BuildRequires:      libggi-devel}
168 BuildRequires:  libjpeg-devel
169 %{?with_mad:BuildRequires:      libmad-devel}
170 BuildRequires:  libmpcdec-devel >= 1.2.1
171 BuildRequires:  libpng-devel
172 %{?with_smb:BuildRequires:      libsmbclient-devel}
173 %{?with_theora:BuildRequires:   libtheora-devel}
174 # tremor is used by default, internal as we don't have system one
175 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
176 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20081023_2245.1}
177 %{?with_vdpau:BuildRequires:    libvdpau-devel}
178 BuildRequires:  libxslt-progs
179 %{?with_lirc:BuildRequires:     lirc-devel}
180 %{?with_live:BuildRequires:     live-devel}
181 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
182 %{?with_nas:BuildRequires:      nas-devel}
183 BuildRequires:  ncurses-devel
184 BuildRequires:  pkgconfig
185 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
186 BuildRequires:  rpmbuild(macros) >= 1.527
187 BuildRequires:  speex-devel >= 1.1
188 %{?with_svga:BuildRequires:     svgalib-devel}
189 %{?with_xmms:BuildRequires:     xmms-libs}
190 BuildRequires:  xorg-lib-libX11-devel
191 BuildRequires:  xorg-lib-libXext-devel
192 BuildRequires:  xorg-lib-libXinerama-devel
193 BuildRequires:  xorg-lib-libXv-devel
194 BuildRequires:  xorg-lib-libXvMC-devel
195 BuildRequires:  xorg-lib-libXxf86dga-devel
196 BuildRequires:  xorg-lib-libXxf86vm-devel
197 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
198 BuildRequires:  zlib-devel
199 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
200 Requires:       OpenGL
201 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
202
203 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
204 %define         specflags_ia32  -fomit-frame-pointer
205 %if %{with altivec}
206 %define         specflags_ppc   -maltivec
207 %endif
208
209 %description
210 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
211 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
212 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
213 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
214 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
215 optionally with SHM extension, X11 using overlays with the Xvideo
216 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
217 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
218
219 If you want to use win32 codecs install w32codec package.
220
221 %description -l de.UTF-8
222 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
223 Kennzeichnend ist die herausragende Format- und
224 Plattform-Kompatibilität.
225
226 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
227 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
228 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
229 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
230 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
231 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
232 installierte Codecs nicht mit MPlayer kollidieren können.
233
234 %description -l es.UTF-8
235 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
236 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
237 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
238 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
239 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
240 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
241 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
242 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
243 v1.1.7 etc.
244
245 Si quiere usar codecs Win32, instale el paquete w32codec.
246
247 %description -l ko.UTF-8
248 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
249 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
250 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
251 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
252 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
253 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
254 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
255 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
256 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
257
258 %description -l pl.UTF-8
259 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
260 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
261 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
262 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
263 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
264 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
265 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
266
267 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
268
269 %description -l pt_BR.UTF-8
270 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
271 áudio. Diferentes mecanismos de reprodução podem também ser
272 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
273
274 %package -n gmplayer
275 Summary:        MPlayer with GTK+ GUI interface
276 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
277 Group:          X11/Applications/Multimedia
278 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
279 Requires:       %{name}-skin
280
281 %description -n gmplayer
282 MPlayer with GUI GTK+ interface.
283
284 %description -n gmplayer -l pl.UTF-8
285 MPlayer z graficznym interfejsem GTK+.
286
287 %package common
288 Summary:        Configuration files and documentation for MPlayer
289 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
290 Group:          Applications/Multimedia
291 Obsoletes:      mplayer-vidix
292
293 %description common
294 Configuration files, man page and HTML documentation for MPlayer.
295
296 %description common -l pl.UTF-8
297 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
298
299 %package -n mencoder
300 Summary:        MEncoder - a movie encoder for Linux
301 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
302 Group:          Applications/Multimedia
303 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
304
305 %description -n mencoder
306 MEncoder is a movie encoder for Linux and is a part of the MPlayer
307 package.
308
309 %description -n mencoder -l pl.UTF-8
310 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
311
312 %prep
313 %setup -q -n mplayer-r%{svnver} -a3 -a6 -a9
314 cp -f etc/codecs.conf etc/codecs.win32.conf
315
316 # build (configure / Makefile) related:
317 %patch10 -p1
318 %patch11 -p1
319 %patch12 -p1
320 %patch13 -p1
321 %{?with_system_ffmpeg:%patch14 -p1}
322 %{?with_live:%patch15 -p1}
323 %{?with_shared:%patch16 -p1}
324
325 # codecs, outputs, demuxers:
326 %patch20 -p1
327 %patch21 -p1
328
329 # goodies:
330 %patch30 -p0
331 %patch31 -p0
332 %patch32 -p1
333 #%{with_gnomess:%patch18 -p1}
334
335 # on2flix
336 mv mencoder-on2flixenglinux{-*-*-*,}
337 #%%patch100 -p1
338 #cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
339 #for a in mencoder-on2flixenglinux/patch/*.diff; do
340 #       patch -p0 < $a
341 #done
342
343 # sparky: works again ?
344 # recent dvdnav-config doesn't support --minilibs.
345 #sed -i 's:--minilibs:--libs:g' configure
346
347 # Set version
348 %if "x%{svnver}" != "x%{nil}"
349         echo "SVN-r%{svnver}" > VERSION
350 %endif
351
352 cat etc/example.conf > etc/mplayer.conf
353
354 %if %{with system_ffmpeg}
355 # using external ffmpeg, but mplayer adds these to includepath
356 rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
357 %endif
358
359 # hot fixes
360 sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
361
362 %build
363 CFLAGS="%{rpmcflags} -fvisibility=hidden %{?with_shared:-fvisibility=default -fPIC}"
364 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
365 %{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
366
367
368 build() {
369 set -x
370
371         ./configure \
372         %{?debug:--enable-debug=3} \
373         --prefix=%{_prefix} \
374         --confdir=%{_sysconfdir}/mplayer \
375         --cc="%{__cc}" \
376         --extra-cflags="$CFLAGS" \
377         --real-ldflags="%{rpmldflags}" \
378         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
379 %if %{with system_ffmpeg}
380         --disable-libavutil_a \
381         --disable-libavcodec_a \
382         --disable-libavformat_a \
383         --disable-libpostproc_a \
384         --enable-libavutil_so \
385         --enable-libavcodec_so \
386         --enable-libavformat_so \
387         --enable-libpostproc_so \
388 %endif
389 %ifnarch %{ix86} %{x8664}
390         --disable-mmx \
391         --disable-mmxext \
392         --disable-3dnow \
393         --disable-3dnowext \
394         --disable-sse \
395         --disable-sse2 \
396         --disable-fastmemcpy \
397 %endif
398         %{__disable ssse3} \
399 %ifarch ppc
400         %{__disable altivec} \
401 %endif
402         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
403         %{__enable_disable directfb} \
404         %{__disable dxr3} \
405         %{__disable ggi} \
406         %{__disable live} \
407         %{__disable lzo liblzo} \
408         %{__disable nas} \
409         %{__disable svga} \
410         %{__disable aalib aa} \
411         %{__disable jack} \
412         %{__enable_disable alsa} \
413         %{__disable arts} \
414         %{__disable caca} \
415         %{__disable cdparanoia} \
416         %{__disable enca} \
417         %{__disable esd} \
418         --disable-faad-internal \
419         %{__disable faad} \
420         %{__disable gif} \
421         %{__enable joystick} \
422         %{__disable libdv} \
423         %{__disable libdts libdca} \
424         %{__enable_disable lirc} \
425         %{__disable mad} \
426         %{__disable pulseaudio pulse} \
427         %{__disable quicktime qtx} \
428         %{__disable real} \
429         %{__enable_disable runtime runtime-cpudetection} \
430         %{__disable select} \
431         %{__disable smb} \
432         %{__disable win32 win32dll} \
433         %{__disable vorbis libvorbis} \
434         %{__enable osd menu} \
435         %{__disable theora} \
436         %{__disable x264} \
437         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
438         %{__disable xvid} \
439         %{__disable vidix} \
440         %{__disable vdpau} \
441         %{__disable mencoder} \
442         --enable-dga1 \
443         --enable-dga2 \
444         %{__enable_disable dvdnav} \
445         --enable-fbdev \
446         --enable-gl \
447         --enable-mga \
448         --enable-radio \
449         --enable-radio-capture \
450         %{__enable_disable sdl} \
451         --enable-tdfxfb \
452         --enable-vm \
453         --enable-x11 \
454         --enable-xmga \
455         --enable-xv \
456         --enable-xvmc \
457         --with-xvmclib=XvMCW \
458         --enable-dynamic-plugins \
459         --enable-largefiles \
460         --language=all \
461         --codecsdir=%{_libdir}/codecs \
462         "$@"
463
464         %{__make}
465 }
466
467 %if %{with gui}
468 # build GUI version
469 build --enable-gui --disable-mencoder
470 mv -f mplayer gmplayer
471 %{__make} distclean
472 %endif
473
474 # now build regular version
475 build --disable-gui
476
477 %if %{with doc}
478 %{__make} -j1 -C DOCS/xml
479 %endif
480
481 %install
482 rm -rf $RPM_BUILD_ROOT
483 install -d \
484         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
485         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
486         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
487         $RPM_BUILD_ROOT%{_desktopdir}
488
489 # default config files
490 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
491
492 # executables
493 %if %{with mencoder}
494 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
495 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
496 %endif
497 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
498 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
499 %if %{with gui}
500 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
501 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
502 %endif
503
504 %if %{with shared}
505 install -d $RPM_BUILD_ROOT%{_libdir}
506 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
507 %endif
508
509 # fonts
510 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
511 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
512
513 %if %{with gui}
514 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
515 %endif
516 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
517 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
518 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
519
520 # man pages
521 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
522 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
523 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
524 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
525 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
526 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
527 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
528 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
529 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
530 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %post -n gmplayer
536 umask 022
537 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
538
539 %postun -n gmplayer
540 umask 022
541 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
542
543 %files
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/mplayer*
546
547 %if %{with gui}
548 %files -n gmplayer
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/gmplayer*
551 %{_desktopdir}/gmplayer.desktop
552 %endif
553
554 %if %{with mencoder}
555 %files -n mencoder
556 %defattr(644,root,root,755)
557 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
558 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
559 %doc DOCS/tech/colorspaces.txt
560 %attr(755,root,root) %{_bindir}/mencoder*
561 %endif
562
563 %files common
564 %defattr(644,root,root,755)
565 %doc DOCS/tech
566 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
567 %if %{with win32}
568 %doc etc/codecs.win32.conf
569 %endif
570 %if %{with doc}
571 # HTML and XML-generated docs
572 %doc DOCS/HTML/en
573 %lang(cs) %doc DOCS/HTML/cs
574 %lang(de) %doc DOCS/HTML/de
575 %lang(es) %doc DOCS/HTML/es
576 %lang(fr) %doc DOCS/HTML/fr
577 %lang(hu) %doc DOCS/HTML/hu
578 %lang(pl) %doc DOCS/HTML/pl
579 %lang(ru) %doc DOCS/HTML/ru
580 #%lang(zh_CN) %doc DOCS/zh
581 %endif
582 %doc AUTHORS README
583
584 %dir %{_sysconfdir}/%{name}
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
586 %{_mandir}/man1/*
587 %lang(cs) %{_mandir}/cs/man1/*
588 %lang(de) %{_mandir}/de/man1/*
589 %lang(es) %{_mandir}/es/man1/*
590 %lang(fr) %{_mandir}/fr/man1/*
591 %lang(hu) %{_mandir}/hu/man1/*
592 %lang(it) %{_mandir}/it/man1/*
593 %lang(pl) %{_mandir}/pl/man1/*
594 #%lang(sv) %{_mandir}/sv/man1/*
595 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
596 %{_desktopdir}/mplayer.desktop
597 %{_pixmapsdir}/mplayer.png
598 %dir %{_datadir}/%{name}
599 %{_datadir}/%{name}/font*
600 %dir %{_datadir}/%{name}/skins
601 %ghost %{_datadir}/%{name}/skins/default
This page took 0.604744 seconds and 4 git commands to generate.