]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- added the release-directfb.patch
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_without  osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dvdnav          # without dvdnav support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio      # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
59 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
60
61 %ifnarch %{ix86}
62 %undefine       with_win32
63 %undefine       with_quicktime
64 %undefine       with_vidix
65 %endif
66
67 %ifnarch %{ix86} %{x8664} ppc ppc64
68 %undefine       with_runtime
69 %endif
70
71 %if %{_lib} == "lib64"
72 %define         _suf    64
73 %else
74 %define         _suf    32
75 %endif
76
77 %define         subver  rc2
78 %define         svnver  27725
79 %define         rel     17
80
81 Summary:        MPlayer - THE Movie Player for UN*X
82 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
83 Summary(es.UTF-8):      Otro reproductor de películas
84 Summary(ko.UTF-8):      리눅스용 미디어플레이어
85 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
86 Summary(pt_BR.UTF-8):   Reprodutor de filmes
87 Name:           mplayer
88 Version:        1.0
89 Release:        5.%{subver}_svn%{svnver}.%{rel}
90 # DO NOT increase epoch unless it's really neccessary!
91 # especially such changes like pre7->pre7try2, increase Release instead!
92 # PS: $ rpmvercmp pre7try2 pre7
93 # pre7try2 > pre7
94 Epoch:          3
95 License:        GPL
96 Group:          Applications/Multimedia
97 Source0:        http://distfiles.gentoo.org/distfiles/mplayer-%{version}_%{subver}_p%{svnver}.tar.bz2
98 # Source0-md5:  d89e86d9183d1a52a7a754d9a3c74724
99 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
100 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
101 Source5:        g%{name}.desktop
102 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
103 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
104 Source7:        %{name}.png
105 Source8:        %{name}.desktop
106 # http://www.on2.com/gpl/mplayer/
107 Source9:        http://support.on2.com/gpl/mplayer/2008-11-25-mencoder-on2flixenglinux.tar.bz2
108 # Source9-md5:  7dd9c22d9d7207c0b42fa530b4f3fc5d
109 Patch1:         %{name}-cp1250-fontdesc.patch
110 #Patch2:                %{name}-codec.patch
111 #Patch3:                %{name}-home_etc.patch
112 Patch4:         %{name}-350.patch
113 Patch5:         %{name}-configure.patch
114 # outdated via ffmpeg?
115 Patch6:         %{name}-system-amr.patch
116 Patch8:         %{name}-altivec.patch
117 #Patch10:       %{name}-pcmsplit.patch
118 #Patch13:       %{name}-mythtv.patch
119 Patch14:        %{name}-shared.patch
120 #http://www.openchrome.org/snapshots/mplayer/
121 #Patch15:       %{name}-xvmc.patch
122 Patch17:        %{name}-auto-expand.patch
123 # update
124 #Patch18:       %{name}-gnome-screensaver.patch
125 Patch19:        %{name}-on2flix.patch
126 Patch22:        %{name}-ffmpeg.patch
127 Patch24:        %{name}-fontconfig_sub.patch
128 Patch26:        %{name}-check-byteswap.patch
129 Patch27:        %{name}-release_directfb.patch
130 URL:            http://www.mplayerhq.hu/
131 %{?with_directfb:BuildRequires: DirectFB-devel}
132 BuildRequires:  OpenAL-devel
133 BuildRequires:  OpenGL-devel
134 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
135 %{?with_aalib:BuildRequires:    aalib-devel}
136 %{?with_alsa:BuildRequires:     alsa-lib-devel}
137 %if %{with amr}
138 BuildRequires:  amrnb-devel
139 BuildRequires:  amrwb-devel >= 5.3.0
140 %endif
141 %{?with_arts:BuildRequires:     artsc-devel}
142 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
143 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
144 %{?with_doc:BuildRequires:      docbook-style-xsl}
145 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
146 %{?with_dxr3:BuildRequires:     em8300-devel}
147 %{?with_enca:BuildRequires:     enca-devel}
148 %{?with_esd:BuildRequires:      esound-devel}
149 BuildRequires:  faac-devel
150 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
151 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
152 BuildRequires:  freetype-devel
153 BuildRequires:  fribidi-devel
154 %{?with_vidix:BuildRequires:    vidix-devel}
155 %ifarch ppc
156 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
157 %endif
158 %{?with_gif:BuildRequires:      giflib-devel}
159 %if %{with gui}
160 BuildRequires:  gtk+2-devel
161 %endif
162 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
163 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
164 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
165 BuildRequires:  lame-libs-devel
166 %{?with_caca:BuildRequires:     libcaca-devel}
167 %{?with_libdts:BuildRequires:   libdts-devel}
168 %{?with_libdv:BuildRequires:    libdv-devel}
169 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
170 %{?with_ggi:BuildRequires:      libggi-devel}
171 BuildRequires:  libjpeg-devel
172 %{?with_mad:BuildRequires:      libmad-devel}
173 BuildRequires:  libmpcdec-devel >= 1.2.1
174 BuildRequires:  libpng-devel
175 %{?with_smb:BuildRequires:      libsmbclient-devel}
176 %{?with_theora:BuildRequires:   libtheora-devel}
177 # tremor is used by default, internal as we don't have system one
178 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
179 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20081023_2245.1}
180 BuildRequires:  libxslt-progs
181 %{?with_lirc:BuildRequires:     lirc-devel}
182 %{?with_live:BuildRequires:     live}
183 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
184 %{?with_nas:BuildRequires:      nas-devel}
185 BuildRequires:  ncurses-devel
186 BuildRequires:  pkgconfig
187 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
188 BuildRequires:  speex-devel >= 1.1
189 %{?with_svga:BuildRequires:     svgalib-devel}
190 %{?with_xmms:BuildRequires:     xmms-libs}
191 BuildRequires:  xorg-lib-libX11-devel
192 BuildRequires:  xorg-lib-libXext-devel
193 BuildRequires:  xorg-lib-libXinerama-devel
194 BuildRequires:  xorg-lib-libXv-devel
195 BuildRequires:  xorg-lib-libXvMC-devel
196 BuildRequires:  xorg-lib-libXxf86dga-devel
197 BuildRequires:  xorg-lib-libXxf86vm-devel
198 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
199 BuildRequires:  zlib-devel
200 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
201 Requires:       OpenGL
202 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
203
204 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
205 %define         specflags_ia32  -fomit-frame-pointer
206 %if %{with altivec}
207 %define         specflags_ppc   -maltivec
208 %endif
209
210 %description
211 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
212 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
213 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
214 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
215 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
216 optionally with SHM extension, X11 using overlays with the Xvideo
217 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
218 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
219
220 If you want to use win32 codecs install w32codec package.
221
222 %description -l de.UTF-8
223 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
224 Kennzeichnend ist die herausragende Format- und
225 Plattform-Kompatibilität.
226
227 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
228 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
229 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
230 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
231 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
232 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
233 installierte Codecs nicht mit MPlayer kollidieren können.
234
235 %description -l es.UTF-8
236 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
237 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
238 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
239 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
240 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
241 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
242 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
243 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
244 v1.1.7 etc.
245
246 Si quiere usar codecs Win32, instale el paquete w32codec.
247
248 %description -l ko.UTF-8
249 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
250 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
251 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
252 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
253 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
254 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
255 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
256 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
257 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
258
259 %description -l pl.UTF-8
260 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
261 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
262 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
263 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
264 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
265 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
266 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
267
268 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
269
270 %description -l pt_BR.UTF-8
271 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
272 áudio. Diferentes mecanismos de reprodução podem também ser
273 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
274
275 %package -n gmplayer
276 Summary:        MPlayer with GTK+ GUI interface
277 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
278 Group:          X11/Applications/Multimedia
279 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
280 Requires:       %{name}-skin
281
282 %description -n gmplayer
283 MPlayer with GUI GTK+ interface.
284
285 %description -n gmplayer -l pl.UTF-8
286 MPlayer z graficznym interfejsem GTK+.
287
288 %package common
289 Summary:        Configuration files and documentation for MPlayer
290 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
291 Group:          Applications/Multimedia
292 Obsoletes:      mplayer-vidix
293
294 %description common
295 Configuration files, man page and HTML documentation for MPlayer.
296
297 %description common -l pl.UTF-8
298 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
299
300 %package -n mencoder
301 Summary:        MEncoder - a movie encoder for Linux
302 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
303 Group:          Applications/Multimedia
304 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
305
306 %description -n mencoder
307 MEncoder is a movie encoder for Linux and is a part of the MPlayer
308 package.
309
310 %description -n mencoder -l pl.UTF-8
311 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
312
313 %prep
314 %setup -q -n mplayer-%{version}_%{subver}_p%{svnver} -a3 -a6 -a9
315 cp -f etc/codecs.conf etc/codecs.win32.conf
316 %patch1 -p0
317 #%%patch2 -p1 -- still needed?
318 ##%%patch3 -p1  -- old home_etc behavior
319 %patch4 -p1
320 %patch5 -p1
321 #%%patch6 -p1 # - try ffmpeg
322 %patch8 -p1
323 #%%patch10 -p1
324 #%%patch13 -p1  # TODO
325 %if %{with shared}
326 %patch14 -p1
327 %endif
328 #%%patch15 -p0  # TODO
329 %patch17 -p1
330 %if %{with gnomess}
331 #%%patch18 -p1
332 %endif
333
334 # on2flix
335 mv mencoder-on2flixenglinux{-*-*-*,}
336 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
337 #rm -f mencoder-on2flixenglinux/patch/version.diff
338 %patch19 -p1
339 for a in mencoder-on2flixenglinux/patch/*.diff; do
340         patch -p0 < $a
341 done
342
343 %{?with_system_ffmpeg:%patch22 -p1}
344 %patch24 -p0
345 %patch26 -p1
346 %patch27 -p1
347
348 # recent dvdnav-config doesn't support --minilibs.
349 sed -i 's:--minilibs:--libs:g' configure
350
351 # Set version #
352 echo %{svnver} > svn_snapshot_id
353
354 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
355 rm -f font-*/runme
356
357 %if %{with system_ffmpeg}
358 # using external ffmpeg, but mplayer adds these to includepath
359 rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
360 %endif
361
362 %build
363 %if %{with shared}
364 CFLAGS="%{rpmcflags} -fPIC"
365 %else
366 CFLAGS="%{rpmcflags}"
367 %endif
368 CC="%{__cc}"
369 LDFLAGS="%{rpmldflags}"
370 export CC CFLAGS LDFLAGS
371
372 build() {
373 set -x
374         ./configure \
375         %{?debug:--enable-debug=3} \
376         --prefix=%{_prefix} \
377         --confdir=%{_sysconfdir}/mplayer \
378         --with-extraincdir=%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} \
379         --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
380 %if %{with system_ffmpeg}
381         --disable-libavutil_a \
382         --disable-libavcodec_a \
383         --disable-libavformat_a \
384         --disable-libpostproc_a \
385         --enable-libavutil_so \
386         --enable-libavcodec_so \
387         --enable-libavformat_so \
388         --enable-libpostproc_so \
389 %endif
390 %ifnarch %{ix86} %{x8664}
391         --disable-mmx \
392         --disable-mmxext \
393         --disable-3dnow \
394         --disable-3dnowext \
395         --disable-sse \
396         --disable-sse2 \
397         --disable-fastmemcpy \
398 %endif
399         %{!?with_ssse3:--disable-ssse3} \
400 %ifarch ppc
401         %{!?with_altivec:--disable-altivec} \
402 %endif
403         %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
404         %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
405         %{?with_directfb:--enable-directfb} \
406         %{!?with_directfb:--disable-directfb} \
407         %{!?with_dxr3:--disable-dxr3} \
408         %{!?with_ggi:--disable-ggi} \
409         %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
410         %{!?with_live:--disable-live} \
411         %{!?with_lzo:--disable-liblzo} \
412         %{!?with_nas:--disable-nas} \
413         %{!?with_svga:--disable-svga} \
414         %{!?with_aalib:--disable-aa} \
415         %{!?with_jack:--disable-jack} \
416         %{!?with_alsa:--disable-alsa} \
417         %{?with_alsa:--enable-alsa --disable-select} \
418         %{!?with_arts:--disable-arts} \
419         %{!?with_caca:--disable-caca} \
420         %{!?with_cdparanoia:--disable-cdparanoia} \
421         %{!?with_enca:--disable-enca} \
422         %{!?with_esd:--disable-esd} \
423         %{!?with_faad:--disable-faad-external --disable-faad-internal} \
424         %{?with_faad:--disable-faad-internal} \
425         %{!?with_gif:--disable-gif} \
426         %{?with_joystick:--enable-joystick} \
427         %{!?with_libdv:--disable-libdv} \
428         %{!?with_libdts:--disable-libdts} \
429         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
430         %{!?with_mad:--disable-mad} \
431         %{!?with_pulseaudio:--disable-polyp} \
432         %{!?with_quicktime:--disable-qtx} \
433         %{!?with_real:--disable-real} \
434         --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
435         %{!?with_select:--disable-select} \
436         %{!?with_smb:--disable-smb} \
437         %{!?with_win32:--disable-win32dll} \
438         %{!?with_vorbis:--disable-vorbis} \
439         %{?with_osd:--enable-menu} \
440         %{!?with_theora:--disable-theora} \
441         %{!?with_x264:--disable-x264} \
442         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
443         %{!?with_xvid:--disable-xvid} \
444         %{!?with_vidix:--disable-vidix} \
445         %{!?with_mencoder:--disable-mencoder} \
446         --enable-dga1 \
447         --enable-dga2 \
448         --%{!?with_dvdnav:dis}%{?with_dvdnav:en}able-dvdnav \
449         --enable-fbdev \
450         --enable-gl \
451         --enable-mga \
452         --enable-radio \
453         --enable-radio-capture \
454         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
455         --enable-tdfxfb \
456         --enable-vm \
457         --enable-x11 \
458         --enable-xmga \
459         --enable-xv \
460         --enable-xvmc \
461         --enable-dynamic-plugins \
462         --enable-largefiles \
463         --language=all \
464         --codecsdir=%{_libdir}/codecs \
465         --with-xvmclib=XvMCW \
466         "$@"
467
468         %{__make}
469 }
470
471 %if %{with gui}
472 # build GUI version
473 build --enable-gui --disable-mencoder
474 mv -f mplayer gmplayer
475 %{__make} distclean
476 %endif
477
478 # now build regular version
479 build --disable-gui
480
481 %if %{with doc}
482 %{__make} -j1 -C DOCS/xml
483 %endif
484
485 %install
486 rm -rf $RPM_BUILD_ROOT
487 install -d \
488         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
489         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
490         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
491         $RPM_BUILD_ROOT%{_desktopdir}
492
493 # default config files
494 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
495
496 # executables
497 %if %{with mencoder}
498 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
499 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
500 %endif
501 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
502 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
503 %if %{with gui}
504 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
505 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
506 %endif
507
508 # fonts
509 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
510 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
511
512 %if %{with gui}
513 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
514 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
515 %endif
516 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
517 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
518
519 # man pages
520 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
521 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
522 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
523 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
524 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
525 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
526 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
527 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
528 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
529 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
530
531 %clean
532 rm -rf $RPM_BUILD_ROOT
533
534 %post -n gmplayer
535 umask 022
536 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
537
538 %postun -n gmplayer
539 umask 022
540 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
541
542 %files
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/mplayer*
545
546 %if %{with gui}
547 %files -n gmplayer
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/gmplayer*
550 %{_desktopdir}/gmplayer.desktop
551 %dir %{_datadir}/%{name}/skins
552 %ghost %{_datadir}/%{name}/skins/default
553 %endif
554
555 %if %{with mencoder}
556 %files -n mencoder
557 %defattr(644,root,root,755)
558 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
559 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
560 %doc DOCS/tech/colorspaces.txt
561 %attr(755,root,root) %{_bindir}/mencoder*
562 %endif
563
564 %files common
565 %defattr(644,root,root,755)
566 %doc DOCS/tech
567 %if %{with win32}
568 %doc etc/codecs.win32.conf
569 %endif
570 %if %{with doc}
571 # HTML and XML-generated docs
572 %doc DOCS/HTML/en
573 %lang(cs) %doc DOCS/HTML/cs
574 %lang(de) %doc DOCS/HTML/de
575 %lang(es) %doc DOCS/HTML/es
576 %lang(fr) %doc DOCS/HTML/fr
577 %lang(hu) %doc DOCS/HTML/hu
578 %lang(pl) %doc DOCS/HTML/pl
579 %lang(ru) %doc DOCS/HTML/ru
580 #%lang(zh_CN) %doc DOCS/zh
581 %endif
582 %doc AUTHORS README
583
584 %dir %{_sysconfdir}/%{name}
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
586 %{_mandir}/man1/*
587 %lang(cs) %{_mandir}/cs/man1/*
588 %lang(de) %{_mandir}/de/man1/*
589 %lang(es) %{_mandir}/es/man1/*
590 %lang(fr) %{_mandir}/fr/man1/*
591 %lang(hu) %{_mandir}/hu/man1/*
592 %lang(it) %{_mandir}/it/man1/*
593 %lang(pl) %{_mandir}/pl/man1/*
594 #%lang(sv) %{_mandir}/sv/man1/*
595 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
596 %{_desktopdir}/mplayer.desktop
597 %{_pixmapsdir}/mplayer.png
598 %dir %{_datadir}/%{name}
599 %{_datadir}/%{name}/font*
This page took 0.607895 seconds and 4 git commands to generate.