]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- rel 3; fix build
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # with DirectFB video output
4 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
5 %bcond_with     ggi             # with ggi video output
6 %bcond_with     nas             # with NAS audio output
7 %bcond_with     svga            # with svgalib video output
8 %bcond_without  osd             # with osd menu support
9 %bcond_without  altivec         # without altivec support
10 %bcond_without  x264            # without x264 support
11 %bcond_with     xmms            # with XMMS inputplugin support
12 %bcond_without  aalib           # without aalib video output
13 %bcond_without  jack            # without JACKD support
14 %bcond_without  alsa            # without ALSA audio output
15 %bcond_with     arts            # with arts audio output
16 %bcond_without  blueray         # disable Blue-ray support
17 %bcond_without  caca            # without libcaca video output
18 %bcond_without  cdparanoia      # without cdparanoia support
19 %bcond_without  dvdnav          # without dvdnav support
20 %bcond_without  enca            # disable using ENCA charset oracle library
21 %bcond_with     esd             # enable EsounD sound support
22 %bcond_without  faad            # disable FAAD2 (AAC) support
23 %bcond_without  gif             # disable GIF support
24 %bcond_without  gui             # without GTK+ GUI
25 %bcond_without  joystick        # disable joystick support
26 %bcond_without  libdts          # disable libdts support
27 %bcond_without  libdv           # disable libdv en/decoding support
28 %bcond_without  lirc            # without lirc support
29 %bcond_without  live            # without LIVE555 libraries
30 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
31 %bcond_without  mad             # without mad (audio MPEG) support
32 %bcond_without  pulseaudio      # without pulseaudio output
33 %bcond_without  quicktime       # without binary quicktime dll support
34 %bcond_without  real            # without Real* 8/9 codecs support
35 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
36                                 #  in compile time (advertised by mplayer authors as working faster); in this case
37                                 #  mplayer may not work on machine other then where it was compiled
38 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
39 %bcond_without  smb             # disable Samba (SMB) input support
40 %bcond_without  theora          # without theora support
41 %bcond_without  win32           # without win32 codecs support
42 %bcond_without  vdpau           # disable vdpau
43 %bcond_without  vidix           # disable vidix
44 %bcond_without  vorbis          # without Ogg-Vorbis audio support
45 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
46 %bcond_without  xvid            # disable XviD codec
47 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
48 %bcond_without  sdl             # disable SDL
49 %bcond_without  doc             # don't build docs (slow)
50 %bcond_with     shared          # experimental libmplayer.so support
51 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
52 %bcond_without  gnomess         # disable controling gnome screensaver
53 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
54 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
55 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
56 %bcond_with     zr              # enable ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
57 %if "%{pld_release}" == "ac"
58 %bcond_with             hidden_visibility       # no gcc hidden visibility
59 %else
60 %bcond_without  hidden_visibility       # no gcc hidden visibility
61 %endif
62
63 %if %{with alsa}
64 %undefine       with_select
65 %endif
66
67 %if %{without vorbis}
68 %undefine       with_system_vorbis
69 %endif
70
71 %ifnarch %{ix86}
72 %undefine       with_win32
73 %undefine       with_quicktime
74 %undefine       with_vidix
75 %endif
76
77 %ifnarch %{ix86} %{x8664} ppc ppc64
78 %undefine       with_runtime
79 %endif
80
81 %ifnarch %{ix86} %{x8664}
82 %undefine       with_vdpau
83 %endif
84
85 %ifnarch ppc
86 %undefine       with_altivec
87 %endif
88
89 %if %{_lib} == "lib64"
90 %define         _suf    64
91 %else
92 %define         _suf    32
93 %endif
94
95 Summary:        MPlayer - THE Movie Player for UN*X
96 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
97 Summary(es.UTF-8):      Otro reproductor de películas
98 Summary(ko.UTF-8):      리눅스용 미디어플레이어
99 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
100 Summary(pt_BR.UTF-8):   Reprodutor de filmes
101 Name:           mplayer
102 Version:        1.1
103 Release:        3
104 # DO NOT increase epoch unless it's really neccessary!
105 # especially such changes like pre7->pre7try2, increase Release instead!
106 # PS: $ rpmvercmp pre7try2 pre7
107 # pre7try2 > pre7
108 Epoch:          3
109 License:        GPL
110 Group:          Applications/Multimedia
111 # svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
112 # cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
113 # tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
114 Source0:        ftp://ftp.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
115 # Source0-md5:  ac7bf1cfedc1c5c24bfc83107eefb1d9
116 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
117 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
118 Source5:        g%{name}.desktop
119 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
120 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
121 Source7:        %{name}.png
122 Source8:        %{name}.desktop
123 # http://www.on2.com/gpl/mplayer/
124 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
125 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
126
127 # build (configure / Makefile) related:
128 Patch10:        %{name}-ldflags.patch
129 Patch11:        %{name}-altivec.patch
130 Patch12:        %{name}-check-byteswap.patch
131 Patch13:        %{name}-visibility-hidden-fix.patch
132 Patch14:        %{name}-ffmpeg.patch
133 Patch15:        %{name}-shared_live.patch
134 Patch16:        %{name}-shared.patch
135
136 # codecs, outputs, demuxers:
137 Patch20:        %{name}-auto-expand.patch
138 Patch21:        %{name}-release_directfb.patch
139
140 # goodies:
141 Patch30:        %{name}-cp1250-fontdesc.patch
142 Patch31:        %{name}-350.patch
143 # update, hard to fix right now because of gnome bug 579430:
144 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
145 #Patch32:       %{name}-gnome-screensaver.patch
146
147 Patch100:       %{name}-on2flix.patch
148 Patch101:       %{name}-link.patch
149 Patch102:       %{name}-build.patch
150
151 URL:            http://www.mplayerhq.hu/
152 %{?with_directfb:BuildRequires: DirectFB-devel}
153 BuildRequires:  OpenAL-devel
154 BuildRequires:  OpenGL-devel
155 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
156 %{?with_aalib:BuildRequires:    aalib-devel}
157 %{?with_alsa:BuildRequires:     alsa-lib-devel}
158 %{?with_arts:BuildRequires:     artsc-devel}
159 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
160 BuildRequires:  bzip2-devel
161 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
162 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
163 BuildRequires:  dirac-devel
164 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
165 %{?with_doc:BuildRequires:      docbook-style-xsl}
166 %{?with_dxr3:BuildRequires:     em8300-devel}
167 %{?with_enca:BuildRequires:     enca-devel}
168 %{?with_esd:BuildRequires:      esound-devel}
169 BuildRequires:  faac-devel
170 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
171 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
172 BuildRequires:  freetype-devel >= 1:2.2.1
173 BuildRequires:  fribidi-devel
174 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
175 %{?with_gif:BuildRequires:      giflib-devel}
176 %{?with_gui:BuildRequires:      gtk+2-devel}
177 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
178 BuildRequires:  lame-libs-devel
179 BuildRequires:  libass-devel >= 0.9.10
180 %{?with_blueray:BuildRequires:  libbluray-devel}
181 %{?with_caca:BuildRequires:     libcaca-devel}
182 %{?with_libdts:BuildRequires:   libdts-devel}
183 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
184 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
185 %{?with_ggi:BuildRequires:      libggi-devel}
186 BuildRequires:  libjpeg-devel
187 %{?with_mad:BuildRequires:      libmad-devel}
188 BuildRequires:  libmng-devel
189 BuildRequires:  libpng-devel
190 %{?with_smb:BuildRequires:      libsmbclient-devel}
191 %{?with_theora:BuildRequires:   libtheora-devel}
192 %{?with_vdpau:BuildRequires:    libvdpau-devel}
193 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
194 BuildRequires:  libvpx-devel
195 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
196 BuildRequires:  libxslt-progs
197 %{?with_lirc:BuildRequires:     lirc-devel}
198 %{?with_live:BuildRequires:     live-devel}
199 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
200 %{?with_nas:BuildRequires:      nas-devel}
201 BuildRequires:  ncurses-devel
202 %{?with_amr:BuildRequires:      opencore-amr-devel}
203 BuildRequires:  pkgconfig
204 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
205 BuildRequires:  rpm >= 4.4.9-56
206 BuildRequires:  rpmbuild(macros) >= 1.527
207 BuildRequires:  schroedinger-devel
208 BuildRequires:  speex-devel >= 1.1
209 %{?with_svga:BuildRequires:     svgalib-devel}
210 BuildRequires:  tar >= 1:1.22
211 BuildRequires:  twolame-devel
212 %{?with_vidix:BuildRequires:    vidix-devel}
213 %{?with_xmms:BuildRequires:     xmms-devel}
214 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
215 %ifarch %{ix86} %{x8664}
216 BuildRequires:  yasm
217 %endif
218 BuildRequires:  zlib-devel
219 %if "%{pld_release}" == "ac"
220 BuildRequires:  XFree86-devel >= 4.0.2
221 %else
222 BuildRequires:  xorg-lib-libX11-devel
223 BuildRequires:  xorg-lib-libXScrnSaver-devel
224 BuildRequires:  xorg-lib-libXext-devel
225 BuildRequires:  xorg-lib-libXinerama-devel
226 BuildRequires:  xorg-lib-libXv-devel
227 BuildRequires:  xorg-lib-libXvMC-devel
228 BuildRequires:  xorg-lib-libXxf86dga-devel
229 BuildRequires:  xorg-lib-libXxf86vm-devel
230 %endif
231 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
232 Requires:       OpenGL
233 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
234
235 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
236 %define         specflags_ia32  -fomit-frame-pointer
237 %if %{with altivec}
238 %define         specflags_ppc   -maltivec
239 %endif
240
241 %if "%{pld_release}" == "ac"
242 %ifarch ppc
243 %define         __cc    gcc4
244 %endif
245 %endif
246
247 %description
248 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
249 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
250 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
251 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
252 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
253 optionally with SHM extension, X11 using overlays with the Xvideo
254 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
255 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
256
257 If you want to use win32 codecs install w32codec package.
258
259 %description -l de.UTF-8
260 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
261 Kennzeichnend ist die herausragende Format- und
262 Plattform-Kompatibilität.
263
264 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
265 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
266 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
267 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
268 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
269 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
270 installierte Codecs nicht mit MPlayer kollidieren können.
271
272 %description -l es.UTF-8
273 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
274 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
275 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
276 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
277 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
278 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
279 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
280 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
281 v1.1.7 etc.
282
283 Si quiere usar codecs Win32, instale el paquete w32codec.
284
285 %description -l ko.UTF-8
286 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
287 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
288 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
289 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
290 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
291 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
292 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
293 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
294 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
295
296 %description -l pl.UTF-8
297 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
298 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
299 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
300 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
301 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
302 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
303 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
304
305 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
306
307 %description -l pt_BR.UTF-8
308 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
309 áudio. Diferentes mecanismos de reprodução podem também ser
310 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
311
312 %package -n gmplayer
313 Summary:        MPlayer with GTK+ GUI interface
314 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
315 Group:          X11/Applications/Multimedia
316 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
317 Requires:       %{name}-skin
318
319 %description -n gmplayer
320 MPlayer with GUI GTK+ interface.
321
322 %description -n gmplayer -l pl.UTF-8
323 MPlayer z graficznym interfejsem GTK+.
324
325 %package common
326 Summary:        Configuration files and documentation for MPlayer
327 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
328 Group:          Applications/Multimedia
329 Suggests:       unrar
330 Obsoletes:      mplayer-vidix
331
332 %description common
333 Configuration files, man page and HTML documentation for MPlayer.
334
335 %description common -l pl.UTF-8
336 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
337
338 %package doc
339 Summary:        HTML documentation for %{name}
340 Group:          Documentation
341
342 %description doc
343 HTML Documentation for %{name}.
344
345 %package -n mencoder
346 Summary:        MEncoder - a movie encoder for Linux
347 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
348 Group:          Applications/Multimedia
349 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
350
351 %description -n mencoder
352 MEncoder is a movie encoder for Linux and is a part of the MPlayer
353 package.
354
355 %description -n mencoder -l pl.UTF-8
356 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
357
358 %prep
359 %setup -q -n MPlayer-%{version} -a3 -a6 -a9
360 cp -f etc/codecs.conf etc/codecs.win32.conf
361
362 # build (configure / Makefile) related:
363 %patch10 -p1
364 %patch11 -p1
365 %patch12 -p1
366 %patch13 -p1
367 %{?with_system_ffmpeg:%patch14 -p1}
368 # patch15 updated, but possibly no longer needed
369 %{?with_live:%patch15 -p1}
370 %{?with_shared:%patch16 -p1}
371
372 # codecs, outputs, demuxers:
373 %patch20 -p1
374 %patch21 -p1
375
376 # goodies:
377 %patch30 -p0
378 %patch31 -p1
379 #%{with_gnomess:%patch32 -p1}
380
381 # on2flix
382 mv mencoder-on2flixenglinux{-*-*-*,}
383 %if %{with on2}
384 #%%patch100 -p1
385 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
386 # remove broken patches:
387 # - first set does not apply
388 # - second set beakes build
389 for PATCH in    asf-correct_movielength avi_check_idxflags \
390                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
391                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
392                 mpegvideo-revert_r18381 \
393                 \
394                 reduce_spurious_logging
395 do
396         rm mencoder-on2flixenglinux/patch/$PATCH.diff
397 done
398 for a in mencoder-on2flixenglinux/patch/*.diff; do
399         patch -p0 < $a
400 done
401 %endif
402
403 %patch101 -p1
404 %patch102 -p1
405
406 # Set version
407 %if "x%{?svnver}" != "x%{nil}"
408         echo "SVN-r%{svnver}%{?with_on2:-on2}" > VERSION
409 %endif
410
411 cat etc/example.conf > etc/mplayer.conf
412 cat <<'CONFIGADD' >> etc/mplayer.conf
413
414 ######################
415 # PLD Linux Defaults #
416 ######################
417 [default]
418
419 # alternate solution for CP1250-encoded subtitles
420 fontconfig = yes
421 subcp = cp1250
422
423 # ...or if you prefer native bitmap fonts shipped with mplayer
424 #fontconfig = no
425 #subcp = iso-8859-1
426
427 # Standard location
428 unrarexec = "%{_bindir}/unrar"
429
430 CONFIGADD
431
432 %if %{with system_ffmpeg}
433 # using external ffmpeg, but mplayer adds these to includepath
434 rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
435 %endif
436
437 # *** HOT FIXES ***
438
439 # typo, fixed in recent svn
440 sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
441
442 # mjpeg encoder is required for Zoran hardware
443 sed '/_libavencoders="MPEG/s/"$/ MJPEG_ENCODER"/' -i configure
444
445 %build
446 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
447 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
448 %{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
449
450 build() {
451         set -x
452
453         ./configure \
454         %{?debug:--enable-debug=3} \
455         --prefix=%{_prefix} \
456         --confdir=%{_sysconfdir}/mplayer \
457         --cc="%{__cc}" \
458         --extra-cflags="$CFLAGS" \
459         --real-ldflags="%{rpmldflags}" \
460         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
461 %if %{with system_ffmpeg}
462         --disable-libavutil_a \
463         --disable-libavcodec_a \
464         --disable-libavformat_a \
465         --disable-libpostproc_a \
466         --enable-libavutil_so \
467         --enable-libavcodec_so \
468         --enable-libavformat_so \
469         --enable-libpostproc_so \
470 %endif
471 %ifnarch %{ix86} %{x8664}
472         --disable-mmx \
473         --disable-mmxext \
474         --disable-3dnow \
475         --disable-3dnowext \
476         --disable-sse \
477         --disable-sse2 \
478         --disable-fastmemcpy \
479 %endif
480         %{__disable ssse3} \
481 %ifarch ppc
482         %{__disable altivec} \
483 %endif
484         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
485         %{__enable_disable directfb} \
486         %{__disable dxr3} \
487         %{__disable ggi} \
488         %{__disable live} \
489         %{__disable lzo liblzo} \
490         %{__disable nas} \
491         %{__disable svga} \
492         %{__disable aalib aa} \
493         %{__disable jack} \
494         %{__enable_disable alsa} \
495         %{__disable arts} \
496         %{__disable caca} \
497         %{__disable cdparanoia} \
498         %{__disable enca} \
499         %{__disable esd} \
500         %{__disable faad} \
501         %{__disable gif} \
502         %{__enable joystick} \
503         %{__disable blueray} \
504         %{__disable libdv} \
505         %{__disable libdts libdca} \
506         %{__enable_disable lirc} \
507         %{__disable mad} \
508         %{__disable pulseaudio pulse} \
509         %{__disable quicktime qtx} \
510         %{__disable real} \
511         %{__enable_disable runtime runtime-cpudetection} \
512         %{__disable select} \
513         %{__disable smb} \
514         %{__disable win32 win32dll} \
515         %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis} \
516         %{__disable_if system_vorbis tremor-internal} \
517         %{__enable osd menu} \
518         %{__disable theora} \
519         %{__disable x264} \
520         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
521         %{__disable xvid} \
522         %{__disable vidix} \
523         %{__disable vdpau} \
524         %{__disable mencoder} \
525         --enable-dga1 \
526         --enable-dga2 \
527         %{__enable_disable dvdnav} \
528         --enable-fbdev \
529         --enable-gl \
530         --enable-mga \
531         --enable-radio \
532         --enable-radio-capture \
533         %{__enable_disable sdl} \
534         --enable-tdfxfb \
535         --enable-vm \
536         --enable-x11 \
537         --enable-xmga \
538         --enable-xv \
539         --enable-xvmc \
540         --with-xvmclib=XvMCW \
541         %{__enable_disable zr} \
542         --enable-unrarexec \
543         --enable-dynamic-plugins \
544         --language=all \
545         --codecsdir=%{_libdir}/codecs \
546         "$@"
547
548         %{__make}
549 }
550
551 %if %{with gui}
552 # build GUI version
553 build --enable-gui --disable-mencoder
554 mv -f mplayer gmplayer
555 %{__make} distclean
556 %endif
557
558 # now build regular version
559 build --disable-gui
560
561 %if %{with doc}
562 %{__make} -j1 doc
563 %endif
564
565 %install
566 rm -rf $RPM_BUILD_ROOT
567 install -d \
568         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
569         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
570         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
571         $RPM_BUILD_ROOT%{_desktopdir}
572
573 # default config files
574 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
575
576 # executables
577 %if %{with mencoder}
578 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
579 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
580 %endif
581 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
582 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
583 %if %{with gui}
584 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
585 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
586 %endif
587
588 %if %{with shared}
589 install -d $RPM_BUILD_ROOT%{_libdir}
590 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
591 %endif
592
593 # fonts
594 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
595 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
596
597 %if %{with gui}
598 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
599 %endif
600 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
601 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
602 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
603
604 # man pages
605 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
606 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
607 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
608 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
609 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
610 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
611 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
612 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
613 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
614 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
615
616 %clean
617 rm -rf $RPM_BUILD_ROOT
618
619 %post -n gmplayer
620 umask 022
621 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
622
623 %postun -n gmplayer
624 umask 022
625 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
626
627 %files
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/mplayer*
630
631 %if %{with gui}
632 %files -n gmplayer
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_bindir}/gmplayer*
635 %{_desktopdir}/gmplayer.desktop
636 %endif
637
638 %if %{with mencoder}
639 %files -n mencoder
640 %defattr(644,root,root,755)
641 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
642 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
643 %doc DOCS/tech/colorspaces.txt
644 %attr(755,root,root) %{_bindir}/mencoder*
645 %endif
646
647 %if %{with doc}
648 %files doc
649 %defattr(644,root,root,755)
650 %doc DOCS/tech
651 # HTML and XML-generated docs
652 %doc DOCS/HTML/en
653 %lang(cs) %doc DOCS/HTML/cs
654 %lang(de) %doc DOCS/HTML/de
655 %lang(es) %doc DOCS/HTML/es
656 %lang(fr) %doc DOCS/HTML/fr
657 %lang(hu) %doc DOCS/HTML/hu
658 %lang(pl) %doc DOCS/HTML/pl
659 %lang(ru) %doc DOCS/HTML/ru
660 #%lang(zh_CN) %doc DOCS/zh
661 %endif
662
663 %files common
664 %defattr(644,root,root,755)
665 %doc AUTHORS README
666 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
667 %if %{with win32}
668 %doc etc/codecs.win32.conf
669 %endif
670
671 %dir %{_sysconfdir}/%{name}
672 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
673 %{_mandir}/man1/*
674 %lang(cs) %{_mandir}/cs/man1/*
675 %lang(de) %{_mandir}/de/man1/*
676 %lang(es) %{_mandir}/es/man1/*
677 %lang(fr) %{_mandir}/fr/man1/*
678 %lang(hu) %{_mandir}/hu/man1/*
679 %lang(it) %{_mandir}/it/man1/*
680 %lang(pl) %{_mandir}/pl/man1/*
681 #%lang(sv) %{_mandir}/sv/man1/*
682 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
683 %{_desktopdir}/mplayer.desktop
684 %{_pixmapsdir}/mplayer.png
685 %dir %{_datadir}/%{name}
686 %{_datadir}/%{name}/font*
687 %dir %{_datadir}/%{name}/skins
688 %ghost %{_datadir}/%{name}/skins/default
This page took 0.098391 seconds and 4 git commands to generate.