]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- update on2 patches to 2008-11-25
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_without  osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dvdnav          # without dvdnav support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio      # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
59 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
60
61 %ifnarch %{ix86}
62 %undefine       with_win32
63 %undefine       with_quicktime
64 %undefine       with_vidix
65 %endif
66
67 %ifnarch %{ix86} %{x8664} ppc ppc64
68 %undefine       with_runtime
69 %endif
70
71 %if %{_lib} == "lib64"
72 %define         _suf    64
73 %else
74 %define         _suf    32
75 %endif
76
77 %define         subver  rc2
78 %define         svnver  27725
79 %define         rel             17
80
81 Summary:        MPlayer - THE Movie Player for UN*X
82 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
83 Summary(es.UTF-8):      Otro reproductor de películas
84 Summary(ko.UTF-8):      리눅스용 미디어플레이어
85 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
86 Summary(pt_BR.UTF-8):   Reprodutor de filmes
87 Name:           mplayer
88 Version:        1.0
89 Release:        5.%{subver}_svn%{svnver}.%{rel}
90 # DO NOT increase epoch unless it's really neccessary!
91 # especially such changes like pre7->pre7try2, increase Release instead!
92 # PS: $ rpmvercmp pre7try2 pre7
93 # pre7try2 > pre7
94 Epoch:          3
95 License:        GPL
96 Group:          Applications/Multimedia
97 Source0:        http://distfiles.gentoo.org/distfiles/mplayer-%{version}_%{subver}_p%{svnver}.tar.bz2
98 # Source0-md5:  d89e86d9183d1a52a7a754d9a3c74724
99 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
100 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
101 Source5:        g%{name}.desktop
102 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
103 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
104 Source7:        %{name}.png
105 Source8:        %{name}.desktop
106 # http://www.on2.com/gpl/mplayer/
107 Source9:        http://support.on2.com/gpl/mplayer/2008-11-25-mencoder-on2flixenglinux.tar.bz2
108 # Source9-md5:  7dd9c22d9d7207c0b42fa530b4f3fc5d
109 Patch1:         %{name}-cp1250-fontdesc.patch
110 #Patch2:                %{name}-codec.patch
111 #Patch3:                %{name}-home_etc.patch
112 Patch4:         %{name}-350.patch
113 Patch5:         %{name}-configure.patch
114 # outdated via ffmpeg?
115 Patch6:         %{name}-system-amr.patch
116 Patch8:         %{name}-altivec.patch
117 #Patch10:       %{name}-pcmsplit.patch
118 #Patch13:       %{name}-mythtv.patch
119 Patch14:        %{name}-shared.patch
120 #http://www.openchrome.org/snapshots/mplayer/
121 #Patch15:       %{name}-xvmc.patch
122 Patch17:        %{name}-auto-expand.patch
123 # update
124 #Patch18:       %{name}-gnome-screensaver.patch
125 Patch19:        %{name}-on2flix.patch
126 Patch22:        %{name}-ffmpeg.patch
127 Patch24:        %{name}-fontconfig_sub.patch
128 Patch26:        %{name}-check-byteswap.patch
129 URL:            http://www.mplayerhq.hu/
130 %{?with_directfb:BuildRequires: DirectFB-devel}
131 BuildRequires:  OpenAL-devel
132 BuildRequires:  OpenGL-devel
133 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
134 %{?with_aalib:BuildRequires:    aalib-devel}
135 %{?with_alsa:BuildRequires:     alsa-lib-devel}
136 %if %{with amr}
137 BuildRequires:  amrnb-devel
138 BuildRequires:  amrwb-devel >= 5.3.0
139 %endif
140 %{?with_arts:BuildRequires:     artsc-devel}
141 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
142 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
143 %{?with_doc:BuildRequires:      docbook-style-xsl}
144 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
145 %{?with_dxr3:BuildRequires:     em8300-devel}
146 %{?with_enca:BuildRequires:     enca-devel}
147 %{?with_esd:BuildRequires:      esound-devel}
148 BuildRequires:  faac-devel
149 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
150 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
151 BuildRequires:  freetype-devel
152 BuildRequires:  fribidi-devel
153 %{?with_vidix:BuildRequires:    vidix-devel}
154 %ifarch ppc
155 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
156 %endif
157 %{?with_gif:BuildRequires:      giflib-devel}
158 %if %{with gui}
159 BuildRequires:  gtk+2-devel
160 %endif
161 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
162 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
163 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
164 BuildRequires:  lame-libs-devel
165 %{?with_caca:BuildRequires:     libcaca-devel}
166 %{?with_libdts:BuildRequires:   libdts-devel}
167 %{?with_libdv:BuildRequires:    libdv-devel}
168 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
169 %{?with_ggi:BuildRequires:      libggi-devel}
170 BuildRequires:  libjpeg-devel
171 %{?with_mad:BuildRequires:      libmad-devel}
172 BuildRequires:  libmpcdec-devel >= 1.2.1
173 BuildRequires:  libpng-devel
174 %{?with_smb:BuildRequires:      libsmbclient-devel}
175 %{?with_theora:BuildRequires:   libtheora-devel}
176 # tremor is used by default, internal as we don't have system one
177 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
178 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20081023_2245.1}
179 BuildRequires:  libxslt-progs
180 %{?with_lirc:BuildRequires:     lirc-devel}
181 %{?with_live:BuildRequires:     live}
182 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
183 %{?with_nas:BuildRequires:      nas-devel}
184 BuildRequires:  ncurses-devel
185 BuildRequires:  pkgconfig
186 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
187 BuildRequires:  speex-devel >= 1.1
188 %{?with_svga:BuildRequires:     svgalib-devel}
189 %{?with_xmms:BuildRequires:     xmms-libs}
190 BuildRequires:  xorg-lib-libX11-devel
191 BuildRequires:  xorg-lib-libXext-devel
192 BuildRequires:  xorg-lib-libXinerama-devel
193 BuildRequires:  xorg-lib-libXv-devel
194 BuildRequires:  xorg-lib-libXvMC-devel
195 BuildRequires:  xorg-lib-libXxf86dga-devel
196 BuildRequires:  xorg-lib-libXxf86vm-devel
197 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
198 BuildRequires:  zlib-devel
199 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
200 Requires:       OpenGL
201 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
202
203 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
204 %define         specflags_ia32  -fomit-frame-pointer
205 %if %{with altivec}
206 %define         specflags_ppc   -maltivec
207 %endif
208
209 %description
210 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
211 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
212 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
213 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
214 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
215 optionally with SHM extension, X11 using overlays with the Xvideo
216 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
217 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
218
219 If you want to use win32 codecs install w32codec package.
220
221 %description -l de.UTF-8
222 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
223 Kennzeichnend ist die herausragende Format- und
224 Plattform-Kompatibilität.
225
226 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
227 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
228 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
229 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
230 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
231 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
232 installierte Codecs nicht mit MPlayer kollidieren können.
233
234 %description -l es.UTF-8
235 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
236 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
237 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
238 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
239 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
240 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
241 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
242 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
243 v1.1.7 etc.
244
245 Si quiere usar codecs Win32, instale el paquete w32codec.
246
247 %description -l ko.UTF-8
248 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
249 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
250 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
251 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
252 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
253 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
254 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
255 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
256 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
257
258 %description -l pl.UTF-8
259 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
260 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
261 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
262 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
263 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
264 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
265 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
266
267 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
268
269 %description -l pt_BR.UTF-8
270 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
271 áudio. Diferentes mecanismos de reprodução podem também ser
272 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
273
274 %package -n gmplayer
275 Summary:        MPlayer with GTK+ GUI interface
276 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
277 Group:          X11/Applications/Multimedia
278 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
279 Requires:       %{name}-skin
280
281 %description -n gmplayer
282 MPlayer with GUI GTK+ interface.
283
284 %description -n gmplayer -l pl.UTF-8
285 MPlayer z graficznym interfejsem GTK+.
286
287 %package common
288 Summary:        Configuration files and documentation for MPlayer
289 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
290 Group:          Applications/Multimedia
291 Obsoletes:      mplayer-vidix
292
293 %description common
294 Configuration files, man page and HTML documentation for MPlayer.
295
296 %description common -l pl.UTF-8
297 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
298
299 %package -n mencoder
300 Summary:        MEncoder - a movie encoder for Linux
301 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
302 Group:          Applications/Multimedia
303 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
304
305 %description -n mencoder
306 MEncoder is a movie encoder for Linux and is a part of the MPlayer
307 package.
308
309 %description -n mencoder -l pl.UTF-8
310 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
311
312 %prep
313 %setup -q -n mplayer-%{version}_%{subver}_p%{svnver} -a3 -a6 -a9
314 cp -f etc/codecs.conf etc/codecs.win32.conf
315 %patch1 -p0
316 #%%patch2 -p1 -- still needed?
317 ##%%patch3 -p1  -- old home_etc behavior
318 %patch4 -p1
319 %patch5 -p1
320 #%%patch6 -p1 # - try ffmpeg
321 %patch8 -p1
322 #%%patch10 -p1
323 #%%patch13 -p1  # TODO
324 %if %{with shared}
325 %patch14 -p1
326 %endif
327 #%%patch15 -p0  # TODO
328 %patch17 -p1
329 %if %{with gnomess}
330 #%%patch18 -p1
331 %endif
332
333 # on2flix
334 mv mencoder-on2flixenglinux{-*-*-*,}
335 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
336 #rm -f mencoder-on2flixenglinux/patch/version.diff
337 %patch19 -p1
338 for a in mencoder-on2flixenglinux/patch/*.diff; do
339         patch -p0 < $a
340 done
341
342 %{?with_system_ffmpeg:%patch22 -p1}
343 %patch24 -p0
344 %patch26 -p1
345
346 # recent dvdnav-config doesn't support --minilibs.
347 sed -i 's:--minilibs:--libs:g' configure
348
349 # Set version #
350 echo %{svnver} > svn_snapshot_id
351
352 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
353 rm -f font-*/runme
354
355 %if %{with system_ffmpeg}
356 # using external ffmpeg, but mplayer adds these to includepath
357 rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
358 %endif
359
360 %build
361 %if %{with shared}
362 CFLAGS="%{rpmcflags} -fPIC"
363 %else
364 CFLAGS="%{rpmcflags}"
365 %endif
366 CC="%{__cc}"
367 LDFLAGS="%{rpmldflags}"
368 export CC CFLAGS LDFLAGS
369
370 build() {
371 set -x
372         ./configure \
373         %{?debug:--enable-debug=3} \
374         --prefix=%{_prefix} \
375         --confdir=%{_sysconfdir}/mplayer \
376         --with-extraincdir=%{_includedir}/xvid \
377         --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
378 %if %{with system_ffmpeg}
379         --disable-libavutil_a \
380         --disable-libavcodec_a \
381         --disable-libavformat_a \
382         --disable-libpostproc_a \
383         --enable-libavutil_so \
384         --enable-libavcodec_so \
385         --enable-libavformat_so \
386         --enable-libpostproc_so \
387 %endif
388 %ifnarch %{ix86} %{x8664}
389         --disable-mmx \
390         --disable-mmxext \
391         --disable-3dnow \
392         --disable-3dnowext \
393         --disable-sse \
394         --disable-sse2 \
395         --disable-fastmemcpy \
396 %endif
397         %{!?with_ssse3:--disable-ssse3} \
398 %ifarch ppc
399         %{!?with_altivec:--disable-altivec} \
400 %endif
401         %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
402         %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
403         %{?with_directfb:--enable-directfb} \
404         %{!?with_directfb:--disable-directfb} \
405         %{!?with_dxr3:--disable-dxr3} \
406         %{!?with_ggi:--disable-ggi} \
407         %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
408         %{!?with_live:--disable-live} \
409         %{!?with_lzo:--disable-liblzo} \
410         %{!?with_nas:--disable-nas} \
411         %{!?with_svga:--disable-svga} \
412         %{!?with_aalib:--disable-aa} \
413         %{!?with_jack:--disable-jack} \
414         %{!?with_alsa:--disable-alsa} \
415         %{?with_alsa:--enable-alsa --disable-select} \
416         %{!?with_arts:--disable-arts} \
417         %{!?with_caca:--disable-caca} \
418         %{!?with_cdparanoia:--disable-cdparanoia} \
419         %{!?with_enca:--disable-enca} \
420         %{!?with_esd:--disable-esd} \
421         %{!?with_faad:--disable-faad-external --disable-faad-internal} \
422         %{?with_faad:--disable-faad-internal} \
423         %{!?with_gif:--disable-gif} \
424         %{?with_joystick:--enable-joystick} \
425         %{!?with_libdv:--disable-libdv} \
426         %{!?with_libdts:--disable-libdts} \
427         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
428         %{!?with_mad:--disable-mad} \
429         %{!?with_pulseaudio:--disable-polyp} \
430         %{!?with_quicktime:--disable-qtx} \
431         %{!?with_real:--disable-real} \
432         --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
433         %{!?with_select:--disable-select} \
434         %{!?with_smb:--disable-smb} \
435         %{!?with_win32:--disable-win32dll} \
436         %{!?with_vorbis:--disable-vorbis} \
437         %{?with_osd:--enable-menu} \
438         %{!?with_theora:--disable-theora} \
439         %{!?with_x264:--disable-x264} \
440         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
441         %{!?with_xvid:--disable-xvid} \
442         %{!?with_vidix:--disable-vidix} \
443         %{!?with_mencoder:--disable-mencoder} \
444         --enable-dga1 \
445         --enable-dga2 \
446         --%{!?with_dvdnav:dis}%{?with_dvdnav:en}able-dvdnav \
447         --enable-fbdev \
448         --enable-gl \
449         --enable-mga \
450         --enable-radio \
451         --enable-radio-capture \
452         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
453         --enable-tdfxfb \
454         --enable-vm \
455         --enable-x11 \
456         --enable-xmga \
457         --enable-xv \
458         --enable-xvmc \
459         --enable-dynamic-plugins \
460         --enable-largefiles \
461         --language=all \
462         --codecsdir=%{_libdir}/codecs \
463         --with-xvmclib=XvMCW \
464         "$@"
465
466         %{__make}
467 }
468
469 %if %{with gui}
470 # build GUI version
471 build --enable-gui --disable-mencoder
472 mv -f mplayer gmplayer
473 %{__make} distclean
474 %endif
475
476 # now build regular version
477 build --disable-gui
478
479 %if %{with doc}
480 %{__make} -j1 -C DOCS/xml
481 %endif
482
483 %install
484 rm -rf $RPM_BUILD_ROOT
485 install -d \
486         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
487         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
488         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
489         $RPM_BUILD_ROOT%{_desktopdir}
490
491 # default config files
492 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
493
494 # executables
495 %if %{with mencoder}
496 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
497 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
498 %endif
499 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
500 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
501 %if %{with gui}
502 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
503 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
504 %endif
505
506 # fonts
507 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
508 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
509
510 %if %{with gui}
511 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
512 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
513 %endif
514 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
515 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
516
517 # man pages
518 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
519 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
520 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
521 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
522 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
523 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
524 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
525 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
526 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
527 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
528
529 %clean
530 rm -rf $RPM_BUILD_ROOT
531
532 %post -n gmplayer
533 umask 022
534 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
535
536 %postun -n gmplayer
537 umask 022
538 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
539
540 %files
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/mplayer*
543
544 %if %{with gui}
545 %files -n gmplayer
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/gmplayer*
548 %{_desktopdir}/gmplayer.desktop
549 %dir %{_datadir}/%{name}/skins
550 %ghost %{_datadir}/%{name}/skins/default
551 %endif
552
553 %if %{with mencoder}
554 %files -n mencoder
555 %defattr(644,root,root,755)
556 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
557 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
558 %doc DOCS/tech/colorspaces.txt
559 %attr(755,root,root) %{_bindir}/mencoder*
560 %endif
561
562 %files common
563 %defattr(644,root,root,755)
564 %doc DOCS/tech
565 %if %{with win32}
566 %doc etc/codecs.win32.conf
567 %endif
568 %if %{with doc}
569 # HTML and XML-generated docs
570 %doc DOCS/HTML/en
571 %lang(cs) %doc DOCS/HTML/cs
572 %lang(de) %doc DOCS/HTML/de
573 %lang(es) %doc DOCS/HTML/es
574 %lang(fr) %doc DOCS/HTML/fr
575 %lang(hu) %doc DOCS/HTML/hu
576 %lang(pl) %doc DOCS/HTML/pl
577 %lang(ru) %doc DOCS/HTML/ru
578 #%lang(zh_CN) %doc DOCS/zh
579 %endif
580 %doc AUTHORS README
581
582 %dir %{_sysconfdir}/%{name}
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
584 %{_mandir}/man1/*
585 %lang(cs) %{_mandir}/cs/man1/*
586 %lang(de) %{_mandir}/de/man1/*
587 %lang(es) %{_mandir}/es/man1/*
588 %lang(fr) %{_mandir}/fr/man1/*
589 %lang(hu) %{_mandir}/hu/man1/*
590 %lang(it) %{_mandir}/it/man1/*
591 %lang(pl) %{_mandir}/pl/man1/*
592 #%lang(sv) %{_mandir}/sv/man1/*
593 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
594 %{_desktopdir}/mplayer.desktop
595 %{_pixmapsdir}/mplayer.png
596 %dir %{_datadir}/%{name}
597 %{_datadir}/%{name}/font*
This page took 0.083718 seconds and 4 git commands to generate.