]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- CVE security blocker
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_with     osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  enca            # disable using ENCA charset oracle library
27 %bcond_without  esd             # disable EsounD sound support
28 %bcond_without  faad            # disable FAAD2 (AAC) support
29 %bcond_without  gif             # disable GIF support
30 %bcond_without  gui             # without GTK+ GUI
31 %bcond_without  joystick        # disable joystick support
32 %bcond_without  libdts          # disable libdts support
33 %bcond_without  libdv           # disable libdv en/decoding support
34 %bcond_without  lirc            # without lirc support
35 %bcond_with     live            # without LIVE555 libraries
36 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
37 %bcond_without  mad             # without mad (audio MPEG) support
38 %bcond_without  pulseaudio      # without pulseaudio output
39 %bcond_without  quicktime       # without binary quicktime dll support
40 %bcond_without  real            # without Real* 8/9 codecs support
41 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
42                                 #  in compile time (advertised by mplayer authors as working faster); in this case
43                                 #  mplayer may not work on machine other then where it was compiled
44 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
45 %bcond_without  smb             # disable Samba (SMB) input support
46 %bcond_without  theora          # without theora support
47 %bcond_without  win32           # without win32 codecs support
48 %bcond_without  vidix           # disable vidix
49 %bcond_without  vorbis          # without Ogg-Vorbis audio support
50 %bcond_without  xvid            # disable XviD codec
51 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
52 %bcond_without  sdl             # disable SDL
53 %bcond_without  doc             # don't build docs (slow)
54 %bcond_with     shared          # experimental libmplayer.so support
55 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
56 %bcond_without  gnomess         # disable controling gnome screensaver
57 %bcond_with     ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
58 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (needs more work or mplayer snapshot)
59
60 %ifnarch %{ix86}
61 %undefine       with_win32
62 %undefine       with_quicktime
63 %undefine       with_vidix
64 %endif
65
66 %ifnarch %{ix86} %{x8664} ppc ppc64
67 %undefine       with_runtime
68 %endif
69
70 %if %{_lib} == "lib64"
71 %define         _suf    64
72 %else
73 %define         _suf    32
74 %endif
75
76 %define         subver  rc2
77 %define         rel             12
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es.UTF-8):      Otro reproductor de películas
82 Summary(ko.UTF-8):      리눅스용 미디어플레이어
83 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR.UTF-8):   Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 Release:        5.%{subver}.%{rel}
88 # DO NOT increase epoch unless it's really neccessary!
89 # especially such changes like pre7->pre7try2, increase Release instead!
90 # PS: $ rpmvercmp pre7try2 pre7
91 # pre7try2 > pre7
92 Epoch:          3
93 License:        GPL
94 Group:          Applications/Multimedia
95 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
96 # Source0-md5:  7e27e535c2d267637df34898f1b91707
97 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
99 Source5:        g%{name}.desktop
100 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
102 Source7:        %{name}.png
103 Source8:        %{name}.desktop
104 # http://www.on2.com/gpl/mplayer/
105 Source9:        http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106 # Source9-md5:  2361e56b40f52dfc20131e458e2aed38
107 Patch1:         %{name}-cp1250-fontdesc.patch
108 #Patch2:                %{name}-codec.patch
109 #Patch3:                %{name}-home_etc.patch
110 Patch4:         %{name}-350.patch
111 Patch5:         %{name}-configure.patch
112 # outdated via ffmpeg?
113 Patch6:         %{name}-system-amr.patch
114 Patch8:         %{name}-altivec.patch
115 #Patch10:       %{name}-pcmsplit.patch
116 #Patch13:       %{name}-mythtv.patch
117 Patch14:        %{name}-shared.patch
118 #http://www.openchrome.org/snapshots/mplayer/
119 #Patch15:       %{name}-xvmc.patch
120 Patch17:        %{name}-auto-expand.patch
121 # update
122 #Patch18:       %{name}-gnome-screensaver.patch
123 Patch19:        %{name}-on2flix.patch
124 Patch22:        %{name}-ffmpeg.patch
125 Patch23:        %{name}-live.patch
126 Patch24:        %{name}-fontconfig_sub.patch
127 Patch25:        http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
128 Patch26:        %{name}-check-byteswap.patch
129 Patch27:        http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
130 URL:            http://www.mplayerhq.hu/
131 # http://securitytracker.com/alerts/2008/Sep/1020952.html
132 BuildRequires:  security(CVE-2008-3827)
133 %{?with_directfb:BuildRequires: DirectFB-devel}
134 BuildRequires:  OpenAL-devel
135 BuildRequires:  OpenGL-devel
136 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
137 %{?with_aalib:BuildRequires:    aalib-devel}
138 %{?with_alsa:BuildRequires:     alsa-lib-devel}
139 %if %{with amr}
140 BuildRequires:  amrnb-devel
141 BuildRequires:  amrwb-devel >= 5.3.0
142 %endif
143 %{?with_arts:BuildRequires:     artsc-devel}
144 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
145 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
146 %{?with_doc:BuildRequires:      docbook-style-xsl}
147 %{?with_dxr3:BuildRequires:     em8300-devel}
148 %{?with_enca:BuildRequires:     enca-devel}
149 %{?with_esd:BuildRequires:      esound-devel}
150 BuildRequires:  faac-devel
151 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
152 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-3.20070626.1.1}
153 BuildRequires:  freetype-devel
154 BuildRequires:  fribidi-devel
155 %{?with_vidix:BuildRequires:    vidix-devel}
156 %ifarch ppc
157 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
158 %endif
159 %{?with_gif:BuildRequires:      giflib-devel}
160 %if %{with gui}
161 BuildRequires:  gtk+2-devel
162 %endif
163 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
164 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
165 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
166 BuildRequires:  lame-libs-devel
167 %{?with_caca:BuildRequires:     libcaca-devel}
168 %{?with_libdts:BuildRequires:   libdts-devel}
169 %{?with_libdv:BuildRequires:    libdv-devel}
170 BuildRequires:  libdvdnav-devel
171 %{?with_ggi:BuildRequires:      libggi-devel}
172 BuildRequires:  libjpeg-devel
173 %{?with_mad:BuildRequires:      libmad-devel}
174 BuildRequires:  libmpcdec-devel >= 1.2.1
175 BuildRequires:  libpng-devel
176 %{?with_smb:BuildRequires:      libsmbclient-devel}
177 %{?with_theora:BuildRequires:   libtheora-devel}
178 # tremor is used by default, internal as we don't have system one
179 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
180 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
181 BuildRequires:  libxslt-progs
182 %{?with_lirc:BuildRequires:     lirc-devel}
183 %{?with_live:BuildRequires:     live}
184 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
185 %{?with_nas:BuildRequires:      nas-devel}
186 BuildRequires:  ncurses-devel
187 BuildRequires:  pkgconfig
188 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
189 BuildRequires:  speex-devel >= 1.1
190 %{?with_svga:BuildRequires:     svgalib-devel}
191 %{?with_xmms:BuildRequires:     xmms-libs}
192 BuildRequires:  xorg-lib-libX11-devel
193 BuildRequires:  xorg-lib-libXext-devel
194 BuildRequires:  xorg-lib-libXinerama-devel
195 BuildRequires:  xorg-lib-libXv-devel
196 BuildRequires:  xorg-lib-libXvMC-devel
197 BuildRequires:  xorg-lib-libXxf86dga-devel
198 BuildRequires:  xorg-lib-libXxf86vm-devel
199 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
200 BuildRequires:  zlib-devel
201 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
202 Requires:       OpenGL
203 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
204
205 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
206 %define         specflags_ia32  -fomit-frame-pointer
207 %if %{with altivec}
208 %define         specflags_ppc   -maltivec
209 %endif
210
211 %description
212 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
213 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
214 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
215 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
216 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
217 optionally with SHM extension, X11 using overlays with the Xvideo
218 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
219 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
220
221 If you want to use win32 codecs install w32codec package.
222
223 %description -l de.UTF-8
224 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
225 Kennzeichnend ist die herausragende Format- und
226 Plattform-Kompatibilität.
227
228 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
229 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
230 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
231 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
232 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
233 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
234 installierte Codecs nicht mit MPlayer kollidieren können.
235
236 %description -l es.UTF-8
237 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
238 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
239 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
240 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
241 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
242 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
243 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
244 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
245 v1.1.7 etc.
246
247 Si quiere usar codecs Win32, instale el paquete w32codec.
248
249 %description -l ko.UTF-8
250 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
251 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
252 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
253 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
254 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
255 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
256 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
257 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
258 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
259
260 %description -l pl.UTF-8
261 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
262 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
263 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
264 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
265 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
266 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
267 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
268
269 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
270
271 %description -l pt_BR.UTF-8
272 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
273 áudio. Diferentes mecanismos de reprodução podem também ser
274 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
275
276 %package -n gmplayer
277 Summary:        MPlayer with GTK+ GUI interface
278 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
279 Group:          X11/Applications/Multimedia
280 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
281 Requires:       %{name}-skin
282
283 %description -n gmplayer
284 MPlayer with GUI GTK+ interface.
285
286 %description -n gmplayer -l pl.UTF-8
287 MPlayer z graficznym interfejsem GTK+.
288
289 %package common
290 Summary:        Configuration files and documentation for MPlayer
291 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
292 Group:          Applications/Multimedia
293 Obsoletes:      mplayer-vidix
294
295 %description common
296 Configuration files, man page and HTML documentation for MPlayer.
297
298 %description common -l pl.UTF-8
299 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
300
301 %package -n mencoder
302 Summary:        MEncoder - a movie encoder for Linux
303 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
304 Group:          Applications/Multimedia
305 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
306
307 %description -n mencoder
308 MEncoder is a movie encoder for Linux and is a part of the MPlayer
309 package.
310
311 %description -n mencoder -l pl.UTF-8
312 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
313
314 %prep
315 %setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
316 cp -f etc/codecs.conf etc/codecs.win32.conf
317 %patch1 -p0
318 #%%patch2 -p1 -- still needed?
319 ##%%patch3 -p1  -- old home_etc behavior
320 %patch4 -p1
321 %patch5 -p1
322 #%%patch6 -p1 # - try ffmpeg
323 %patch8 -p1
324 #%%patch10 -p1
325 #%%patch13 -p1  # TODO
326 %if %{with shared}
327 %patch14 -p1
328 %endif
329 #%%patch15 -p0  # TODO
330 %patch17 -p1
331 %if %{with gnomess}
332 #%%patch18 -p1
333 %endif
334
335 # on2flix
336 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
337 rm -f mencoder-on2flixenglinux/version.diff
338 %patch19 -p1
339 for a in mencoder-on2flixenglinux/*.diff; do
340         patch -p0 < $a
341 done
342
343 %{?with_system_ffmpeg:%patch22 -p1}
344 %patch23 -p1
345 %patch24 -p0
346 %patch25 -p0
347 %patch26 -p1
348 %patch27 -p0
349
350 # recent dvdnav-config doesn't support --minilibs.
351 sed -i 's:--minilibs:--libs:g' configure
352
353 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
354 rm -f font-*/runme
355
356 %if %{with system_ffmpeg}
357 # using external ffmpeg, but mplayer adds these to includepath
358 rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
359 %endif
360
361 %build
362 %if %{with shared}
363 CFLAGS="%{rpmcflags} -fPIC"
364 %else
365 CFLAGS="%{rpmcflags}"
366 %endif
367 CC="%{__cc}"
368 LDFLAGS="%{rpmldflags}"
369 export CC CFLAGS LDFLAGS
370
371 build() {
372 set -x
373         ./configure \
374         %{?debug:--enable-debug=3} \
375         --prefix=%{_prefix} \
376         --confdir=%{_sysconfdir}/mplayer \
377         --with-extraincdir=%{_includedir}/xvid \
378         --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
379         --enable-menu \
380 %if %{with system_ffmpeg}
381         --disable-libavutil_a \
382         --disable-libavcodec_a \
383         --disable-libavformat_a \
384         --disable-libpostproc_a \
385         --enable-libavutil_so \
386         --enable-libavcodec_so \
387         --enable-libavformat_so \
388         --enable-libpostproc_so \
389 %endif
390 %ifnarch %{ix86} %{x8664}
391         --disable-mmx \
392         --disable-mmxext \
393         --disable-3dnow \
394         --disable-3dnowext \
395         --disable-sse \
396         --disable-sse2 \
397         --disable-fastmemcpy \
398 %endif
399         %{!?with_ssse3:--disable-ssse3} \
400 %ifarch ppc
401         %{!?with_altivec:--disable-altivec} \
402 %endif
403         %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
404         %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
405         %{?with_directfb:--enable-directfb} \
406         %{!?with_directfb:--disable-directfb} \
407         %{!?with_dxr3:--disable-dxr3} \
408         %{!?with_ggi:--disable-ggi} \
409         %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
410         %{!?with_live:--disable-live} \
411         %{!?with_lzo:--disable-liblzo} \
412         %{!?with_nas:--disable-nas} \
413         %{!?with_svga:--disable-svga} \
414         %{!?with_aalib:--disable-aa} \
415         %{!?with_jack:--disable-jack} \
416         %{!?with_alsa:--disable-alsa} \
417         %{?with_alsa:--enable-alsa --disable-select} \
418         %{!?with_arts:--disable-arts} \
419         %{!?with_caca:--disable-caca} \
420         %{!?with_cdparanoia:--disable-cdparanoia} \
421         %{!?with_enca:--disable-enca} \
422         %{!?with_esd:--disable-esd} \
423         %{!?with_faad:--disable-faad-external --disable-faad-internal} \
424         %{?with_faad:--disable-faad-internal} \
425         %{!?with_gif:--disable-gif} \
426         %{?with_joystick:--enable-joystick} \
427         %{!?with_libdv:--disable-libdv} \
428         %{!?with_libdts:--disable-libdts} \
429         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
430         %{!?with_mad:--disable-mad} \
431         %{!?with_pulseaudio:--disable-polyp} \
432         %{!?with_quicktime:--disable-qtx} \
433         %{!?with_real:--disable-real} \
434         --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
435         %{!?with_select:--disable-select} \
436         %{!?with_smb:--disable-smb} \
437         %{!?with_win32:--disable-win32dll} \
438         %{!?with_vorbis:--disable-vorbis} \
439         %{?with_osd:--enable-menu} \
440         %{!?with_theora:--disable-theora} \
441         %{!?with_x264:--disable-x264} \
442         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
443         %{!?with_xvid:--disable-xvid} \
444         %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
445         %{?with_vidix:--disable-vidix-internal} \
446         %{!?with_mencoder:--disable-mencoder} \
447         --enable-dga1 \
448         --enable-dga2 \
449         --enable-dvdnav \
450         --enable-fbdev \
451         --enable-gl \
452         --enable-mga \
453         --enable-radio \
454         --enable-radio-capture \
455         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
456         --enable-tdfxfb \
457         --enable-vm \
458         --enable-x11 \
459         --enable-xmga \
460         --enable-xv \
461         --enable-xvmc \
462         --enable-dynamic-plugins \
463         --enable-largefiles \
464         --language=all \
465         --codecsdir=%{_libdir}/codecs \
466         --with-xvmclib=XvMCW \
467         "$@"
468
469         %{__make}
470 }
471
472 %if %{with gui}
473 # build GUI version
474 build --enable-gui --disable-mencoder
475 mv -f mplayer gmplayer
476 %{__make} distclean
477 %endif
478
479 # now build regular version
480 build --disable-gui
481
482 %if %{with doc}
483 %{__make} -j1 -C DOCS/xml
484 %endif
485
486 %install
487 rm -rf $RPM_BUILD_ROOT
488 install -d \
489         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
490         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
491         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
492         $RPM_BUILD_ROOT%{_desktopdir}
493
494 # default config files
495 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
496
497 # executables
498 %if %{with mencoder}
499 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
500 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
501 %endif
502 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
503 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
504 %if %{with gui}
505 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
506 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
507 %endif
508
509 # fonts
510 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
511 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
512
513 %if %{with gui}
514 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
515 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
516 %endif
517 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
518 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
519
520 # man pages
521 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
522 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
523 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
524 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
525 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
526 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
527 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
528 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
529 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
530 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %post -n gmplayer
536 umask 022
537 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
538
539 %postun -n gmplayer
540 umask 022
541 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
542
543 %files
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/mplayer*
546
547 %if %{with gui}
548 %files -n gmplayer
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/gmplayer*
551 %{_desktopdir}/gmplayer.desktop
552 %dir %{_datadir}/%{name}/skins
553 %ghost %{_datadir}/%{name}/skins/default
554 %endif
555
556 %if %{with mencoder}
557 %files -n mencoder
558 %defattr(644,root,root,755)
559 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
560 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
561 %doc DOCS/tech/colorspaces.txt
562 %attr(755,root,root) %{_bindir}/mencoder*
563 %endif
564
565 %files common
566 %defattr(644,root,root,755)
567 %doc DOCS/tech
568 %if %{with win32}
569 %doc etc/codecs.win32.conf
570 %endif
571 %if %{with doc}
572 # HTML and XML-generated docs
573 %doc DOCS/HTML/en
574 %lang(cs) %doc DOCS/HTML/cs
575 %lang(de) %doc DOCS/HTML/de
576 %lang(es) %doc DOCS/HTML/es
577 %lang(fr) %doc DOCS/HTML/fr
578 %lang(hu) %doc DOCS/HTML/hu
579 %lang(pl) %doc DOCS/HTML/pl
580 %lang(ru) %doc DOCS/HTML/ru
581 #%lang(zh_CN) %doc DOCS/zh
582 %endif
583 %doc AUTHORS README
584
585 %dir %{_sysconfdir}/%{name}
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
587 %{_mandir}/man1/*
588 %lang(cs) %{_mandir}/cs/man1/*
589 %lang(de) %{_mandir}/de/man1/*
590 %lang(es) %{_mandir}/es/man1/*
591 %lang(fr) %{_mandir}/fr/man1/*
592 %lang(hu) %{_mandir}/hu/man1/*
593 %lang(it) %{_mandir}/it/man1/*
594 %lang(pl) %{_mandir}/pl/man1/*
595 #%lang(sv) %{_mandir}/sv/man1/*
596 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
597 %{_desktopdir}/mplayer.desktop
598 %{_pixmapsdir}/mplayer.png
599 %dir %{_datadir}/%{name}
600 %{_datadir}/%{name}/font*
This page took 0.075283 seconds and 4 git commands to generate.