]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- release 2
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # with DirectFB video output
4 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
5 %bcond_with     ggi             # with ggi video output
6 %bcond_with     nas             # with NAS audio output
7 %bcond_with     svga            # with svgalib video output
8 %bcond_without  osd             # with osd menu support
9 %bcond_without  altivec         # without altivec support
10 %bcond_without  x264            # without x264 support
11 %bcond_with     xmms            # with XMMS inputplugin support
12 %bcond_without  aalib           # without aalib video output
13 %bcond_without  jack            # without JACKD support
14 %bcond_without  alsa            # without ALSA audio output
15 %bcond_without  arts            # without arts audio output
16 %bcond_without  caca            # without libcaca video output
17 %bcond_without  cdparanoia      # without cdparanoia support
18 %bcond_without  dvdnav          # without dvdnav support
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  esd             # disable EsounD sound support
21 %bcond_without  faad            # disable FAAD2 (AAC) support
22 %bcond_without  gif             # disable GIF support
23 %bcond_without  gui             # without GTK+ GUI
24 %bcond_without  joystick        # disable joystick support
25 %bcond_without  libdts          # disable libdts support
26 %bcond_without  libdv           # disable libdv en/decoding support
27 %bcond_without  lirc            # without lirc support
28 %bcond_without  live            # without LIVE555 libraries
29 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
30 %bcond_without  mad             # without mad (audio MPEG) support
31 %bcond_without  pulseaudio      # without pulseaudio output
32 %bcond_without  quicktime       # without binary quicktime dll support
33 %bcond_without  real            # without Real* 8/9 codecs support
34 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
35                                 #  in compile time (advertised by mplayer authors as working faster); in this case
36                                 #  mplayer may not work on machine other then where it was compiled
37 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
38 %bcond_without  smb             # disable Samba (SMB) input support
39 %bcond_without  theora          # without theora support
40 %bcond_without  win32           # without win32 codecs support
41 %bcond_without  vdpau           # disable vdpau
42 %bcond_without  vidix           # disable vidix
43 %bcond_without  vorbis          # without Ogg-Vorbis audio support
44 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
45 %bcond_without  xvid            # disable XviD codec
46 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
47 %bcond_without  sdl             # disable SDL
48 %bcond_without  doc             # don't build docs (slow)
49 %bcond_with     shared          # experimental libmplayer.so support
50 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
51 %bcond_without  gnomess         # disable controling gnome screensaver
52 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
53 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
54 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
55
56 %if %{with alsa}
57 %undefine       with_select
58 %endif
59
60 %if %{without vorbis}
61 %undefine       with_system_vorbis
62 %endif
63
64 %ifnarch %{ix86}
65 %undefine       with_win32
66 %undefine       with_quicktime
67 %undefine       with_vidix
68 %endif
69
70 %ifnarch %{ix86} %{x8664} ppc ppc64
71 %undefine       with_runtime
72 %endif
73
74 %if %{_lib} == "lib64"
75 %define         _suf    64
76 %else
77 %define         _suf    32
78 %endif
79
80 %define         subver  rc4
81 %define         svnver  29930
82 %define         rel     2
83
84 Summary:        MPlayer - THE Movie Player for UN*X
85 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
86 Summary(es.UTF-8):      Otro reproductor de películas
87 Summary(ko.UTF-8):      리눅스용 미디어플레이어
88 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
89 Summary(pt_BR.UTF-8):   Reprodutor de filmes
90 Name:           mplayer
91 Version:        1.0
92 Release:        5.%{subver}_svn%{svnver}.%{rel}
93 # DO NOT increase epoch unless it's really neccessary!
94 # especially such changes like pre7->pre7try2, increase Release instead!
95 # PS: $ rpmvercmp pre7try2 pre7
96 # pre7try2 > pre7
97 Epoch:          3
98 License:        GPL
99 Group:          Applications/Multimedia
100 Source0:        mplayer-r%{svnver}.tar.xz
101 # Source0-md5:  b3261cc2e8cb2240131e58e0ce734f8a
102 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
103 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
104 Source5:        g%{name}.desktop
105 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
106 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
107 Source7:        %{name}.png
108 Source8:        %{name}.desktop
109 # http://www.on2.com/gpl/mplayer/
110 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
111 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
112
113 # build (configure / Makefile) related:
114 Patch10:        %{name}-ldflags.patch
115 Patch11:        %{name}-altivec.patch
116 Patch12:        %{name}-check-byteswap.patch
117 Patch13:        %{name}-visibility-hidden-fix.patch
118 Patch14:        %{name}-ffmpeg.patch
119 Patch15:        %{name}-shared_live.patch
120 Patch16:        %{name}-shared.patch
121
122 # codecs, outputs, demuxers:
123 Patch20:        %{name}-auto-expand.patch
124 Patch21:        %{name}-release_directfb.patch
125
126 # goodies:
127 Patch30:        %{name}-cp1250-fontdesc.patch
128 Patch31:        %{name}-350.patch
129 # update, hard to fix right now because of gnome bug 579430:
130 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
131 #Patch32:       %{name}-gnome-screensaver.patch
132
133 Patch100:       %{name}-on2flix.patch
134
135 URL:            http://www.mplayerhq.hu/
136 %{?with_directfb:BuildRequires: DirectFB-devel}
137 BuildRequires:  OpenAL-devel
138 BuildRequires:  OpenGL-devel
139 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
140 %{?with_aalib:BuildRequires:    aalib-devel}
141 %{?with_alsa:BuildRequires:     alsa-lib-devel}
142 %{?with_arts:BuildRequires:     artsc-devel}
143 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
144 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
145 %{?with_doc:BuildRequires:      docbook-style-xsl}
146 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
147 BuildRequires:  dirac-devel
148 %{?with_dxr3:BuildRequires:     em8300-devel}
149 %{?with_enca:BuildRequires:     enca-devel}
150 %{?with_esd:BuildRequires:      esound-devel}
151 BuildRequires:  faac-devel
152 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
153 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
154 BuildRequires:  freetype-devel >= 2.0.9
155 BuildRequires:  fribidi-devel
156 %{?with_vidix:BuildRequires:    vidix-devel}
157 %ifarch ppc
158 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
159 %endif
160 %{?with_gif:BuildRequires:      giflib-devel}
161 %{?with_gui:BuildRequires:      gtk+2-devel}
162 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
163 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
164 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
165 BuildRequires:  lame-libs-devel
166 %{?with_caca:BuildRequires:     libcaca-devel}
167 %{?with_libdts:BuildRequires:   libdts-devel}
168 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
169 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
170 %{?with_ggi:BuildRequires:      libggi-devel}
171 BuildRequires:  libjpeg-devel
172 %{?with_mad:BuildRequires:      libmad-devel}
173 BuildRequires:  libmng-devel
174 BuildRequires:  libmpcdec-devel >= 1.2.1
175 BuildRequires:  libpng-devel
176 %{?with_smb:BuildRequires:      libsmbclient-devel}
177 %{?with_theora:BuildRequires:   libtheora-devel}
178 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
179 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
180 %{?with_vdpau:BuildRequires:    libvdpau-devel}
181 BuildRequires:  libxslt-progs
182 %{?with_lirc:BuildRequires:     lirc-devel}
183 %{?with_live:BuildRequires:     live-devel}
184 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
185 %{?with_nas:BuildRequires:      nas-devel}
186 BuildRequires:  ncurses-devel
187 %{?with_amr:BuildRequires:      opencore-amr-devel}
188 BuildRequires:  pkgconfig
189 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
190 BuildRequires:  rpmbuild(macros) >= 1.527
191 BuildRequires:  schroedinger-devel
192 BuildRequires:  speex-devel >= 1.1
193 %{?with_svga:BuildRequires:     svgalib-devel}
194 BuildRequires:  twolame-devel
195 %{?with_xmms:BuildRequires:     xmms-devel}
196 BuildRequires:  xorg-lib-libX11-devel
197 BuildRequires:  xorg-lib-libXScrnSaver-devel
198 BuildRequires:  xorg-lib-libXext-devel
199 BuildRequires:  xorg-lib-libXinerama-devel
200 BuildRequires:  xorg-lib-libXv-devel
201 BuildRequires:  xorg-lib-libXvMC-devel
202 BuildRequires:  xorg-lib-libXxf86dga-devel
203 BuildRequires:  xorg-lib-libXxf86vm-devel
204 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
205 %ifarch %{ix86} %{x8664}
206 BuildRequires:  yasm
207 %endif
208 BuildRequires:  zlib-devel
209 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
210 Requires:       OpenGL
211 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
212
213 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
214 %define         specflags_ia32  -fomit-frame-pointer
215 %if %{with altivec}
216 %define         specflags_ppc   -maltivec
217 %endif
218
219 %description
220 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
221 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
222 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
223 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
224 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
225 optionally with SHM extension, X11 using overlays with the Xvideo
226 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
227 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
228
229 If you want to use win32 codecs install w32codec package.
230
231 %description -l de.UTF-8
232 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
233 Kennzeichnend ist die herausragende Format- und
234 Plattform-Kompatibilität.
235
236 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
237 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
238 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
239 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
240 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
241 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
242 installierte Codecs nicht mit MPlayer kollidieren können.
243
244 %description -l es.UTF-8
245 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
246 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
247 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
248 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
249 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
250 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
251 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
252 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
253 v1.1.7 etc.
254
255 Si quiere usar codecs Win32, instale el paquete w32codec.
256
257 %description -l ko.UTF-8
258 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
259 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
260 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
261 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
262 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
263 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
264 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
265 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
266 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
267
268 %description -l pl.UTF-8
269 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
270 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
271 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
272 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
273 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
274 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
275 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
276
277 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
278
279 %description -l pt_BR.UTF-8
280 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
281 áudio. Diferentes mecanismos de reprodução podem também ser
282 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
283
284 %package -n gmplayer
285 Summary:        MPlayer with GTK+ GUI interface
286 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
287 Group:          X11/Applications/Multimedia
288 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
289 Requires:       %{name}-skin
290
291 %description -n gmplayer
292 MPlayer with GUI GTK+ interface.
293
294 %description -n gmplayer -l pl.UTF-8
295 MPlayer z graficznym interfejsem GTK+.
296
297 %package common
298 Summary:        Configuration files and documentation for MPlayer
299 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
300 Group:          Applications/Multimedia
301 Suggests:       unrar
302 Obsoletes:      mplayer-vidix
303
304 %description common
305 Configuration files, man page and HTML documentation for MPlayer.
306
307 %description common -l pl.UTF-8
308 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
309
310 %package -n mencoder
311 Summary:        MEncoder - a movie encoder for Linux
312 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
313 Group:          Applications/Multimedia
314 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
315
316 %description -n mencoder
317 MEncoder is a movie encoder for Linux and is a part of the MPlayer
318 package.
319
320 %description -n mencoder -l pl.UTF-8
321 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
322
323 %prep
324 %setup -q -n mplayer-r%{svnver} -a3 -a6 -a9
325 cp -f etc/codecs.conf etc/codecs.win32.conf
326
327 # build (configure / Makefile) related:
328 %patch10 -p1
329 %patch11 -p1
330 %patch12 -p1
331 %patch13 -p1
332 %{?with_system_ffmpeg:%patch14 -p1}
333 %{?with_live:%patch15 -p1}
334 %{?with_shared:%patch16 -p1}
335
336 # codecs, outputs, demuxers:
337 %patch20 -p1
338 %patch21 -p1
339
340 # goodies:
341 %patch30 -p0
342 %patch31 -p1
343 #%{with_gnomess:%patch32 -p1}
344
345 # on2flix
346 mv mencoder-on2flixenglinux{-*-*-*,}
347 %if %{with on2}
348 #%%patch100 -p1
349 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
350 # remove broken patches:
351 # - first set does not apply
352 # - second set beakes build
353 for PATCH in    asf-correct_movielength avi_check_idxflags \
354                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
355                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
356                 mpegvideo-revert_r18381 \
357                 \
358                 reduce_spurious_logging
359 do
360         rm mencoder-on2flixenglinux/patch/$PATCH.diff
361 done
362 for a in mencoder-on2flixenglinux/patch/*.diff; do
363         patch -p0 < $a
364 done
365 %endif
366
367 # Set version
368 %if "x%{svnver}" != "x%{nil}"
369         echo "SVN-r%{svnver}%{?with_on2:-on2}" > VERSION
370 %endif
371
372 cat etc/example.conf > etc/mplayer.conf
373 cat <<'CONFIGADD' >> etc/mplayer.conf
374
375 ######################
376 # PLD Linux Defaults #
377 ######################
378 [default]
379
380 # alternate solution for CP1250-encoded subtitles
381 fontconfig = yes
382 subcp = cp1250
383
384 # ...or if you prefer native bitmap fonts shipped with mplayer
385 #fontconfig = no
386 #subcp = iso-8859-1
387
388 # Standard location
389 unrarexec = "%{_bindir}/unrar"
390
391 CONFIGADD
392
393 %if %{with system_ffmpeg}
394 # using external ffmpeg, but mplayer adds these to includepath
395 rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
396 %endif
397
398 # *** HOT FIXES ***
399
400 # typo, fixed in recent svn
401 sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
402
403 # mjpeg encoder is required for Zoran hardware
404 sed '/_libavencoders="MPEG/s/"$/ MJPEG_ENCODER"/' -i configure
405
406 %build
407 CFLAGS="%{rpmcflags} -fvisibility=hidden %{?with_shared:-fvisibility=default -fPIC}"
408 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
409 %{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
410
411 build() {
412         set -x
413
414         ./configure \
415         %{?debug:--enable-debug=3} \
416         --prefix=%{_prefix} \
417         --confdir=%{_sysconfdir}/mplayer \
418         --cc="%{__cc}" \
419         --extra-cflags="$CFLAGS" \
420         --real-ldflags="%{rpmldflags}" \
421         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
422 %if %{with system_ffmpeg}
423         --disable-libavutil_a \
424         --disable-libavcodec_a \
425         --disable-libavformat_a \
426         --disable-libpostproc_a \
427         --enable-libavutil_so \
428         --enable-libavcodec_so \
429         --enable-libavformat_so \
430         --enable-libpostproc_so \
431 %endif
432 %ifnarch %{ix86} %{x8664}
433         --disable-mmx \
434         --disable-mmxext \
435         --disable-3dnow \
436         --disable-3dnowext \
437         --disable-sse \
438         --disable-sse2 \
439         --disable-fastmemcpy \
440 %endif
441         %{__disable ssse3} \
442 %ifarch ppc
443         %{__disable altivec} \
444 %endif
445         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
446         %{__enable_disable directfb} \
447         %{__disable dxr3} \
448         %{__disable ggi} \
449         %{__disable live} \
450         %{__disable lzo liblzo} \
451         %{__disable nas} \
452         %{__disable svga} \
453         %{__disable aalib aa} \
454         %{__disable jack} \
455         %{__enable_disable alsa} \
456         %{__disable arts} \
457         %{__disable caca} \
458         %{__disable cdparanoia} \
459         %{__disable enca} \
460         %{__disable esd} \
461         --disable-faad-internal \
462         %{__disable faad} \
463         %{__disable gif} \
464         %{__enable joystick} \
465         %{__disable libdv} \
466         %{__disable libdts libdca} \
467         %{__enable_disable lirc} \
468         %{__disable mad} \
469         %{__disable pulseaudio pulse} \
470         %{__disable quicktime qtx} \
471         %{__disable real} \
472         %{__enable_disable runtime runtime-cpudetection} \
473         %{__disable select} \
474         %{__disable smb} \
475         %{__disable win32 win32dll} \
476         %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis} \
477         %{__disable_if system_vorbis tremor-internal} \
478         %{__enable osd menu} \
479         %{__disable theora} \
480         %{__disable x264} \
481         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
482         %{__disable xvid} \
483         %{__disable vidix} \
484         %{__disable vdpau} \
485         %{__disable mencoder} \
486         --enable-dga1 \
487         --enable-dga2 \
488         %{__enable_disable dvdnav} \
489         --enable-fbdev \
490         --enable-gl \
491         --enable-mga \
492         --enable-radio \
493         --enable-radio-capture \
494         %{__enable_disable sdl} \
495         --enable-tdfxfb \
496         --enable-vm \
497         --enable-x11 \
498         --enable-xmga \
499         --enable-xv \
500         --enable-xvmc \
501         --with-xvmclib=XvMCW \
502         --enable-zr \
503         --enable-unrarexec \
504         --enable-dynamic-plugins \
505         --enable-largefiles \
506         --language=all \
507         --codecsdir=%{_libdir}/codecs \
508         "$@"
509
510         %{__make}
511 }
512
513 %if %{with gui}
514 # build GUI version
515 build --enable-gui --disable-mencoder
516 mv -f mplayer gmplayer
517 %{__make} distclean
518 %endif
519
520 # now build regular version
521 build --disable-gui
522
523 %if %{with doc}
524 %{__make} -j1 -C DOCS/xml
525 %endif
526
527 %install
528 rm -rf $RPM_BUILD_ROOT
529 install -d \
530         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
531         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
532         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
533         $RPM_BUILD_ROOT%{_desktopdir}
534
535 # default config files
536 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
537
538 # executables
539 %if %{with mencoder}
540 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
541 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
542 %endif
543 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
544 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
545 %if %{with gui}
546 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
547 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
548 %endif
549
550 %if %{with shared}
551 install -d $RPM_BUILD_ROOT%{_libdir}
552 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
553 %endif
554
555 # fonts
556 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
557 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
558
559 %if %{with gui}
560 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
561 %endif
562 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
563 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
564 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
565
566 # man pages
567 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
568 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
569 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
570 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
571 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
572 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
573 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
574 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
575 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
576 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 %post -n gmplayer
582 umask 022
583 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
584
585 %postun -n gmplayer
586 umask 022
587 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
588
589 %files
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_bindir}/mplayer*
592
593 %if %{with gui}
594 %files -n gmplayer
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/gmplayer*
597 %{_desktopdir}/gmplayer.desktop
598 %endif
599
600 %if %{with mencoder}
601 %files -n mencoder
602 %defattr(644,root,root,755)
603 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
604 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
605 %doc DOCS/tech/colorspaces.txt
606 %attr(755,root,root) %{_bindir}/mencoder*
607 %endif
608
609 %files common
610 %defattr(644,root,root,755)
611 %doc DOCS/tech
612 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
613 %if %{with win32}
614 %doc etc/codecs.win32.conf
615 %endif
616 %if %{with doc}
617 # HTML and XML-generated docs
618 %doc DOCS/HTML/en
619 %lang(cs) %doc DOCS/HTML/cs
620 %lang(de) %doc DOCS/HTML/de
621 %lang(es) %doc DOCS/HTML/es
622 %lang(fr) %doc DOCS/HTML/fr
623 %lang(hu) %doc DOCS/HTML/hu
624 %lang(pl) %doc DOCS/HTML/pl
625 %lang(ru) %doc DOCS/HTML/ru
626 #%lang(zh_CN) %doc DOCS/zh
627 %endif
628 %doc AUTHORS README
629
630 %dir %{_sysconfdir}/%{name}
631 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
632 %{_mandir}/man1/*
633 %lang(cs) %{_mandir}/cs/man1/*
634 %lang(de) %{_mandir}/de/man1/*
635 %lang(es) %{_mandir}/es/man1/*
636 %lang(fr) %{_mandir}/fr/man1/*
637 %lang(hu) %{_mandir}/hu/man1/*
638 %lang(it) %{_mandir}/it/man1/*
639 %lang(pl) %{_mandir}/pl/man1/*
640 #%lang(sv) %{_mandir}/sv/man1/*
641 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
642 %{_desktopdir}/mplayer.desktop
643 %{_pixmapsdir}/mplayer.png
644 %dir %{_datadir}/%{name}
645 %{_datadir}/%{name}/font*
646 %dir %{_datadir}/%{name}/skins
647 %ghost %{_datadir}/%{name}/skins/default
This page took 0.178701 seconds and 4 git commands to generate.